Jump to content

MS-1763 upgrade to 880M driver install fails with modded INF


Recommended Posts

Greetings everybody,

I have an MSI Whitebook (MS-1763) that was purchased barebone- no CPU/RAM/HDD, just Mobo and GTX 780M.
As many MSI users know, the optimus driver support can be strange- it required a specific install order: intel VGA first, then MSI-flavor Nvidia drivers only (although when I first went through this I was not modding INF files).
It also seems like the Whitebook BIOS cannot be upgraded- under "Advanced" the EFI Update option is absent. My BIOS version is E1763IG6.70C

Anyway I recently saw a chance on ebay to cheaply upgrade my 4700MQ to a 4800MQ and 780M to 880M.
I bought both and swapped them in. The 4800MQ had no problem. At first I didn't update the Intel VGA driver but after problems (see next) I reinstalled them (via MSI site).
The 880M wouldn't install. At first I tried the official driver from Nvidia, next I tried the official MSI driver for the GT70 Dominator Pro (appeared to be the same 1763 haswell platform but with an 880M). Both installers would fail to find compatible hardware, so I disabled automatic Windows drivers, disabled Driver Signature checking, and started modding INF files.

The card appears in Device Manager as the generic Microsoft Display device (or whatever).
The hardware ID for the card is  PCI\VEN_10DE&DEV_1198&SUBSYS_05AA1462&REV_A1

Once I got the hang of modding INF files, both installlers would pass the compatibility check and proceed to the installation. However after selecting Custom/Express the installer would fail. It would pass the "Preparing" stage and get about 30 seconds into the installation before notifying me that it had failed.
After the failure, in the device manager the generic Microsoft Display device disappeared and "Unknown Device" appeared under Other Devices. It still has the correct hardware ID.
I tried modding nv_dispi.INF after that, but no change. I tried modding the 780M driver for the 2od, same result.

Can anyone shed some light on this? Experience with updating or upgrading a Whitebook? Successfully installed an 880M with the 05AA subsystem? Think the BIOS is somehow the problem?
I'm very close to selling off the card- but I've already sold my 780M. If I did buy another 880M or 980M, I'm concerned the same problem will occur. Don't make me buy back my old card!

Link to comment
Share on other sites

I got it working, finally, after days of failure.

Attempted vBIOS:
First I flashed the default MSI vBIOS from techPowerup. (Smh, the whole reason I upgraded from a 780M to 880M was to get an OC without messing with the vBIOS. Oh well!)
The flash went smoothly and the Hardware ID was updated to 1198.1105 (MSI 880M). However all of the drivers still failed.

Attemped BIOS and EC Firmware update:
None of the BIOS or firmware files from MSI worked at all- for the BIOS I didn't have the install link, and for the EC FW I got "Wrong Project" error, suggesting the wrong hardware.
I ended up going to MSI Forums asking for a BIOS and FW, and paying 20 Euro to Svet (extremely helpful, completely worth it). Svet provided the correct BIOS for a Whitebook: E1763IG6.71D
The FW I updated to was 1763EG61.517
Notice these are completely different codes (1763EG6x.xxx) than the MSI official GT70 firmwares (1763EMSx.xxx).
Svet provided several tools to install these.
The BIOS update went smoothly, however the EC Firmware update gave error: Missing Myio.dll . According to Svet this was a mistake by MSI. He provided another tool to create a USB BIOS flasher loaded with the EC Firmware and this worked. Now my BIOS and EC Firmware are both updated.

THIS DID SOLVE THE PROBLEM. However, the drivers from MSI still did not work- First I tried the ones for GT70 2QD, tried again, tried the official Nvidia download from yesterday... then I got another installer from Nvidia- they had updated the drivers again (375.57, literally an update from today) and it worked. I don't know how or why, but I am now running an 880M successfully.

Edited by Spats
Link to comment
Share on other sites

Since I bothered with all this, my next step is to try some overclocking.
Any thoughts on stable ranges without a PSU upgrade? I'm currently using the 19.5V 9.2A (180W).
I saw rumors about reduced performance or reduced OC ability with some 880M drivers- is this true?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.