Jump to content

15" MBP GT750m + GTX980@16Gbps-TB2 (Thunder2) + Ammo Case + W10/macOS 10.12 Sierra

Recommended Posts

11 minutes ago, UncleGravity said:

It always says "There are no applications running on this GPU", no matter what I throw at it.


I wouldn't trust the system tray widget. Can you run an app (e.g. Furmark) or game and see which card the app is using, as reported by the app itself?

Link to comment
Share on other sites

That is the oddest thing. It does look like the apps are running on the wrong card, but what's weird to me is Furmark's benchmark report...


It says the renderer is the Intel GPU, but has the PCI ID of the GTX 970 (10DE is NVIDIA's Vendor Code...)


I'm really stumped at this point. Does the 970 work when you have a monitor hooked up to it, and boot into Windows "normally" (i.e. non-Optimus mode)?

Link to comment
Share on other sites

That is pretty weird.  Yeah, I've played a few games already with the external monitor hooked up to the 970.  Can run most things 1080p at max (or almost max), certainly miles better than the 750m.  


What nVidia drivers are you using?  Latest (368.81)?

Link to comment
Share on other sites

Here's what it looks like on my end. Maybe try creating a program-specific NVIDIA settings page for furmark and setting it to use High-Performance, see if that changes anything?








Edited by P-Mac
Link to comment
Share on other sites

Tried that too.  Nothing.  I mean I would've given up a long time ago if it wasn't for the fact that we're running basically the same setup.  Same computer, OS, drivers, akitio thunder 2, we ruled out that it was the card.  I'm really out of ideas.  Super lame.


Here's an overview of the setup with more details (note: I rolled back drivers to 368.39, just to check, since someone had done it successfully with those)




Evidence that GTX 970 works with external monitor.  I had to disable the 750m for furmark to use the 970, this was before setting up optimus.


Edited by UncleGravity
Link to comment
Share on other sites

17 minutes ago, UncleGravity said:

I had to disable the 750m for furmark to use the 970, this was before setting up optimus.


Just to check the obvious, the 750m is disabled while you're trying to run Optimus, correct?

Link to comment
Share on other sites

Yeah, I boot normally, disable the 750m, set igpu with gpu-switch, restart with egpu plugged in.  I can see all three on device manager, and 750m is disabled.  When I mouse over the optimus icon in the toolbar it says:


GeForce GTX 970 (Inactive)

GeForce GT 750M (Disabled)

Link to comment
Share on other sites

6 minutes ago, UncleGravity said:

GeForce GTX 970 (Inactive)

GeForce GT 750M (Disabled)


...weird, it shouldn't say inactive.


Does the 970 show up in Device Manager okay? No exclamation marks or "device could not start" messages?


You're booting up with apple_set_os before you boot into Windows, correct?

Edited by P-Mac
Link to comment
Share on other sites

Everything looks good. 




And yeah, I'm using apple_set_os with rEFInd before booting windows.  Otherwise the Iris Pro doesn't run.

Damn. I'm stumped. I know that the 970 for sure works with Optimus as one of the guides I used for enabling Optimus was running a 970.

Wish I could help figure out your problem but I'm at wit's end over here. Sorry man.

Link to comment
Share on other sites

  • Tech Inferno Fan changed the title to 15" MBP GT750m + GTX980@16Gbps-TB2 (AKiTiO Thunder2) + Win10/OSX 10.11.5 + Ammo Case [P-Mac]

Added this to original topic:


(NEW) FIX FOR macOS NOT POSTing: Run Goalque's script in "-a mode". This apparently alters something regarding the thunderbolt chipset on every shutdown, so when rebooting back into macOS, the eGPU will initialize properly every time. 

Link to comment
Share on other sites

  • 2 weeks later...

My setup: late 2013 MBP 15" + 750M + Palit GTX 980 Ti Super Jetstream eGPU + Akitio2 + Enermax ELT500AWT PSU.. 

Under OS X 11.6 with security update: GTX 980 Ti were recognized as "NViadia Chip Model" only. So done a clean install with El Capitan (15G31) and wiped out the SSD, installed OS X and Windows 8.1 (EFI-Mode). I tried to use the eGPU-Setup-1.30 to activate the iGPU, but no luck to run successfully the PCI-Compaction. After all I'm only using the automate-eGPU with "-a" switch, otherwise it will be impossible to see the boot manager and boot into OS X or Windows 8.1 (EFI-mode). Only at the first boot after Windows Installation could GTX 980 Ti be recognized by windows. Installed the newest NVIDIA driver and in Device Manager appeared 750M and 980 Ti, both working correctly.

Here the trick to boot into Windows with always working GTX 980 Ti (and maybe other)  - automate-eGPU-Script with "-a" switch already installed:

  1. Boot into OS X - TB unplugged 
  2. Plug TB in and restart OS X - from now on TB is plugged in
  3. Boot into OSX again  and restart OS X
  4. Boot into Windows - Check Device Manager - only 750M will appear
  5. Restart Windows - Check Device Manager - 750M AND 980 Ti are enabled 

For Optimus in this constellation it is not necessary to have an Optimus-GPU like GTX 970. All you need to have is a dummy HDMI-to-VGA-Adaptor and tolls like "Dual Monitor", setting the dummy Display as primary. 


OS X recognizes the 980 Ti with the Dummy Adaptor:


Bildschirmfoto 2016-12-31 um 17.00.52.jpg


Look at NVIDIA Driver Manager:


Bildschirmfoto 2016-12-31 um 17.01.36.jpg


It works fine so far, BUT every time i try to start an Benchmark Tool like Cinebench, the PSU stops working after 6 seconds of running. During this 6 seconds the PSU makes noises that sounds like "buzzing". After reboot I got this:

Anonymous UUID:       901C2BA4-A48D-2526-8E28-6D8A7A81BE7B

Sun Jan  1 16:13:54 2017

*** Panic Report ***
panic(cpu 2 caller 0xffffff7f8efa8bd5): "GPU Panic: [<None>] 5 3 5f 1d 0 8 0 3 : NVRM[1/194:0:0]: Read Error 0x0061c004: CFG 0xffffffff 0xffffffff 0xffffffff, BAR0 0xc2000000 0xffffff9221548000 0x120080a1, D0, P3/4\n"@/Library/Caches/com.apple.xbs/Sources/AppleGraphicsControl/AppleGraphicsControl-3.12.8/src/AppleMuxControl/kext/GPUPanic.cpp:127
Backtrace (CPU 2), Frame : Return Address
0xffffff91f9bb3110 : 0xffffff800c0dab52 
0xffffff91f9bb3190 : 0xffffff7f8efa8bd5 
0xffffff91f9bb3270 : 0xffffff7f8cda7e96 
0xffffff91f9bb3330 : 0xffffff7f8ce836ce 
0xffffff91f9bb3390 : 0xffffff7f8f1bfa7b 
0xffffff91f9bb33c0 : 0xffffff7f8f1bee9a 
0xffffff91f9bb3440 : 0xffffff7f8cdd0fd0 
0xffffff91f9bb3510 : 0xffffff7f8cf32c5c 
0xffffff91f9bb3740 : 0xffffff7f8cd75a05 
0xffffff91f9bb37c0 : 0xffffff7f8cd73494 
0xffffff91f9bb3870 : 0xffffff7f8cdabf5c 
0xffffff91f9bb3a60 : 0xffffff7f8cdad21b 
0xffffff91f9bb3b40 : 0xffffff7f8cf90af5 
0xffffff91f9bb3b90 : 0xffffff7f8cf88f9e 
0xffffff91f9bb3bd0 : 0xffffff7f8cf85386 
0xffffff91f9bb3d50 : 0xffffff7f8cd43545 
0xffffff91f9bb3dd0 : 0xffffff7f8cd2e908 
0xffffff91f9bb3e40 : 0xffffff7f8cced79b 
0xffffff91f9bb3e60 : 0xffffff7f8cd2ae24 
0xffffff91f9bb3e90 : 0xffffff800c690608 
0xffffff91f9bb3ed0 : 0xffffff800c6b35ce 
0xffffff91f9bb3f10 : 0xffffff800c68f764 
0xffffff91f9bb3f90 : 0xffffff800c68f9e7 
0xffffff91f9bb3fb0 : 0xffffff800c1c9117 
      Kernel Extensions in backtrace:
            dependency: com.apple.iokit.IOPCIFamily(2.9)[F51AA3D6-EC2F-3AD3-A043-06DB79027AA2]@0xffffff7f8c962000
            dependency: com.apple.iokit.IOGraphicsFamily(2.4.1)[A360453D-2050-3C49-A549-AC0DD5E87917]@0xffffff7f8cce3000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[F51AA3D6-EC2F-3AD3-A043-06DB79027AA2]@0xffffff7f8c962000
            dependency: com.apple.driver.AppleGraphicsControl(3.12.8)[C57F5F56-2229-365F-9765-F24AA4687584]@0xffffff7f8ef92000
            dependency: com.apple.iokit.IOACPIFamily(1.4)[5D7574C3-8E90-3873-BAEB-D979FC215A7D]@0xffffff7f8d58c000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[F51AA3D6-EC2F-3AD3-A043-06DB79027AA2]@0xffffff7f8c962000
            dependency: com.apple.iokit.IOGraphicsFamily(2.4.1)[A360453D-2050-3C49-A549-AC0DD5E87917]@0xffffff7f8cce3000
            dependency: com.apple.driver.AppleBacklightExpert(1.1.0)[C49819CE-729A-36B2-9AC1-744A43DC236F]@0xffffff7f8ef95000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[F51AA3D6-EC2F-3AD3-A043-06DB79027AA2]@0xffffff7f8c962000
            dependency: com.apple.iokit.IONDRVSupport(2.4.1)[4EB2843C-C821-3AD0-B333-575FD6ED6FB1]@0xffffff7f8cd2a000
            dependency: com.apple.iokit.IOGraphicsFamily(2.4.1)[A360453D-2050-3C49-A549-AC0DD5E87917]@0xffffff7f8cce3000
            dependency: com.apple.AppleGraphicsDeviceControl(3.12.8)[81C2784E-285A-38A7-A16E-515DCB816E0A]@0xffffff7f8cd3a000
            dependency: com.nvidia.web.NVDAResmanWeb(10.1.1)[D20B3654-86D1-3A67-8820-36317169A465]@0xffffff7f8cd41000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[F51AA3D6-EC2F-3AD3-A043-06DB79027AA2]@0xffffff7f8c962000

BSD process name corresponding to current thread: kernel_task
Boot args: nvda_drv=1

Mac OS version:

Kernel version:
Darwin Kernel Version 15.6.0: Thu Jun 23 18:25:34 PDT 2016; root:xnu-3248.60.10~1/RELEASE_X86_64
Kernel UUID: B5AA8E3E-65B6-3D0E-867B-8DCCF81E536C
Kernel slide:     0x000000000be00000
Kernel text base: 0xffffff800c000000
__HIB  text base: 0xffffff800bf00000
System model name: MacBookPro11,3 (Mac-2BD1B31983FE1663)

System uptime in nanoseconds: 120399971468
last loaded kext at 4907836910: com.apple.driver.AppleHWSensor	1.9.5d0 (addr 0xffffff7f8ec8a000, size 36864)
loaded kexts:
com.nvidia.web.NVDAGM100HalWeb	10.1.1
com.paragon-software.filesystems.ntfs	359.2.14
com.nvidia.web.GeForceWeb	10.1.1
com.nvidia.web.NVDAGK100HalWeb	10.1.1
com.nvidia.web.NVDAResmanWeb	10.1.1
com.nvidia.NVDAStartupWeb	10.1.1
com.apple.driver.AppleHWSensor	1.9.5d0
com.apple.driver.AudioAUUC	1.70
com.apple.filesystems.ntfs	3.13
com.apple.filesystems.autofs	3.0
com.apple.driver.AGPM	110.22.0
com.apple.driver.ApplePlatformEnabler	2.6.0d0
com.apple.driver.X86PlatformShim	1.0.0
com.apple.driver.AppleOSXWatchdog	1
com.apple.driver.AppleGraphicsDevicePolicy	3.12.7
com.apple.driver.AppleHDAHardwareConfigDriver	274.12
com.apple.driver.AppleHDA	274.12
com.apple.driver.AppleUpstreamUserClient	3.6.1
com.apple.driver.pmtelemetry	1
com.apple.iokit.IOUserEthernet	1.0.1
com.apple.iokit.IOBluetoothSerialManager	4.4.6f1
com.apple.Dont_Steal_Mac_OS_X	7.0.0
com.apple.driver.AppleIntelHD5000Graphics	10.1.4
com.apple.driver.ACPI_SMC_PlatformPlugin	1.0.0
com.apple.driver.AppleHV	1
com.apple.driver.AppleFIVRDriver	4.1.0
com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport	4.4.6f1
com.apple.nvidia.NVDAStartup	10.1.0
com.apple.driver.AppleBacklight	170.8.9
com.apple.driver.AppleCameraInterface	5.46.0
com.apple.driver.AppleLPC	3.1
com.apple.driver.AppleSMCLMU	208
com.apple.driver.AppleIntelFramebufferAzul	10.1.4
com.apple.driver.AppleMuxControl	3.12.8
com.apple.driver.AppleIntelSlowAdaptiveClocking	4.0.0
com.apple.driver.AppleThunderboltIP	3.0.8
com.apple.driver.AppleMCCSControl	1.2.13
com.apple.iokit.IOBluetoothUSBDFU	4.4.6f1
com.apple.iokit.SCSITaskUserClient	3.7.7
com.apple.driver.AppleUSBTCButtons	245.4
com.apple.driver.AppleUSBStorageCoexistentDriver	3.7.1
com.apple.driver.AppleUSBCardReader	3.7.1
com.apple.driver.AppleUSBTCKeyEventDriver	245.4
com.apple.driver.AppleUSBTCKeyboard	245.4
com.apple.driver.CoreStorageFsck	517.50.1
com.apple.driver.AppleFileSystemDriver	3.0.1
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless	1.0.0d1
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib	1.0.0
com.apple.BootCache	38
com.apple.iokit.IOAHCIBlockStorage	2.8.5
com.apple.driver.AppleAHCIPort	3.1.8
com.apple.driver.AirPort.Brcm4360	1040.1.1a6
com.apple.driver.AppleSmartBatteryManager	161.0.0
com.apple.driver.AppleACPIButtons	4.0
com.apple.driver.AppleRTC	2.0
com.apple.driver.AppleHPET	1.8
com.apple.driver.AppleSMBIOS	2.1
com.apple.driver.AppleACPIEC	4.0
com.apple.driver.AppleAPIC	1.7
com.apple.nke.applicationfirewall	163
com.apple.security.quarantine	3
com.apple.security.TMSafetyNet	8
com.apple.kext.triggers	1.0
com.apple.driver.DspFuncLib	274.12
com.apple.kext.OSvKernDSPLib	525
com.apple.iokit.IOSerialFamily	11
com.apple.iokit.IOSurface	108.2.3
com.apple.driver.CoreCaptureResponder	1
com.apple.driver.IOPlatformPluginLegacy	1.0.0
com.apple.iokit.IOBluetoothHostControllerUSBTransport	4.4.6f1
com.apple.iokit.IOBluetoothFamily	4.4.6f1
com.apple.driver.AppleHDAController	274.12
com.apple.iokit.IOHDAFamily	274.12
com.apple.iokit.IOAudioFamily	204.4
com.apple.vecLib.kext	1.2.0
com.apple.driver.AppleSMBusPCI	1.0.14d1
com.apple.AppleGraphicsDeviceControl	3.12.8
com.apple.iokit.IOAcceleratorFamily2	205.11
com.apple.driver.AppleBacklightExpert	1.1.0
com.apple.iokit.IONDRVSupport	2.4.1
com.apple.driver.AppleGraphicsControl	3.12.8
com.apple.driver.X86PlatformPlugin	1.0.0
com.apple.driver.IOPlatformPluginFamily	6.0.0d7
com.apple.iokit.IOSlowAdaptiveClockingFamily	1.0.0
com.apple.driver.AppleThunderboltEDMSink	4.1.1
com.apple.driver.AppleSMC	3.1.9
com.apple.driver.AppleSMBusController	1.0.14d1
com.apple.iokit.IOGraphicsFamily	2.4.1
com.apple.driver.usb.IOUSBHostHIDDevice	1.0.1
com.apple.iokit.IOUSBMassStorageClass	4.0.2
com.apple.iokit.IOSCSIBlockCommandsDevice	3.7.7
com.apple.iokit.IOUSBMassStorageDriver	1.0.0
com.apple.iokit.IOSCSIArchitectureModelFamily	3.7.7
com.apple.driver.AppleUSBMultitouch	250.5
com.apple.iokit.IOUSBHIDDriver	900.4.1
com.apple.driver.usb.cdc	5.0.0
com.apple.driver.usb.networking	5.0.0
com.apple.driver.usb.AppleUSBHostCompositeDevice	1.0.1
com.apple.driver.usb.AppleUSBHub	1.0.1
com.apple.driver.CoreStorage	517.50.1
com.apple.driver.AppleThunderboltDPInAdapter	4.1.3
com.apple.driver.AppleThunderboltDPOutAdapter	4.1.3
com.apple.driver.AppleThunderboltDPAdapterFamily	4.1.3
com.apple.driver.AppleThunderboltPCIUpAdapter	2.0.2
com.apple.driver.AppleThunderboltPCIDownAdapter	2.0.2
com.apple.driver.AppleUSBMergeNub	900.4.1
com.apple.driver.AppleXsanScheme	3
com.apple.iokit.IOAHCIFamily	2.8.1
com.apple.driver.AppleThunderboltNHI	4.0.4
com.apple.iokit.IOThunderboltFamily	6.0.2
com.apple.iokit.IO80211Family	1110.26
com.apple.driver.mDNSOffloadUserClient	1.0.1b8
com.apple.iokit.IONetworkingFamily	3.2
com.apple.driver.corecapture	1.0.4
com.apple.driver.usb.AppleUSBXHCIPCI	1.0.1
com.apple.driver.usb.AppleUSBXHCI	1.0.1
com.apple.iokit.IOUSBFamily	900.4.1
com.apple.iokit.IOUSBHostFamily	1.0.1
com.apple.driver.AppleUSBHostMergeProperties	1.0.1
com.apple.driver.AppleEFINVRAM	2.0
com.apple.driver.AppleEFIRuntime	2.0
com.apple.iokit.IOHIDFamily	2.0.0
com.apple.iokit.IOSMBusFamily	1.1
com.apple.security.sandbox	300.0
com.apple.kext.AppleMatch	1.0.0d1
com.apple.driver.AppleKeyStore	2
com.apple.driver.AppleMobileFileIntegrity	1.0.5
com.apple.driver.AppleCredentialManager	1.0
com.apple.driver.DiskImages	417.4
com.apple.iokit.IOStorageFamily	2.1
com.apple.iokit.IOReportFamily	31
com.apple.driver.AppleFDEKeyStore	28.30
com.apple.driver.AppleACPIPlatform	4.0
com.apple.iokit.IOPCIFamily	2.9
com.apple.iokit.IOACPIFamily	1.4
com.apple.kec.Libm	1
com.apple.kec.pthread	1
com.apple.kec.corecrypto	1.0
Model: MacBookPro11,3, BootROM MBP112.0138.B18, 4 processors, Intel Core i7, 2,6 GHz, 16 GB, SMC 2.19f12
Graphics: Intel Iris Pro, Intel Iris Pro, Built-In
Graphics: NVIDIA GeForce GT 750M, NVIDIA GeForce GT 750M, PCIe, 2048 MB
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54343147533641465238412D50422020
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54343147533641465238412D50422020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x134), Broadcom BCM43xx 1.0 (
Bluetooth: Version 4.4.6f1 17910, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: APPLE SSD SM1024F, 1 TB
USB Device: USB 3.0 Bus
USB Device: Card Reader
USB Device: Apple Internal Keyboard / Trackpad
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
Thunderbolt Bus: MacBook Pro, Apple Inc., 17.1

Same on Windows: whenever 980 Ti is under load (game or benchmark) I have a black screen with white mouse on display, sometimes freezes. Can anyone explain what's going on?


EDIT: Probably found the cause of the freezes and it might be my insufficient psu that is unable to provide enough power for the 980 Ti. I thought 500W will be fine, but taking a look into manual shows me I was wrong. 250W is reserved for the CPU and another 250W for the rest on two +12V rails.  Conclusion: a new psu is already ordered and on the way.

Edited by irokez
info update
Link to comment
Share on other sites

@irokez dude lol you're posting a general tech support question directly into my build thread FYI haha. 


Might wanna post it somewhere where it'll get more hits, like a new topic in the eGPU experiences forum. 


FWIW I think it's your PSU as well. 

Link to comment
Share on other sites

Yes, it was... Thanks for your advice!

Now all works ok! I'm working on a solution to work with my 980 Ti on Windows and OS X with high refresh rate through HDMI dummy adapter and HiDPI resolution. 980 Ti is not Optimus compatible, so it's working with the dummy adapter only that simulates a second display.

Link to comment
Share on other sites

  • 2 weeks later...

Awesome setup. Gives me hope that you have a 750m and got optimus to work!


What is your osx setup? clamshell mode? When you are running FCPX are you just using your external display?


I thought I was getting a bump in Resolve, but after hours of rendering I noticed I was not getting a gain over the 750m. From my research Davinci has a problem choosing a cuda enabled device and always defaults to the internal.


thanks in advance!


Link to comment
Share on other sites

@Jmlee5 - in macOS I use it with the laptop open, and use https://github.com/Eun/DisableMonitor to blank the laptop LCD and prevent my cursor from going to it. I have a 4K IPS panel at work that I hook directly to the 980 via DisplayPort, and that is my primary monitor.


I never tried clamshell, though I used to have the laptop open slightly (around 10-15 degrees) underneath my monitor stand...but after I had to take it into AppleCare for a display failure, and noticing how hot the surface of the display was getting...those two facts may not be related but it scared me enough to always try to keep the laptop open at least 90º when using it with the eGPU. 


I have no acceleration issues on FCPX or 3D apps (Elite Dangerous on macOS uses the 980), but it's probably because I'm using an external monitor.

  • Thumbs Up 1
Link to comment
Share on other sites

You are the best! There is a whole thread about this problem. 


I get 14fps with my gtx980ti with 3 color correction nodes and daisy chained my ultra studio mini monitor for output with 

alexa uhd 444 footage. You are going to make a lot of people happy. Footage can not be on the same thunderbolt bus.


optimus next.... Have you successfully overclocked the Retina display to fire at higher hz?

Link to comment
Share on other sites

optimus next.... Have you successfully overclocked the Retina display to fire at higher hz?

Nah, I rarely use Optimus (am on a 4K 60Hz at work and a 1080p 120Hz monitor at home for gaming) so I haven't tried to overclock the internal display at all.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.