Jump to content

2014 MBP 15" Sometimes Doesn't POST With eGPU


Recommended Posts

Hi all, thanks to your posts and knowledge, I was able to get an eGPU rig with a GTX 980 up and running with very few issues! It's been great so far.


One of the lingering issues I've had is having to play the lottery whenever I start up the Mac...it seems like only one time out of 5 will the machine actually POST and play the startup chime and continue booting. Most other times, the GPU will initialize (I see the LEDs turn on and the fans spin up and return to idle), but the Mac just sits there at a black screen and never plays the startup chime.


No amount of shuffling between thunderbolt ports (on both the Thunder2 and the laptop), or praying to the PC Master Race gods has seemed to have any effect on whether the machine will successfully boot or not.


Sometimes it'll boot right on the first try, and do so 10 times in a row, other times I'll have to sit there and hold power to force-shutdown the machine and retry 6 or 7 times before it'll boot.


Any ideas? Specs are as follows:


2014 MacBook Pro 15", i7-4980HQ, GT 750m

Akitio Thunder2, MSI GTX 980 Gaming 4G, Corsair 650w PSU

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 months later...

I don't think there's a clear solution for everyone regarding the notorious black screen thing at the moment, but the following threads could at least bring you some ideas and things to try (in case you haven't visited them yet), depending on whether you boot into Windows or OS X. On a side note, it might be worthwhile to make sure that the drivers (the system folders) "match" among MBP 2013/14 (GT 750M; black screen issue) and MBP 2012 (GT 650M; no black screen issue as far as I can tell). If not, significant differences could, perhaps, hold a key to something subtle but potentially important.


Link to comment
Share on other sites

  • 2 months later...

A little late, but I'd like to reply that when running macOS (shutting down from macOS, starting back up in macOS), running the goalque script in "-a mode" actually solved this issue 100% for me.


That being said, Windows booting is still the same crapshoot, and running the script in -a mode seems to prevent Windows from detecting the eGPU on first startup (gotta reboot into Windows twice for it to work). 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.