Jump to content

Search the Community

Showing results for tags 'dsdt'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Forum Introduction & Feedback
    • Site Announcements, Rules & New Member Intros
    • TechInferno Forum Feedback
  • Tech News & Reviews
    • News & Reviews
  • Notebooks & e-GPU Discussions
    • DIY e-GPU Projects
    • General Notebook Discussions
    • Notebook OEM Subforums
    • What Notebook Best Fits My Needs?
    • Legacy Articles
  • Desktop & General Hardware
    • General Desktops Discussion
    • Desktop Hardware
    • Overclocking, Cooling & Build Logs
  • Software, Networking & PC Gaming
    • PC Gaming
    • Video Driver Releases & Discussion
    • Networking
    • General Software Discussion
  • Everything Else
    • Off Topic

Categories

  • SVL7 & Klem VBIOS Mods
    • AMD
    • Alienware M11x R3
    • Alienware M14x R2
    • Alienware M17x R4
    • Alienware M18x R1
    • Alienware M18x R2
    • Kepler VBIOS
    • Lenovo Y400-Y500
    • Lenovo Y410p-Y510p
    • Lenovo Y580-Y480
    • Legacy BIOS/VBIOS
    • Maxwell VBIOS
    • Sony Vaio SVS13 / SVS15 series
  • BAKED BIOS Mods
    • Clevo
  • Utilities

Product Groups

  • Tech|Inferno Elite Membership
  • Hardware

Categories

  • Frontpage News
    • General News
    • Reviews
    • Hardware News
    • Software News
    • PC Gaming News
    • Science & Technology News
  • Promoted Posts
    • Guides
    • Hardware
    • Software

Categories

  • Hardware
    • Notebooks and Components
    • Desktop and Components
    • Phones
    • Accessories
  • Software
    • PC Games
    • All Other Software

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Steam


AIM


MSN


Website URL


Yahoo


Jabber


Skype


Location


Interests


Occupation

Found 6 results

  1. Hi guys, I need some help from you guys if you wouldn't mind. I'm useless Specs:- Samsung RV520 8gb DDR3 I7 2720qm @2.2ghz 1x HDD 500gb 1x HDD 300gb Nvidia GTX 650 Ti BOOST EXP GDC BEAST 8.5c DIY Setup 1.3 DELL 220w PSU After a lot of messing around I have managed to get this egpu to work when downgrading to 2gb, Which makes me think I just need to change my TOLUD to get it to work. I have read and tried to make a successful DSDT file however I don't really know what I'm doing with these driver edits and haven't been able to get it to work particularly the error fixing on compiling the dsdt. However When I did have it working on 2gb ram. I ran heaven Bench, The GTX 650 under load makes strange noises and crashes the display driver multiple times. Could any of you more knowledgeable individuals give me a hand please Thanks
  2. t3rminat04

    [HELP] Fix dsdt errors

    Greetings, I'm doing a dsdt override for an egpu setup and i'm unable to find a fix for few errors. Using Windows Binary Tools (WBT – Dec 2016), Windows Driver Kit (WDK) and Notepad++ text editor System: Dell n5110 i5-2450m Windows 10 x64 pro gt525m + hd3000. Attached is the .dsl file. Kindly help me out as i'm out of options. Method (UXDV, 1, NotSerialized) { Local0 = 0xFF _T_0 = (Arg0 + Zero) If ((_T_0 == 0x03F8)) { Local0 = Zero } ElseIf ((_T_0 == 0x02F8)) { Local0 = One } ElseIf ((_T_0 == 0x0220)) { Local0 = 0x02 } ElseIf ((_T_0 == 0x0228)) { Local0 = 0x03 } ElseIf ((_T_0 == 0x0238)) { Local0 = 0x04 } ElseIf ((_T_0 == 0x02E8)) { Local0 = 0x05 } ElseIf ((_T_0 == 0x0338)) { Local0 = 0x06 } ElseIf ((_T_0 == 0x03E8)) { Local0 = 0x07 } Return (Local0) } Method (RRIO, 4, NotSerialized) { _T_0 = (Arg0 + Zero) If ((_T_0 == Zero)) { CALE = Zero Local0 = UXDV (Arg2) If ((Local0 != 0xFF)) { CADR = Local0 } If (Arg1) { CALE = One } } ElseIf ((_T_0 == One)) { CBLE = Zero Local0 = UXDV (Arg2) If ((Local0 != 0xFF)) { CBDR = Local0 } If (Arg1) { CBLE = One } } ElseIf ((_T_0 == 0x02)) { LTLE = Zero If ((Arg2 == 0x0378)) { LTDR = Zero } If ((Arg2 == 0x0278)) { LTDR = One } If ((Arg2 == 0x03BC)) { LTDR = 0x02 } If (Arg1) { LTLE = One } } ElseIf ((_T_0 == 0x03)) { FDLE = Zero If ((Arg2 == 0x03F0)) { FDDR = Zero } If ((Arg2 == 0x0370)) { FDDR = One } If (Arg1) { FDLE = One } } ElseIf ((_T_0 == 0x08)) { If ((Arg2 == 0x0200)) { If (Arg1) { GLLE = One } Else { GLLE = Zero } } If ((Arg2 == 0x0208)) { If (Arg1) { GHLE = One } Else { GHLE = Zero } } } ElseIf ((_T_0 == 0x09)) { If ((Arg2 == 0x0200)) { If (Arg1) { GLLE = One } Else { GLLE = Zero } } If ((Arg2 == 0x0208)) { If (Arg1) { GHLE = One } Else { GHLE = Zero } } } ElseIf ((_T_0 == 0x0A)) { If (((Arg2 == 0x60) || (Arg2 == 0x64))) { If (Arg1) { KCLE = One } Else { KCLE = Zero } } } ElseIf ((_T_0 == 0x0B)) { If (((Arg2 == 0x62) || (Arg2 == 0x66))) { If (Arg1) { MCLE = One } Else { MCLE = Zero } } } ElseIf ((_T_0 == 0x0C)) { If ((Arg2 == 0x2E)) { If (Arg1) { C1LE = One } Else { C1LE = Zero } } If ((Arg2 == 0x4E)) { If (Arg1) { C2LE = One } Else { C2LE = Zero } } } ElseIf ((_T_0 == 0x0D)) Sample segment causing errors. dsdt-modified.zip
  3. Ok, a little background. I have a lenovo L420 laptop and bought an EGPU adapter via Express Card. I used a Geforce GTX 1050 TI In order for this to work you need to first disconnect any egpu external device and perfrom DSDT override to your system. Very easy guide thanks to user 'angerthosenear' found here (JAVA MUST BE INSTALLED IN ORDER TO RUN .BAT FILE. Other wise nothing will open) Keep in mind step 5 on his tutorial was a bit off. The correct code should look like this: DWordMemory (ResourceProducer, PosDecode, MinFixed, MaxFixed, Cacheable, ReadWrite, 0x00000000, // Granularity 0x000A0000, // Range Minimum 0x000BFFFF, // Range Maximum 0x00000000, // Translation Offset 0x00020000, // Length ,, , AddressRangeMemory, TypeStatic) /*above this line is only for reference. only copy below*/ QWordMemory (ResourceProducer, PosDecode, MinFixed, MaxFixed, Cacheable, ReadWrite, 0x0000000000000000, // Granularity 0x0000000C20000000, // Range Minimum, set it to 48.5GB 0x0000000E0FFFFFFF, // Range Maximum, set it to 56.25GB 0x0000000000000000, // Translation Offset 0x00000001F0000000, // Length calculated by Range Max - Range Min. ,, , AddressRangeMemory, TypeStatic) Restart your computer and confirm your DSDT override worked by going to Device Manager -> Resources by Connection -> Memory and you should see a hierarchy for 'Large Memory' When I was at this point I was still getting error 43. I thought it was a driver issue, but ****** via email thought it was a timing issue with clocks so he suggested I 'Jumpered' the powersupply so it would constantly stay on as long as it was plugged in. So when I plugged my expresscard in the laptop, the GPU would already be powered on. I would first plug your EGPU in your system and see if you still get this error. If so, jump the power supply unit by grounding the greenwire with either of the black wires to the right or left of it. This can be done in many ways, be smart about it. Try to make it reversible. Don't be like me and cut it, splice it, and jam in behind the ground wire. It works, but, not very pretty. This should get yours working. Unless you have a 1050 TI, if so, read on. Download driver versions 372.70 and 375.63 and extract them 1:) - Open the INF for 375.63 Extract the drivers you want to modify using something like 7zip. (with 7zip installed, just rightclick and press "Extract to "/File name here"") Inside the extracted driver folder open Display.Driver. The "nv_dispi.inf" in that folder is what we need to modify. If you can't find nv_dispi.inf, look for "nvts.inf", "nv_dispwi.inf", or "nv4_dispi.inf" instead. 2:) - Your GPU string Search (CTRL+F) for your gpu '1050 TI' Copy these lines, should be 3 if I remember correctly 3:) - paste them in the appropriate place on the 372.70 INF file 4:) install 372.70 Drivers and restart 5:) Now, your error 43 should be gone but your GPU will run like dog sh*t. You need to install drivers 375.63 EXPRESS INSTALL ONLY. If done correctly you will not be prompted to restart. Congratulations, you're done. Took me 3 days to figure this out. If an idiot like me can do it, so can you. I will gladly answer any questions
  4. Hy there! I have an interesting question that can help more people. If i extend the root bridge into 36 bit space that can allow me to use concurrently the eGPU and dGPU? That is important because due to some BIOS it's impossibile to disable the dGPU. If the dGPU isn't disable win 10 crash after the logo. Is that possibile?
  5. Please ask for support in the main DSDT Override or DIY eGPU Experiences Thread. I have been out of the eGPU realm for too long to provide adequate support. Here is a guide to performing a DSDT override with hopefully less misery, and setting up your computer to have your iGPU, dGPU, and eGPU working at the same time! Oh boy this is going to be fun. This is my system specs (Fujitsu T901): i7-2620M 16GB RAM NVS 4200M GTX 660 Ti Windows 7 Enterprise x64 Now it begins.. Disconnect your eGPU until I say so. If you can, you should perform a DSDT override. The method shown in the official thread was really hard at How to perform a DSDT override: Now for the fun part........ Disconnect your eGPU Uninstall ALL (ALL MEANS ALL) (dGPU included!!!) Nvidia drivers (keep the Intel graphics driver) Use Driver Sweeper and check all the Nvidia options, run, reboot, turn off computer -- don't install the driver for the dGPU yet Connect eGPU and go to Setup 1.x Set your eGPU port to G2 (assuming your have an adapter that supports G2, and your computer as well - if not, then skip setting the port to G2) dGPU off 32-bitA compaction for iGPU eGPU chainload to your OS Windows may yell at you to reboot due to hardware changes, don't quite yet Check device manager, you might (I did) have error 43 Attempt to install the latest Nvidia drivers for you eGPU -- still don't install drivers for your dGPU If your lucky, it will install, if not: shutdown/reboot Setup 1.x do the same as before (dGPU off and such) Attempt to install the Nvidia drivers again for your eGPU After a few hours of fiddling around, you should get them installed (keep your dGPU off this whole time) ONLY AFTER YOU GET YOUR eGPU DRIVERS INSTALLED!! (and as such, error 12 in device manager) Go to Setup 1.x Set port G2 on your eGPU port (again, if you support G2) 32-bitA compaction for iGPU dGPU eGPU (or choose 36-bit if you performed a DSDT override) chainload You will probably get the reboot due to new devices again, but before you do, check device manager Might have a generic VGA device or something instead of the NVS 4200M Attempt to install the drivers for you dGPU now If no luck, reboot and do the same Setup 1.x as before (with dGPU on) Attempt to install dGPU drivers again Reboot after you get your dGPU drivers installed Keep the same Setup 1.x method If your lucky you should have your iGPU dGPU and eGPU show up fine in device manager. You can go to the Nvidia control panel and dedicate your dGPU as your PhysX processor, it works really well. (If you play stuff that supports PhysX and have an at least somewhat useful dGPU) ------------------------------------ I hope this helps. ^ over 20 hrs of fiddling around well spent ;-; ------------------------------------ HOW TO: Update drivers (probably): Note: You can check your driver version for both your eGPU and dGPU in the System Information dialogue box under 'Help' in the NVIDIA Control Panel (you can even check your Bus here too (PCI Express x1 Gen2 as shown for my eGPU). Results::::: iGPU + dGPU + eGPU dGPU PhysX dedicated: WEI: ALL THE MONITORS (and all different resolutions too ): Weeee~~~~~~~~~~~~~~ Check out a video here:
  6. Hi, this thread will be my "Blog" of the experiences and troubles with my S430 and the eGPU Setup. I am currently collecting the pictures and make videos of how I build my case. Updates will come regularly. Update from 12.06.2013: Hey, I got my PE4L 2.1b mod to work. Sadly I rarely have issues with the connection. I think that a downgrade to Gen1 link speed could fix the issue. Bplus now has a cable for the PE4H 2.4 that will allow me to run Gen2 and lucky as I am I was able to get my hands on a Cheap PE4H 2.4 from ebay. I also purchased the new cable from BPlus already. The plans about my case have also changed, I wanted to make a metal one and already had the plans layed out. But with the announcemend of payable Thunderbolt adapters in (hopefully) early 2014 I decided to just make a "cheap" case for these 6 Months that I'll use it. When the cases that come with the Thunderbolt adapter do not fit my needs I'll use the materials and layouts I gathered/made to make a metal case for the Thunderbolt eGPU solution. I will also make some minor changes to the XBOX 360 PSU. So until my new hardware arrives in approx. two weeks there will be no updates. Sorry. Until then Lets start with my System specs: Lenovo S430 3364-57G Core I7 3520M 2 x 2,9Ghz HT 2x 4GB Hyundai DDR3 1600Mhz Plextor 128GB M5S Travelstar Z7K500 500GB Intel HD4000 Zotac GTX 560 Multiview Windows 7 64bit Professional eGPU Setup Specs: PE4L 2.1b with PM3N XBOX 360 Power Brick 203 Watt ( 12V @ 16,5A = 198W , 5Vsb @ 1A = 5W ) DELOCK HUB USB 2.0 4 Port ext. ZSlimZ Molex wire from an old PC PSU Diagnostic Tools: Imgur album: Lenovo S430 eGPU with GTX560 - Imgur 1.2opt ≈368MiB/s H -> D ( ≈ 385MB/s ≈ 77% of 2.0 x1 ) ≈403MiB/s D -> H ( ≈ 422MB/s ≈ 84,5% of 2.0 x1 ) Benchmarks: 3DMark06 -- 20584 ≈ 80% of 25800 3DMark -- Ice Storm: 86378 ≈76% of 113619 ---- Graphics: 125785 ≈ 82,5% of 152566 ---- Physics: 41201 -- Cloudgate: 9652 ≈ 55% of 17605 ---- Graphics: 20463 ≈ 93% of 21922 ---- Physics: 3388 -- Fire Strike: 2398 ≈ 87,5% of 2738 ---- Graphics: 2638 ≈ 91% of 2886 ---- Physics: 4834 ---- Combined: 984 -- 3DMark11 3706 ≈ 91% of 4060 ---- Graphics: 3645 ---- Physics: 4222 ---- Combined: 3507 Software DSDT Override: Windows 8 DSDT Override: I tried, I read several guides on the topic, because I didn't want to setup a new OS, but I haven't found the solution, I experimented a bit myself, but to no avail. Windows 7 DSDT Override: File: DSDT Override + S430.zip The file contains a guide in german aswell. Die Datei enthält auch eine Deutsche Anleitung. DSDT Override for Lenovo S430 (3364-57G) and other Notebooks ===================================================== There is a short guide for the S430 and a long one for other Notebooks. USE AT OWN RISK. NO WARRANTY! If you have a S430 (3364-57G) and Windows 7 installed: Step 1: Open CMD in Admin Mode. Windowskey -> type "cmd" -> right click on it -> start as admin. Step 2: Navigate to this directory. Step 3: Type "asl /loadtable DSDT-S430.aml" into the commandline. Step 4: Reboot. Check Device Manager -> view -> resource by connection. If you have a "Large Memory" entry now, you're done. ===================================================== ===================================================== If you have no Lenovo S430 you have to go the full way. Step 1: Open your Device Manager and click on view -> ressources by connection. Step 2: Search for the last "PCI bus" entry. It should have a lot of subentries, including "Motherboard resources". Step 3: Write down or memorise the last digits of the second value inside the brackets. e.g. Entry: [00000000BFA00000 - 00000000FEAFFFFF] PCI bus Value to memorise would be "FEAFFFFF". Step 4: Open CMD in Admin Mode. Windowskey -> type "cmd" -> right click on it -> start as admin. Step 5: Navigate to this directory. Step 6: Type "iasl -g" into the command line. You should have some new files in your directory now. One of them should end with ".dsl". Step 7: Open the .dsl file with the editor. Step 8: Press STRG + F and search for the memorised value. Step 10: You will see a bunch of "DWordMemory" Methods, go to the end of that list, put your cursor behind the last "TypeStatic)" ( yes after the bracket ) press Enter and now copy the following at the place: QWordMemory (ResourceProducer, PosDecode, MinFixed, MaxFixed, Cacheable, ReadWrite, 0x0000000000000000, // Granularity 0x0000000C20000000, // Range Minimum, set it to 48.5GB 0x0000000E0FFFFFFF, // Range Maximum, set it to 56.25GB 0x0000000000000000, // Translation Offset 0x00000001F0000000, // Length calculated by Range Max - Range Min. ,, , AddressRangeMemory, TypeStatic) It should look like this: Now indent if you like for better readability. ( Notice the Method you inserted is a 64bit QWordMemory not DWordMemory ) Step 11: Go to the top of the textfile, you should see two lines that start with "AHCI" delete both and save the file. Step 12: Switch to the command line again. Type "iasl <name of="" the="" file="" you="" got=""><dsl file="" name="">.dsl". Step 13: Check the output, if there are 0 Errors you are fine if not check some DSDT sites like: DIY eGPU experiences - Page 1003 tonymacx86 Don't forget to thank them for their efforts. Step 14: If you got 0 Errors you'll get a "DSDT.aml" file. Type "asl /loadtable DSDT.aml" into the command line. Step 15: Reboot. Check Device Manager -> view -> resource by connection. If you have a "Large Memory" entry now, you're done. Hardware & Case XBOX360 PowerBrick: Q: Won't 198W be too much for a Molex wire to handle? Aren't you afraid of cable fire? A: Yes you are right, 198Watt would be too much for a single Molex wire, but I have a GTX560 that just consumes 150Watt. Molex oficially handles up to 11A per lane, what would make 132W on the 12V lane. I know I am slightly above that and tested the wire heat while my GPU was on maximum Load during a 3DMark benchmark. it got warm, but far from Hot. I would guess that the single 12V cable had about 26°-30°C and I decided that this is okay for me. Edit: I tested the temperature with a device now, the cables surface got 24,3°C warm. So please keep 11A per lane in mind and be careful! Cable fire is very dangerous. Test thoroughly beforehand! Q: Why do 5Vsb and PSU Enable go into the red lane? A: When you plug in the XBOX PSU it will be on standby and only provide 5V on the 5Vsb lane ( Vsb = Volt Standby ), to wake the PSU up there must be a 1,5V to 5V current on the PSU Enable lane. Only then you'll have power on the 12V lane to power your GPU. Q: Why did you seperate the GND lanes? A: I noticed that the 3 lanes get a bit too thick for my shrinking hose, so I split it up. The thinner wires handle up to 8A per lane and my GPU needs 12,5A so I am safe with my GTX560 in this case. The male Molex connector is connected with the female one on the XBOX PSU. The female connectors are for the PCI-E power adapters and the female floppy for the PE4L. I just cut them off from an old ATX PSU. Discontinued attempts PE4L Socket and Plug: I tried to connect the PE4L via a HDMI cable to get more mobility. Sadly it didn't work. I soldered everything right, but it seems that the impedance of 4 soldered bridges and one HDMI connection is too much. Here are some pictures: Photo Album - Imgur Ferrit Cores for the PCI-EMM060B Cable: Short: It didn't work no Gen2 Speeds: to be continued...</dsl></name>
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.