Jump to content

Search the Community

Showing results for tags '2013'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Forum Introduction & Feedback
    • Site Announcements, Rules & New Member Intros
    • TechInferno Forum Feedback
  • Tech News & Reviews
    • News & Reviews
  • Notebooks & e-GPU Discussions
    • DIY e-GPU Projects
    • General Notebook Discussions
    • Notebook OEM Subforums
    • What Notebook Best Fits My Needs?
    • Legacy Articles
  • Desktop & General Hardware
    • General Desktops Discussion
    • Desktop Hardware
    • Overclocking, Cooling & Build Logs
  • Software, Networking & PC Gaming
    • PC Gaming
    • Video Driver Releases & Discussion
    • Networking
    • General Software Discussion
  • Everything Else
    • Off Topic

Categories

  • SVL7 & Klem VBIOS Mods
    • AMD
    • Alienware M11x R3
    • Alienware M14x R2
    • Alienware M17x R4
    • Alienware M18x R1
    • Alienware M18x R2
    • Kepler VBIOS
    • Lenovo Y400-Y500
    • Lenovo Y410p-Y510p
    • Lenovo Y580-Y480
    • Legacy BIOS/VBIOS
    • Maxwell VBIOS
    • Sony Vaio SVS13 / SVS15 series
  • BAKED BIOS Mods
    • Clevo
  • Utilities

Product Groups

  • Tech|Inferno Elite Membership
  • Hardware

Categories

  • Frontpage News
    • General News
    • Reviews
    • Hardware News
    • Software News
    • PC Gaming News
    • Science & Technology News
  • Promoted Posts
    • Guides
    • Hardware
    • Software

Categories

  • Hardware
    • Notebooks and Components
    • Desktop and Components
    • Phones
    • Accessories
  • Software
    • PC Games
    • All Other Software

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Steam


AIM


MSN


Website URL


Yahoo


Jabber


Skype


Location


Interests


Occupation

Found 4 results

  1. Hey guys, Let me introduce you my eGPU setup, realized on a 2013 15" retina Macbook Pro, model equipped with a dedicated GT 750M. I am using an Akitio Thunder2 PCIe enclosure and a EVGA Geforce GTX 1060 SC 6Gb. I wanted to use both internal and external display on my Mac. I was looking for information during weeks before buying it and wasn’t really sure if it would work as I wanted to. Many people are convinced that using the internal screen is impossible or way more complicated if the Mac has a dedicated GPU. I spend a whole week formatting and testing, using UEFI, BIOS, considering going back to Windows 7 (not for long)… I finally used Windows 10 UEFI, the programs rEFInd and GPU-switch and nothing else ! No need for an HDMI headless ghost or any program to spoof the number of screens. I made a video to show you the whole installation process, I hope that it will help: My GF did the voice acting as I wasn't convinced by my own If you prefer a text-based tutorial, here are the different steps: 1) Installation of Windows 10 in UEFI mode On the 2013 retina Macbook Pro, the SSD is a PCIe model. This seems related to the UEFI mode used by default when using the Boot camp assistant. If you don’t want to use it or are using another model of Macbook, you can follow this excellent tutorial to force the UEFI mode: http://fgimian.github.io/blog/2016/03/12/installing-windows-10-on-a-mac-without-bootcamp/ You just need to create a conventional partition and convert your table partition from “hybrid” to “protective”. By doing this, Windows will see a GPT disk instead of MBR. You just need to boot your USB drive on EFI mode. Once Windows is properly installed with the correct Macbook drivers (another reason to prefer the boot camp assistant), you need to go back to Mac OS. 2) Installing rEFInd rEFInd is a boot manager tool, like rEFIt or GRUB. Its first advantage is the ability to choose the OS without the need to press a key at startup. And the real reason why we are using it is to spoof the computer to allow Windows seeing the entire installed hardware. You can install refind from this link: http://www.rodsbooks.com/refind/ Then you need to activate this spoof ability by opening a terminal and typing these two commands: sudo mkdir /Volumes/efi sudo mount -t msdos /dev/disk0s1 /Volumes/efi Now, you can see your EFI partition in your Finder. Go to EFI/EFI/refind and open the file refind.conf with textedit. Search for the “spoof OS version” and remove the comment symbol # Reboot your computer and choose Windows on the rEFInd screen. Open your device manager, you’ll see your iGPU (intel iris pro graphics 5200) and dGPU (Geforce GT 750M) 3) gpu-switch GPU-switch can be downloaded from there: https://github.com/0xbb/gpu-switch Download the windows version, available in the description (direct link : https://github.com/0xbb/gpu-switch/releases/download/v0/gpu-switch-windows.zip ) Install Microsoft C++ redistributable (not sure which version do the trick, I’ve installed each version in x64 and x86 just to be sure) open the file integrated.bat with administrator rights, you should see the word “success” 4) GPU driver installation Not sure if this step is necessary but I’ve removed the dGPU driver before installing nVidia GeForce experience. The program DDU (Display Driver Uninstaller) is perfect for that. You can download it using this link: http://www.guru3d.com/files-details/display-driver-uninstaller-download.html Choose to uninstall and shutdown the computer, as you will install a new hardware indeed When your computer is off, plug the power supply to your eGPU, press the computer power button, wait for the chime and the rEFInd screen to appear, then plug your eGPU to the Macbook and launch Windows. If rEFInd is stucked, hold the power button until the computer is off. You should now see three graphics cards in the device manager, two of them not recognized at this point. Install nVidia GeForce experience and the latest nVidia driver. The GPU list will be updated at the end of the installation process. Re-launch GPU-switch and reboot. You don’t need to unplug the eGPU when rebooting. Now, your eGPU should have an error code 12, with unsufficient resources available. Just right clic on the dGPU (GT 750M) and disable it. Re-launch gpu-switch just to be sure (integrated.bat) and reboot. Just a last step and you’ll good to go Right click on the nVidia icon in your systray and open the configuration panel. Go to PhysX and set it to automatic instead of processor, like on this picture: That’s it, you can now launch your games on the internal screen or using an external monitor To switch between both, just plug the display on the eGPU and use the shortcut Win + P (Cmd + P on a Mac keyboard) to toggle between both screens. You can also duplicate them, it works, but don’t expect any kind of good performances doing this Now, the most important part, to avoid screwing your configuration: every time you go back to Mac OS, Windows will switch to the dedicated GPU (maybe also when turning off the computer, I’m not sure). For this reason, always re-enable the GT 750M before turning off the computer! Otherwise, you’ll get a black screen at Windows startup. Just follow this procedure when you want to use your eGPU: - Use gpu-switch to set the integrated GPU as primary - Disable the dGPU from the device manager - Turn off your computer or reboot - When you see the reEFInd screen, plug your eGPU and launch Windows - Play you favorite video game or launch your intensive GPU application (there are two schools) - Re-enable your dGPU from the device manager - Turn off your computer - Unplug your eGPU Now, some advices based on my little experience: If your end up with a black screen, you can restore Windows to a previous restauration point or remove the display driver. If you really can’t boot windows, using Parallels Desktop, you can boot your Windows partition from a virtual machine, then remove the display driver. At first, I was experiencing a game crash and the GPU fan running at max speed, when launching any sort of game. This issue was caused by the power supply connection, using an Xbox 360 S adapter with too thin wires These wires caused a voltage drop when consuming the 100W needed when playing a game (against 15W on Windows) About the electrical connections, here are a few pictures I’ve added a connector on the free PCB footprint to avoid soldering wires on the board. The cables are 0,75mm2 section and fits perfectly the original jack hole. About the PCIe power connector at the top of the graphic card, I had to cut it with a Dremel to fit the enclosure. You can find specific (and pretty expensive) cables on Ebay if you don’t want to modify one. For the ventilation, a colleague helped me cutting holes in front of the fan. I’m not sure to keep this solution, as some games make it very noisy. Let me know if this tutorial or the video did help you. Don't hesitate to ask for support if you want to do the same setup. Some websites are pretty discouraging about the concept of eGPU, the whole process is not pretty user-friendly but I'm happy to see that there is an active community growing each year !
  2. Hello! My name is Arman! I from Armenia, and sorry for my English! I have iMac Late 2013 with Intel core i5, 8Gb, NVIDIA GeForce GT 750M 1024 Mb. I have Boot Camp installation on my iMac (now i have 7 Windows, but i can update it to 10 or 8 Windows) I discover that there is an Akitio 2, wich can use with iMac 2013 for productivity increase. I want to use akitio 2 with GTX 1050 ti 4Gb, but i dont know how it is intalling on iMac? Who can write for me the process of installation ALL equipment (akitio 2 + GTX 1050 ti + imac)? What i must to do? I talking about from the very beginning to the very end. PLEASE everyone, help me. You are my last chance !!!!
  3. EDIT: SOLUTION on my 4th post. Hi all, I just wanted to know if anyone found a fix for the cpu idle bug without hibernating. First of all, I made my setup in 2015 and I just used an external monitor since at the time making it work with optimus having a dgpu was unknown. Recently I read that disabling the dgpu was an option so I quickly got "up to date" reading the new stuff, but I might have missed something. Keeping that in mind: I have a MBPr Late 2013 (GT750M dgpu) with an Akitio Thunder Box, with a dell power supply (which I always thought it might not be enough because I had to limit the power with Afterburner to 80% so it wouldn't shut down when playing a few hours) and an Nvidia GTX970 (KFA 4GB). Since I was using a Win 7 on Bootcamp/BIOS I decided to start from scratch: got a Win 10 EFI installed, got reFind so I could activate the visibility of the Iris igpu, and although it seems to be much more buggy, got to run the system with the egpu. Then disabled the dgpu on the device manager, used the switch-gpu bat file as admin to get the igpu as main, so far so good. Shut down, Boot. I get to the point where I basically have the egpu working and I tried running Tomb Raider's benchmark (what I had at hand) and it was going smoothly (which wouldn't be like that with the iris or dgpu). Also, looking at msi afterburner my egpu was at 100%. The ONLY thing that I can't by any means get to work is to not have the CPU idle crazy load. I get around 25-30% of CPU load and if I try to hibernate the system it... well it goes to hell, haha. The MBP seems to hibernate (sleep/shutdown black, fans out) but the egpu is still on with the fans (doesn't really hibernate), and from there its impossible to make it run. Pressing any button, alt, power, whatever, it tries to wake up/power on for a moment, but it simply can't finish, just black screen with the fans turning on. The only way to shut it down is to hold the power button. And after that it basically locks there and becomes even difficult to boot again, I actually have to press alt, go back to osx, reinstall refind - since it no longer appears with it trying to wake up from hibernation- run windows efi and quickly press shift+f8 to run in safe mode and then boot correctly (and again with the cpu load). I have to say that even when working, my macbook pro doesn't consistently boot with the egpu via thunderbolt2, with any combination (wait to plug the cable, have it powered on, off, preboot, when starting windows, etc.) it just seems to randomly work. It used to work a bit better before refind, though, but never consistently (don't know if that has changed in the past years). So... any ideas of how to get that cpu load off? Or to make hibernation work? Oh, as a note, I read that when you disable the dgpu and use the switchgpu script you can control the screen brightness again, but I just have it locked to the max. The control osd appears and moves but it doesn't actually change. I don't care about it but I thought it might give a hint of something not done properly? Many thanks to whoever can give me any ideas!!! EDIT: Reduced part of the cpu idle from known w10 small stuff but the main bug is still there, about 15%)
  4. billmavra

    iMac+EXP GDC+M.2

    Hi guys i am new to the forum and i would like to start with a question. I have an iMac late 2013 2.7 no dedicated graphics and i would like to install an egpu. I have seen many of the suggestions you have in the forum but i would like you to tell me your opinion about what i am thinking to do. I want to teardown the imac + buy the exp gdc m.2/ngff edition and connect it on iMacs ssd slot using this adapter. http://eshop.sintech.cn/ngff-m2-pcie-ssd-card-as-2013-2014-2015-macbook-ssd-p-1139.html. 1) Do you think it will work properly? 2) i was thinking to pass the cable through one of the air ventilation holes on the bottom of the iMac. Can anyone that has exp gdc tell me if it will fit? Thank you in advance.
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.