Jump to content
EwinRacing Flash Series Gaming Chairs

Freddyicy

Registered User (Pre-Promotion)
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Freddyicy

  • Rank
    Curious Beginner

Contact Methods

  • Steam
    Freddyicy

Profile Information

  • Location
    Canada

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Just looking into a new computer and there are so many more options! Just seeing what peoples thoughts are!
  2. I am looking to upgrade from you old Alienware, I heard that this company had many of the old Alienware techs before they sold out to Dell. Any thoughts?
  3. Follow up on this issue incase anyone else is having the same one. I finally broke down and took it to a shop. They told me it was my graphics card! Time to replace it! then do some up grades! Possibly hope this helps others
  4. I have spent a little time in the past few days looking around this site. I would love for someone to point me in the right direction to a forum that has information that could help me out with my problem. I have a: Alienware M17XR3 Windows 7 Home Premium 64-bit Intel I7-2820QM 2.3 Bios InsydeH20 Version 1.0 A12 NVIDIA GeForce GTX 460M (4x) 4 GB Ram samsung 2.5" 256 SSD (SATA3.0Gbps) It has been an amazing machine for the last 10+ years. Minor issues, nothing that an Alien Respawn could not fix, till now! On battery power it works just perfect. Then I plug it in and it's all OK until I try to do anything, and then the screen goes white. The screen sometimes goes yellow, sometimes blue, but mostly white screen. It will do nothing until I do a hard reset (holding the power button till it turns off and turn it back on) with the power unplugged. If the power is not unplugged then it will go through boot up to windows swirling dots then go white again. If I plug it in and do nothing I can charge it, unplug and continue what i was doing. I have tried a lot of solutions bouncing around the internet, and thought I was having a DC Jack connection issue (replaced the ac/dc power adapter, then the motherboard). I get a better connection now but with the same white screen result. I stumbled into this forum and I'm hoping to find solutions to my issues. Then upgrade like so many others have. Any ideas, comments or suggestions welcome. Thank you in advance!
  5. I am looking to do this same sort of set up to my M17XR3 as well, been a great computer for me! Just starting to learn how to change parts and pieces and came here for some of the knowledge and expertise that i hope to find here for troubleshooting some of the problems i am experiencing. Love to hear how well this worked out.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.