Jump to content

kkzhe

Registered User (Promoted)
  • Content Count

    21
  • Joined

  • Last visited

Community Reputation

10 Semi Elite

About kkzhe

  • Rank
    Junior Member
  • Birthday 12/23/1993

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. kkzhe

    Clevo P150EM + GTX 970M FPS Issue

    Nope, I just flashed the vBIOS from prema's site which I thought might be updated compared to the one that came with the card. The one with the card only allowed me to use drivers from 359 and below, but after flashing the vBIOS again I was able to update it to a 361 driver which worked.
  2. kkzhe

    Clevo P150EM Slow USB 3.0 Speeds

    Yeah, I've tried downloading it directly from the eurcom site but the driver only supports Windows 7 and I 've got windows 10 so I get a compatibility error message. I've also tried running it in compatibility mode, but it still doesn't work.
  3. kkzhe

    Clevo P150EM + GTX 970M FPS Issue

    ***SOLVED***
  4. kkzhe

    Clevo P150EM + GTX 970M FPS Issue

    Hi sirana! Thanks for the tips. I did all of the above, but still nothing. CSGO is getting less than 50 FPS in the main menu and even less in game. I've been checking for any nVidia GPU activity but everything seems to be taken over by my intel HD 4000 integrated graphics. I noticed that after unintsalling the intel display driver, my 970M was finally showing some activity but I wasn't able to start a game to see if it was actually working due to crashing caused by insufficient specs I believe it was. MSI Afterburner is reading my nVidia GPU's temps, but there it is flatlining every other graph regarding GPU usage.
  5. kkzhe

    Clevo P150EM + GTX 970M FPS Issue

    Hi all, I've my GTX 970M working for a good while, but I decided to re-apply the thermal paste today because my card seemed to get a bit hot and my gaming would suffer from fps drops. I figured re-applying the thermal paste would work, but it didn't. I then uninstalled the drivers and tried reinstalling different drivers to see if they'd perform better, but for some reason my FPS is constantly below 60 FPS no matter what game it is. I've tried checking my settings in nVidia control panel, I tried flashing the vBios, I've changed countless settings to try and make it work but nothing is working. I also noticed that when I use Speed Fan, the GPU section doesn't consistently show my GPU temps. It stays at 0 Celsius for the most part, but then randomly reads 47 Celsius. Any ideas of what could be wrong or how to possibly fix this?
  6. kkzhe

    Clevo P150EM + GTX 970M FPS Issue

    Hi all, I've my GTX 970M working for a good while, but I decided to re-apply the thermal paste today because my card seemed to get a bit hot and my gaming would suffer from fps drops. I figured re-applying the thermal paste would work, but it didn't. I then uninstalled the drivers and tried reinstalling different drivers to see if they'd perform better, but for some reason my FPS is constantly below 60 FPS no matter what game it is. I've tried checking my settings in nVidia control panel, I tried flashing the vBios, I've changed countless settings to try and make it work but nothing is working. I also noticed that when I use Speed Fan, the GPU section doesn't consistently show my GPU temps. It stays at 0 Celsius for the most part, but then randomly reads 47 Celsius. Any ideas of what could be wrong or how to possibly fix this? **EDIT** So I've noticed that the card just isn't working at all, which explains the low FPS. Although i'm not entirely sure why it's doing that. MSI Afterburner shows that it doesn't have any activity as well as the built-in nVidia GPU activity application I've got going on my task bar. In-game the icon isn't even colored, it's just black and white. I updated my bios with Prema's latest for my P150EM and I flashed my vBios, but still nothing. I've also tried installing 5 different drivers and they all yield the same results. Help would be much appreciated!!!!!
  7. kkzhe

    Clevo P150EM Slow USB 3.0 Speeds

    Hi all, It didn't dawn on me until recently after I purchased a new external harddrive with USB 3.0 that the transfer/write speeds seem to be really slow for USB 3.0. It got me thinking so I checked the Eurocom website for my laptop model for the drivers and they don't have drivers for USB 3.0 eXtensible Host for windows 10. I went onto Intel to try and find it but I couldn't find the drivers for windows 10 either, only windows 7 and 8. Any idea what might be the issue here and how to get my speeds up to par?
  8. kkzhe

    Clevo P150EM + GTX 970M

    Don't use the latest drivers. I'm using 358.50 so hopefully that'll work for you too
  9. kkzhe

    Clevo P150EM + GTX 970M

    Sorry, I wish I could help you!
  10. kkzhe

    Clevo P150EM + GTX 970M

    Yeah, I've done exactly what that video I link shows, but when I type into command prompt screen it closes on its own. The person I bought the card from provided me with thermal pads so I couldn't tell you even if I wanted to, sorry.
  11. kkzhe

    Clevo P150EM + GTX 970M

    Okay, well it's good to hear that the buzzing is normal. I've tried running the ModMe.bat file but it just says that it can't open the 970vbios.rom file. I've also tried running the nvflash.exe file but it quits on its own and doesn't allow for any typing. I tried using this video as a guide, but all of the menus close on their own. NVIDIA Inspector says that my current bios is 84.04.22.00.EC [MODIFIED].
  12. kkzhe

    Clevo P150EM + GTX 970M

    Hi all, I just received and installed a new GTX 970M into my Clevo P150EM. It was a bit tricky at first but I finally got it to work by modding the .inf and installing the 358.50 driver from nVidia. However, I had a couple questions. The card is working but I can hear a buzzing sound when playing GTA V, The Witcher 3, etc... Also, when the game is fullscreen and I click anywhere within the game, the screen flickers and then minimizes. I've also been trying to figure out how to flash Prema's vBios for the 6gb 970M onto this card, but whenever I try to take the write protection off a menu pops up with a beep but then promptly disappears. Any help would be greatly appreciated!
  13. kkzhe

    Clevo P150EM + GTX 980M

    I was actually looking online on eBay for cards similar to mine, but the ones that are going for around $400 dollars all have 2gb, whereas the 4gb version on rj-tech is going for upwards of $900. Is that just rj-tech blowing up the prices out of proportion or am I missing something here?
  14. kkzhe

    Clevo P150EM + GTX 980M

    Yeah, I was actually looking through rj-tech and thought they'd be the cheapest option. I was a bit confused because the P150EM wasn't listed under the models so I wasn't exactly sure whether or not it would be compatible. So this GPU from rj-tech would be the one to get for my laptop, correct? Apologies in advanced, I'm still new to all of this upgrading stuff!
  15. kkzhe

    Clevo P150EM + GTX 980M

    Thanks for the insight. I'm hoping to be able to sell my 680M for around that price so hopefully there is a pretty good market for this card. I'll probably just go ahead and purchase a thermal pad to put onto the 980M. I'm pretty new to customizing the internals of a computer, especially a laptop, so will I need to buy a thermal pad AND thermal paste to apply?
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.