Jump to content
bleeper4

HP Pavilion dm4-2191us + GTX560Ti + mPCIe2 (EXP GDC V8) + Win10

Recommended Posts

HP Pavilion dm4-2191us, 8GB RAM, 250GB SSD, Windows 10

EVGA GTX 560 Ti (1GB VRAM?)

Blue Star 650W PSU

EXP GDC Beast V8.3 (from GearBest)

 

Hey guys, just got my GDC Beast V8 in yesterday and put my eGPU setup all together. I know my PSU works and I know my GPU works (tested in another machine). My HP laptop has whitelist, so I tried booting with my wifi card, putting computer to sleep, hotplugging mPCIe adapter in, and turning the computer back on - but windows doesn't detect the GPU. I've also bought DIY eGPU Setup and hotplugged whilst in that, and even then the GPU doesn't register. I tried doing the same on another (Dell Inspiron 1420) laptop, with the same results. I can't figure out what is wrong, short of the HDMI to mPCIe cable being bad. But it doesn't seem bad since the GPU/PSU turn on/off when I turn my laptop on/off.

 

Further, I've tried taping over pin 22, as well as hotwiring the PSU to be always on before hotplugging the adapter into my mPCIe port. Still no luck.

 

Are there more settings I need to be changing in DIY eGPU Setup, such as link speed or width? I really thought hot plugging was the defacto tell on whether or not your setup works or not. Thanks for your help!

Share this post


Link to post
Share on other sites

Update, I finally got the card working (needed 2 PCIe 6-pin power plugs!), but now I have driver issues. I can boot with my internal laptop screen and see my card (with no PCI compaction or anything), but once I install Nvidia drivers and reboot, I get a BSOD with SYSTEM_SERVICE_EXCEPTION. I assume it's because my drivers are incorrect. I've tried standard drivers straight from nvidia, as well as drivers with modded .inf for my specific card.

From there I've also tried PCI compaction. I can only compact iGPU + eGPU successfully; anything else messes up my SATA and DIY Setup can no longer read from the hard drive. But PCI compaction doesn't fix anything.

 

I've also come across a case where if I warm reboot (instead of cold shutdown and reboot), my BIOS sees the eGPU as primary and disables my iGPU (Intel 3000). I've tried toying around with drivers in that configuration as well, with no luck.

 

Any help appreciated, thanks!

Share this post


Link to post
Share on other sites

Update, finally got everything working. The conclusion I've come to is that PCIe gen1 with Optimus is too slow for me. Cross-posting some thoughts I posted on the EXP GDC thread:

  • I couldn't get gen2 speeds to work on it at all. I told the guys I bought it from, and they were kind enough to send me another Beast, so I actually took it, removed the HDMI socket connection, and soldered the cable directly to the Beast's PCB. It still did not work in gen2 but it did work on gen1 still.
  • At PCIe gen1 speed, the GPU bus is almost always saturated (e.g. at 100% usage). This will be your bottleneck 90% of the time, unless you are only running a GPU stress test. You can download EVGA Precision x16 and see for yourself; put the bus usage on the overlay while you play a game and watch it. By comparison, I have another laptop with an nVidia dGPU, and I can watch its bus usage stay below 10% all the time, just because it is tied via x8 or x16 connection (and probably PCIe gen3).
  • I play CS:GO a lot and wanted an eGPU to up my frames; sadly I don't think this is a good solution for me. I have not tried a gen2 speed adapter, but I don't think it would work even then. With gen1 speeds I get micro-lags every time I see an enemy, likely because at that exact moment the processor and GPU are communicating vigorously, and my GPU bus doesn't allow the information to travel that fast. I wonder if the same will happen on gen2 speeds, but to a lesser extent.
  • The particular Beasts I received from GearBest had a few missing things about it. It was missing an on switch even when there was space for it. The delay switch (0sec - 7sec - 15sec) was there but if you look at the PCB, the components around it are completely missing, so the switch does nothing. And, the Beast has a USB port, but as I was soldering the cable I discovered that the USB port did not connect to the HDMI cable at all, so USB doesn't work (though I haven't tested it in reality). I think these are ways to cut costs on manufacturing...though admittedly these are tiny cost cuts.

Hope that helps!

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

You should avoid Optimus as it adds noticeable latency. Use kyran 30awg wire or PATA/SCSI (preferred) solder the wires, then tape the entire wire (shield) with copper tape, and connect ground to the copper tape. Don't do twists, single flat 90 degrees is ok, helix like twists are bad. Keep no-dry flux over the soldered pins/contact with wire. Then cover the copper tape with kapton tape to avoid shorts. I was able to do pcie 3.0 gen x8 with my mxm laptop, should be easier with mpcie @gen2.0

Sent from my LG-D855 using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By sslmm
      Hi there!

      I'm interested to know what is the best Wifi/bluetooth adapter that i can install on a clevo P150EM. All new models come in M.2 form factor, and the P150EM only has the mPCIe conection.

      I've searched and found out that there are m.2 to mpcie connecter adapters but i don't know if the adapter+ the wifi card will fit under my keyboard (the place where the mpcie is located), and even if it fits, i still need connector adapters for the antenna plugs.

      Any help is much apreciated
    • By bavnotroclum
      Posted March 27
      Hi folks
       
      I am trying to do a project  feels like a project for me -) with w100er - Windows7 , Intel 3632q, HD4000 , dGPU - 650m  and eGPU 1050 - using EVGA 500b as a PSU..
      I looked around in the last 3-4 days but I am stuck with error 43 sometimes error 10) .
      I installed Prema Bios just yesterday after some worries about ruining my good 11inch  friend , but that gone well.
       
      I tried with couple of nvidia packages and on couple of occasions it get to the point of 1050 recognised as such but not starting - because of the error I presume.
       
      1) I used safe mode / no network  to deinstall the drivers using DDU
      2) Then again in Safe  Mode /no Network i used to install package and disable 650m graphics
      3) I looked into Prema Bios but couldn't see any options of PCI enabling for hot swapping  ...?
       
      I looked into the corecting the .info files of NVIdia installation but could,n make it up what exactly to write and read that if using Premas Bios could be avoided that step.
       
      I have tried to find a Bios for w110er with PCI unlocked but the last ones that I found and installed  ( just for that reason ) Win7 v1.5 UV EDITION  and OUV editions - did not have that options.
      I saw that BIOS for W230 probably have it  but I am not sure could be used in any way /modification for my laptop.
      I managed to  make recognised  GTX 1050 and I eve tried to install 720.20 but couldnt despite trying with modified by e .inf files  copied lines from 375.63 or 375.95
       
      I saw on forum about success with 1050ti in similar manner - installed 372.20 and straight after that removing Register coded requirements for reboot - another later version
       
      Any advice which way to go ?  I should decide if  I am going to return the 1050 card and go for RX 480 or something else - I preferred Nvidia because I had a thought of using the internal monitor and looks less power hungry ( 1050 ) compared to 1060  /RX 470
       
      Thanks
    • By Raoul
      For Sale - Bplus: PE4C version 3.0, PCIe x16 interface for mPICe; Length 60c
       
      Specifications
      Description (derived from Amazon.com):
      Support two delay switch to avoid registration problems when boot. (SW1, SW3) Support two sets external pin to setup delay time. (J2, J4) PE4C V3.0 is mPCIe 1-Lane 8.0Gbps bandwidth limit passive adapter in compliance with Expresscard 3.0 specification Cable length of 60cm (cable is rather stiff) PE4C V3.0 package DOES NOT include an AC Adapter an APU  
      More information on the adapter:
      http://www.hwtools.net/Adapter/PE4C%20V3.0.html (see the mPCIe version) https://www.amazon.com/gp/product/B00ZI33ZQK/  
      Condition:
      Used - Very Good The longer mPCIe fixtures have been removed! (see pictures) Originally bought from M-Factors Storage on Amazon.com on August 30, 2016. Adapter has been used to connect a NVIDIA GTX770 to a SONY VAIO VPCSB2C5E laptop running Windows 10.  
      Transaction Details
      Shipping with: DHL/Deutsche Post or local pick-up
      Shipping from: Munich, Germany
      Shipping to:
      European Union (free shipping) Switzerland (+10 USD) United States of America (+12 USD) Anywhere else (+12 USD)  
      Price: 47 EUR, 50 USD, or 0.05 Bitcoin
      Payment: Paypal, Bank Transfer, or Bitcoin
       
       
      Please feel free to contact me! I am happy to answer any questions or provide additional information and pictures.
    • By Dr. Spacetime
      Hey
       
      Is it possible for me to connect an eGPU to my laptop via the mPCIe port?
       
      I’m trying to connect an eGPU to my laptop, the laptop is a HP Pavilion TS 15 Notebook PC and I’m trying to connect a GeForce GTX 750 Ti via a PCIe x16 adapter (PE4C V3.0) that connects via an expresscard, but the problem is that it turned that out my notebook did not have an expresscard slot (I had somehow mistaken the memory card reader for an expresscard slot), so I tried using an expresscard to USB adapter, the graphic card starts spinning when i start my laptop but it can’t detect the graphics card and I’m having a lot of problems with the drivers, so I’m guessing that connecting it via a USB doesn’t work, is this true?
       
      But if this is true I was thinking of instead connecting it via the mPCIe slot, but I don’t know if my laptop is compatible with mPCIe and I’ve also heard that HP whitelists its mPCIe ports, if this is true is there anyway you can get around this?
      So what do you think, any hope?
       
      Some system specs:
      Operative system: Microsoft Windows 10 Home
      Version: 10.0.14393 build 14393
      Processor: AMD A6-5200 APU with Radeon(™) HD Graphics, 2000 Mhz
      BIOS version: Insyde F.02, 2013 08-06
      RAM: 8,00 GB
    • By NoScopeNinja25
      I am having trouble setting up my egpu for a Dell Inspiron 15R-5521.  I can't get it to detect my egpu.  I have egpu setup 1.30 installed on a usb drive but I can't get it to chainload to windows.  It works fine if I plug it into my destop PC so I know it's not the egpu board.  The only thing I can think of is to reformat the hard drive to mbr instead of gpt, but I don't want to do that if I don't have to.  Please help.
       
      Notebook
      15" Dell Inspiron 15R-5521
      i5-3337U 1.8GHz CPU
      8GB RAM
      Intel HD4000 iGPU
      Windows 10
      eGPU hardware
      ELEGIANT PCI-E USB 3.0
      EVGA GTX750Ti video card
      Corsair CX 500 PSU
      Samsung External Display
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.