Jump to content
EwinRacing Flash Series Gaming Chairs
Strack

14" Lenovo T420s (working in progress)

Recommended Posts

Hello guys,

 

First of all, really appreciate this project and I want to thank to all of you guys sharing your experience and creating such a great community.

if there's anybody that managed to do it successfuly on this Thinkpad model, please PM me so I can talk with him, and I promise at the end I will post a full guide for this type of Thinkpad (wasn't able to find more that 2 posts related to this type of Thinkpad, and at one nobody responded, the second one I cannot find it anymore).

I decided to start my own eGPU project, on my Lenovo Thinkpad T420s. 

 

I have waited for the PE4C-EC060A V3.0 ( eGPU PCIe x16 interface for ExpressCard) to be released and decided to order one (since Thinkpad T420s has an Express Card port) but instead I ordered an PE4C version 3.0, PCIe x16 interface for mPICe; Length 60c  and it has been shipped. I than opened my laptop and I've noticed I do have a 2nd mPICe slot, and here comes my first question:

1st question: do you guys recommend me in switching to the Express Card version, or the mPICe one behaves the same as the Express Card one? The only inconvenience is that it will be harder to plug it in and out, since I take my laptop to work at a daily bases.

 

Looking at the requirements, I saw that it is possible to do it for this type of laptop by having a bios version of 1.3x. 

2nd question: The bios version of 1.3x refers to the bios versioin developed by @Tech Inferno Fan, or just the market one? ( I currently have 1.31 installed).

 

I than need to consider what GPU to order. 

The post that I found about GPU installed on a Thinkpad T420s, it was talking about an Geforce GTX 570 (from what I remember - this is the post that I cannot find anymore) . 

I was thinking about buying an GTX 750 Ti OC2 2GB, beeing a 3rd Generation that seems to work with the PE4C V3.0, but while reading the forums, most of the guys installed a 2nd Generetion GPU.

3rd question: Does anyone know if the PE4C v3.0 Gen3 is stable or it';s safer to go with older GPUs.

 

That's it for know.

 

Thanks and really appreciate the support.

 

Regards,

 

Strack

Share this post


Link to post
Share on other sites

1) Expresscard can be either one PCIe 1.0 lane or one PCIe 2.0 lane. mPCIe can be either one PCIe 1.0 lane, or one PCIe 2.0 lane, or even one PCIe 3.0 lane. Assuming both are the same generation in your case (and they quite likely are), then they behave identically (but, as you pointed out, the Expresscard is a lot more convenient). mPCIe is more likely to have a BIOS whitelist of some sort, however, so if it doesn't work, Expresscard might still do.

2) Sorry, no idea...

3) The link speed established via the PE4C will be dependent on the host laptop. Since the T420s is an older model, it will establish a PCIe 2.0 link, regardless of the video card you use. That said, the GTX750Ti should work.

Share this post


Link to post
Share on other sites

1. They are the same in the context of the T420s. Except the BIOS whitelist, but I don't think that applies to the second mPCIe slot. If you do run into a whitelist issue, I'm sure there exists a BIOS mod for the T420s that removes the whitelist.

2. That depends. Has anyone really been far even as decided to use even go want to do look more like? I've been further even more decided to use even go need to do look more as anyone can. Can you really be far even as decided half as much to use go wish for that? My guess is that when one really been far even as decided once to use even go want, it is then that he has really been far even as decided to use even go want to do look more like.

3. Doesn't matter.

Edited by Arbystrider

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By jcrcarmo
      Hi folks,
        Greetings from Brazil!  Not sure I'm posting in the right place, but I have a question:  how do I find out the brand and model of my BIOS chip without having to open my laptop?  I can't find this information anywhere.  Been searching for days... I have a Lenovo Ideapad 300-15ISK 80RS (motherboard Paris 5A8).  Thanks a lot for your time and help! I really appreciate it!   Best regards,   JC.
    • By PrecastFlame
      Hi, I'm having problems trying to connect a GTX 750 Ti to my Lenovo T420 using the dock EXP GDC Beast (express card version).
      My laptop: Lenovo T420
      RAM: 8GB DDR3
      CPU: Intel Core i5 2520M
      GPU: Intel HD Graphics 3000
       
      My problem is: if I plug the express card and I turn on the laptop it doesn't boot up and the screen becomes horrible, with coloured pixels and a sound like "bip-bip".
      If I try plugging the express card when the laptop is already turned on it sees the gpu, but if try installing the drivers I have to apply the modifies restarting the computer.
      I hope you understood my problem (I don't speak English very well).
      Please help me, It's making me crazy!
       
      EDIT: I didn't say that if I plug the express card when the pc is already turned on, in the device menager there is "Error 12" on the gtx 750 ti
    • By Kel
      I got the exp gdc beast 8.5 got all the connections right... laptop boots up... fans turn on the gpu.... device manager detects gtx 1060 with a “ ! “ in a yellow triangle. Now what to do.... i tried to do the bios mod.... but realised that i have 3.07 version. 
      Questions-
      1 is there any way to get this done without the mod?? 
      2 if mod is the only way... kindly help me with step by step instruction in laymans terms... i m not a techy... so i might not understand technical terms.... altho i am interested... but learning yet. Please help. 
    • By Klem
      In this thread you can post your requests for Lenovo Y50-70, Lenovo Y70-70, Lenovo Z50-70, Lenovo Z70-70, Lenovo G50-70, Lenovo G70-70.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, or unlocked vbios for overclock NVIDIA card, then you can post your request in this thread. Also, if you have a problem with fan pulsating/clicking on any modified bios then you can post your request in this thread.
       
      The flashing procedure include two steps:
      1.  Flash main system bios.
      2.  Flash EC firmware.
    • By rusTORK
      When my first CPU fan on Y500 is broke i replaced it on something compatible (non-original) and planned to replace it later on original. Since that time happened a lot things, but i still using that non-original fan. But i did some research and here is what i founded:
       
      I. ORIGINALS
       
      1. Forcecon (marked as FCN on fan)
      DFS5413005MH0T-FC1C (5V - 0.5A)
      Spotted in: Y400, Y500.

       
      2. Asia Vital Components (marked as AVC on fan)
      BNTA0612R5H-P007 (5V - 0.5A)
      Spotted in: Y410p, Y500, Y510p.

       
      3. Sunon (marked as SUNON MagLev on fan)
      MG60120V1-C230-S99 (5V - 2.25W (0.45A))
      Spotted in: Y410p, Y500.

      So, which to choose? Any recomendation? Maybe there also unexpected way (completely diffirent fan from another company for another laptop)?
       
       
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.