Jump to content
EwinRacing Flash Series Gaming Chairs
None696

MacBook Pro Retina mid-2012 OS X 10.11 / Win 10

Recommended Posts

First off I want to say thank you to the community here. I wouldn't have been able to do any of this without the hard work and dedication of everyone who blazed the trail before me and shared their experience. 

 

I wanted to post my success story in case others  were trying to do something similar. 

 

Hardware

  • 15" MacBook Pro Retina, Mid 2012
  • 2.6 GHz Intel Core i7 (Turbo boot to 3.6 Ghz)
  • 16 GB 1600 MHz DDR3
  • Sonnet Echo Express SE II
  • Asus NVIDIA GeForce GTX 980 4 GB
  • LG Ultrawide 34" 34UC97 curved 4K display [3440 x 1440 @ 60 Hz]
  • Apple Cinema Display 20" (2006 or 2008, I forget) [1920 x 1200]

 

OS X (worked on both 10.10 Yosemite and 10.11 El Capitan

I've been successfully using my eGPU under OS X for over a year. Thanks to Goalque's Automate eGPU script. Really is super easy. Major props.

 

Some thoughts, in no particular order

  •  Original setup was using the MBPr in clamshell mode in a Hinge Dock --> Did not work well, issues booting, internal screen stayed on
  • Updates can randomly break everything --> easy fix with the automate eGPU script
  • Very stable --> quite pleased with the success 

 

Windows 10

Just got this working last weekend. I originally used bootcamp, which on my device sets up windows to use MBR. Could not get it to work even with the help of Setup 1.30 / 1.2. Out of boredom I nuked the windows partition and re-configured everything to boot EFI. I eventually got everything working using the DSDT override. 

 

Some additional thoughts, in no order

  • The integrated  Intel GPU causes all sorts of trouble. Windows updates drives a lot without telling you. Causes blue screens. Needed to keep disabling the device in safe mode
    • This slowed down and frustrated the process, often times I didn't realize the integrated GPU was causing issues
  • I believe the DSDT override was done correctly, and after that everything began working correctly (the large memory device is in device manager, but there is nothing below it)
  • My game of choice is Heroes of the Storm. Conveniently I can test it in both windows and OS X. 
    • It runs much better in OS X
    • Seems to be CPU limited.
      • In OS X Turbo boost is constantly overclocking to 3.4 GHz. CPU temp in the mid 90s. Fans at Max. (GPU does not seem pushed, fans slow). 50-70 FPS @ max res, mix of Ultra on more GPU intensive settings and Low on CPU settings
      • In Win 10, Turbo boost was all over the place 2.8-3.2 GHz. Game was much choppier. 25-60 FPS. CPU temps were ~102. Same settings. 

 

I have screenshots of everything. Unigine Valley benchmarks in both OS X and Win. I'll add tomorrow. 

 

Realize this may not be a great guide for others trying to replicate, but wanted to share my success story as a guide post for others with similar hardware. And to say thanks again to the community. I've been an avid reader of the guides and other builds as I worked through mine.  

 

Feel free to ask any questions. I'll help where I can. 

 

 

Share this post


Link to post
Share on other sites

Do you have the Idle CPU load bug? When you boot Windows, is there already a constant 10-20% load that does not fade?!

If yes, try and hiberante your MacBook with the eGPU for 1min and wake it up again.

Share this post


Link to post
Share on other sites

Are you running 64bit Windows 10? I can't seem to get the eGPU past the Code 12 error. Windows see's the 980Ti, but it can't get enough resources. I've tried everything I can think of even bought setup 1.3, but can't get it to work properly with EFI.

 

Thanks.

Share this post


Link to post
Share on other sites

Hi none, it looks strange you get high performance playing games in OS X than WIN

 

I have also MBPr Mid 2012 and works better when playing games in WIN, not huge but you can see the difference.

 

Those temperatures are really high, I strongly recommend you change thermal paste and use Mac Fan Control Software, I can´t remember the exact temperature before i changed the paste.

 

Temperatures.png

 

Could you compare your temperatures with mine please?

 

This is my MBPr 2012 just with Safari, some mail, just regular use. 

Edited by Charly

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By m0ng0
      First post. Hope this helps some of you. Now to change your power plan to ULTIMATE Performance. Just toss this in Powershell or Command prompt as ADMIN,
       
      powercfg -duplicatescheme e9a42b02-d5df-448d-aa00-03f14749eb61
       
      Then Check out your Power plan settings.  Wifi power settings are great for performance.
       

    • By m0ng0
      First post. Hope this helps some of you. Now to change your power plan to ULTIMATE Performance. Just toss this in Powershell or Command prompt as ADMIN,
       
      powercfg -duplicatescheme e9a42b02-d5df-448d-aa00-03f14749eb61
       
      Then Check out your Power plan settings. 
       

    • By TheLoser1124
      Hello, A couple of days ago I got a new GPU but when I installed it into my computer I was unable to use it but now I know why. When checking the device manger I went into the events tab of my GPU when I went to view all events, I noticed an error it said " event 411 kernel PnP " and It also said Problem Status: 0xC01E0438. I believe this is why my GPU hasn't been working on my PC. If you know how to fix this problem or have info on how to fix this problem that would be greatly appreciated. I'm also using a EVGA NVIDIA GeForce GTX 1660.
    • By Rommancen
      Hello. I want to install Windows 10 on my old man msi gt 680. If someone has already done this, please write. What drivers were installed, does turbo boost work normally, does the touch panel work completely? thank
    • By adam.jakey
      I have always been a big fan of Windows 7. I have 4 Media PCs throughout my house and a laptop. I have recently updated some of them to Windows 10 Pro. I have tried everything to get them talking on my LAN. I cannot share files anymore. They all ping, but are missing in the network folder. Thank God for Plex. Any advice? 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.