Jump to content

Recommended Posts

Hey Everyone,

 

I'm looking for some testers to see if we can get LEGACY SUPPORT for the m17xR4.  

Furthermore, I've also done MANY updates on this bios, too...  

 

I updated RAID (EFI & LEGACY) to v12.9.0.2006 (This may need to be downgraded as the chipset you have may NOT support this raid version, but this is the latest version that will work IF youre running RAID.  It also supports TRIM in RAID0.  If you are not running raid, I can update to v13 if you want, but we need to test one at a time!)

Updated GOP Drivers & GOP Policy

Updated vbios from 2098 to 2171

Updated Microcode for all cpu's

Added M.2 Support

Added NvMe support

Updated Atheros Lan Firmware & PXE Boot Firmware

Updated To Possibly Give Legacy Support, BUT.......

 

I NEED TESTERS!!! :)

 

Please contact me if you want to try.  Understand, HOWEVER, that  am NOT responsible for ANYTHING that happens to your system if it goes wrong.

(Just a SMALL disclaimer, heh)

 

Thanks,

Swick

Edited by Swick1981
  • Thumbs Up 2

Share this post


Link to post
Share on other sites

hi, i have m17x r4 and i use legacy mode.... (i havent uefi set in bios).

 

are u referring to that ?

Share this post


Link to post
Share on other sites

Hello, can I test your mod bios for m17x R4.

I'd be very glad to be a tester.

Thank you,

Share this post


Link to post
Share on other sites

If this project is not dead @Swick1981 I can help testing - have a spare M17x R4, GTX 970m and eeprom programmer so can easily recover from any bad flashes :-)

 

Kind Regards,

 

Jon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By handale30
      I added this post in the another forum a few months ago but felt like it could also help someone here, enjoy... So ive owned quite a few Alienware laptops but out of all of them my favorite has always been the great m17x R4. I love its aggressive looks, its lines and grills remind me of lamborgini design, the 1 glass sheet screen, the media keys looked futuristic and its laser etched name plate added a touch of personalization and attention to detail that they used to have. So considering it still has powerful specs for modern standards, i7 processors, 32gb ram, 2ssd and 1msata slots, 120hz 3D display, mxm slot, sd card reader, I couldn't help but to sell my 2 current laptops (15 R1 980m, 4k, 15 R3 1060) and purchase a pristine example of this machine with all its original packaging to upgrade it up to todays specs.   The Original Specs of this particular system were:  * Intel i7 3820qm 2.7ghz / 3.7ghz  * Nvidia GTX680m 2gb  * 8gb DDR3 RAM 1600mhz CL11  * 250gb Samsung 840pro SSD  * 1tb Seagate Momentum HDD  * 17" 1080p 120hz 3D display Desired Upgrades:  * Intel i7 3940mx 3.0ghz / 3.9ghz  * Nvidia GTX 1070 8gb  * 32gb DDR3 Ram 1600 CL10 Corsair  * 1tb Samsung 860 EVO SSD  * Liquid Metal and better thermal pads    2019 Specs: * Intel i7 3940mx 3.0ghz / 3.9ghz  * Zotac GTX 1070mxm 8gb  * 32gb DDR3 Ram 1866 CL9 Corsair Vengeance  * 1tb Samsung 860 Evo SSD  * 256gb Samsung 840 Pro SSD  * Liquid Metal and Fujipoly 17w/mk thermal pads  * 17.3" 1080p 120hz 3D display   I already purchased the GTX 1070 mxm, 32gb RAM and the 1tb SSD. The GTX1070 is installed and working at its full power. I applied Thermal Grizzly Conductonaut liquid metal thermal compound to both CPU and GPU and Fujipoly ultra extreme 17.0 W/mK thermal pads with my modified GPU heatsink and new X-bracket. CPU is overclocked from OEM BIOS to stage1    4.1ghz  3.9ghz 4cores. No chasis or board was cut or damaged during this process as I wanted to keep its integrity and no throttle issues what so ever. As I already had the 120hz edp screen, it was an easier job to do and thanks to @Striker123 and to @D4ddy for their threads as they made me have the guts to go through the project and to Rick for selling me this perfect example of a computer.   Alienware m17x r4 1070 mxm http://forum.notebookreview.com/threads/msi-gtx-1070-mxm-successfully-working-on-alienware-m17x-r4-another-socket-victory-against-bga-crap.803637/ Alienware m17 Ranger 1070 mxm http://forum.notebookreview.com/threads/alienware-17-r5-gtx-1070-mxm-3-1b.800137/   Here are some before and after benchmarks so you can see this baby flying let me know what you think about these numbers... I will be uploading more pictures soon as it only lets me upload 5. If you guys have any questions id be glad to help out.   current issues:    - the GPU fan does not automatically work so I have to use HWinfo to manually build the fan table but HWinfo sucks balls at this and doesn't start them automatically either, also with HWinfo I take control of both CPU and GPU fans at the same time and sometimes I just want my CPU fan to be spinning. so if someone has a fix for this man that would be great!    
    • By Klem
      In this thread you can post your requests for Lenovo ThinkPad T450s.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, then you can post your request in this thread.
      Important!
      For creating bios backup and to flash bios mod, you must use any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip!
       
      Just dump your Bios using any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip, then post it in this thread or upload it to any fileserver and send me the link.
       
       

      CH341A programmer:
      https://www.ebay.com/itm/USB-Programmer-CH341A-Series-Burner-Chip-24-EEPROM-BIOS-Writer-25-SPI-Flash-AU/153117073868?epid=577511738&hash=item23a67d21cc:g:XKEAAOSw5UdbW-iL
       
      https://www.amazon.com/Parts-tower-CH341A-Programmer-Software/dp/B01FVVHCVC/ref=sr_1_4?ie=UTF8&qid=1522179315&sr=8-4&keywords=ch341a&dpID=51BO7eGgO5L&preST=_SY300_QL70_&dpSrc=srch
       
      SOIC8/SOP8 test clip:
      https://www.ebay.com/itm/Soic8-Sop8-Flash-Chip-Ic-Test-Clips-Socket-Adpter-Bios-24-25-93-Programmer/201414947737?hash=item2ee5443399:g:up8AAOSw1Fda8qkt
       
      https://www.amazon.ca/MAUSAN-Socket-Adapter-150MIL-205MIL/dp/B06ZYSNJF3/ref=pd_sbs_21_3?_encoding=UTF8&psc=1&refRID=XM79QJWGED6B4K2VEZDJ
       
      How to use it:
       
      Also, you can search on YouTube a lot of guide for CH341a.
       
    • By Meik
      Hi... 
       
      i would like insert one WWAN Card -> 
      HUAWEI MU736
       
      but my Lenovo Thinkpad L560 say me on start that this card is unauthorized plugged in card...
       
      I tried to start Laptop without this card and install it when windows was start... Driver was installed and card was founded... LTE is there...
       but if i restart pc ... the same error -> unauthorized plugged in card...
      (wtf.... )
       
      that same is with ssd module M.2 2242, version B & M Key
       
      i buyed Bios write USB (CH341A programmer).
       
      i wrote my bios and there is my bios *.bin 
       
      can u please help me to open  my bios ??? 
       
      there is that file
       
      https://yadi.sk/d/i8Iqx0_n61N9tg
       
       
      i tried to search much Hex codes there but i dont found enyone there. i tried to found sertificated wwan card from lenovo
       
      -> Huawei ME906S 4G LTE   ->  VID/PID=03F0/4E1D  -> Hex; f003:1d4e
      (i tried all that to:
      Vendor ID : 12D1 (Huawei)
      Normal mode PID : 1573
      Update mode PID : 1568
      Debug mode PID : 157E
      )
       
      and -> Sierra Wireless EM7455 4G LTE  to
       
      but found nothing on BIOS chip...
       
      p.s.: sorry for my english..

    • By picardilly
      Hey guys, I am Grga and i am new here. I rarely use forums but i am desperate in this case.
      So, as i have seen many of you have had the issue with obsolete BIOS versions for clevo P7xxZM machines,
      So i would like to hear your experiences and how you went about it. 
      I have recently bought an ssd Samsung 970 PRO NVMe M.2. From which i would like to boot the windows10.
      Little did i know that there was no support for that kind of protocol in the BIOS or that there is such thing as UEFI (for which i am still not sure what that is exactly, except some kind of successor of BIOS).
      So i did a bit of research and updated my Bios and ec to 1.03.15 and 1.03.09 respectively for which i understand is the last available official release. I changed to uefi mode with secure boot disabled etc... in short i did everything that my (limited) knowledge about these things allowed me to do (and the sweat of excitement and fear when i was flashing the bios for the first time in my life). But, alas, it all yielded no success,  and now i am lost. I have really no idea what to do, and whom to ask for help except for you guys here. The only thing that i understand worked for some of you is when you mentioned a wizard named @Prema so therefore i will try to do the same....
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.