Jump to content
gerald

Y510p Ultrabay Graphics card

Recommended Posts

2 hours ago, Swung Huang said:

It’s a finished product:) 

Anyone who wants it may reply to this posting and I will consider shipping them?

Won’t before June :)

Does it include the Adapter as well or just the casing? Count me in if its both.

Share this post


Link to post
Share on other sites
23 minutes ago, DesPaIR said:

Does it include the Adapter as well or just the casing? Count me in if its both.

There might be 2 versions.

I. Board adapter with acrylic supporting (You can also buy the supporting part individually and assemble it to your existing Gerald version of adapter)

II.Adapter with cable and daughter board in a case. It might be expensive, for the PCIe cable is not cheap anyway. I don’t have the time to trial and error, but I can guarantee I ship the things works well.

Won’t begin shipping before June.

I’m preparing for an exam and I had to spend all my time into it. :( will be back then.

(have already send the pics of my design in this thread. Just browse the previous pages of the thread if you want to take a look at it)

Share this post


Link to post
Share on other sites
8 hours ago, Zakyn said:

So I did some tests. 
1) power off with charger and measure the transistor gate voltage (before the resistor) -> still 3,3V
2) no effect if gpu is inserted or not

3) tryied various bios settings, nothing seems to help
4) if the charger is plugged back in psu wont switch back on

I cant find any bios setting which could influence it. Any advice welcome.

 

So, If you haven't already, you could try such options in BIOS as:

1) Disabling Wake-on-LAN

2) Disabling the Always-ON function on the right USB port

 

If that doesn't help, you can check whether the other supply voltages on the adapter power off correctly (there's also 5V and 19V). If they do, you can use them to detect power-on and off instead.

Share this post


Link to post
Share on other sites
Posted (edited)

@Swung Huang, for the second option do you offer multiple sizes/choices of acrylic case where the daughter board is located? Eg. Flex ATX PSU + mini ITX GPU,  SFX PSU + mid length GPU (270mm) or for full length GPU (300mm) etc? Your sample images in page 47 is only suitable for mini ITX GPU. Any price estimation?

Edited by jxfong2

Share this post


Link to post
Share on other sites
Posted (edited)
44 minutes ago, jxfong2 said:

@Swung Huang, for the second option do you offer multiple sizes/choices of acrylic case where the daughter board is located? Eg. Flex ATX PSU + mini ITX GPU,  SFX PSU + mid length GPU (270mm) or for full length GPU (300mm) etc? Your sample images in page 47 is only suitable for mini ITX GPU. Any price estimation?

There will be another version for full length GPU+SFX PSU

I won’t do ATX PSU for they’re too big and therefore being meaningless.

Also there can be a version without casing.

 

I can’t give out any price estimate for now. Maybe I will double check the costs later and label it for an reasonable price.

Everything will be subject to the final announcement.

(ps. I think it won’t be very cheap, as I said above. As a student this project has drained my wallet :(

Edited by Swung Huang
  • Thumbs Up 1

Share this post


Link to post
Share on other sites
19 minutes ago, Swung Huang said:

There will be another version for full length GPU+SFX PSU

I won’t do ATX PSU for they’re too big and therefore being meaningless.

Also there can be a version without casing.

 

I can’t give out any price estimate for now. Maybe I will double check the costs later and label it for an reasonable price.

Everything will be subject to the final announcement.

(ps. I think it won’t be very cheap, as I said above. As a student this project has drained my wallet :(

What I said here may be absolutely false. Everything can be changed. Please be subject to my final announcement.

Share this post


Link to post
Share on other sites
On 4/16/2019 at 3:36 PM, Swung Huang said:

There might be 2 versions.

I. Board adapter with acrylic supporting (You can also buy the supporting part individually and assemble it to your existing Gerald version of adapter)

II.Adapter with cable and daughter board in a case. It might be expensive, for the PCIe cable is not cheap anyway. I don’t have the time to trial and error, but I can guarantee I ship the things works well.

Won’t begin shipping before June.

I’m preparing for an exam and I had to spend all my time into it. :( will be back then.

(have already send the pics of my design in this thread. Just browse the previous pages of the thread if you want to take a look at it)

 

I certainly have interest in buying one when it will be avaliable, please keep us posted and good luck with your exams!

Share this post


Link to post
Share on other sites

I am also intersted in.

Share this post


Link to post
Share on other sites

I am also interested in this project.

It seems there is also a SATA connector in the ultrabay aside from the PCIe.  Is there anyway we can add a SATA connection or better, Fit a 2.5" HDD self-made enclosure in the empty space?

 

On 4/20/2019 at 7:15 PM, Swung Huang said:

What I said here may be absolutely false. Everything can be changed. Please be subject to my final announcement.

Do you plan on adding the hardware mod  too?

If I had the actual PCB file(altium or eagle file) I can add a atmega328 to it so we had the hardware mod built into the PCB.

 

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, elecsdude said:

I am also interested in this project.

It seems there is also a SATA connector in the ultrabay aside from the PCIe.  Is there anyway we can add a SATA connection or better, Fit a 2.5" HDD self-made enclosure in the empty space?

 

Do you plan on adding the hardware mod  too?

If I had the actual PCB file(altium or eagle file) I can add a atmega328 to it so we had the hardware mod built into the PCB.

 

This can be a good implementation too, I can imagine plugging in egpu on the top of egpu dock (option 1 from swung huang) while another 2.5'' sata drive at side or bottom of the dock. GTX 1650 may be a good option specifically on Y510p as we dont have to add one more psu to it (TDP 75W), saving more bucks and space on the dock.

 

AND..... There is only 5 more weeks before swung huang is free!!!! Yeah~~~

Edited by jxfong2

Share this post


Link to post
Share on other sites

A little step a side from me...

 

I finally fonded problem with my build (Lenovo Y500 + Gerald Ultrabay adapter + GTX 1080 Ti). The issue was in lower results in 3DMark after i did some service maintenance for GPU (replacing TIM, cleaning PCB, replacing thermal pads). I thought that i may damage accidently something on PCB during that process and now card show lower results. When i compare with original testing results (screenshot with score 11 577) i can't get something close to it - 1000 or more lower result. Maximum i get was 10 577.

 

I tested all settings, including:

 

1. Lenovo Energy Management (High performance);

2. NVIDIA power management (Maximum performance);

3. PCI-Express version (Gen3 in BIOS).

 

But i just forgot that before GPU maintenance i installed Graphite sheet on CPU and dGPU for testing. When i run 3DMark and go in custom run of Time Spy benchmark (windowed and borderless mode = ON and 1920x1080 resolution) - CPU frequency drop to 2.4 GHz and don't resore during test. Only after it complete and dGPU temp drop down to 53℃. I tested disabling BD PROCHOT in BIOS and in ThrottleStop - it didn't helped. In 6 diffirent combinations of settings (BIOS and ThrottleStop) - CPU frequency always dropped. I can only fix it by setting it manually for all cores. On today i tested:

 

1. 3.2 GHz on all cores - thermal throttling in last CPU test (103℃ on one of the core). Final score 11 648 (graphics) & 1 763 (CPU);

2. 3.1 GHz on all cores - passed all test. No thermal throttling (max temp was 99℃). Final score 11 623 (graphics) & 3 110 (CPU).

 

3DMark_Time_Spy.thumb.jpg.488bbf60c645685526faf65586360034.jpg

 

In attach i added ZIP-file with 3DMark result, so you may load it in you 3DMark and look results if you wish.

11623_3DMark_Time_Spy_v1.1_Windowed_Borderless_Gen3_Max_Performance_425_TS_3.1GHz.zip

Share this post


Link to post
Share on other sites
11 hours ago, elecsdude said:

It seems there is also a SATA connector in the ultrabay aside from the PCIe.  Is there anyway we can add a SATA connection or better, Fit a 2.5" HDD self-made enclosure in the empty space?

I won’t include it in my design but it can be a relatively simple mod to do the trick.

 Maybe I have sent them before in this thread, but I will sent it once again in case you can’t find’em.

There’s two ways of doing it.

You can either glue a ordinary ODD to 2.5inch HDD tray to the adapter or using a slim SATA cable to attach the drive outside the machine.

Under the circumstance of the external cable one you could just run a SATA powering line from your PSU so that you can power a 3.5inch drive.(If you decide to use your PSU for your drive’s power, there’s no need for slim SATA cable. An ordinary SATA will do the trick. 

There can be some aligning and fitting work to do to make it working.:)

AF8245C2-E17A-4124-8345-40C3840821DE.jpeg

6E26205A-192C-412A-8B61-DCCD1E4FA292.jpeg

D4D316C9-3364-42FF-92D4-6ED013E6485B.jpeg

Share this post


Link to post
Share on other sites

It is quite easy to build one body with integrated connectors for ultrabay and sata and then 3d print it (both connectors should be on cables, not on pcb). I can do it and share complete 3d model ready to print.

Share this post


Link to post
Share on other sites
On 3/31/2019 at 8:13 AM, WholeGrainOats said:

Would it be possible to instead design a thunderbolt ultrabay adapter?

Now it can be possible. I heard that the thunderbolt 3 card from gigabyte called GC-Titan-Ridge can work without attaching to the TB3-header and just short the pin3 and pin5 of the header! So maybe it will work on ultrabay adapter!

Haven’t tried though.

Share this post


Link to post
Share on other sites

Can anyone with modded bios send me exact settings from each card in bios menu please? I really dont know how to solve psu power off issue. I tried other power lanes of ultrabay but there is no voltage, maybe they depedns on some other signal. Last thing is to try original bios. 

Share this post


Link to post
Share on other sites

Surprised to see this thread is currently active. Awesome work on the Adapters & all the best. I will be waiting too.

Share this post


Link to post
Share on other sites

I would be interested too if a new adapter design will be available. :)

Share this post


Link to post
Share on other sites

Confirming that I still want to buy 2

Share this post


Link to post
Share on other sites
Posted (edited)

Kind of bad news. I tried to install few latest NVIDIA drivers (v430.39, 430.53 HotFix and 430.64) and they all are failed. Error saying that my OS (Windows 10 Pro x64 is not supporting and compatible graphic device wasn't founded) So, there is no support of GeForce GT 650M.

 

I spotted it first when installed driver v430.53. After installing was complete - i saw only one VGA active - GTX 1080Ti. GT 650M was inactive and have got error 43. I can't get rid of it. So, i disconnected GTX 1080Ti and decided to install driver only with dGPU (GT 650M). And here is error pop-up.

 

I have to use good old trick to manually add GT 650M in driver and install it under windows mode without driver certificate check. It's worked, but i didn't tested it with GTX 1080Ti installed. Maybe i will try tomorrow.

 

P.S. Last "no problem" driver version is v425.31, but i can't force EVGA Precision X1 to work with it. v430.53 working with X1, but no GT 650M. LOL

PiC.png

Edited by rusTORK

Share this post


Link to post
Share on other sites

Surely this is not so bad? Or is there an application which you need the 650M - rather than the 1080 or Intel graphics - for?
 

Share this post


Link to post
Share on other sites
10 hours ago, rusTORK said:

Kind of bad news. I tried to install few latest NVIDIA drivers (v430.39, 430.53 HotFix and 430.64) and they all are failed. Error saying that my OS (Windows 10 Pro x64 is not supporting and compatible graphic device wasn't founded) So, there is no support of GeForce GT 650M.

 

I spotted it first when installed driver v430.53. After installing was complete - i saw only one VGA active - GTX 1080Ti. GT 650M was inactive and have got error 43. I can't get rid of it. So, i disconnected GTX 1080Ti and decided to install driver only with dGPU (GT 650M). And here is error pop-up.

 

I have to use good old trick to manually add GT 650M in driver and install it under windows mode without driver certificate check. It's worked, but i didn't tested it with GTX 1080Ti installed. Maybe i will try tomorrow.

 

P.S. Last "no problem" driver version is v425.31, but i can't force EVGA Precision X1 to work with it. v430.53 working with X1, but no GT 650M. LOL

PiC.png

 

I found this same issue for GT750M not being included in the latest driver.

 

I use the GT750M as dedicated PhysX and GTX1060 as main monitor.

 

So I started on fail safe and manually installed the driver for GT750M using the latest available one. Did work flawlessly and I don't expect new NVIDIA updates to touch that driver, since the card is no longer on the list of hardware.

 

Hope that works for you too!

Share this post


Link to post
Share on other sites
4 hours ago, Bos Maior said:

Surely this is not so bad? Or is there an application which you need the 650M - rather than the 1080 or Intel graphics - for?
 

Actually when i start useing eGPU i fully understand why you need both iGPU and eGPU in PC. It's really convinient to have one low powered GPU (i or d) for browsing or view YouTube\Twitch. System quiet and eGPU fans not spin, no extra noise, no unneccessary power consumption and also no damage to eGPU fans when they do nothing, but spinning. When you want to run game - it's time for powerful eGPU.

 

With Lenovo Y500 i stuck with dGPU and eGPU, since iGPU is disabled.

 

With such problem with driver - i can't get last version and have got easy installation process. I forced to mod it by myself and entire process (now for both dGPU and eGPU) is a bit more complicated. Before fix of "Error 43" we got exactly the same problem with eGPU, now we returned to same problem, but now with dGPU.

 

Lenovo Y510p have diffirent story, since it's have got iGPU.

Share this post


Link to post
Share on other sites
Posted (edited)

Maybe l found an elegant way to implement this project. It can make the attach/detach process as convenient as thunderbolt does.(Not hot unpluggable tho)It might be very expensive(can make the enclosure kit above US$200 but I will try my best to find cheaper part sourcesto lower the final price). Are you interested in it and willing to let me make it alive? How many of you are willing to buy it? Let me know.

(ps. It didn’t go through the proof of concept. It should work but I don’t know if I could make it work. Let me know if you DO want to PURCHASE it.

(I’m running out of money and the R&D for this project has cost me a lot :(. If you don’t REALLY want it, I don’t want to study on it any more. It cost too much of my life and money.

For anyone who wants to dive into it, it’s called oculink.

Edited by Swung Huang

Share this post


Link to post
Share on other sites
Posted (edited)

I don’t listed ANY of my design on ANY platform.

That’s tricky, but the fact is that I posted my design somewhere in Chinese and somebody ripped it  off and made their own. And they just claim that’s their work, which makes me angry.

What’s more, they just did a bad job and most of these boards have a bad connection or unstable performance or weird behavior(like often BSOD or running at x4 or even x1 instead of x8),which bring me a bad reputation and frustrate me.

That’s why I hesitated to public my design.

 I’m still working on my exam and have no extra effort dealing on this mess. But I haven’t listed any of  my adapters on eBay, aliexpress , dealextreme, taobao or anything like that for the time being. Stay tuned for that.

In defense of China, I don’t hate China and I am a Chinese myself. Not all the Chinese are evil. But there’s nothing to promise a country of 1.3 trillion population won’t have something unfavorable mixed into it.

 

Edited by Swung Huang

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Sparkhunter
      Hi there guys,
       
      I've been looking into getting a new GPU for my laptop (4-lane PCI-e) and enclosure (HP Omen Enclosure) but I cannot decided between the RX 5700 XT and the RTX 2070 (non SUPER).
       
      I did some price to performance calculations (higher is better) with some of the best prices I can currently get in the UK.
       

       
      The RX 5700 XT does perform better and is cheaper than the RTX 2070 (Although the 2070 does come with 2 games) but my main concern is drivers and from what I've heard NVIDIA cards work a lot better with eGPUs than AMD.
       
      If anyone has experience using both red & green or if anyone else has any other input i'd love to hear your experiences and input.
       
      Thanks.
       
    • By Blocker35
      Hi guys, bit of a rookie to the whole EGPU scene. Currently I have:
       
      - MacBook Pro 2015 13inch (3.1GHz Core i7 16GB RAM)
      - Razer X Core 
      - Apple TB3 to TB2 Adapter
      -  TB2 Cable (Cable Matters)
      - 23inch AOC External Monitor
       
      I am wonder about what graphics card to get to run X-Plane11 with high graphic settings?
      I have purgewrangler set up and ready to use with an AMD graphics card, but am also open to the idea of an Nvidia graphics card.
      Any advice appreciated. I did not buy a Windows PC as I need a Mac for various other things and wanted an all-in-one laptop.
    • By adam.jakey
      Hey Everyone. I'm looking through the forums and found out that I can make my old Lenovo a Hackintosh. Is it worth doing? Can you dual boot Windows 10 and OS10? 
    • By SnipeKing17
      The GPU works, The PSU works, The system works. [individually they all do work]
       
      The system works perfectly fine without the WLAN card.
       
      When i put the system to sleep and hotswap the mPCIe riser and WLAN press something on the keyboard.. Restarts.
      Will shutdown in roughly 27 seconds for those 27 seconds it works just fine like how it normally would on external monitor.
       
      When i shut it down and plug the riser and switch it on, same story. 27 seconds.
       
      I don't even see a error. I get to login screen directly. I used DDU already.
       
      I timed it. no matter what i do if i use the eGPU, External monitor it restarts instead of pause-play. I have 27 seconds.
       
      Need help!
    • By can rx
      Hello to all dear visitors, 
       
      I have been using Lenovo y510p notebook for two years but in games I think my graphic card is inadequate. After that I've bought Mini PCI-e EXP GDC and attached it to where the wireless card socket is.  However because it has x1 speed its performance is too low. Even though on tests rx460's ranks is low than rx480, it has more performance.
       
      In x1 PCI-e port, the performance is too low and inefficient. On GPUz programme, use of memory controller is 20% but use of GPU is 100%. I mean, I've been hooked to the x1 speed.
       
      Components : EXP GDC version 8.0 +450w PSU + rx480
       
      I've read all pages about ultrabay, I want to buy and to share in forum.
       
      If anyone has ultrabay to PCI-e port, I want to buy. Please help.
       
      Thanks for everything.
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.