Jump to content
EwinRacing Flash Series Gaming Chairs
gerald

Y510p Ultrabay Graphics card

Recommended Posts

I got my Ultrabay adapter today, but i think i will start all things only tomorrow. In new day.

 

I want to test it's working, maybe even see it's reboot after 40 sec, then flash new BIOS for Y500 and test again.

Share this post


Link to post
Share on other sites
On 8/18/2018 at 4:09 PM, balint234 said:

I havent seen which one of these cables do not work, can you have a look at this one if it was mentioned by others. (Kinda lazy to re-read the thread and you might recognise it by the name if it was tested as uncompatible.)

 

https://www.amazon.de/EASYDIY-Express-Flexibles-Verlängerung-Card-30cm/dp/B07D335BS9/ref=sr_1_7?s=computers&ie=UTF8&qid=1534623701&sr=1-7&keywords=flexible+pcie+riser

 

Thanks in advance

 

I bought that one, just waiting for it to arrive, I'll let you know if it works or not.

 

EDIT: I actually bought the 25cm version. Same brand though. I will post after I test it.

Edited by cajuil

Share this post


Link to post
Share on other sites

So, here is actual tests: (Post will be edited after each test)

 

I. I just assembled everything:

 

1. Disconnected second nVidia GeForce GT 650M,

2. Connected Gerald Ultrabay adapter,

3. Connected FSP FX500-A power supply,

4. Connected Palit Radeon X700.

 

Result: Obvious re-boot after 40 seconds. So, everything working fine!

 

II. Flashing @High_Voltage modded BIOS. I used already created BIOS backup from last modding (when i flashed svl7 modded BIOS) and also because Universal BIOS Backup ToolKit 2.0 created *.ROM file instead of *.BIN. Even when i changed it to *.BIN - patcher can't validate it. During flash - PDR and GBE regions wasn't founded, but everything was 100% complete (i checked every line) and FPT Operation Passed. I think everything is cool.

 

1. Connected Gerald Ultrabay adapter,

2. Connected FSP FX500-A power supply,

3. Connected Palit Radeon X700.

 

First boot stuck at LENOVO logo, so i re-boot, go in BIOS, double-check boot options (it was UEFI), exith with save. After that windows boot normally and i go in Device Manager - there is new device founded with Microsoft Basic Display Adapter. After that i just waited 40 seconds... there was no re-boot, SO look's like everything working fine. I run AIDA64 Business and GPU-Z v2.10.0. Here is screenshots:

5b7bb6a6566ae_SecondRun.thumb.jpg.b6cfbb7ba2d548a35d1a7c52ff95685d.jpg

Also, important thing - device manager saying that new device have got error code 31 AND also Running driver do not match with driver adapter passed POST verification. Which is obvious - it's Radeon! I need to find old Radeon X700 driver and test it. I got it before, but after first fail with my first adapter from Gerald i delete it.

 

Update: last working driver is Catalyst 10.2, but after some research i founded ATI Catalyst v12.11 B11 HotFix 11.09 v6 Beta that see X700 without problem. I even run S.T.A.L.K.E.R. Dead Air, but FPS was so low it was unplayable.

 

Result: ATI card is working, it's possible to install driver. Just need new card.

 

III. Switching to GeForce GTX 660.

 

1. Disconnecting Radeon X700,

2. Connecting GeForce GTX 660.

 

After boot, windows start normally, device manager founded new device and later installed driver for a card. It's lost somehow 64bit of Bus width, but anyway.

5b7bd73642590_ThirdTest.thumb.jpg.fa42fddfa4e164de1f046fd598cabaee.jpg

I downloaded last driver from NVIDIA (v398.82) and re-boot laptop. When windows loaded again i installed new driver, it' founded card with no problems and install all drivers for it. GPU-Z saying card support PCIE x16 2.0, but currently working as x8 1.1. In NVIDIA control panel i founded funny settings about PhysX - it's possible to allow calculate PhysX with GT 650M.

 

5b7bd7d33641d_LastDriver.thumb.jpg.a87e64603bad5c9a14c069c74809a35d.jpg

Also, i am NOT useing internal display yet. More then that, i have got error 43 in device manager on NVIDIA GT 650M, but not on GTX 660. Is it how it should be?

Edited by rusTORK

Share this post


Link to post
Share on other sites

Regarding physx , you can even use dedicated gpu for physx with amd gpu in ultrabay adapter(not sure do all new drivers support it but some did when i was testing my adapter). I belive i tested that with liquidmark and msi aftherburner showed gt755m activity in physx tests. But there arent that many gpu based physx titles, so it dosent really matter that much, besides if you go with beefy gpu in adapter it might do better job by itself anyways.

Share this post


Link to post
Share on other sites
On 12.08.2018 at 3:38 PM, Celestus said:

@rusTORK But i wouldent trust it for longer period of time, its old and of questionable quality.

Yeah, after i connected small Samsung TV (i don't have spare monitor) to GeForce GTX 660 via HDMI cable and run Deus Ex: Mankind Divided - i can't even see main menu. After few intro videos PSU make really nasty sound (like god of electricity itself will show up) and shutdown GTX 660 and kick me in windows. Plus in device manager was error 43. I re-boot laptop and everything back to normal. I see windows on both laptop display and on Samsung TV. This PSU is WEAK and probably to danger use for real game tests.

Share this post


Link to post
Share on other sites
On 8/18/2018 at 4:09 PM, balint234 said:

I havent seen which one of these cables do not work, can you have a look at this one if it was mentioned by others. (Kinda lazy to re-read the thread and you might recognise it by the name if it was tested as uncompatible.)

 

https://www.amazon.de/EASYDIY-Express-Flexibles-Verlängerung-Card-30cm/dp/B07D335BS9/ref=sr_1_7?s=computers&ie=UTF8&qid=1534623701&sr=1-7&keywords=flexible+pcie+riser

 

Thanks in advance

 

Cable arrived. I attached some pictures (box and cable) . I tested it and it works perfectly!

 

P.S.: This is the 25cm version.

 

https://prnt.sc/km4wyc

IMG_20180822_200354.jpg

IMG_20180822_200932.jpg

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

Just discovered this thread through the BIOS mod after wanting to upgrade my wireless card. It never even crossed my mind that something like this would be possible and it seems like an excellent solution for this laptop which is slightly hindered in the games I want to play by its graphics card. I have a lot of catching up to do on this.


Gerald I have sent you a message regarding getting one of these units, I see as of last month you mentioned you still had some.

 

Hopefully, if I can pick up one of these units I'll start making this a reality. I'm going to spend a ton of time reading through this topic and do some more research but if anybody has tips or suggestions on this it would be greatly appreciated. I'll be looking at doing this with a nVidia card so anything prevalent to that would be appreciated as well.

Share this post


Link to post
Share on other sites
1 hour ago, Jeklund said:

It never even crossed my mind that something like this would be possible and it seems like an excellent solution for this laptop...

It's a consequence of work Lenovo marketing (SLI in laptop sound cool, right?) and Compal engineers (let's... let's just connect second GPU directly to CPU).

 

Very unusual design AND hidden features!

 

I even want one time sent an e-mail to Intel and Compal about "killed" Intel iGPU and how to unlock it. But i just don't know how to properly assemble this difficult story. =)))

Edited by rusTORK

Share this post


Link to post
Share on other sites
4 hours ago, cajuil said:

 

Cable arrived. I attached some pictures (box and cable) . I tested it and it works perfectly!

 

P.S.: This is the 25cm version.

 

https://prnt.sc/km4wyc

IMG_20180822_200354.jpg

IMG_20180822_200932.jpg

Glad to hear that its working for you :)

Thanks for the share ;)

Share this post


Link to post
Share on other sites
On 5/12/2018 at 9:03 PM, Swung Huang said:

Ah that's relatively easy. you just buy that odd to 2.5' bay. you could align the cables to it and make a cutout on the bay to let the cables run outside the laptop. I have tried it before that's ok


I just wanted to touch on this as I'm brainstorming for what I'd like to get out of a setup if I do this. This was all mentioned a few months back but what I'm thinking of doing to keep the laptop portable would be ordering two ODD trays (As I'm thinking I'll just sell my 755m ultrabay if I do this, so if anyone is interested pm me), one would just as filler for when I take my laptop to school and the other used as a medium to connect geralds adapter in a similar way as @David 'SOAP' Washington did:
 

On 1/27/2018 at 7:48 AM, David 'SOAP' Washington said:

image.thumb.png.87ee4677ed850ffca5357488c05cdead.png

 

Share a mod from other man with you guys , Ultrabay Adaptor & Sata3 box.

Finally, it can be locked in, and won't be plug out by accident anymore.

 


The only difference being that I would like to have the GPU a little bit away from the laptop. Would this be as simple as running a similar PCIe cable like the one @cajuil just mentioned above through the ODD tray to the location of my adapter? Ideally, I'll create some sort of enclosure to support the adapter, GPU, and PSU and then my setup would be as simple as plugging in my modded tray and connecting the cable to the location of my enclosure.

Am I on the right track with my thoughts or am I missing something? Apologies for the long post I'm still trying to make sense of some aspects of this project after reading through all the pages and I'm also not super well versed in this stuff. My assumption is that somewhere within my theoretical setup the connectors won't be compatible and if so what would I need to do in order to make this happen?

Share this post


Link to post
Share on other sites

I just plugged the GTX 970, and it's working!

 

Thank you @High_Voltage for the BIOS, and Thank you @gerald for the adapter!

 


 image.jpeg.deca05b71dc8c1125a2f63423cb6edfc.jpeg


image.jpeg.6c84c5fa5f2ed3de743e2a22c0d4e2ab.jpeg





_________________________________________________________________



Now, how can I COMPLETELY DISABLE the internal GT750m?

The GPU is still powered and spreading heat (helping throttle the CPU).
Every time I try to make a test with the CPU the GT750m is there on the way.

 

image.gif.0cd64f90fc915340579775d6af917559.gif

 

Thank you

Edited by AllanDavidson

Share this post


Link to post
Share on other sites
6 hours ago, AllanDavidson said:

I just plugged the GTX 970, and it's working!

 

Thank you @High_Voltage for the BIOS, and Thank you @gerald for the adapter!

 


 image.jpeg.deca05b71dc8c1125a2f63423cb6edfc.jpeg


image.jpeg.6c84c5fa5f2ed3de743e2a22c0d4e2ab.jpeg





_________________________________________________________________



Now, how can I COMPLETELY DISABLE the internal GT750m?

The GPU is still powered and spreading heat (helping throttle the CPU).
Every time I try to make a test with the CPU the GT750m is there on the way.

 

image.gif.0cd64f90fc915340579775d6af917559.gif

 

Thank you

If you are only planning to use your laptop as a desktop, then try uninstalling it from device manager.

I havent tried it yet so i dont know if it works but as long as intel hd is enabled you shouldnt get into any trouble with it.

 

 

Share this post


Link to post
Share on other sites
15 hours ago, AllanDavidson said:

Now, how can I COMPLETELY DISABLE the internal GT750m?

The GPU is still powered and spreading heat (helping throttle the CPU).
Every time I try to make a test with the CPU the GT750m is there on the way.

 

 

I think it can be done from BIOS. I never tried it though.

 

21 hours ago, Jeklund said:


I just wanted to touch on this as I'm brainstorming for what I'd like to get out of a setup if I do this. This was all mentioned a few months back but what I'm thinking of doing to keep the laptop portable would be ordering two ODD trays (As I'm thinking I'll just sell my 755m ultrabay if I do this, so if anyone is interested pm me), one would just as filler for when I take my laptop to school and the other used as a medium to connect geralds adapter in a similar way as @David 'SOAP' Washington did:
 

 


The only difference being that I would like to have the GPU a little bit away from the laptop. Would this be as simple as running a similar PCIe cable like the one @cajuil just mentioned above through the ODD tray to the location of my adapter? Ideally, I'll create some sort of enclosure to support the adapter, GPU, and PSU and then my setup would be as simple as plugging in my modded tray and connecting the cable to the location of my enclosure.

Am I on the right track with my thoughts or am I missing something? Apologies for the long post I'm still trying to make sense of some aspects of this project after reading through all the pages and I'm also not super well versed in this stuff. My assumption is that somewhere within my theoretical setup the connectors won't be compatible and if so what would I need to do in order to make this happen?

 

I'm currently using two HDD caddy's, 1 for HDD and 1 as an enclosure for the adapter.

 

Having HDD+ultrabay adapter in 1 caddy is not possible as it increases the thickness too much. It can be squeezed into the slot but i rather prefer two caddy's.

 

Yes. Creating an enclosure for GPU+PSU is easy. You'll just need a working pcie riser cable to connect ultrabay adapter with the enclosure.

Share this post


Link to post
Share on other sites
3 hours ago, intruder said:

I'm currently using two HDD caddy's, 1 for HDD and 1 as an enclosure for the adapter.

 

Having HDD+ultrabay adapter in 1 caddy is not possible as it increases the thickness too much. It can be squeezed into the slot but i rather prefer two caddy's.

 

Yes. Creating an enclosure for GPU+PSU is easy. You'll just need a working pcie riser cable to connect ultrabay adapter with the enclosure.

 

Awesome that's good to know. I don't really have much intent to use either with a HDD, i have more than enough with my 1tb and soon to arrive 480gb m2 ssd. It would be more so just as a dummy when I take the laptop away from my desk.

 

As far as moving the GPU and PSU away I get that process fairly well. What I'm more interested in is the ability to have the adapter with the GPU plugged in and moved away, then build an enclosure around that. Similar to what @Swung Huang did with his custom setup however I would just use Gerald's adapter as I don't have any experience with designing PCBs.

 

Essentially is there some cable I can use and run through a modified tray (for aesthetic reasons and to avoid plugging and unplugging geralds adapter vs just a cable)? Basically I would modified the tray to run a cable through to the location of the adapter, GPU and PSU if parts for that exist.

Edited by Jeklund

Share this post


Link to post
Share on other sites

Look's like i need help with VGA. I am stuck with selection of 1070/Ti/1080. What's maximum cooler system height to use with adapter?

Share this post


Link to post
Share on other sites
47 minutes ago, Celestus said:

@rusTORK 2 slot card goes in easy, the only thing that would block 2,5 or 3 slot card is the laptop screen.

Some manufacturers write height as "slots", but some of them do it in mm. I just don't know how much mm in 2 slots. =) I don't have desktop PC. When i did my tests i measured distance from card to edge of laptop and got something about 43 mm.

 

Also, when i tested GeForce GTX 660 i saw how VGA leans on left side, since it got more weight on it's side. I don't think it's good for slot itself. maybe build some kind of support (bracket)?

Edited by rusTORK

Share this post


Link to post
Share on other sites

@rusTORK My vega 64lc is 40mm(with the backplate) and theres 5mm left between screen and the card(at the bottom). It leans left towoards the screen and touches it slightly, no issues for me so far so i wouldent worry to much about it leaning.

Share this post


Link to post
Share on other sites

Hello guys! I am kinda new to the forum, but i've been going crazy looking for that bay extension you guys have. 

Share this post


Link to post
Share on other sites
59 minutes ago, Andiml2012 said:

I've been going crazy looking for that bay extension you guys have. 

Contact the OP. He may still have one available.

Share this post


Link to post
Share on other sites

Hello guys,

I'm also owner of a Y510p and looking to upgrade the graphic card, mainly to play "No Man's Sky". What would be the best card you recommend for it?

 

I'll request Gerald one of his adapters, as it seems other options like PCIe or NGFF are not as good as this one.

 

Thanks!

Share this post


Link to post
Share on other sites

While i still looking for best VGA for me (1070 Ti or 1080) i want to understand why Y510p got PCIe v3.0, but Y500 got PCIe v2.0?

 

Y510p have got chipset HM86 => https://ark.intel.com/products/75531/Intel-HM86-Chipset

Y500 have got chipset HM76 => https://ark.intel.com/products/64345/Mobile-Intel-HM76-Express-Chipset

 

Table showing both have got v2.0. Intel lie? In the topic few screenshot of Y510p with PCIe v3.0... At intel ARK there is also links on Chipset Data Sheet, but that docs SO BIG: 86 - 822 pages, 76 - 988 pages!

Edited by rusTORK

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By damianalex
      Hi,
      I want to show you my new project.
      I bought my laptop about 5 years ago.  It was never speed deamon, but for every day use, it was enough to me.
       
      Its specification:
      Intel i7-4700MQ
      Nvidia GeForce GT745M
      16GB RAM
      512 SSD Adata SU800

       
      Yesterday I bought Witcher 3. Of course on 1080p it's impossible to play, because of about 10fps
       
      So I make a decision to buy external grahpic card.
      I choose GTX970 and now I am looking for occasion to buy it.
       
      I've already bought EXP GDC v8.4d mPCI-E. It is used and cost about 30$.

       
      I will use ATX PSU to supply graphic card, because I have old desktop PSU at home.
       
      My plan:
      1) unlock bios
      2) buy GTX 970
      3) enjoy Witcher 3!
       
      BTW I try to cool down my laptop, so I replaced thermal paste to Kryonout Thermal Grizzly and make some tests. Temperatures and fps are on screenshots.
       
      1) laptop on table, playing GTA V 1080p

       
      - first minute (GPU core 1045MHz)

       
      -after some time, because of high temperature and GPU throlttling (GPU core drop down even to 400MHz)

       
      2) with thermalpad Glacier NC400 SilentiumPC

      - 30 minute and longer (GPU core drop to about 900MHz)
       
      3) without down case of laptop (like on picture with thermal paste) on thermalpad.
      Here laptop never drops down MHz and max temp are about 72 Celsius degrees.

       
       
      Bacause of that I bought second down case for my laptop and I will cut there additional holes.
       
      Greetings!
       
      I will describe next step when I get all stuff I need!
       
       
    • By popozitos
      Hello everyone
      I created a case for egpu using 2.5mm acrylic sheets. The first time I created a case to support a GPU + ATX psu
      Now I created another one for the GPU with an external Xbox 360 203w psu.
      the finish was not good but for my use it is already good.
       
      *both cases album
      *Construction of the second case 
      *adapting xbox psu to 8pin power (taken from 24pin)
       
      all made by hand with the tools I had.

      from Brazil.

    • By jcrcarmo
      Hi folks,
        Greetings from Brazil!  Not sure I'm posting in the right place, but I have a question:  how do I find out the brand and model of my BIOS chip without having to open my laptop?  I can't find this information anywhere.  Been searching for days... I have a Lenovo Ideapad 300-15ISK 80RS (motherboard Paris 5A8).  Thanks a lot for your time and help! I really appreciate it!   Best regards,   JC.
    • By Consumerofmulch
      Hello!
       
      I have recently acquired my Dell Inspiron 15 7000, and I am interested in building an egpu setup for it. It has a USB-C port. Any recommendations/guides out there?
       
      thanks.
    • By Donz7733
      I am planning to get this Charger (170w 20v 8.5a) - https://www.amazon.in/Lenovo-ThinkPad-4X20E50574-170W-AC/dp/B00MLTQ99Y
      &
      the Adapter - https://www.aliexpress.com/item/32975526334.html?spm=a2g0o.productlist.0.0.27cb747e6TEc28&algo_pvid=a7db42d0-97cb-4a37-be7a-d19c44bddf73&algo_expid=a7db42d0-97cb-4a37-be7a-d19c44bddf73-0&btsid=8d6ee0f9-08e9-4474-b63b-cc751403b4c7&ws_ab_test=searchweb0_0,searchweb201602_,searchweb201603_60
       
      Will this combination work to run Both GT755m of Y510p?
       
       
      Thanks
       
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.