Jump to content
gerald

Y510p Ultrabay Graphics card

Recommended Posts

Does anyone use nvidia via geralds adapter on Y500. I can't instal driver for 1060 6gb. There is error code 43 device was stopped, in device manager.

Share this post


Link to post
Share on other sites

@Kuneroll, As I've written in literally every BIOS mod installation guide, the Error 43 is going to be quite common when NVidia's latest 1000 series GPUs are used. Please, follow this guide in order to fix it. This guide has also been confirmed working by @MWichni and his GTX1070ti.

Share this post


Link to post
Share on other sites

If anybody would like to sell their Ultrabay adapter a little bit cheaper, please message me.

Share this post


Link to post
Share on other sites
Posted (edited)

EROR 43.

1060 6gb on Y500 all right. Download driver 368.81,no modify. Clean driver via DDU. in device manager rightclick on the basic graphic adapter on port PCI2, actualize driver, from disc, search driver 368.81,instal. restart. then instal Geforce expirience and actualize. in device manager disconnect GT650m.

PS: maybe is possible to instal only newest driver after clean via DDU. I didn´t try.

 

Does anyone know why I have bus interface only  x16 2.0 @ x8 2.0 ?

Swung Huang has 3.0

2018-06-13 (4).png

2018-06-13 (1).png

Edited by Kuneroll

Share this post


Link to post
Share on other sites
Posted (edited)

Hello guys. I am watching this thread for about some months because i have also a lenovo y510p and i was interesting for a solution for external gpu because now the laptop is kinda limited in power on gpu. I would like to ask if it's possible to use a cable like this https://www.aliexpress.com/item/Riser-Gen3-0-PCI-E-PCIe-x8-to-PCIe-x16-Graphics-card-extension-Riser-Ribbon-Cable/32839943463.html with the end of the connector being in sr mode as the pictures show into the link to extend the internal of the connector combining with an hdd caddy like this https://www.amazon.com/Nimitz-Drive-Caddy-Lenovo-Ideapad/dp/B00NAMUETC. At the end of the hdd caddy with some modification we can put the end of the riser connector and then with another riser like this https://www.aliexpress.com/item/Riser-Gen3-0-PCI-E-3-0-16x-male-To-pcie-x16-female-Right-Left-Elbow/32832150338.html?scm=1007.13339.90158.0&scm_id=1007.13339.90158.0&scm-url=1007.13339.90158.0&pvid=f0e9c06e-bae3-4a72-8af1-63cd1f8c80fa&_t=pvid:f0e9c06e-bae3-4a72-8af1-63cd1f8c80fa,scm-url:1007.13339.90158.0 we can easily connect and disconnect the gpu and retain portability for the machine. The only thing i can't understand is if the ultrabay port is something like PCI-E PCIe x8 connector or something else because i don't have a pci-e x8 connector to compare with ultrabay connector. Something like that linus tech tips did in their video.

 

Edited by DARKShadow45

Share this post


Link to post
Share on other sites
5 hours ago, Kuneroll said:

EROR 43.

1060 6gb on Y500 all right. Download driver 368.81,no modify. Clean driver via DDU. in device manager rightclick on the basic graphic adapter on port PCI2, actualize driver, from disc, search driver 368.81,instal. restart. then instal Geforce expirience and actualize. in device manager disconnect GT650m.

PS: maybe is possible to instal only newest driver after clean via DDU. I didn´t try.

 

Does anyone know why I have bus interface only  x16 2.0 @ x8 2.0 ?

Swung Huang has 3.0

2018-06-13 (4).png

2018-06-13 (1).png

At y400/500 it only has 2.0. 

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Do you currently sell this adapter and could i buy it with credit card? @gerald and does it support gtx1080?

Share this post


Link to post
Share on other sites

Hi,

 

I still have some adapters.

Pls pay €95,- (incl. €25,- for int. shipping) to my PayPal account. (Gerald.pichler@gmx.at).

I will send the adapter within a few days.

 

A GTX1080 does work with the latest BIOS upgrade -> the upgrade procedure is described in this forum.

 

 

Share this post


Link to post
Share on other sites
On 19/06/2018 at 11:49 AM, gerald said:

Hi,

 

I still have some adapters.

Pls pay €95,- (incl. €25,- for int. shipping) to my PayPal account. (Gerald.pichler@gmx.at).

I will send the adapter within a few days.

 

A GTX1080 does work with the latest BIOS upgrade -> the upgrade procedure is described in this forum.

 

 

Is it possible to attach a 2.5" HDD on the ODD-Sata using the current version of your adapter?

Share this post


Link to post
Share on other sites

There is a suggest in this thread how you can modify the adapter to connect a HDD and this adapter.

Share this post


Link to post
Share on other sites
Posted (edited)

Hey @gerald ! I just got my adapter today Ty! But I'm having some trouble, im using a rx470 card with a 600w psu.

 

Card is not being detected by windows.

When i power the laptop, the card fans blow for 2 sec then stops, but card lights stay powered on.

Im using 3.07 oficial bios, retail uefi grub dualboot w8.1 - debian

Bios setup is in Legacy mode

 

Any insights? @Tesla @David 'SOAP' Washington @Kuneroll @Swung Huang

Edited by caitdeen
more specs.

Share this post


Link to post
Share on other sites
3 hours ago, caitdeen said:

Hey @gerald ! I just got my adapter today Ty! But I'm having some trouble, im using a rx470 card with a 600w psu.

 

Card is not being detected by windows.

When i power the laptop, the card fans blow for 2 sec then stops, but card lights stay powered on.

Im using 3.07 oficial bios, retail uefi grub dualboot w8.1 - debian

Bios setup is in Legacy mode

 

Any insights? @Tesla @David 'SOAP' Washington @Kuneroll @Swung Huang

Looks like the problem was in PSU.

 

Any one have had trouble with a modular psu? I swapped psu to a 600w regular one (from a 700w modular) and it worked.

 

Btw, im using 3 monitor setup. (Internal, VGA output, and eGPU hdmi output). When i put some weight on gpu (cinebench) there are signal degradation in VGA laptop output. Any one have had experienced this?

  • Thumbs Up 2

Share this post


Link to post
Share on other sites
Posted (edited)

Hmm never heard of Signal degradation. But why are you using the Laptops VGA output anyway? All the outputs are hardwired to the internal resources, if you want to connect multiple displays with your ultrabay adaptor correctly make sure all the connections go into your external gpu.

 

If someone is looking for an extender prepare to use your right to return, because length and build quality determine wether your card will work well or not.

 

A 1080 should work fine with pcie 3.0 8x, a TI might begin to loose a bit performance, but that effect might be negligible most of the time and only relevant in some scenarios which need faster pcie speed.

 

In my case with the gtx 980 which is quite equivalent to a 1060, I do not loose any performance whatsoever, the only factor in determining gaming speed here is the -compared to desktop setup framerates- slower CPU.

 

I run at 2.4 ghz most of the games (its a 4900 MQ for 8 MB of cache inside) and its stays below 80. With 2.8 ghz (which is stock speed/throttle target) it rallies at 80 and without changing anything about airflow i can manage to keep 3 ghz without throttling (happens when the cpu hits 90).

 

Any more speed would need an upgrade of the cooling solution, 3.2 ghz might be manageable with certain games but not all.

Edited by Marvin
Cpu info added

Share this post


Link to post
Share on other sites
Posted (edited)
On 28.6.2018 at 6:39 AM, caitdeen said:

Looks like the problem was in PSU.

 

Any one have had trouble with a modular psu? I swapped psu to a 600w regular one (from a 700w modular) and it worked.

 

Btw, im using 3 monitor setup. (Internal, VGA output, and eGPU hdmi output). When i put some weight on gpu (cinebench) there are signal degradation in VGA laptop output. Any one have had experienced this?

When connecting graphics cards make sure you use two different power cables for connection when your gpu has two sockets.

 

Not every psu is built the same, so even if a company prints 1200watts on the box, there might be scum inside.

Always look for tests online or take the silver/gold/platinum ranking as a hint.

 

I am working with a, be quiet bronze modular (got it cheap off craigslist), no problems here. Had an antec gold non-modular before, was too noisy and the cables were ennervating. But worked well!

Edited by Marvin
Added info

Share this post


Link to post
Share on other sites
On 25.5.2018 at 10:07 PM, mikmaze said:

looks good, how is it working?   how much $ involved for setup? board, wires, video card, power supply???

I pay in €, so you have to use that as indicator: 100€ for the adaptor, 60€ for the pci extender, 40€ for the used power supply and 150€ for the gfx card. Total about 350€. Depends on how much you spend, for the gfx card, but you are always in the 100 for the adaptor.

Better than spending 1000€ for a new laptop, especially since i have now performance on par with a 1070 max q.

Share this post


Link to post
Share on other sites

Hi guys, a question for those of you who now have a beefy eGPU in your y510p. Is your CPU now bottle-necking your system? What cooling/overclocking steps have you taken and what has the result been? Thanks in advance

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
On 7/11/2018 at 1:12 PM, doyouevenbinary said:

Hi guys, a question for those of you who now have a beefy eGPU in your y510p. Is your CPU now bottle-necking your system? What cooling/overclocking steps have you taken and what has the result been? Thanks in advance

 

There are some dudes here with a GTX 1070 on the adapter.

 

The CPU will sure bottleneck it as much as a i7 4770k running at 2.4GHz ~ 3.4GHz.

Read my previous post about cooling.

  • Thumbs Up 2

Share this post


Link to post
Share on other sites
Posted (edited)

Depends on the resolution you ar using, i went with vega 64 lc (was chosing at the time nvidia cards did not work, oterwise id go with 1080ti) and in 4k i have maybe 20%-30% cpu usage in most games on max settings.

More or less in comparison with top end cpu/ram, you should expect 5% less in 4k , 10% less in 1440p and 15-20% less in 1080p(wont matter on 1080p, since most games will still be in hundreds fps)

A few examples is doom maxed 4k 60fps with dips to 50s ,witcher 3 maxed 4k without hairworks about 46fps avarage.

Either way if you still think you will need better cpu, consider it an upgrade path, you can buy adapter/gpu/monitor/psu and use with laptop now. And later on you can buy mobo/cpu/ram as an upgrade path and ditch the laptop.

 

And a samll thing ill add is that on y510p(non sli gt755m) without the adapter/gpu witcher 3 ran at lowest settings/resolution at 24 fps.....

Edited by Celestus
  • Thumbs Up 2

Share this post


Link to post
Share on other sites

Hi all,

 

I know that I am probably (very) late to this party, but I really would love to purchase one of this ultrabay epci gpu adpater for my y510p.

I wonder if this is still available...

Share this post


Link to post
Share on other sites

Yes, I still have some adapters.

Pls send me a message with your address.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
On 7/21/2018 at 1:43 AM, AllanDavidson said:

 

There are some dudes here with a GTX 1070 on the adapter.

 

The CPU will sure bottleneck it as much as a i7 4770k running at 2.4GHz ~ 3.4GHz.

Read my previous post about cooling.

 

@AllanDavidson

I read through your findings and they were interesting. Have you gotten the chance to test limits with only the eGPU enabled?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By MessiWessi
      Hi,
       
      I read a lot of different threads about the maximum possible M17X R2 configuration. But after I was more and more irritated.
       
      What is at the end the best performant GPU solution (with unlocked bios and dirver mod) but WITHOUT manual fan control and such things. Because if I want to sell one day my M17X R2 I don't want to explain and force the buyer to control the GPU fan per hand.  
    • By rusTORK
      When my first CPU fan on Y500 is broke i replaced it on something compatible (non-original) and planned to replace it later on original. Since that time happened a lot things, but i still using that non-original fan. But i did some research and here is what i founded:
       
      I. ORIGINALS
       
      1. Forcecon (marked as FCN on fan)
      DFS5413005MH0T-FC1C (5V - 0.5A)
      Spotted in: Y400, Y500.

       
      2. Asia Vital Components (marked as AVC on fan)
      BNTA0612R5H-P007 (5V - 0.5A)
      Spotted in: Y410p, Y500, Y510p.

       
      3. Sunon (marked as SUNON MagLev on fan)
      MG60120V1-C230-S99 (5V - 2.25W (0.45A))
      Spotted in: Y410p, Y500.

      So, which to choose? Any recomendation? Maybe there also unexpected way (completely diffirent fan from another company for another laptop)?
       
       
    • By Drozof
      Has any company out there launched a laptop with an external MXM port? 
       
      Just curious since with the boom in the gaming laptop market and some companies launching eGPU thunderbolt enclosures, isnt the MXM faster?
       
      Is it because of licensing issues? or hardware problems?
       
    • By Iwillsolo
      Hello guys ...

      i wanna make sure that everything is going to work fine with my laptop so i got some questions

      First of all my laptop is Lenovo Z51-70
      CPU: I5-5200U 2.2ghz
      iGPU Intel HD 5500
      dGPU:AMD R9 M375
      Ram: 8GB (will raise it to 16GB)
      HDD: 1TB stock one
      SSD: 120GB (for my games and windows only)

      now i investigated  a little about eGPUs and found that i need a M.2 or thunderbolt, i've found that my wifi card use a M.2 a/e key aka ngff, so i will be using the GDC Beast NGFF version

      to the bad part / question part

      What do i need to know other than the stuff above?
      what is the white-listing thing? i found on support forums that my laptop support some wifi cards only and it's bios cann't be modified according to bios modifying forums (not here)
      in same time saw some posts on reddit that says if ur bios have UMA graphic option then you will need to disable PAX / WIRELESS and enable UMA and it will work fine, the question is that true?

      i wasn't able to find anyone who did it on Z51-70 i found only 1 post on reddit for Z41-70 (which after research found that both are using same M.2 a/e key slot and also same bios... but the one who posted only replied that it's recognized with some errors and never replied back with any updates so still not sure about it.....

       
    • By Bullfrog098
      Hi, just a quick question what would be the best EGPU adapter, because i see the really expensive ones but then you have the 400$ dollar one that Lowspecgamer used. Which do you guys recommend ?
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.