Jump to content
Review: E-Win Champion Series Gaming Chair Read more... ×
EwinRacing Flash Series Gaming Chairs
gerald

Y510p Ultrabay Graphics card

Recommended Posts

Can anyone tell me using this adapter with say a gtx 1080 how much of a bottleneck ultra bay slot connection be?  Whats the difference between this adaptor and the beast pci e adaptor? 

Share this post


Link to post
Share on other sites
43 minutes ago, sHaNo said:

Can anyone tell me using this adapter with say a gtx 1080 how much of a bottleneck ultra bay slot connection be?  Whats the difference between this adaptor and the beast pci e adaptor? 

 

beast is only 1x. This adapter is 8x. 8 more lines, so theoretically 8 times faster some pcie operations. 

Share this post


Link to post
Share on other sites

Does anyone use nvidia via geralds adapter on Y500. I can't instal driver for 1060 6gb. There is error code 43 device was stopped, in device manager.

Share this post


Link to post
Share on other sites

@Kuneroll, As I've written in literally every BIOS mod installation guide, the Error 43 is going to be quite common when NVidia's latest 1000 series GPUs are used. Please, follow this guide in order to fix it. This guide has also been confirmed working by @MWichni and his GTX1070ti.

Share this post


Link to post
Share on other sites

If anybody would like to sell their Ultrabay adapter a little bit cheaper, please message me.

Share this post


Link to post
Share on other sites

EROR 43.

1060 6gb on Y500 all right. Download driver 368.81,no modify. Clean driver via DDU. in device manager rightclick on the basic graphic adapter on port PCI2, actualize driver, from disc, search driver 368.81,instal. restart. then instal Geforce expirience and actualize. in device manager disconnect GT650m.

PS: maybe is possible to instal only newest driver after clean via DDU. I didn´t try.

 

Does anyone know why I have bus interface only  x16 2.0 @ x8 2.0 ?

Swung Huang has 3.0

2018-06-13 (4).png

2018-06-13 (1).png

Edited by Kuneroll

Share this post


Link to post
Share on other sites

Hello guys. I am watching this thread for about some months because i have also a lenovo y510p and i was interesting for a solution for external gpu because now the laptop is kinda limited in power on gpu. I would like to ask if it's possible to use a cable like this https://www.aliexpress.com/item/Riser-Gen3-0-PCI-E-PCIe-x8-to-PCIe-x16-Graphics-card-extension-Riser-Ribbon-Cable/32839943463.html with the end of the connector being in sr mode as the pictures show into the link to extend the internal of the connector combining with an hdd caddy like this https://www.amazon.com/Nimitz-Drive-Caddy-Lenovo-Ideapad/dp/B00NAMUETC. At the end of the hdd caddy with some modification we can put the end of the riser connector and then with another riser like this https://www.aliexpress.com/item/Riser-Gen3-0-PCI-E-3-0-16x-male-To-pcie-x16-female-Right-Left-Elbow/32832150338.html?scm=1007.13339.90158.0&scm_id=1007.13339.90158.0&scm-url=1007.13339.90158.0&pvid=f0e9c06e-bae3-4a72-8af1-63cd1f8c80fa&_t=pvid:f0e9c06e-bae3-4a72-8af1-63cd1f8c80fa,scm-url:1007.13339.90158.0 we can easily connect and disconnect the gpu and retain portability for the machine. The only thing i can't understand is if the ultrabay port is something like PCI-E PCIe x8 connector or something else because i don't have a pci-e x8 connector to compare with ultrabay connector. Something like that linus tech tips did in their video.

 

Edited by DARKShadow45

Share this post


Link to post
Share on other sites
5 hours ago, Kuneroll said:

EROR 43.

1060 6gb on Y500 all right. Download driver 368.81,no modify. Clean driver via DDU. in device manager rightclick on the basic graphic adapter on port PCI2, actualize driver, from disc, search driver 368.81,instal. restart. then instal Geforce expirience and actualize. in device manager disconnect GT650m.

PS: maybe is possible to instal only newest driver after clean via DDU. I didn´t try.

 

Does anyone know why I have bus interface only  x16 2.0 @ x8 2.0 ?

Swung Huang has 3.0

2018-06-13 (4).png

2018-06-13 (1).png

At y400/500 it only has 2.0. 

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Do you currently sell this adapter and could i buy it with credit card? @gerald and does it support gtx1080?

Share this post


Link to post
Share on other sites

Hi,

 

I still have some adapters.

Pls pay €95,- (incl. €25,- for int. shipping) to my PayPal account. (Gerald.pichler@gmx.at).

I will send the adapter within a few days.

 

A GTX1080 does work with the latest BIOS upgrade -> the upgrade procedure is described in this forum.

 

 

Share this post


Link to post
Share on other sites
On 19/06/2018 at 11:49 AM, gerald said:

Hi,

 

I still have some adapters.

Pls pay €95,- (incl. €25,- for int. shipping) to my PayPal account. (Gerald.pichler@gmx.at).

I will send the adapter within a few days.

 

A GTX1080 does work with the latest BIOS upgrade -> the upgrade procedure is described in this forum.

 

 

Is it possible to attach a 2.5" HDD on the ODD-Sata using the current version of your adapter?

Share this post


Link to post
Share on other sites

There is a suggest in this thread how you can modify the adapter to connect a HDD and this adapter.

Share this post


Link to post
Share on other sites

Hey @gerald ! I just got my adapter today Ty! But I'm having some trouble, im using a rx470 card with a 600w psu.

 

Card is not being detected by windows.

When i power the laptop, the card fans blow for 2 sec then stops, but card lights stay powered on.

Im using 3.07 oficial bios, retail uefi grub dualboot w8.1 - debian

Bios setup is in Legacy mode

 

Any insights? @Tesla @David 'SOAP' Washington @Kuneroll @Swung Huang

Edited by caitdeen
more specs.

Share this post


Link to post
Share on other sites
3 hours ago, caitdeen said:

Hey @gerald ! I just got my adapter today Ty! But I'm having some trouble, im using a rx470 card with a 600w psu.

 

Card is not being detected by windows.

When i power the laptop, the card fans blow for 2 sec then stops, but card lights stay powered on.

Im using 3.07 oficial bios, retail uefi grub dualboot w8.1 - debian

Bios setup is in Legacy mode

 

Any insights? @Tesla @David 'SOAP' Washington @Kuneroll @Swung Huang

Looks like the problem was in PSU.

 

Any one have had trouble with a modular psu? I swapped psu to a 600w regular one (from a 700w modular) and it worked.

 

Btw, im using 3 monitor setup. (Internal, VGA output, and eGPU hdmi output). When i put some weight on gpu (cinebench) there are signal degradation in VGA laptop output. Any one have had experienced this?

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

Hmm never heard of Signal degradation. But why are you using the Laptops VGA output anyway? All the outputs are hardwired to the internal resources, if you want to connect multiple displays with your ultrabay adaptor correctly make sure all the connections go into your external gpu.

 

If someone is looking for an extender prepare to use your right to return, because length and build quality determine wether your card will work well or not.

 

A 1080 should work fine with pcie 3.0 8x, a TI might begin to loose a bit performance, but that effect might be negligible most of the time and only relevant in some scenarios which need faster pcie speed.

 

In my case with the gtx 980 which is quite equivalent to a 1060, I do not loose any performance whatsoever, the only factor in determining gaming speed here is the -compared to desktop setup framerates- slower CPU.

 

I run at 2.4 ghz most of the games (its a 4900 MQ for 8 MB of cache inside) and its stays below 80. With 2.8 ghz (which is stock speed/throttle target) it rallies at 80 and without changing anything about airflow i can manage to keep 3 ghz without throttling (happens when the cpu hits 90).

 

Any more speed would need an upgrade of the cooling solution, 3.2 ghz might be manageable with certain games but not all.

Edited by Marvin
Cpu info added

Share this post


Link to post
Share on other sites
On 28.6.2018 at 6:39 AM, caitdeen said:

Looks like the problem was in PSU.

 

Any one have had trouble with a modular psu? I swapped psu to a 600w regular one (from a 700w modular) and it worked.

 

Btw, im using 3 monitor setup. (Internal, VGA output, and eGPU hdmi output). When i put some weight on gpu (cinebench) there are signal degradation in VGA laptop output. Any one have had experienced this?

When connecting graphics cards make sure you use two different power cables for connection when your gpu has two sockets.

 

Not every psu is built the same, so even if a company prints 1200watts on the box, there might be scum inside.

Always look for tests online or take the silver/gold/platinum ranking as a hint.

 

I am working with a, be quiet bronze modular (got it cheap off craigslist), no problems here. Had an antec gold non-modular before, was too noisy and the cables were ennervating. But worked well!

Edited by Marvin
Added info

Share this post


Link to post
Share on other sites
On 25.5.2018 at 10:07 PM, mikmaze said:

looks good, how is it working?   how much $ involved for setup? board, wires, video card, power supply???

I pay in €, so you have to use that as indicator: 100€ for the adaptor, 60€ for the pci extender, 40€ for the used power supply and 150€ for the gfx card. Total about 350€. Depends on how much you spend, for the gfx card, but you are always in the 100 for the adaptor.

Better than spending 1000€ for a new laptop, especially since i have now performance on par with a 1070 max q.

Share this post


Link to post
Share on other sites

Hi guys, a question for those of you who now have a beefy eGPU in your y510p. Is your CPU now bottle-necking your system? What cooling/overclocking steps have you taken and what has the result been? Thanks in advance

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
On 7/11/2018 at 1:12 PM, doyouevenbinary said:

Hi guys, a question for those of you who now have a beefy eGPU in your y510p. Is your CPU now bottle-necking your system? What cooling/overclocking steps have you taken and what has the result been? Thanks in advance

 

There are some dudes here with a GTX 1070 on the adapter.

 

The CPU will sure bottleneck it as much as a i7 4770k running at 2.4GHz ~ 3.4GHz.

Read my previous post about cooling.

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

Depends on the resolution you ar using, i went with vega 64 lc (was chosing at the time nvidia cards did not work, oterwise id go with 1080ti) and in 4k i have maybe 20%-30% cpu usage in most games on max settings.

More or less in comparison with top end cpu/ram, you should expect 5% less in 4k , 10% less in 1440p and 15-20% less in 1080p(wont matter on 1080p, since most games will still be in hundreds fps)

A few examples is doom maxed 4k 60fps with dips to 50s ,witcher 3 maxed 4k without hairworks about 46fps avarage.

Either way if you still think you will need better cpu, consider it an upgrade path, you can buy adapter/gpu/monitor/psu and use with laptop now. And later on you can buy mobo/cpu/ram as an upgrade path and ditch the laptop.

 

And a samll thing ill add is that on y510p(non sli gt755m) without the adapter/gpu witcher 3 ran at lowest settings/resolution at 24 fps.....

Edited by Celestus
  • Thumbs Up 2

Share this post


Link to post
Share on other sites

Hi all,

 

I know that I am probably (very) late to this party, but I really would love to purchase one of this ultrabay epci gpu adpater for my y510p.

I wonder if this is still available...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By popozitos
      Hello everyone
      I created a case for egpu using 2.5mm acrylic sheets. The first time I created a case to support a GPU + ATX psu
      Now I created another one for the GPU with an external Xbox 360 203w psu.
      the finish was not good but for my use it is already good.
       
      *both cases album
      *Construction of the second case 
      *adapting xbox psu to 8pin power (taken from 24pin)
       
      all made by hand with the tools I had.

      from Brazil.

    • By jcrcarmo
      Hi folks,
        Greetings from Brazil!  Not sure I'm posting in the right place, but I have a question:  how do I find out the brand and model of my BIOS chip without having to open my laptop?  I can't find this information anywhere.  Been searching for days... I have a Lenovo Ideapad 300-15ISK 80RS (motherboard Paris 5A8).  Thanks a lot for your time and help! I really appreciate it!   Best regards,   JC.
    • By Consumerofmulch
      Hello!
       
      I have recently acquired my Dell Inspiron 15 7000, and I am interested in building an egpu setup for it. It has a USB-C port. Any recommendations/guides out there?
       
      thanks.
    • By Donz7733
      I am planning to get this Charger (170w 20v 8.5a) - https://www.amazon.in/Lenovo-ThinkPad-4X20E50574-170W-AC/dp/B00MLTQ99Y
      &
      the Adapter - https://www.aliexpress.com/item/32975526334.html?spm=a2g0o.productlist.0.0.27cb747e6TEc28&algo_pvid=a7db42d0-97cb-4a37-be7a-d19c44bddf73&algo_expid=a7db42d0-97cb-4a37-be7a-d19c44bddf73-0&btsid=8d6ee0f9-08e9-4474-b63b-cc751403b4c7&ws_ab_test=searchweb0_0,searchweb201602_,searchweb201603_60
       
      Will this combination work to run Both GT755m of Y510p?
       
       
      Thanks
       
    • By Sparkhunter
      Hi there guys,
       
      I've been looking into getting a new GPU for my laptop (4-lane PCI-e) and enclosure (HP Omen Enclosure) but I cannot decided between the RX 5700 XT and the RTX 2070 (non SUPER).
       
      I did some price to performance calculations (higher is better) with some of the best prices I can currently get in the UK.
       

       
      The RX 5700 XT does perform better and is cheaper than the RTX 2070 (Although the 2070 does come with 2 games) but my main concern is drivers and from what I've heard NVIDIA cards work a lot better with eGPUs than AMD.
       
      If anyone has experience using both red & green or if anyone else has any other input i'd love to hear your experiences and input.
       
      Thanks.
       
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.