Jump to content
EwinRacing Flash Series Gaming Chairs
gerald

Y510p Ultrabay Graphics card

Recommended Posts

no worries about that... you can share the model with the community.

I'm very happy to have people who work on this project and push it.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Hi everyone!

 

Here's the experimental mod for Y400/Y500: https://mega.nz/#!qBYE0BLa!Nos2gBVE8-_eOX8O5bSyxSEjgOQ154QSu4BWnk6C3qc

 

It is also based on Svl7's work and should enable both AMD and Nvidia eGPUs for Y400/Y500. So far, @Swung Huang has successfully tested it with GTX 1070 on his Y400, but I'd be grateful if more people verified that it works for them. Especially, would be interesting to hear whether AMD cards work too.

 

If everything is good, I'll create the separate topic for this one too.

 

-High_Voltage

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

hi

i just wanted to let you know guys that I've just fleshed the new 3.08 moded bios proved by: @High_Voltage 

I'm using it with an AMD Sapphire RX480 Nitro+ and its more stable then before. With bios 2.07 i sometimes had greeenscreen/blackscreen while playing games like: overwatch, PUBG and had to hardreset it because it stoped reponding. But now its gone thanks to you guys.

 

Ps: i had problem (DOS memory buffer 2 allocate failed) while fleshing the EC with freedos so i downloaded Rufus 1.1.7 and made a portable MSDOS on win7 (win10  doesent support this option just freedos) after that everything went fine :))

Share this post


Link to post
Share on other sites
1 hour ago, QDIR said:

hi

i just wanted to let you know guys that I've just fleshed the new 3.08 moded bios proved by: @High_Voltage 

I'm using it with an AMD Sapphire RX480 Nitro+ and its more stable then before. With bios 2.07 i sometimes had greeenscreen/blackscreen while playing games like: overwatch, PUBG and had to hardreset it because it stoped reponding. But now its gone thanks to you guys.

 

Ps: i had problem (DOS memory buffer 2 allocate failed) while fleshing the EC with freedos so i downloaded Rufus 1.1.7 and made a portable MSDOS on win7 (win10  doesent support this option just freedos) after that everything went fine :))

 Good to hear.

 

2 hours ago, AllanDavidson said:

Anyone tried a 1080/Ti? I'm thinking of getting one, but the current prices is holding me.

I tried it with GTX1070Ti which is nearly the same performance as GTX1080. Keep in mind that for 1080p and higher resolutions it is good to have more than 8GB of RAM.

Share this post


Link to post
Share on other sites
4 hours ago, QDIR said:

I'm using it with an AMD Sapphire RX480 Nitro+ and its more stable then before.

 

Good to hear that! Although I think that with AMD cards you would get the same result by just flashing stock v3.08 BIOS. There's nothing changed in the modded bios that would affect operation with AMD cards.

 

4 hours ago, QDIR said:

Ps: i had problem (DOS memory buffer 2 allocate failed) while fleshing the EC with freedos so i downloaded Rufus 1.1.7 and made a portable MSDOS on win7 (win10  doesent support this option just freedos) after that everything went fine :))

 

This is a really nice and important observation! Thanks a lot! Looks like I was right assuming that installing MSDOS by Svl7's insruction would solve the issue. Even though your method is different, it still requires Windows 7 (as does the HP Disk utility used by Svl7's). So, looks like people who encounter the error and still want their EC flashed have no other choice but to find a Win7 machine somewhere...

 

3 hours ago, Luthercorp said:

I got the adapter a couple days ago and I am running a Nvidia GTX 780 with Windows 8.1, and it works like a dream!

 

Glad that it works! Enjoy your new Nvidia eGPU! By the way, it would be cool if you tried to get the eGPU to pass the image to laptop's internal screen by using Optimus. There are plenty of instructions on how to do it on the Internet.

Share this post


Link to post
Share on other sites

One of the main problems I have with this GPU is that I can't use optimus. The Intel GPU doesn't even appear on the hardware list and I cannot install the driver. The 2 GPUs are always on (even on Idle) and the Battery Life is about 55 minutes. 

 

Iread somewhere that I need to remove the extra card, disable it on BIOS (which I can't do) or maybe uninstall the Nvidia Driver and use only the Intel driver, and since I game everyday, none of this is an Option.

 

Also, by enabling Intel iGPU I could use Quicksync and off CPU/GPU resources on encoding/decoding.

 

If taking one GPU away and using the adapter with another will make Optimum possible, allowing me to use the iGPU and increase my battery life, I would kill 3 duck with a single shot.

Share this post


Link to post
Share on other sites

From what I've learned while making those BIOS mods, it looks like this behavior is hard-coded in BIOS. Whenever you boot with Ultrabay GPU installed, the Intel GPU gets disabled and some SLI-related features are possibly activated. I think this is done deliberately because SLI systems don't support Optimus technology. When you remove your Ultrabay graphics, Intel GPU gets enabled and Optimus becomes available. Of course, such solution is not perfect, but it's still MUCH better than what they've done in Y500 series (they disabled the Intel GPU permanently even for when Ultrabay adapter is removed).

 

This way fiddling with drivers or disabling GPUs in hardware manager obviously won't help. There might be a way to design a BIOS mod that allows you to boot with all three GPUs at the same time, but I can't think of any practical use for this (as it will obviously break the SLI and would be equivalent to just booting without Ultrabay at all).

 

Theoretically, using any Nvidia-branded eGPU that supports Optimus with an adapter would allow you to play games on laptop's internal screen. There's plenty of information regarding how to do this across the Internet, including Techinferno. The procedure shouldn't be different to that for mPCI-e x1 setups. It might be that you'll need to disable internal GT750M, which should be possible via the Svl7's unlocked menu in BIOS. Moreover, it seems that there's a way to use laptop's internal screen even without Optimus (therefore it can be done on Y500/Y400 too). But this only works for games that run in Windowed / Borderless windowed mode.

Share this post


Link to post
Share on other sites

External GPU docks are expensive! Just wondering if it's worth the money to upgrade to an external GPU or should I just save the money towards a newer laptop.

Share this post


Link to post
Share on other sites
5 hours ago, Bowser said:

External GPU docks are expensive! Just wondering if it's worth the money to upgrade to an external GPU or should I just save the money towards a newer laptop.

 

Wrong forum thread maybe, because its about external GPU, but if you can get external GPU cheap now - upgrade to it. If you want to play some game which you cannot now - upgrade to it. But I myself am thinking that in 1-2 years there will be equally as good laptop with desktop version of the GPUs (like 1080) so I am saving for a new one.

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

@Swung Huang You mentioned it earlier, but can the ultrabay gpu work in tandem with the mSATA ultrabay connector? I thought those two connectors used the same PCIe lanes so it would have to be one or the other

Share this post


Link to post
Share on other sites
14 minutes ago, Luthercorp said:

can the ultrabay gpu work in tandem with the mSATA ultrabay connector?

I am not sure what you are talking about.

For the sata inside the ultrabay,that is a dedicated standard SATA port.

And it has nothing to do with the one connected to the GPU.(actually there are two ports there).it just physically conflict with the GPU port. Just run a cord and all things will be fine.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
22 minutes ago, Swung Huang said:

I am not sure what you are talking about.

I got my terminology messed up, I thought that it was a mSATA port in the ultrabay slot. Thanks!

Edited by Luthercorp
Grammar

Share this post


Link to post
Share on other sites
On 3/28/2018 at 12:47 PM, QDIR said:

hi

i just wanted to let you know guys that I've just fleshed the new 3.08 moded bios proved by: @High_Voltage 

I'm using it with an AMD Sapphire RX480 Nitro+ and its more stable then before. With bios 2.07 i sometimes had greeenscreen/blackscreen while playing games like: overwatch, PUBG and had to hardreset it because it stoped reponding. But now its gone thanks to you guys.

 

Ps: i had problem (DOS memory buffer 2 allocate failed) while fleshing the EC with freedos so i downloaded Rufus 1.1.7 and made a portable MSDOS on win7 (win10  doesent support this option just freedos) after that everything went fine :))

Interesting. I've been interested in using a more up to date BIOS. To reiterate, this modded BIOS works with the first version of gerald's adapter? Also allows nVidia? I too am using an RX480, but curious about the future.

 

 

Edited by Blk6Jeff

Share this post


Link to post
Share on other sites
On 1/27/2018 at 5:48 AM, David 'SOAP' Washington said:

image.thumb.png.87ee4677ed850ffca5357488c05cdead.png

 

Share a mod from other man with you guys , Ultrabay Adaptor & Sata3 box.

Finally, it can be locked in, and won't be plug out by accident anymore.

@David 'SOAP' Washington do you have any more pictures/information on this mod? What is this? A Ultrabay adaptar that have both PCI Express and SATA connectors?

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

@gerald

I'd love to buy one of your adapters, depending on the price. How much would it be total to ship to the US?

Also, is there anyway you could release your schematic? I think it would be really cool to have an ultrabay adapter that sat in the laptop all of the time with a connector on the outside of the laptop that would go to a separate full sized pci slot. That way you wouldn't have to keep inserting the board everytime you docked. 

Thanks 

Edited by Lemons
Typo

Share this post


Link to post
Share on other sites
16 minutes ago, Lemons said:

I think it would be really cool to have an ultrabay adapter that sat in the laptop all of the time with a connector on the outside of the laptop that would go to a separate full sized pci slot. That way you wouldn't have to keep inserting the board everytime you docked. 

Hey I'm currently working on it. Stay tuned for that.(But I'm not planning to sell one of them)

Share this post


Link to post
Share on other sites

I bought it at online components.com

You purchased 3 items
44869647.jpg 2199015-1 TE Connectivity / AMP Brand 
Conn Power PL 30Power/88Signal POS Solder RA Thru-Hole/SMD 118 T
$10.90
   
 
50 Ships Today Quantity:  50

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By raqall
      Hi!

      I would love to have my BIOS modded to disable the wireless whitelist.
      I tried to do it myself (dump BIOS from chip, disassemble, locate the reference to the error message "Unauthorized Wireless network card is plugged in..." memory address and modify the condition in the binary file so not to "land" in the infinite loop) but I couldn't dig to anything meaningful I could easily change.

      Laptop: Lenovo ThinkPad S440 (TYPE 20BB-S00400)
      BIOS version: 73ET71WW (1.71)
      Original WiFi/BT card: Intel Wireless-N 7260 (7260HMW BN) (vendor: 0x8086, device: 0x08B2, subdevice: 0x4262)
      Target WiFi/BT card: Broadcom BCM94352HMB (I haven't received it yet, waiting for delivery)

      Manufacturer BIOS download: bootable ISO, updater for Windows
      My BIOS dump (using CH341A SPI Programmer under Linux): http://www.mediafire.com/file/mn0gfr9ext7yqrn/S440_73ET71WW.bin/file
       
      Thanks!
    • By Klem
      In this thread you can post your requests for Lenovo Y50-70, Lenovo Y70-70, Lenovo Z50-70, Lenovo Z70-70, Lenovo G50-70, Lenovo G70-70.
      If someone want upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, or unlocked vbios for overclock NVIDIA card, then you can post your request in this thread. Also, if you have a problem with fan pulsating/clicking on any modified bios then you can post your request in this thread.
       
      The flashing procedure include two steps:
      1.  Flash main system bios.
      2.  Flash EC firmware.
    • By damianalex
      Hi,
      I want to show you my new project.
      I bought my laptop about 5 years ago.  It was never speed deamon, but for every day use, it was enough to me.
       
      Its specification:
      Intel i7-4700MQ
      Nvidia GeForce GT745M
      16GB RAM
      512 SSD Adata SU800

       
      Yesterday I bought Witcher 3. Of course on 1080p it's impossible to play, because of about 10fps
       
      So I make a decision to buy external grahpic card.
      I choose GTX970 and now I am looking for occasion to buy it.
       
      I've already bought EXP GDC v8.4d mPCI-E. It is used and cost about 30$.

       
      I will use ATX PSU to supply graphic card, because I have old desktop PSU at home.
       
      My plan:
      1) unlock bios
      2) buy GTX 970
      3) enjoy Witcher 3!
       
      BTW I try to cool down my laptop, so I replaced thermal paste to Kryonout Thermal Grizzly and make some tests. Temperatures and fps are on screenshots.
       
      1) laptop on table, playing GTA V 1080p

       
      - first minute (GPU core 1045MHz)

       
      -after some time, because of high temperature and GPU throlttling (GPU core drop down even to 400MHz)

       
      2) with thermalpad Glacier NC400 SilentiumPC

      - 30 minute and longer (GPU core drop to about 900MHz)
       
      3) without down case of laptop (like on picture with thermal paste) on thermalpad.
      Here laptop never drops down MHz and max temp are about 72 Celsius degrees.

       
       
      Bacause of that I bought second down case for my laptop and I will cut there additional holes.
       
      Greetings!
       
      I will describe next step when I get all stuff I need!
       
       
    • By popozitos
      Hello everyone
      I created a case for egpu using 2.5mm acrylic sheets. The first time I created a case to support a GPU + ATX psu
      Now I created another one for the GPU with an external Xbox 360 203w psu.
      the finish was not good but for my use it is already good.
       
      *both cases album
      *Construction of the second case 
      *adapting xbox psu to 8pin power (taken from 24pin)
       
      all made by hand with the tools I had.

      from Brazil.

    • By jcrcarmo
      Hi folks,
        Greetings from Brazil!  Not sure I'm posting in the right place, but I have a question:  how do I find out the brand and model of my BIOS chip without having to open my laptop?  I can't find this information anywhere.  Been searching for days... I have a Lenovo Ideapad 300-15ISK 80RS (motherboard Paris 5A8).  Thanks a lot for your time and help! I really appreciate it!   Best regards,   JC.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.