Jump to content
flyingfishfinger

Thinkpad X61 <-> Quadro K610M; No NVIDIA Control Panel?

Recommended Posts

Hi,

I've got a Thinkpad X61 (C2D, 2GB RAM) running Win 7 Pro SP1 to which I'd like to connect my eGPU. I've made my own PCB (MXM <-> mPCIe adapter) so I'm testing it, but I have too many variables for the moment. This is a clean install of Windows.

 

I have an NVIDIA Quadro K610M card and have installed driver package 364.51. I have done the Large Memory DSDT override successfully and conquered error 43 using the PCI dump in Setup 1.30. It detects the GPU fine and initializes it, once I get to Windows everything *seems* to work, but only if I disable my internal Intel GPU (ok for now, I'll fix that later). Device Manager tells me I have a working NVIDIA card. GPU-Z detects it fine as well.

 

The issue I'm having is that I'm not getting anything at all on the VGA port. I realize this very well might be a HW issue, but I'm not convinced yet. I would like to try to use the NVidia Control Panel to verify what's going on, but I can't open it. nvcplui.exe is running in the Task Manager, but I don't get anything else. I read that this is a known issue with no particular fix and I wanted to see what folks here thought, given that this is being used for an eGPU.

 

By the way, the normal "Adjust resolution" dialogue doesn't detect any 2nd screen, but then it seems to be specific to the iGPU (which is listed as the hardware under "Advanced") so it shouldn't work anyway. Is there a way to get the built-in Windows Control Panel to detect / use the new GPU?

Any input is appreciated, and further clarification gladly provided.

Thanks!

 

Rafael

Edited by flyingfishfinger

Share this post


Link to post
Share on other sites

I have the same issuer but with out Setup 1.30. How can help us?

flyingfishfinger can we remain in contact to solve this issue? Send me a private message if you want it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Kel
      I got the exp gdc beast 8.5 got all the connections right... laptop boots up... fans turn on the gpu.... device manager detects gtx 1060 with a “ ! “ in a yellow triangle. Now what to do.... i tried to do the bios mod.... but realised that i have 3.07 version. 
      Questions-
      1 is there any way to get this done without the mod?? 
      2 if mod is the only way... kindly help me with step by step instruction in laymans terms... i m not a techy... so i might not understand technical terms.... altho i am interested... but learning yet. Please help. 
    • By thechillhacker
      Hello all
       
      I have a Clevo P370EM3 laptop with a pair of GTX 680Ms in SLI mode and have never been able to get Linux to work properly with full acceleration and without tearing. I have tried every xorg config I can find, and even all the modifications from the nvidia configurator to no avail. Has anyone been able to get these things to work 100% in Linux? I have typically used ubuntu based distros, including Mint, and every available driver version from the repositories, but can never get it to work quite right.
       
      Thanks for any help anyone can provide. It is killing me to run Windows on this machine because of these issues, and I am almost to the point of installing the inferior 7970 cards.
       
      Have a great day
      -TCH
    • By jhsd1124013561
      Help! I created a BOS BOOT DISK and use legacy to boot in DOS.   But it is saying that "An operating system wasn't found".   I have extracted all the files (the alienware m18x r2 a11 unlocked bios) into my external hard drive (format: NTFS)
    • By Say
      Wlc,
      I want to create an afermarket diy cooling solution for my laptop.
    • By Brian
      The new leak of NVFlash version 5.513.0 with their new RTX GPU (Turing) support is now available in our download section. This includes support for NVIDIA's new RTX 2080 Ti, 2080 and 2070 desktop GPUs. As always, use caution when reading/writing vbios files as you can potentially brick your card and void your warranty. 

      View full article
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.