Jump to content
EwinRacing Flash Series Gaming Chairs
lebraeu

Problem | Mac Mini Late 2014 + Aikito Thunder 2 + Asus GTX 970

Recommended Posts

Hey Guys,

i've got bit of a problem with my current eGPU Setup. I followed some of the excellent guides and wanted to do a small but powerful setup. 

 

My Aikito Thunder 2 is only powered by a 150Watt Leicke AC Adapter but i think the gtx 970 also needs power supply maybe thats the error here. 


When i'm booting with everything plugged in i get an "ACPI_BOOT_ERROR" from windows if i hot plug everything i get this little warning sign in the devices manager with an error 43, maybe cause the graphic card don't get enough power.

 

I also ordered the Dell DA-2 from amazon and it's coming tomorrow but what i'm missing is this 6 to 8 pin to dc barrel plug adapter which i cant find online and i have no expertise in building cables :( Maybe if someone of you guys knows how to build something like this i would be very thankful and of course paying you something for this.

 

Hope you can help me :) thanks in advance

 

Here is the current setup:

1jeb7?response-content-disposition=inlin

 

yEWf?response-content-disposition=inline

 

 

 

Here is the error:

 

1fHc3?response-content-disposition=inlin

 

 

 

and here is the cable i need but i dont know how to build or where to buy:

1bW5t?response-content-disposition=inlin

 

 

 

 

Share this post


Link to post
Share on other sites

The 120W PSU is way too little to power that setup. Also the GPU has to have the 8-Pin PCIe plug inside!

So getting the Dell DA-2 is a good choice. The adapter can easily be done with some soldering.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By PrecastFlame
      Hi, I'm having problems trying to connect a GTX 750 Ti to my Lenovo T420 using the dock EXP GDC Beast (express card version).
      My laptop: Lenovo T420
      RAM: 8GB DDR3
      CPU: Intel Core i5 2520M
      GPU: Intel HD Graphics 3000
       
      My problem is: if I plug the express card and I turn on the laptop it doesn't boot up and the screen becomes horrible, with coloured pixels and a sound like "bip-bip".
      If I try plugging the express card when the laptop is already turned on it sees the gpu, but if try installing the drivers I have to apply the modifies restarting the computer.
      I hope you understood my problem (I don't speak English very well).
      Please help me, It's making me crazy!
       
      EDIT: I didn't say that if I plug the express card when the pc is already turned on, in the device menager there is "Error 12" on the gtx 750 ti
    • By baddea
      I want to know if i can using external gpu RX 480 GPU with windows laptop ASUS G751JT that have dgpu
       
      i need to using interal gpu  in my linux arch and second gpu to using with windows 10
       
      please i need answers
       
    • By Ignacio
      Hello .

      My laptop (clevo p170em) have a  problem. When powered on  only show the power button light in white and the bluetooth in orange. Then show three blinking lights (num lock, caps lock, scroll lock) and the fan runs, and past few seconds then the laptop powered itself off. The screen always black 

      you tell me what happens, or what does that code indicate? 

      Best regards

      Ignacio
    • By Solaire
      Hi everyone,
      I hope I'm not going to write off-topic;
      I own an Acer Predator 15 (G951) notebook, and it never gave me problems before; I've never used the integrated audio jack port because I usually listen to music and other stuff through Bluetooth headphones, but few weeks ago I noticed that putting a jack connector in the jack port only deactivates the sound from the pc speakers, but the headphones don't appear in the "devices" section, and the sound coming out from the headphones is really faint and distorted (only if the system slider of sound is at the maximum level and the sound should be very noisy, when the level is lower I don't hear anything at all). Also, when I put a jack in the microphone jack port of the pc I hear the classic sounds of the jack which touches the pin connectors inside the port, but it doesn't happen with the headphones port. I tried almost everything: I changed a lot of headphones, both phone headphones with a single jack and pc headsets with two jacks (for the headphones and for the microphone) but every time it's the same. I installed and reinstalled a lot of different versions of the audio drivers, both from Acer and the productor (Realtek), and nothing changes, I also tried with Ubuntu and it's the same. What could be the cause, and can the problem be solved without any technic intervention? Anyway the warranty for my pc is still valid, but the assistance should be the very last resource (I should do a backup of everything and format and so on). And, the last question, I flashed a custom VBIOS some time ago, does this compromise the warranty? Should I really reflash the original VBIOS or it's not so likely they're going to check on this?
       
      Thank you all for your attention!
    • By matthieuv
      Hey guys,
       
      Let me introduce you my eGPU setup, realized on a 2013 15" retina Macbook Pro, model equipped with a dedicated GT 750M. I am using an Akitio Thunder2 PCIe enclosure and a EVGA Geforce GTX 1060 SC 6Gb.
       
      I wanted to use both internal and external display on my Mac.
       
      I was looking for information during weeks before buying it and wasn’t really sure if it would work as I wanted to. Many people are convinced that using the internal screen is impossible  or way more complicated if the Mac has a dedicated GPU.
       
       
       
      I spend a whole week formatting and testing, using UEFI, BIOS, considering going back to Windows 7 (not for long)…
       
      I finally used Windows 10 UEFI, the programs rEFInd and GPU-switch and nothing else !
      No need for an HDMI headless ghost or any program to spoof the number of screens.
       
      I made a video to show you the whole installation process, I hope that it will help:
       
       
       
       
       
      My GF did the voice acting as I wasn't convinced by my own
       
      If you prefer a text-based tutorial, here are the different steps:
       
      1)    Installation of Windows 10 in UEFI mode
       
      On the 2013 retina Macbook Pro, the SSD is a PCIe model. This seems related to the UEFI mode used by default when using the Boot camp assistant. If you don’t want to use it or are using another model of Macbook, you can follow this excellent tutorial to force the UEFI mode:
      http://fgimian.github.io/blog/2016/03/12/installing-windows-10-on-a-mac-without-bootcamp/
       
      You just need to create a conventional partition and convert your table partition from “hybrid” to “protective”. By doing this, Windows will see a GPT disk instead of MBR. You just need to boot your USB drive on EFI mode.
       
      Once Windows is properly installed with the correct Macbook drivers (another reason to prefer the boot camp assistant), you need to go back to Mac OS.
       
      2)    Installing rEFInd
       
      rEFInd is a boot manager tool, like rEFIt or GRUB. Its first advantage is the ability to choose the OS without the need to press a key at startup. And the real reason why we are using it is to spoof the computer to allow Windows seeing the entire installed hardware.
       
      You can install refind from this link: http://www.rodsbooks.com/refind/
       
      Then you need to activate this spoof ability by opening a terminal and typing these two commands:
       
      sudo mkdir /Volumes/efi
      sudo mount -t msdos /dev/disk0s1 /Volumes/efi
       
       
      Now, you can see your EFI partition in your Finder.
      Go to EFI/EFI/refind and open the file refind.conf with textedit.
       
      Search for the “spoof OS version” and remove the comment symbol #
       
      Reboot your computer and choose Windows on the rEFInd screen.
      Open your device manager, you’ll see your iGPU (intel iris pro graphics 5200) and dGPU (Geforce GT 750M)
       
      3)    gpu-switch
       
      GPU-switch can be downloaded from there: https://github.com/0xbb/gpu-switch
      Download the windows version, available in the description
      (direct link : https://github.com/0xbb/gpu-switch/releases/download/v0/gpu-switch-windows.zip )
       
      Install Microsoft C++ redistributable (not sure which version do the trick, I’ve installed each version in x64 and x86 just to be sure)
      open the file integrated.bat with administrator rights, you should see the word “success”
       
      4)    GPU driver installation
       
      Not sure if this step is necessary but I’ve removed the dGPU driver before installing nVidia GeForce experience. The program DDU (Display Driver Uninstaller) is perfect for that.
      You can download it using this link: http://www.guru3d.com/files-details/display-driver-uninstaller-download.html
       
      Choose to uninstall and shutdown the computer, as you will install a new hardware indeed
       
      When your computer is off, plug the power supply to your eGPU, press the computer power button, wait for the chime and the rEFInd screen to appear, then plug your eGPU to the Macbook and launch Windows. If rEFInd is stucked, hold the power button until the computer is off.
       
      You should now see three graphics cards in the device manager, two of them not recognized at this point.
      Install nVidia GeForce experience and the latest nVidia driver. The GPU list will be updated at the end of the installation process.
      Re-launch GPU-switch and reboot. You don’t need to unplug the eGPU when rebooting.
       
      Now, your eGPU should have an error code 12, with unsufficient resources available.
      Just right clic on the dGPU (GT 750M) and disable it. Re-launch gpu-switch just to be sure (integrated.bat) and reboot.
       
      Just a last step and you’ll good to go
      Right click on the nVidia icon in your systray and open the configuration panel. Go to PhysX and set it to automatic instead of processor, like on this picture:
       
       
       
      That’s it, you can now launch your games on the internal screen or using an external monitor
       
      To switch between both, just plug the display on the eGPU and use the shortcut Win + P (Cmd + P on a Mac keyboard) to toggle between both screens.
       

       
      You can also duplicate them, it works, but don’t expect any kind of good performances doing this
       
       
      Now, the most important part, to avoid screwing your configuration: every time you go back to Mac OS, Windows will switch to the dedicated GPU (maybe also when turning off the computer, I’m not sure).
      For this reason, always re-enable the GT 750M before turning off the computer! Otherwise, you’ll get a black screen at Windows startup.
       
      Just follow this procedure when you want to use your eGPU:
      -       Use gpu-switch to set the integrated GPU as primary
      -       Disable the dGPU from the device manager
      -       Turn off your computer or reboot
      -       When you see the reEFInd screen, plug your eGPU and launch Windows
      -       Play you favorite video game or launch your intensive GPU application (there are two schools)
      -       Re-enable your dGPU from the device manager
      -       Turn off your computer
      -       Unplug your eGPU
       
       
      Now, some advices based on my little experience:
       
      If your end up with a black screen, you can restore Windows to a previous restauration point or remove the display driver. If you really can’t boot windows, using Parallels Desktop, you can boot your Windows partition from a virtual machine, then remove the display driver.
       
      At first, I was experiencing a game crash and the GPU fan running at max speed, when launching any sort of game. This issue was caused by the power supply connection, using an Xbox 360 S adapter with too thin wires
       
      These wires caused a voltage drop when consuming the 100W needed when playing a game (against 15W on Windows)
       
      About the electrical connections, here are a few pictures
       
       
      I’ve added a connector on the free PCB footprint to avoid soldering wires on the board. The cables are 0,75mm2 section and fits perfectly the original jack hole.
      About the PCIe power connector at the top of the graphic card, I had to cut it with a Dremel to fit the enclosure. You can find specific (and pretty expensive) cables on Ebay if you don’t want to modify one.
       

       
       
      For the ventilation, a colleague helped me cutting holes in front of the fan. I’m not sure to keep this solution, as some games make it very noisy.
       

       
       
      Let me know if this tutorial or the video did help you. Don't hesitate to ask for support if you want to do the same setup.
       
      Some websites are pretty discouraging about the concept of eGPU, the whole process is not pretty user-friendly but I'm happy to see that there is an active community growing each year !
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.