Jump to content
EwinRacing Flash Series Gaming Chairs
Sign in to follow this  
tiger_1829

RapidDrive VS ExpressCache

Recommended Posts

I just recently clean installed with Windows 10. I'm somewhat confused with the caching feature for my mSATA SSD. People on other forums have shared their frustration on getting the caching feature to work and have narrowed them down to Intel's Rapid Storage Technology's Acceleration feature, Lenovo RapidDrive, and ExpressCache. I scoured all over to find my particular instance but I was left more confused than when I started. I did learn that the acceleration feature no longer works since I do not have an acceleration tab anymore and that RapidDrive no longer seems to apply. I've yet to try ExpressCache. Anyone who has experience with this can lead me to the right direction? 

Share this post


Link to post
Share on other sites

Ive been using express cache myself.  I bought the version of the Y500 without an SSD.  Shortly after I bought a 32GB Crucial mpcie SSD and installed it myself.  I then dealt with the exact question as I was trying to figure out how to make sure it worked.  I ended up going with ExpressCache, though I also had the Intel Rapid Storage on my system.  ExpressCache can be a little confusing as there isnt a specific utility, its all command line based.  But if you get it installed you can confirm it working via the command line and then you are good.  As you may be aware your SSD will not show up under my computer. 

 

This is what I followed to get it working:

https://support.lenovo.com/us/en/documents/ht074404

 

 

Share this post


Link to post
Share on other sites

Thanks man, seems like I managed to get it working I think. I ran "eccmd -info" in my CMD after installing ExpressCache and letting it take over my entire mSATA and this is what I got:

 

EC Cache Info
==================================================

Mounted                   : Yes
Partition Size            : 14.88 GB
Reserved Size             : 2.00 MB
Volume Size               : 14.88 GB
Total Used Size           : 12.92 GB
Total Free Space          : 1.96 GB
Used Data Size            : 12.85 GB
Used Data Size on Disk    : 12.92 GB

Tiered Cache Stats
==================================================
Memory in use             : 1024.00 MB
Blocks in use             : 8188
Read Percent              : 5.64%


Cache Stats
==================================================
Cache Volume Drive Number : 0
Total Read Count          : 5867
Total Read Size           : 262.84 MB
Total Cache Read Count    : 2855
Total Cache Read Size     : 115.09 MB
Total Write Count         : 18299
Total Write Size          : 430.77 MB
Total Cache Write Count   : 12711
Total Cache Write Size    : 141.97 MB

Cache Read Percent        : 43.79%
Cache Write Percent       : 32.96%

 

 

Share this post


Link to post
Share on other sites

You bet.  Looks good to me, I get a similar readout.  It will take some time to notice the effects, but once it establishes your common used files etc, it really speeds certain things up, especially boot times.

Edited by IR1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By sam@83
      Hello !
      I tried a tutorial on the forum to remove the supervisor password on a X260 thinkpad but the winbond 25Q128FVPQ chip is not recognized with the programmer CH341A and ASprogramer (does not detect automatically and not manually). Plugged into the motherboard with a soic8.

      Can you help me with detection?
      Can I find the password with the software or do I have to write it?
       
      Thank you so much !!!
    • By Cubitci
      To install the unlocked bios, I prepared and booted a freedos usb. I start the installation by typing flash.bat but every time I get the following error: Error 28: Protected Range Registers are currently set by BIOS, preventing flash Access. Please contact the target System BIOS vendor for an option to disable Protected Range Registers.
      How can i solve this problem ?
    • By arifhsn
      https://www.sendspace.com/file/0zjk9f
       
      please help i can't access my g5070's advanced menu
    • By raqall
      Hi!

      I would love to have my BIOS modded to disable the wireless whitelist.
      I tried to do it myself (dump BIOS from chip, disassemble, locate the reference to the error message "Unauthorized Wireless network card is plugged in..." memory address and modify the condition in the binary file so not to "land" in the infinite loop) but I couldn't dig to anything meaningful I could easily change.

      Laptop: Lenovo ThinkPad S440 (TYPE 20BB-S00400)
      BIOS version: 73ET71WW (1.71)
      Original WiFi/BT card: Intel Wireless-N 7260 (7260HMW BN) (vendor: 0x8086, device: 0x08B2, subdevice: 0x4262)
      Target WiFi/BT card: Broadcom BCM94352HMB (I haven't received it yet, waiting for delivery)

      Manufacturer BIOS download: bootable ISO, updater for Windows
      My BIOS dump (using CH341A SPI Programmer under Linux): http://www.mediafire.com/file/mn0gfr9ext7yqrn/S440_73ET71WW.bin/file
       
      Thanks!
    • By Klem
      In this thread you can post your requests for Lenovo Y50-70, Lenovo Y70-70, Lenovo Z50-70, Lenovo Z70-70, Lenovo G50-70, Lenovo G70-70.
      If someone want upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, or unlocked vbios for overclock NVIDIA card, then you can post your request in this thread. Also, if you have a problem with fan pulsating/clicking on any modified bios then you can post your request in this thread.
       
      The flashing procedure include two steps:
      1.  Flash main system bios.
      2.  Flash EC firmware.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.