Jump to content
EwinRacing Flash Series Gaming Chairs
Sign in to follow this  
xorgal

Zotac GTX 970 e-GPU performance issue

Recommended Posts

Hi all,

Just finished assembling Zotac GTX 970 e-GPU build based on Akitio Thunder2 box and have tried to test it with internal display using Optimus and Windows 10.

 

It seems like GTX 970 is recognized by Windows and starting without any problems, however when I'm running 3DMax Firestrike benchmark performance is very poor and I've got only 1347 scores just like using Intel Iris graphics. Here is a link for my recent results: http://www.3dmark.com/3dm/10641833

 

And my spec is as follow:
MBPr 15" (Mid 2014) Intel Iris only + Zotac GTX 970 + Akitio Thunder 2

Win 10 (Latest updates) and NVidia drivers ver.: 361.75

 

Any ideas what might be wrong?

 

Thanks in advance and apologize if that question was already asked. :)

 

 

 

 

 

 

ZotacGTX970.gif

ZotacGTX970_2.gif

Edited by xorgal
Added pictures

Share this post


Link to post
Share on other sites

Can you test with an external display? Are both GPUs in your device manager?

Share this post


Link to post
Share on other sites

Using win10, thats your problem, only win8.1 works internal for egpu for now

Verzonden vanaf mijn iPhone met Tapatalk

Share this post


Link to post
Share on other sites
14 hours ago, Dschijn said:

Can you test with an external display? Are both GPUs in your device manager?

 

That's correct Dschijn, both Iris and GTX can be seen in device manager. Did a bit of search on forum, looks like Optimus is not working properly with Win 10, at least for now... So I would guess downgrading to Win 8.1 wil solve that issue?

 

Cannot test with external display for a moment, do not have any. :)

 

 

 

 

4 hours ago, Light said:

Using win10, thats your problem, only win8.1 works internal for egpu for now

Verzonden vanaf mijn iPhone met Tapatalk

 

Thanks for info !

2 hours ago, Dschijn said:

Windows 10 works great for on the internal display!

 

?? It is running well for me as well, but only  with Iris, e-GPU is not active during tests and gaming...

Edited by xorgal

Share this post


Link to post
Share on other sites
On 2/7/2016 at 5:39 AM, xorgal said:

 

That's correct Dschijn, both Iris and GTX can be seen in device manager. Did a bit of search on forum, looks like Optimus is not working properly with Win 10, at least for now... So I would guess downgrading to Win 8.1 wil solve that issue?

 

Cannot test with external display for a moment, do not have any. :)

 

 

 

 

 

Thanks for info !

 

?? It is running well for me as well, but only  with Iris, e-GPU is not active during tests and gaming...

I know you already reverted back to Windows 8.1 but for everyone else out there. Try out different boot procedures! Every setup is unique and there is no one-size-fits-all for boot procedures. Sometimes, even though the EGPU is seen, it wasn't actually initialized correctly, leading to it not actually working; yes, it does take a bit of fiddling around to get it to work properly.

 

But in my case, I found that Windows 10 works perfectly fine for Optimus for me with a mid-2014 15" MBP with Iris only.

I use a Gigabyte miniITX 970

Edited by ZapCord

Share this post


Link to post
Share on other sites

The new nvidia driver fixes optimus for win10 apparantly

Verzonden vanaf mijn iPhone met Tapatalk

Share this post


Link to post
Share on other sites
On 9 февраля 2016 г. at 6:10 PM, ZapCord said:

I know you already reverted back to Windows 8.1 but for everyone else out there. Try out different boot procedures! Every setup is unique and there is no one-size-fits-all for boot procedures. Sometimes, even though the EGPU is seen, it wasn't actually initialized correctly, leading to it not actually working; yes, it does take a bit of fiddling around to get it to work properly.

 

But in my case, I found that Windows 10 works perfectly fine for Optimus for me with a mid-2014 15" MBP with Iris only.

I use a Gigabyte miniITX 970

 

Thank you very much for info ZapCord, very nice to see that you've managed to make it working under Windows 10! In my case I didn't have enough time for testing, since had to leave home for the next month due to work and my goal was to bring with me 100% working e-GPU and avoid re-installing OS and games while abroad. So I've sticked with Win 8.1 for a moment but for sure upon return I will give Win 10 another try. Would be very nice to figure out what is the cause why sometimes Optimus is not working under Windows 10. Any ideas is it something that was fixed recently with latest NVidia drivers or problem is somewhere else?

 

BTW, here is my box. I know, there are a lot of unnecessary stickers on it, but that was done on purpose to avoid questions like "what is that black box with plenty wires" when passing security checks at the airports.  :) However, looks like that didn't help much since had to pass separate check at Frankfurt yesterday when Akitio was placed on X-Ray scan's belt. :P 

 

Not sure if it's worth to make a separate post for it, since it is not brining anything innovative to already well described guides from pioneers of DIY e-GPUs, but anyway I would like to give a huge thanks to Dschijn, HammerFET and other folks on this forum for posting their builds and answering my often silly questions during assembling. :)

 

 

 

 

e-GPU_GTX970.jpg

Edited by xorgal
  • Thumbs Up 2

Share this post


Link to post
Share on other sites

Ok, had to bring my first post up since another question appeared after some time of heavy gaming. :) Hopefully, somebody can give an a bit of help on my issue...

 

After about 60 hours of almost flawless Witcher 3 gameplay using both Optimus mode and External display have experienced several consecutive e-GPU crashes obviously caused by power failure, since  Dell DA-2 adaptor led is not showing any light indication after crash. In order to restart Akitio box have to unplug it from 220V socket and plug it again. Then, reboot Windows and everything works OK.

 

I didn't make any diagnostic yet since not sure where to start from but what was found, all crashes happened in different locations but with similar textures prevailing on screen which are looking very similar to haze. Attached screenshot was made just a moment before crash occured and upon restarting from saved game, another crash happened just on the same scene.

 

I haven't overclocked or changed any stock settings, the only alteration was made is custom e-GPU fan curve which is applied using MSI Afterburner. Akitio box is powered using Dell DA-2 adaptor and self made barrel plug. Any ideas what might be a cause of crashes will be much appreciated!

 

Thanks ! :)

 

 

 

b4_crash.jpg

Share this post


Link to post
Share on other sites

Hmmmmmm... might be the PSU. Maybe it gets too hot or your GPU has high peak loads.

What is the GPU you are using? Gigabyte?

If you monitor your GPU power in Afterburner, how high does it get? Try and lowering the power limit to 90%.

Share this post


Link to post
Share on other sites
8 hours ago, Dschijn said:

Hmmmmmm... might be the PSU. Maybe it gets too hot or your GPU has high peak loads.

What is the GPU you are using? Gigabyte?

If you monitor your GPU power in Afterburner, how high does it get? Try and lowering the power limit to 90%.

 

Hi Dschijn,

 

I'm using Zotac GTX 970 . Strange thing! I've just spent another hour in Witcher 3 in same location where I've experienced crashes before and today everything is running smooth. No problems... I was keeping MSI Afterburner and GPU-Z in background and made few screenshots of graphs.

 

The only thing that I've noticed is GPU power usage peak that was 113% at some point. Max GPU temperature 78, suppose that is normal.

 

Also, in GPU-Z prevailing PerfCap Reason during game session was Power restriction.

 

It might be a good idea to lower power limit as you advised above, however not sure if it is a case, since this time game was running stable in same locations without any adjustments... Will keep monitoring graphs and will post e-GPU behaivor in any further crashes.

 

It is also possible to suspect problem with Dell DA-2. Forgot to mention in previous post that I have power switch button installed in Akitio and after e-GPU failed, I was not able to start it by switching power button on and off and had to unplug DA-2 adaptor from socket in order to get yellow/green light indication back. 

 

 

3 hours ago, davidexD said:

Hi, if you see an high peak load and then it crashes might be a driver issue

 

Hi davidexD,

 

Thanks for reply, I've expereinced same crashes both with 361.75 and 364.51 drivers (updated yesterday), not an expert but seems like drivers are not an issue.

Desktop_2016_03_15_17_02_38_875.jpg

Witcher3.gif

Edited by xorgal

Share this post


Link to post
Share on other sites

Your Afterburner is not giving you all the options. In general you should also be able to set a power target. Yours seems to be unlocked and the GPU can boost freely. 113% of the custom power target could be a lot, since Zotac definetly set the 100% already way higher than a reference card. So with a propper 100-105% power target it should be stable.

Maybe try EVGA Precision X?!

 

Edit: Could be "skin" problem. Can you select a different skin of the Afterburner tool?

Edited by Dschijn

Share this post


Link to post
Share on other sites
1 hour ago, Dschijn said:

Your Afterburner is not giving you all the options. In general you should also be able to set a power target. Yours seems to be unlocked and the GPU can boost freely. 113% of the custom power target could be a lot, since Zotac definetly set the 100% already way higher than a reference card. So with a propper 100-105% power target it should be stable.

Maybe try EVGA Precision X?!

 

Edit: Could be "skin" problem. Can you select a different skin of the Afterburner tool?

 

Have checked Afterburner settings and found that all custom voltage settings were disabled by default so ticking appropriate options and changing skin to v3 made a trick and now I can play with power limit, change core voltage, etc! Thanks for tip, @Dschijn!

 

I have lowered Power limit down to 90%, saved profile settings and run the game to see how it works...

 

First run about 20 minutes - everything stable. What was found that actual GPU power usage is a bit higher then Afterburner settings, so sometimes it jumped up to 103%. Then, I've loaded location where I've experienced crash before and after 5 minutes in game e-GPU shutted down once again, same place, same textures...

 

I've managed to capture Afterburner screenshot just after crash occured, looks like a huge jump in power usage! :)

 

Now I'm wondering is it something wrong with Afterburner or is it more hardware related?... 

 

crash.thumb.JPG.3315672411ec4ada64aeee62

 

Edited by xorgal

Share this post


Link to post
Share on other sites

@xorgal i lowered the power limit to 70%, and i tested it on most wanted 6 hours today (i skipped work) no crashes 

i have 362.00 on

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.