Jump to content
useafo

BPlus PE4C V3/V2 discussion

Recommended Posts

Hello everybody !

I received the PE4C 2.1 with EC cable and one additional mPCI-e cable for trying double lane.

I haven't already bought the graphic card since I want to test it with some graphic card loaned from someone before investing on a GTX970.

post-34761-14494999943024_thumb.jpg

but not all news are good news PAY ATTENTION TO THE TOTAL COST The egpu costed me around 250 DOLLARS !!!

So please BE AWARE, if myself did knew about the extra coste of the hole thing I would never purchased this egpu. Because with the additionnal transit taxes that the DHL (wich seller chooses) imposes and if you add the customs taxes... for me it would be better idea to add an extra GAMING DESKTOP.

Now ? what's to do.. I am already got on the tramp, so no choice but continuing to try this setup...

I will inform you from my evolution.

N.B : I contacted Bplus questioning them why they did'n't speak of the additional DHL costs, and why they didn't give me the choice with another mailing service and that I feel misinformed I got NO REPLY. I am considering to open a dispute on paypal, any advice ?

Share this post


Link to post
Share on other sites

Import taxes and/or VAT are something you should have known about as well as curier handling fees when taxation happens.

In my country you get slamed for both on items over 26€.

Im sorry you didnt know that but those are not seller responsibilities and that extra money goes to DHL and your government.

Sent from my C1905 using Tapatalk

Share this post


Link to post
Share on other sites

The thing is that when I read our contract for payment, It was CLEARLY mentioned that the shipment adress is X and the total cost for the shipment to this adress is X. I'm not forced to be a guru of DHL manners to know that the contract isn't what it's written. I understand for the custom taxes, but for DHL it's not my problem, it's the seller who made a contract so I can receive my product to my exact adress for 23 Dollars, now if the shipment arrive to another city and I must go there with additionnal cost or pay DHL so they bring it to me, I'm sorry but this is a SCAM and stolen money. Transactions must be clear and me as a buyer I have the right to be protected.

BPLUS should say to me : HEY look we can't get the parcel to youy shipment adress, we only send it to a far city for this cost, and then I can give them the green light OR NOT. Or am I wrong ?? isn't this an abuse ?!

Share this post


Link to post
Share on other sites
SO NOW I AM CENSORED BECAUSE I SPOKE ABOUT THE EXTRA MONEY I PAID FOR GETTING THE PE4C ??

You were never band or censored. All I did was move your PE4C posts and any responses to it to this appropriate PE4C thread where your issue can be discussed and others learn from your experience.

The quoted comment in your spoiler was removed because it has previously been explained that PE4L 1.5 > PE4C V2.1 > EXP GDC in terms of Gen2 signalling from my experience with a Dell E6440. His comment suggests there are no issues with EXP GDC which is NOT true as others have also had this problem.

In any case, both the PE4C V2.1 and EXP GDC have been flagged as having Gen2 signalling issues on some systems. I had no probems with the soldered cable PE4L 1.5.

However, given your experience with high customs and given the response that suggest EXP GDC has no incoming customs cost, then the more cost effective approach for you would be:

EXP GDC > BPlus products

Even if the EXP GDC fails Gen2 you can still switch to Gen1 using the Setup 1.30 software.

Please edit your post appropriately for (1) casting blame on me for not noticing this post being moved and (2) repeating your previous post.

A PM has been sent to you to alert you to this post.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Okay I understand now, at first I had no notification that the posts were moved, so naturally I thought It was deleted just like that. Thanks anyways and sorry.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

I can say one thing that import taxes are not anything seller will know that you will be charged or not or even how much of the charging cost.

Actually in my country the same item can be charged with different cost or sometimes never been charged at all.

And I believe in most website there are always state "The seller will not take responsibility for the taxes" before buyers click buy button.

Share this post


Link to post
Share on other sites
Okay I understand now, at first I had no notification that the posts were moved, so naturally I thought It was deleted just like that. Thanks anyways and sorry.

If BPlus have no such disclaimer about you absorbing the incoming custom costs then you are within your rights to send it back and get a refund. Then can take a risk on EXP GDC which according to a poster has no custom fees. Even if it can only maintain Gen1 link speed it's still far more cost effective for you than paying 6 times more for a PE4C V2.1.

As an aside, I'll mention that BPlus are studying how to correct Gen2 signalling issues with it too. I've asked for a PE4C V2.1 type adapter with a soldered-cable like a PE4L 1.5 to solve that but none has been forthcoming as yet. I'll be alerted once there is any progress.

Share this post


Link to post
Share on other sites

Now I paid it all and it's difficult to resend it all and wait additionnal time, you know I want this product just for fun, gaming and for gpu based 3d software like lumion, and it will consume me more time to resend it and all...

I only wanted to share this because I felt misinformed, and mainly because I got no response from them. So if someone want to buy this product it would be recommended to discuss it all with them because there are surprises for the shipment cost (not the customs one) not said int he beginning.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
I can say one thing that import taxes are not anything seller will know that you will be charged or not or even how much of the charging cost.

Actually in my country the same item can be charged with different cost or sometimes never been charged at all.

And I believe in most website there are always state "The seller will not take responsibility for the taxes" before buyers click buy button.

@errin the problem isn't with the customs, but with the shipment, since BPlus didn't send the item to my near postal service and I go there where customs exist and I pay them. They send it to an airport and then DHL "force" you to pay them extra fees for the transit since you can't come 400 km to pay the customs yourself. The product is locked in your same country but in another city, and you must pay extra shipment and handling for getting the product near you. And, as a buyer I think it's not your responsibility, the contract mention the adress exactly and also the seller is the one who choosed the mailing service. (I already bought from internet with the products arriving to my city and then I pay the customs)

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

So a slight clarification on this issue:

The PE4C V2.1 is claimed to have no Gen2 signalling issues.

I recommend a slightly pricier BPlus PE4C V2.1 over any EXP GDC product as it has no Gen2 expresscard signalling issues when tested on my Dell E6440.

But recent discussion has been about getting stable Gen2 signalling on the PE4C.

As an aside, I'll mention that BPlus are studying how to correct Gen2 signalling issues with it too.

So are you saying that only the Express Card option has no Gen2 signalling issue but the mPCIe option on the PE4C still has it?

Share this post


Link to post
Share on other sites
So a slight clarification on this issue:

The PE4C V2.1 is claimed to have no Gen2 signalling issues.

But recent discussion has been about getting stable Gen2 signalling on the PE4C.

So are you saying that only the Express Card option has no Gen2 signalling issue but the mPCIe option on the PE4C still has it?

I am not saying another about mPCIe since I didn't test that. mPCIe might fare better since it has has less edge connectors as a cable comparative test done here found out.

Share this post


Link to post
Share on other sites

PE4C V1.2 is x2 capable, but Gen1 only

@All, PE4C V1.2 is x2 capable, but the thin FCC cable is not Gen2 compliant as explained by Roger @ BPlus. Gen2 signal quality is in order from best to worst: PE4L 2.1b > PE4C 2.1 > PE4C 1.2.

From: Roger @ bplus

Date: Thu, May 7, 2015 at 6:48 PM

Subject: RE: PE4C 1.2 - is it x2 capable? How is Gen2 signal integrity?

To: Nando

Hi Nando,

Please check the attached file for PE4C V1.2 schematic.

It design for x2 PCIE.

The performance is PE4L 2.1b > PE4C 2.1 > PE4C 1.2

PE4C 1.2 use FFC cable, PE4C 2.1 use HDMI cable.

The quality is HDMI better than FFC cable.

-----

From: Nando <Tech Inferno Faneva@gmail.com>

Date: Wed, May 6, 2015 at 4:56 PM

Subject: PE4C 1.2 - is it x2 capable? How is Gen2 signal integrity?

To: Bplus

Hi BPlus,

I've just had a customer confirm that a second FFC connector exists on the PE4C 1.2

Pictured at:

http://forum.techinferno.com/diy-e-gpu-projects/7910-diy-egpu-macbook-experiences-69.html#post131949

Could you please provide more info on what that does? Or better yet, link schematics on your website and/or post them to me so I can review them?

Interest there is:

1. Does the PE4C 2.1 support a x2 link?

2. Does the FFC connector and cable give better Gen2 signal integrity than the PE4C V2.1 with HDMI cable?

Due to the signalling issues from my experiences, I'm now reverting customers to consider purchasing in the following order:

PE4L 2.1b > PE4C 2.1 > EXP GDC

Drawbacks of the PE4L 2.1b being the missing niceties of the PE4C - x1 slot instead of x16, power connectivity.

Share this post


Link to post
Share on other sites

Dear all,

For my curiosity and also because of GTA5, I decided to have a look at the eGPU option.

My laptop:

- HP ENVY dv6t-7300 Quad Edition

- i7 3630QM

- 8Go RAM

- Geforce GT 635M

My eGPU:

- Geforce GTX 970 PNY

My eGPU board:

- PE4C v2.1a

My external PSU:

- 450W (https://www.afuture.nl//productview.php?productID=14658)

Current situation:

I did not use Setup1.x at all, my card is well detected, everything seems to be fine (I have just uninstalled the dGPU and rebooted):

https://fbcdn-sphotos-c-a.akamaihd.n...39be92cae5bebe

https://fbcdn-sphotos-e-a.akamaihd.n...5e86f2da073fb1

https://scontent-ams.xx.fbcdn.net/hp...69276896_o.jpg

https://fbcdn-sphotos-b-a.akamaihd.n...26230143_o.jpg

Problem:

When I run a really low requirement game e.g. Counter Strike 1.6, everything works perfectly fine. But when I try 3DMark 13 or GTA5, then it crashes not even 1 second after the game starts (after loading) and the laptop reboots.

Here is a video that illustrates my problem:

I am not experienced at all with eGPU, so I am not able to find out what might the problem be. What do you think?

Thanks!

Share this post


Link to post
Share on other sites

That's what I have in the Windows Event Viewer logs:

The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.

Source: Kernel Power

Event ID 41

Task Category 63

I installed other drivers (older) but still the same thing. I will get another graphic card from a friend of mine, we'll see what happens...

Only CS 1.6 works, the rest does not. 3D graphic tests from "Performance Tests" have all the same behaviour, they crash as soon as they start. 2D tests are OK.

Share this post


Link to post
Share on other sites

Another video that shows how the PC performance 3D test crashes. Here you can see how it crashes right after it starts:

Share this post


Link to post
Share on other sites
Another video that shows how the PC performance 3D test crashes. Here you can see how it crashes right after it starts:

This may be due to Gen 2 signaling instability. To test for that, you would either have to go into your BIOS or Setup 1.30 and set the slot to 1.1 speeds and run the same tests.

Share this post


Link to post
Share on other sites

Well I still did not check with gen1, but I have performed some test with GPUtest from Geeks3D and some work, some doesnt and show the same behavior(crash).

For those working (1280x1024 Fullscreen, no AA), both are heavy pixel shader tests.

- Piano: 2014

- Volplosion: 5593

To compare, my dGPU GT635 gets:

- Piano: 206

- Volplosion: 599

It seems pretty fair to me. The fan of the card starts to spin faster and the temperature increases. But When I run the FurMark (GPU burning test) it crashes as soon as it starts.

So I dont get it... I will try with Gen1 and with another PSU, I have currently a no name one.

Share this post


Link to post
Share on other sites

Any news regarding updated PE4L with resolved gen2 issues? It's starting to take quite a lot of time...

Share this post


Link to post
Share on other sites
Any news regarding updated PE4L with resolved gen2 issues? It's starting to take quite a lot of time...

I would suggest you contact BPlus to ask questions on the progress. I've already asked several times. The latest advice BPlus provided here is to use a PE4L 2.1b instead of a PE4C as giving the best Gen2 signalling.

Share this post


Link to post
Share on other sites

Hi guys,

I can't figure out how to get the PE4C to work with my ThinkPad W540 - any help would be greatly appreciated! Below is a copy of the email I sent to bplus support.

Thanks!

1. Bplus model Name

PE4C ver. 2.1a

PM100C mPCIe to HDMI

P15F ver. 1.0, M.2 (NGFF) to mPCIe Extender Board

Setup:

  • The WLAN card is removed from the PC's M.2 slot - and the P15F is inserted instead.
  • The PM100C is mounted on the P15F M.2 to mPCIe Extender Board
  • The HDMI cable from the PM100C is connected to the X1 port on the PE4C.

See photo!

post-36199-14495000189289_thumb.jpg

2. Question (problem description)

Not working at all.

The first problem to address, I believe, is that the GPU fan does not turn on at all - and hasn't at any point (not even for a second).

Note: I've tried with two different power supplies and two different GPUs (as listed below) - and the result is the same.

What happens:

  • The LED (R8 on the circuit board) on the P15F lights green when the computer is turned on.
  • When the HDMI cable is connected to the X1 connector (not the X2) on the PE4C:
    • The O1 LED on the PE4C lights red - and stays lid.
    • The O2 and O3 LEDs on the PE4C lights (flashes) green - but turns off again instantly.

Things I've tried:

  • Different power supplies (listed below)
  • Different GPUs (listed below)
  • All combinations of settings for SW1 and SW2
  • Different orders of connecting and turning things on:
    • Connect HDMI first, then turn on PC, and then the PE4C
    • Connect HDMI first, then turn on PE4C, and then the PC
    • First turn on the PC, then the PE4C, and then plug in the HDMI cable
    • First turn on the PE4C, then the PC, and then plug in the HDMI cable

    [*]Turning the WLAN option on and off in the BIOS.

3. System Environment (attach a PHOTO file if you can)

Computer:

Lenovo ThinkPad W540

Note: this machine is listed on the bplus website as being compatible with the PE4C.

Power Supplies tested:

Dell DA-2

Corsair AX1500i PSU

GPUs tested:

NVIDIA Titan X

NVIDIA GT 120

4. OS version

Ubuntu 14.04

Note: I don't think the OS is responsible for the GPU fan not turning on, but I can install Windows later, if that is required to get everything working.

Thank you in advance!

Share this post


Link to post
Share on other sites

US$88-shipped PE4C 3.0 just listed

Hooray. They've now made a soldered-cable version of PE4C 3.0. This product will give the best Gen2 signalling, same as the PE4L 2.1b but with the better x16 slot, Dell DA-2 input, direct ATX PSU input, two clock delays + more. It's even rated for 8Gbps PCIe 3.0 (!!)

This will should go a long way towards eliminating the "NVidia driver has stopped responding" glitches seen on the socketted EXP GDC and PE4C 2.x. This product costs a bit more than a US$50-delivered EXP GDC but (imho) worth it.

PE4C V3.0 (PCIe x16 Adapter)

<A HREF=http://www.hwtools.net/jpg/Bplus-taobao-2_PE4C_V3.0.jpg><img width=800 src=http://www.hwtools.net/jpg/Bplus-taobao-2_PE4C_V3.0.jpg></A>

Share this post


Link to post
Share on other sites

Maybe I'm just being a little ignorant, but how much difference is there between the PE4C and something like [this] with a connector like [this] instead of the one that comes with it. Is it just a case of getting what you pay for?

I was going to buy v2.1 but now that v3.0 is out I guess there's no reason to (even though I don't really like the soldered-on cable setup). I'm wondering if I should wait for it to hit amazon or just go ahead and buy it, but at $88 it would cost more than the graphics card I intend to purchase.

Is there any difference in speed between using ExpressCard and mPCIe? ExpressCard would be more convenient but I don't want to sacrifice performance if I'm paying this much for something I can't switch out the connectors on.

Share this post


Link to post
Share on other sites
Maybe I'm just being a little ignorant, but how much difference is there between the PE4C and something like [this] with a connector like [this] instead of the one that comes with it. Is it just a case of getting what you pay for?

I was going to buy v2.1 but now that v3.0 is out I guess there's no reason to (even though I don't really like the soldered-on cable setup). I'm wondering if I should wait for it to hit amazon or just go ahead and buy it, but at $88 it would cost more than the graphics card I intend to purchase.

Is there any difference in speed between using ExpressCard and mPCIe? ExpressCard would be more convenient but I don't want to sacrifice performance if I'm paying this much for something I can't switch out the connectors on.

You can't do the swap that you propose because the mPCIe adapter only wires through USB.

There is no different in speed between mPCIe and expresscard (EC). As strange as it may sound, I actually found mPCIe to give a better Gen2 signal than EC when testing on a 2570P Elitebook and a more flakey adapter. REF: http://forum.techinferno.com/diy-e-gpu-projects/2109-diy-egpu-experiences-%5Bversion-2-0%5D-142.html#post55765

I understand your concern about pricing. What I can say is some ppl have posted no issues with their EXP GDC adapter. Others, inc myself, have had issues with both EXP GDC and PE4C. My conclusion was that for Gen2:

PE4L 2.1b > PE4C 2.1 > EXP GDC > PE4H 2.4

PE4C 3.0 uses the same cabling as PE4L 2.1b and has the same Gen3 compliance. Means that it's the best adapter to get for cleanest Gen2 signal? It comes down to whether you are prepared to risk the cheaper adapter and if affected, either downgrade the link with Setup 1.30 software to Gen1 or then payup to get a better Gen2 adapter.

From my perspective, it's worth paying more from the get go to get better Gen2 signalling.

Though I can see for mPCIe users with more cumbersome access may want a socketted connector. Just a shame it's on the eGPU adapter and not the mPCIe end (though HDMI is a bit big for that!).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Sparkhunter
      Hi there guys,
       
      I've been looking into getting a new GPU for my laptop (4-lane PCI-e) and enclosure (HP Omen Enclosure) but I cannot decided between the RX 5700 XT and the RTX 2070 (non SUPER).
       
      I did some price to performance calculations (higher is better) with some of the best prices I can currently get in the UK.
       

       
      The RX 5700 XT does perform better and is cheaper than the RTX 2070 (Although the 2070 does come with 2 games) but my main concern is drivers and from what I've heard NVIDIA cards work a lot better with eGPUs than AMD.
       
      If anyone has experience using both red & green or if anyone else has any other input i'd love to hear your experiences and input.
       
      Thanks.
       
    • By Blocker35
      Hi guys, bit of a rookie to the whole EGPU scene. Currently I have:
       
      - MacBook Pro 2015 13inch (3.1GHz Core i7 16GB RAM)
      - Razer X Core 
      - Apple TB3 to TB2 Adapter
      -  TB2 Cable (Cable Matters)
      - 23inch AOC External Monitor
       
      I am wonder about what graphics card to get to run X-Plane11 with high graphic settings?
      I have purgewrangler set up and ready to use with an AMD graphics card, but am also open to the idea of an Nvidia graphics card.
      Any advice appreciated. I did not buy a Windows PC as I need a Mac for various other things and wanted an all-in-one laptop.
    • By SnipeKing17
      The GPU works, The PSU works, The system works. [individually they all do work]
       
      The system works perfectly fine without the WLAN card.
       
      When i put the system to sleep and hotswap the mPCIe riser and WLAN press something on the keyboard.. Restarts.
      Will shutdown in roughly 27 seconds for those 27 seconds it works just fine like how it normally would on external monitor.
       
      When i shut it down and plug the riser and switch it on, same story. 27 seconds.
       
      I don't even see a error. I get to login screen directly. I used DDU already.
       
      I timed it. no matter what i do if i use the eGPU, External monitor it restarts instead of pause-play. I have 27 seconds.
       
      Need help!
    • By Kel
      I got the exp gdc beast 8.5 got all the connections right... laptop boots up... fans turn on the gpu.... device manager detects gtx 1060 with a “ ! “ in a yellow triangle. Now what to do.... i tried to do the bios mod.... but realised that i have 3.07 version. 
      Questions-
      1 is there any way to get this done without the mod?? 
      2 if mod is the only way... kindly help me with step by step instruction in laymans terms... i m not a techy... so i might not understand technical terms.... altho i am interested... but learning yet. Please help. 
    • By Drozof
      Has any company out there launched a laptop with an external MXM port? 
       
      Just curious since with the boom in the gaming laptop market and some companies launching eGPU thunderbolt enclosures, isnt the MXM faster?
       
      Is it because of licensing issues? or hardware problems?
       
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.