Jump to content
EwinRacing Flash Series Gaming Chairs
stephen0205

M15X possibly dead

Recommended Posts

Hi guys, im new to the forums. Looking for a little help.

 

Been on so many forums and tried so many things.

 

So basically my 260m in my m15x kicked the bucket. So i was using the onboard gpu but i couldnt game. So i decided i was gonna take one of my 6970s out of my m18x and fire it in the m15x.

 

I read that it was possible, so i got the bios file to make it work in the m15x, got the card prepped and installed, then proceded to flash the new bios for it. Flashed it, machine turned off to restart i presume. And nothing. No power at all. Tried the power button and nothing.

 

No lights at all coming on, not even charging ones.

 

Removed the gpu = nothing

removed the cmos and discarge = nothing

blind flash = wont come on to do it

 

so kinda crapping myself right now.

 

So i had a look online for a new motherboard and holly god are they dear. So i thought i may be able to salvage it with the correct bios so i have ordered the bios chip to replace the one thats on it, local place gonna do it for £35 quid. Hoping that solves the problem.

 

Question is. Is there anything else i can try to make it work. And if the new bios chip fixes the boot issue how can i get my 6970 working in this machine without having to go buy a new 260m. Quite like the idea of having a powerful card in my college laptop. I used the bios that had the volt mod, so it ran cooler, think there was 3 to pick from.

 

Anyhow, thanks for anyone willing to help me bring this beast back from hell

 

 

Share this post


Link to post
Share on other sites

I'm not clear, did you flash the motherboard or the video card? If you flashed the motherboard, then it's pretty much dead and it might be easier to just buy a spare one from ebay or somewhere. If it's the video card, then there's ways of salvaging it and reprogramming a new chip but that takes some technical expertise. T|I's @svl7used to offer this service but he's not around much these days. @Khenglishmay be able to point you in the right direction regardless since he's pretty good at tinkering w/these things. 

Share this post


Link to post
Share on other sites

right update fellas, need some advice on what to do next.

my dad bought an m15x (Score, test time)

So I take a ride down with mines and my tool kit. Here's

My cpu in dads m15x = working
My Hard drive in dads m15x = Working
My Memory in dads m15x = Working
My 260m in dads m15x = Surprisingly working (black screen on mine before buggering it)
1st 6970m In dads m15x = Complete black screen no boot
2nd 6970m In dads m15x = Machine boots but is glitch (green and black bars and flickering, possibly dead gpu)

Now everything out of my dads in mines = Nothing lol. No boot or nothing.

Sooooo now my dilemma. I presume both 6970s are damaged. And the 260m to be temp working, so I have the chip for the bios for the motherboard but. Local places even far out places for repair are quoting £25 - £40 to change it. And saying it might not fix the problem.

I Can order a board from aliexpress for just over £50 but need to wait a month for it :(, also for £50 I can get a firepro m6000 which I believe is play from what I read.

Any thoughts fellas ?

Id be happy to send the gpus to anyone in the uk who might be able to test better than I can

Share this post


Link to post
Share on other sites

So which parts did you pull from your dad's M15x and put them in yours? If it was the GPU and it failed to boot but it did for your dad's M15x, then that is a sure sign the motherboard on yours is toast (assuming that is what you originally flashed). 

 

Also, did you read this guide before attempting to use the 6970m in M15x? 

 

 

The part about drivers is outdated but there is a lot of good info in there. 

Share this post


Link to post
Share on other sites

Yeah i read the guide mate had a good look over it. But i listed all the parts i had tried from mines in his and tried all his in mines bar the motherboard obv. Defo a motherboard issue. 

 

But i do have a question how come 1 6970 booted but was super glitchy even from alien bios screen al the way to windows and 1 just gave me a black screen. But the machine seemed to be powering up.

 

Completely confused and muddled by the volume of informations, my understanding was that by being a dell part no it should have worked no mods needed unless i wanted to flash teh vbios and drop or increase the voltages. 

 

Was an unlocked bios flash that killed my machine i think tbh, but still not convinced. Wondering to just buy the damb board

Share this post


Link to post
Share on other sites

Well the reason I brought up the guide that @svl7wrote is because it is mentions how careful you have to be w/the rear bracket and the standoffs w/the motherboard to ensure proper operating temperature. I know from experience that if you force the rear X bracket w/too much pressure while attaching it, the card can warp and become damaged. Did you do any types of modification to either card before installing them? 

 

You should not have needed any bios flash apart from the latest dell system bios for the M15x. In the past Clevo cards were flashed with Dell vbios to enable DP/HDMI I believe but since your cards are Dell, that isn't even an issue. 

Share this post


Link to post
Share on other sites

the cards defo came from a m17x or m18x. Cant mind which, i was careful when installing the brackets into the motherboard. Anyhow im ok having to buy a new gpu, Or send these ones to be repaired if they need it, i never modded them.. was the mobo bios flash i done first then bricked it ove

 

More concern is the motherboard, pay the 40 quid and risk it not being fixed if the ec is scrambled or just buy a new one and wait. Would rather spend 100 on new parts than 150

 

anyway to check the bios chip would fix my problem or check the ec chip is corrupt ?

Share this post


Link to post
Share on other sites

That should work out as long as the problem is for sure your mainboard. Good luck w/it and let us know how it turns out.

Share this post


Link to post
Share on other sites

i shall do, not sure if i should buy a new gpu tho, 2 of three worked in my dads laptop 1 with green blocks , 1 which worked fine but no bracket for it, the x bracket, the last one laptop powered but black screen

Share this post


Link to post
Share on other sites

If your M260 works in your dads computer then most likely the old Motherboard mightve been on its last legs. Did you check it to see any signs of wear or damage on it?

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Dont look like much in the way or marks or anything, If i didnt know it it was i would have said it was new 

Share this post


Link to post
Share on other sites
Ok dudes and dudettes (if there is any)
 
Update on the alienware. The motherboard came today finally no help to dhl, the dude was gonna drive away, he took it to the wrong house and i seen the van luckily, not a dhl one tho a rented one and a polish fellow doing the driving, anyhow shouted him over and got it. Nice
IMG-20160115-WA0006_zpsjw5uoh1v.jpeg
So to the fun part, i tore it all down and poped in the new mobo
 
IMG-20160115-WA0010_zpshgarje5l.jpeg
IMG_20160115_121043_zpsishmokbr.jpg
And wola on it came, not i had the assumed borked 260m in there, which has no x bracket. So machine works and turns on however i cant hold the card in place.
IMG_20160115_122724_HDR_zpszspjkqlf.jpg
IMG-20160115-WA0016_zpsmdbbjtrb.jpeg
 
Now the other fun part. I got to test the 2 6970m i have. One boots up fine and windows loads and such, but it is glitchy, like blocks and all pink. I assume on its way out, probably due to how it was stored cause both cards came from a working m17 or m18x i cant mind which.
 
IMG_20160115_122247_zps2dsmrk1b.jpg
So the second card, when its in and u switch on does....nothin. Black screen, everything sounds like its booting and that but no shabang, does hee haw. So i presume this card is borked also.
 
 
Thinking of trying to bake them, seen it in a few posts putting them in the oven, I did however hold the back heatsink on, altho they were screwed in it didnt seem to be making much if any contact with the die. Ive seen about grinding the pegs down or using longer screws and sometime even a shim. 
 
Anyhow glitchy card on the right and black screen on the right 
IMG_20160115_122714_HDR_zpskiiqrwrx.jpg
 
 
 
So now i just have to wait for the m6000 to come which should at this rate be tuesday, once that appears ill be able to grab a shim or get screws or whatever and hopefully from  what i read just plug and play.
  • Thumbs Up 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By mrwayne
      My laptop is Monster Tulpar T7 v2.6. i7 4710MQ, 16 GB DDR3 1600 mHZ, GTX 970M 3GB.
    • By Klem
      In this thread you can post your requests for Lenovo ThinkPad T440p / T440s / T540p.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, then you can post your request in this thread.
      Important!
      For creating bios backup and to flash bios mod, you must use any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip!
       
      Just dump your Bios using any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip, then post it in this thread or upload it to any fileserver and send me the link.
       
       


       
       
    • By Cubitci
      To install the unlocked bios, I prepared and booted a freedos usb. I start the installation by typing flash.bat but every time I get the following error: Error 28: Protected Range Registers are currently set by BIOS, preventing flash Access. Please contact the target System BIOS vendor for an option to disable Protected Range Registers.
      How can i solve this problem ?
    • By Cubitci
      İ'm trying to backup my bios but program shows this error: Error 201: [FPTw.exe] cannot be run on the current platform. Please contact your vendor. And my system is x64 but programs shows System = x32 . How can i solve this error ?
       
      EDİT: Now shows "Error 285: Fail to load driver (PCİ access for Windows). Tool needs to run with an administrator priviledge account." And at the end the system says it cannot find the specified location, and therefore no results. 
       
      EDİT 2: Now shows Error 284 but i cant see text.
       
      ------------------------
      Intel's FPT v.1.0.4.1089
      ------------------------
      System = x32
      Desktop path = C:\Users\Remzi Ince\Desktop
       
      program shows its my desktop path but its not my desktop path. My laptop language is turkish and my desktop path is C:\Kullanıcılar\Remzi Ince\Masaüstü
       
    • By Hyuk Yun
      I need help to unlock my BIOS can somebody teach or help me??
       
      I want to unlock the hidden advanced and chipset tab plz help me.....
       
      https://drive.google.com/open?id=172WwwQC-IGfGeFA55lr2a5ahe7rIS0Sf
       
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.