Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

M14x R1 - BIOS A08 with SATA fix

Recommended Posts

I just used Linux' "tail" command to read the last 4 MB of the file and output that to a different file.  Problem now is, it didn't contain the EC's .bin file.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Flashing the "tailed" bios results in 4 beeps when trying to boot up.  Dell considers this a memory failure, but I know there's nothing wrong with the RAM chips themselves.

Share this post


Link to post
Share on other sites

Thinking back a bit, I think I had the memory overclocked through the bios.  Would that have something to do with this?

Share this post


Link to post
Share on other sites
22 hours ago, Alaric323 said:

How did you remove the header?  I'm having the same problem with a bad bios that you did, but I'm using an SPI programmer with a clip instead.

 

I tried several times to use the clip, but other components onboard where interfering with the SPI communication causing some problems.  You will most likely need to remove U48 chip from the board.

 

I used a program called HxD (hex editor) to just delete the header data. https://mh-nexus.de/en/hxd/

 

if you're going to use Linux to do the programming with flashrom, I believe i used Wxhexeditor as it could do file compares like HxD

Edited by razblack

Share this post


Link to post
Share on other sites
21 hours ago, Alaric323 said:

Thinking back a bit, I think I had the memory overclocked through the bios.  Would that have something to do with this?

 

it could have, but you would think that after flashing all settings would have been reset.

22 hours ago, Alaric323 said:

I just used Linux' "tail" command to read the last 4 MB of the file and output that to a different file.  Problem now is, it didn't contain the EC's .bin file.

 

let me know if you need the EC file.. i don't believe it contains anything that would be helpful, I took one from a good mainboard and flashed it to the one I've been working on though and it just seemed to change the LED colors.  but I'm not 100% sure.  I was; however, able to use the clip to flash the EC instead of removing it from the MB like I did with the BIOS

Edited by razblack

Share this post


Link to post
Share on other sites
1 hour ago, razblack said:

 

it could have, but you would think that after flashing all settings would have been reset.

 

let me know if you need the EC file.. i don't believe it contains anything that would be helpful, I took one from a good mainboard and flashed it to the one I've been working on though and it just seemed to change the LED colors.  but I'm not 100% sure.  I was; however, able to use the clip to flash the EC instead of removing it from the MB like I did with the BIOS

My clip seemed to work for the main bios chip.  Got a completely verified hash after flashing the chip, and double-verified just to make sure.

 

I'm figuring the EC must do SOMETHING other than colour settings for the AlienFX.  Wouldn't need 1~2 MB just for that, I think.  Maybe it holds the settings that were changed from an unlocked BIOS, but since I'm far more familiar with UEFI chip layouts than BIOS layouts, I could be completely wrong.

Share this post


Link to post
Share on other sites
4 hours ago, Alaric323 said:

My clip seemed to work for the main bios chip.  Got a completely verified hash after flashing the chip, and double-verified just to make sure.

 

I'm figuring the EC must do SOMETHING other than colour settings for the AlienFX.  Wouldn't need 1~2 MB just for that, I think.  Maybe it holds the settings that were changed from an unlocked BIOS, but since I'm far more familiar with UEFI chip layouts than BIOS layouts, I could be completely wrong.

 

here's the EC, i did not find this anywhere else so maybe this can help others too:

https://www.dropbox.com/s/yp0w736v6sk7ykz/W25Q80-m14xr1-EC.7z?dl=0

Share this post


Link to post
Share on other sites

I'm hoping to be able to get the file and test it.  my intel management says i have sata 3 but my ocz ssd software says i'm only running sata 2

Share this post


Link to post
Share on other sites

So when im able to download the bios update will this help me with games not seeing my video card? also when i try the latest nvidia drivers it lets me install them but cant run any games because they dont see the card. im also looking for a fix for my ssd sometimes laptop doesnt turn on and sometimes it does. thanks for any help 

 

running m14x r1

i7 2630qm

8gb ram

bios a08

pny ssd 240gb

gtx 555m 3gb

Share this post


Link to post
Share on other sites

Hi!

 

I'm about to buy an SSD for my m14x R1, and wondering if I should give this a try.

 

In case this update doesn't work as expected, how easy is it to revert to the official BIOS (assuming the computer starts normally)? Is it just a matter of reinstalling the official BIOS?

 

 

Share this post


Link to post
Share on other sites
On 1/13/2018 at 7:26 AM, Luis Herräm said:

Hi!

 

I'm about to buy an SSD for my m14x R1, and wondering if I should give this a try.

 

In case this update doesn't work as expected, how easy is it to revert to the official BIOS (assuming the computer starts normally)? Is it just a matter of reinstalling the official BIOS?

 

 

I was wondering the same thing. Though I'm pretty sure reverting back to the original bios isn't a problem.

Share this post


Link to post
Share on other sites

HI guys,

 

I recently turn on my M14xR1 after a long period of time (my current computer broke so had to use my old alienware laptop), it was horrified how slow the boot time is. I love my alienware and decide i want to upgrade the hard drive.

 

So here i am browsing what SSD to get and bump into many user from other forum saying that the R1 does not support the mSata format, and also does not support sata 3 speed.

 

Which bring me to this thread where the fix file is. Just wondering since is quite a old thread can anyone tell me if the link still works (i think i cant access it yet). I am planning to get a Samsung 860 Evo SSD.

 

PS: on the side note any old M14xR1 laptop user had the experience to reapply thermal paste to the CPU and GPU. I think mine dried up and is spinning the fan crazy.

 

Thanks!

 

 

Share this post


Link to post
Share on other sites

I guess this thread been long dead, can anyone with permission confirmed if the link is still alive?

Didnt want to pay for the tier fee and knowing the link doesnt work.

Share this post


Link to post
Share on other sites

did anyone was able to disable the nvidia optimus from this bios ? as it is freezing the laptop when another gpu is attached through pci-e.

Edited by aakashzxv2

Share this post


Link to post
Share on other sites

Are there any recent updates on the status of the BIOS download? Any dead links?

I’m assuming that flashing from A08 to the modded A08 doesn’t have any setbacks; any one with any recent experience flashing? Just got an SSD and the perfectionist side of me wants SATA III capability. 

Share this post


Link to post
Share on other sites

My question above pertains specifically to this one: Crucial MX500 2.5" 1TB SATA III 3D NAND Internal Solid State Drive (SSD) CT1000MX500SSD1

https://www.newegg.ca/Product/Product.aspx?item=N82E16820156174 Also which form factor to choose

2.5" orM.2 2280

It's not really cheap and I'd rather not spend the money if it won't work.

Share this post


Link to post
Share on other sites

Hey guys, I've been lead to believe that the Unlocked BIOS for the m14x r1 allows access to UEFI mode.  Can anyone confirm whether this is actually true?  Or does the  m14x r1 not have UEFI capability at all, unlocked BIOS or not?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Klem
      In this thread you can post your requests for Lenovo ThinkPad T440p / T440s / T540p.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, then you can post your request in this thread.
      Important!
      For creating bios backup and to flash bios mod, you must use any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip!
       
      Just dump your Bios using any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip, then post it in this thread or upload it to any fileserver and send me the link.
       
       


       
       
    • By Cubitci
      To install the unlocked bios, I prepared and booted a freedos usb. I start the installation by typing flash.bat but every time I get the following error: Error 28: Protected Range Registers are currently set by BIOS, preventing flash Access. Please contact the target System BIOS vendor for an option to disable Protected Range Registers.
      How can i solve this problem ?
    • By Cubitci
      İ'm trying to backup my bios but program shows this error: Error 201: [FPTw.exe] cannot be run on the current platform. Please contact your vendor. And my system is x64 but programs shows System = x32 . How can i solve this error ?
       
      EDİT: Now shows "Error 285: Fail to load driver (PCİ access for Windows). Tool needs to run with an administrator priviledge account." And at the end the system says it cannot find the specified location, and therefore no results. 
       
      EDİT 2: Now shows Error 284 but i cant see text.
       
      ------------------------
      Intel's FPT v.1.0.4.1089
      ------------------------
      System = x32
      Desktop path = C:\Users\Remzi Ince\Desktop
       
      program shows its my desktop path but its not my desktop path. My laptop language is turkish and my desktop path is C:\Kullanıcılar\Remzi Ince\Masaüstü
       
    • By Hyuk Yun
      I need help to unlock my BIOS can somebody teach or help me??
       
      I want to unlock the hidden advanced and chipset tab plz help me.....
       
      https://drive.google.com/open?id=172WwwQC-IGfGeFA55lr2a5ahe7rIS0Sf
       
       
    • By Luisrr2029
      Hello can anyone suggest a mod for bios or alternative bios for Msi GE72 2qc apache gaming laptop to overclock 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.