Jump to content
EwinRacing Flash Series Gaming Chairs
Mumak

Looking for users of RADEON HD 6970M and 6990M

Recommended Posts

Guys, I want to improve the recognition of 6970M / 6990M and AMD doesn't make this easy (uses the same IDs)..

So I need your feedback - if you have such a card, please post here which one (6970 or 6990) and the corresponding Hardware ID reported by HWiNFO32/64 under GPU (like: PCI\VEN_1002&DEV_6720&SUBSYS_04A41028&REV_00).

Share this post


Link to post
Share on other sites

My 6970m is momentarily a FirePro M8900, but it gets reported as :

"Video Card: ATI RADEON HD 6970M (BLACKCOMB XT/PRO) [DELL]

The ID string is: PCI\VEN_1002&DEV_6720&SUBSYS_04A41028&REV_00

But GPU-Z reports it as a FirePro:

2374d1316544744-m8900-gpu-z.jpg

I see that HWiNFO als reads out the VBIOS version, since they're different for each card (6970m 6990m, M8900) you might be able to differ between them by comparing the VBIOS version. Of course there are also different VBIOS revisions for the same card, but I might be able to help in case you decide to do it this way, I have quite a couple of different 6970m VBIOS versions, as well as some of the 6990m. And you can find a lot of them by looking at benchmark screenshots.

Share this post


Link to post
Share on other sites

Thanks. What version of HWiNFO do you have (you posted a GPU-Z screenshot)? Later ones should properly recognize your card as FirePro.

I think it might be possible to properly distinguish the models using Subsystem IDs, I just need more reports from different cards.

Share this post


Link to post
Share on other sites
Thanks. What version of HWiNFO do you have (you posted a GPU-Z screenshot)? Later ones should properly recognize your card as FirePro.

I think it might be possible to properly distinguish the models using Subsystem IDs, I just need more reports from different cards.

Oh, you might be right... it's not the latest version. I'll install it, check again and let you know.

Share this post


Link to post
Share on other sites

Ok, updated HWiNFO to v3.87-1385 and the video card now gets reported as "AMD FirePro M8900 [DELL]"

Edited by svl7

Share this post


Link to post
Share on other sites

6990M

Hardware ID: PCI\VEN_1002&DEV_6720&SUBSYS_04BA1028&REV_00

Video Card: AMD RADEON HD 6970M [DELL]

From HWINFO64 v3.86-1370

Edited by Revelator

Share this post


Link to post
Share on other sites

Thanks guys. So not even the subsystem ID can be trusted to distinguish 6970 from 6990 (Michael and Jimbo have the same ID on different cards) :(

Edited by Mumak

Share this post


Link to post
Share on other sites

That seems like an issue they aren't the same cards seems to me it could cause problems for someone eventually

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.