Jump to content
EwinRacing Flash Series Gaming Chairs
Sign in to follow this  

[QUESTION] Acer V3-772G Fail to recognize eGPU after blocking pin22 #PERST on mPCIE

Recommended Posts

Hello guys


I have some problem regarding to implementing eGPU on Acer V3-772G-9822 with EXP GDC Beast. Here is the specification


Notebook: Acer V3-772G-9822

OS: Windows 8.1

CPU: i7-4702MQ

iGPU: Intel 4600


Adapter: EXP GDC Beast



Yesterday I was tried to get the eGPU work by replacing the mPCIE wifi slot with my eGPU adapter. After I push the power button, the external monitor shows nothing but no signal warning, both HDMI slot on laptop and eGPU have the same result. But then I somehow managed to get the GTX960 show on the device manager using "sleep system, swap wifi card for mPCIe eGPU adapter method" (https://forum.techinferno.com/index.php?/forums/topic/8747-mpcie-egpu-troubleshooting-steps/#post149873) but with code 12 and hang right after reboot.


After all I realize my acer hang before the BIOS load up, turn out it may related to the #PERST problem ( https://forum.techinferno.com/index.php?/forums/topic/8350-pe4x-series-understanding-clkreq-and-perst-delay/&_fromLogin=1 ). This morning I block the PERST signal by placing a small tape over the pin 22. This time the acer boot  successfully to the OS with eGPU connected, the eGPU fan is spinning and all things go well until I found out that the acer fail to recognize my eGPU.




Even I tried with "DIY eGPU Setup 1.3x", enable the wifi port and do a rescan, reboot and rescan or using the sleep method before. The laptop still cannot catch the eGPU signal. 


Did anyone have the same experience with me? Any possible solutions? Please help guys and thank you!



Edited by edmund2018

Share this post

Link to post
Share on other sites

Damn that eGPU adapter is boss! It could be possible that that mpcie slot does not support the gpu. I heard that some of the slots have different specs.

Share this post

Link to post
Share on other sites



u found a Solution ? Because i have a Packard Bell (Acer) and i have exactly the same issue

Edited by F3nd3RR

Share this post

Link to post
Share on other sites

Hey guys!


I think i have some solution - if someone willing to try - contact me.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.