Jump to content
EwinRacing Flash Series Gaming Chairs
AscheWandler

Solved: IntelHD Screen Flicker under DX11 FullHD!

Recommended Posts

I had the Problem with my P150SM (GTX770M) ´, that on various Games (ex. Homefront, both Metro Games, GTA5) under FullHD the screen flickers.

But only under DX11 and FullHD. Other Resolutions or the switch to DX10 runs everything fine!

The Problem most (me too) people had is an issue of the Intel HD graphics card switches 60p Hz in FullHD DX11 gaming back to 60i Hz on an external Screen.

That causes the screen flickers and made gaming annoying.

Searching the net made the most hits like "install newest driver" or "switch back to the driver of the brand" (Clevo in my case). Tried all of these suggestions but nothing worked.

The solution is (in my case) very simpel at all: (made with Driver 10.18.15.4256 (17.07.2015))

1. go to the Intel graphics options

2. under "Display" you can find "user defined Resolution"

3. Warning appears "changes can cause crashes" ect.

4. there you can choose between "internal Display" or the external (S273HL in my Case)

5. put the 1920x1080 60p in both Displays and "add" them to the List.

My Screen goes for 2sec. black and after it was back on every game works fine in FullHD with DX11!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.