Jump to content
Review: E-Win Champion Series Gaming Chair Read more... ×
EwinRacing Flash Series Gaming Chairs
geezergamer

Fallout 3 on Windows 10?

Recommended Posts

Hey friends,

I've upgraded to W10 and this weekend I wanted to play FO3 once more before FO4 comes out. It plays for 10-20 mins and freezes. So hard that it takes a reboot to fix it! I've looked online and there are paid patches but nothing free to fix my already paid for game! My pc is a beast w/980ti g1 and an over clocked 5820k. Are there any settings or work around you know of? Thanks!

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Hello, I was having the same issue, in my case it was because FO3 do not support more than 2 cores (CPU), I fixed it by editing the fallout3.ini;

Open the folder My documents / My Games / Fallout3

* Edit the file FALLOUT.ini.

* Inside FALLOUT.ini look for a group called [general].

* Inside the general group, after all the configuration parameters, just copy and paste the following 2 lines:

bUseThreadedAI=1

iNumHWThreads=2

Now close and save the Fallout 3 configuration file.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

You could try running compatibility mode. I just installed it on Windows 10 and it runs fine without a problem, however when I installed it on Windows 8 there was some trouble. If you ran Fallout 3 on a previous verison of Windows, go into your fallout 3 game directory (C:\Program Files (x86)\Steam\SteamApps\common\Fallout 3 goty) and right click fallout launcher and create a short cut to desktop.

Share this post


Link to post
Share on other sites

What rocknarutoxx has said can be very helpful. It is widely known among pc Fallout 3 players of how bad of a port it was from console to pc. Generally the game just has poor optimization and compatibility. People generally load the game up in compatibility with I believe was windows xp. You can access this by right clicking the game exe and selecting properties. Then choose the compatibility tab and select one from the drop down list. Once it gets working you may experience a crash here and there but it runs quite decent. Remember to save often to prevent loss of progress!

Share this post


Link to post
Share on other sites

win 10 forced vsync on games like FO3, FO4, Skyrim and i don't know what doing whith it

Share this post


Link to post
Share on other sites

I had a similar problem a while back.  Installing Games for Windows Live fixed it for me.  

Share this post


Link to post
Share on other sites

Also, check nexus mods for unofficial bug fixes. FO3 is actually a great looking game because of the NM community.

Share this post


Link to post
Share on other sites

On me horks fine but i have little fps drop than windows 8

Share this post


Link to post
Share on other sites

Had the same problem with the Anthology Version, u think u going to by a pack like this and it will run instantly :angry:

compatibility mode is one part of the solution the other is an Intel HD graphics Bypass package,

 

which can be found here:   http://www.nexusmods.com/fallout3/mods/17209/?

 

have fun

Edited by casis86

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.