Jump to content
Prema

[vBIOS - MODS] Alienware - Prema Mod™

Recommended Posts

T|I and the author are no longer associated. 

For support kindly contact the author directly

 

 

 

  • Thumbs Up 5

Share this post


Link to post
Share on other sites

If you also want Prema Mod vBIOS for other AW systems, then just dump your current vBIOS with this tool and PM me the files.

 

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

https://www.techinferno.com/applications/core/interface/file/attachment.php?id=11400

 

Looking at the M18 GTX980 bios. My computers the older M18Xr2 with the 980M's installed are those firmware files you got ok for it even tho theyre for the newer M18 model?

No flashing the wrong system BIOS would probably brick it!

You can use the vBIOS, but the Clevo version is even better for the M18XR2.

Share this post


Link to post
Share on other sites

This is a SS of my current setup for my graphic cards atm as im not sure which bios file is the correct one to flash. Setup is a M18Xr2 on the A12 Bios with Dual GTX980M's. Anyone know which would be the best file to use dont wanna pick the wrong one and brick it accidentally.

1.gif

Share this post


Link to post
Share on other sites
On 1/11/2016 at 3:29 AM, Infini said:

This is a SS of my current setup for my graphic cards atm as im not sure which bios file is the correct one to flash. Setup is a M18Xr2 on the A12 Bios with Dual GTX980M's. Anyone know which would be the best file to use dont wanna pick the wrong one and brick it accidentally.

1.gif

 

You can either use the AW18 version or the Clevo Mod...just stay away from 361 driver as it crashes, freezes on far too many systems... 

Share this post


Link to post
Share on other sites

@Prema  I am having issues with the clevo 1.1.1 vbios in my Alienware 17 R1. I have a 980m I installed using the 3 pipe heatsink and I keep having the card overheat, but only in certain games. ie. World of Warcraft will take my gpu up to 85*C+ where as looping uniengine benchmarks or 3dmark will never take the gpu over 75*C.

I am using a Cooling pad with 2 80mm fans directly pointing at the fan intakes. I have also upgraded the gpu fan in the laptop from the stock 1.Xcfm one to the 10.6cfm model from the R3. 

I have an ASIC reading of 81.3%. What I am thinking is maybe this vbios has too much voltage applied for long term gaming for the cooling system in this machine? Will this Alienware 18 vbios help me with my issues at all or should I try a vbios with a lower 3dclock voltage? My current load voltage is 1.062v.

I am running 359.06 mobile modded inf drivers.

I honestly don't care about overclocking I just want this thing to be stable with or without my laptop cooler under it.

 

Share this post


Link to post
Share on other sites

Hello Prema, can u unlock / enable the SATA RAID in the BIOS for Alienware 15 (R1), i need to run my SSD in RAID 0 configuration, many thanks.

Share this post


Link to post
Share on other sites

I have just updated the AW18 GTX980M Prema Mod vBIOS to v2.

It'll properly support the latest NVIDIA driver releases.

 

ENJOY! :sorcerer:

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
16 minutes ago, wanttolove said:

Hi Prema,

I'm using alienware 17r3 with 980m 8GB . Can I flash your vbios ?

Thanks

 

 

 

It works but for systems other than AW18 the Clevo base works best:

 

 

Share this post


Link to post
Share on other sites
17 hours ago, Prema said:

 

My 17r3 with 8gb 980m flash with MXM 8gb version or soldered 4gb version ? 

THanks

 

It works but for systems other than AW18 the Clevo base works best:

 

 

 

Share this post


Link to post
Share on other sites

Updated AW18 GTX970M Mod also to v2!

 

ENJOY! :)

 

Will look at the 17 R3 8GB BGA as soon as I find time...for now you van use the 4GB version from the R2.

Share this post


Link to post
Share on other sites
On 4/6/2016 at 3:23 AM, Prema said:

Updated AW18 GTX970M Mod also to v2!

 

ENJOY! :)

 

Will look at the 17 R3 8GB BGA as soon as I find time...for now you van use the 4GB version from the R2.

Thank you. I can't wait :)

Share this post


Link to post
Share on other sites
On 4/9/2016 at 8:18 PM, a_Criminai said:

Thank you. I can't wait :)

 

 

OK AW 15 R2 / AW 17R3 GTX980M 8GB Prema Mod is up!

 

ENJOY! :)

Share this post


Link to post
Share on other sites
On 2.10.2015 at 0:55 PM, Prema said:

If you also want Prema Mod vBIOS for other AW systems, then just dump your current vBIOS with this tool and PM me the files.

 

EDIT: AW 15 R2 / 17 R2 GTX 980M vBIOS Prema Mod added to OP. Will add the others as dumps come in.

 

EDIT2: AW 15 R2 / 17 R2 GTX 970M vBIOS Prema Mod added to OP! ENJOY! :)

 

NVFLASH_TOOLKIT_x64_PM

 

Im trying to download stuff on this site and its not working (newbie account). Tried to upgrade many times my Elite mebership, without success. Contacted one of your mods, he created some invoices but somehow my paypal doesnt accept my payment. I use my paypal for several other things, so if i could just straight forward send you some money to your account and you in exhange help me with my card (gtx980m on M17xr4 /3d), that would be great.

Please let me know.

 

EDIT: NVM got my membership now.

Edited by angelorusso_

Share this post


Link to post
Share on other sites
9 hours ago, angelorusso_ said:

 

Im trying to download stuff on this site and its not working (newbie account). Tried to upgrade many times my Elite mebership, without success. Contacted one of your mods, he created some invoices but somehow my paypal doesnt accept my payment. I use my paypal for several other things, so if i could just straight forward send you some money to your account and you in exhange help me with my card (gtx980m on M17xr4 /3d), that would be great.

Please let me know.

 

EDIT: NVM got my membership now.

 

The best public Mod for your card/system would be this one:

 

 

Use it alongside this driver Mod:

 

 

Share this post


Link to post
Share on other sites

Hello Prema.

Please help, I upgrade M18R2 GTX675 to GTX970(single), upgrade BIOS to A12 and flash  AW18_6GB_GTX970M_OC_PM_v2.rar to GTX970.

But still have 8 BEEPs after switch on laptop, is there any differences between SLI vBios and single mod?

How I can solve my problem?

Thank You in advance. 

Share this post


Link to post
Share on other sites

Hello Prema!

 

Can you please make a mod bios for alienware 15/17 R2 (2015) with RAID option selection enabled. A lot of people will thank you for it!

 

Regards!

Share this post


Link to post
Share on other sites

I am rather curious, the 970m 6GB card I got for my m17xR4 was from an Alienware 18, given the machine it is used in right now, would it be best to flash the Alienware 18 vBios for the card? I have the Clevo vBios flashed, lets me overclock and go bananas but power throttles once it hits 105 Watts. (35% TDP via GPU-Z).

 

A curiosity as I want to push this card and not worry about the wattage as much, I have a 330W Brick at my disposal and the card hits maybe 66-68 *C under load. I just want to see what this card is capable of and see how it compares to his 980m,

Edited by cskx2001

Share this post


Link to post
Share on other sites
On 22.04.2016 at 9:12 AM, Prema said:

 

The best public Mod for your card/system would be this one:

 

 

 

Hi, Prema) Could you please tell what does this mean? Tnx

980M.jpg

Edited by Red Line

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Similar Content

    • By learnfromit
      alienware 15 r2 970m with i7-6700hq vbios request so i can overclock and mess with voltage.

      BIOS version backup made with techpowerup GPU-z.

      GM204.rom
       
      or can someone re direct me to one already made that will work? all links i find are dead, thanks.

    • By Kunal Shrivastava
      Hi guys, I am the proud owner of a Clevo p775dm3-g notebook purchased from azom.systems (authorized Clevo reseller in India, Model rebranded as Azom Legion-17.3 inches). Here are my specs:

      Core i7 7700 (non-K version): undervolted by 110 mv and turbo boost disabled in BIOS- machine uses prema mod BIOS.
      GTX 1080: undervolted by 100 mv on all frequency steps using MSI afterburner voltage/frequency curve editor. clocks are untouched.
      16 GB DDR4: Cant remember clocks.
      1440p 120 Hz screen: No tinkering done to refresh rate.

      CPU has been delidded and repaste has been done on both CPU/GPU dies with gallium based TIM-Coolaboratory liquid ultra if I recall correctly.

      My issue is GPU hitting max temp limit of 90 degrees while playing DOOM and framerate drops from 110 avg to mid 60s-70s with horrible stuttering- this is thermal throttling for sure.

      System was running beautifully after repaste at 86 degrees max/ 77 degrees average at 100 percent fan speed. A month later I decided to see how much further I could push the system and ended up undervolting the CPU/GPU and RAM even further. The RAM undervolting part didnt work as well as I'd hoped, and I ended up resetting the BIOS to undo everything and reapply the previous setting (-110 for CPU with turbo boost disabled.) 

      I noticed that immediately after BIOS reset, both my CPU and GPU temps were 5-10 degrees higher even with the undervolt/underclock applied. Also, I think the fans were a bit louder before I reset the BIOS which leads me to believe that for some reason the fans are now capped at 80% max fan speed. There doesnt seem to be a fan speed selector in the BIOS or anywhere else so I cant say for sure whether this is a fan related issue or something else.Before the reset I could override the BIOS setting and set the fans to 100% by pressing fn+1, could I have done something to that setting after resetting the BIOS ? I dont think I have damaged the CPU or GPU as temps are holding fairly steady at 90-91 degrees and laptop doesn't shut down while gaming.

      If I have overlooked something or if anyone reading this has any solution help would be greatly appreciated.
      All settings/drivers/windows version/app version are exactly the same before and after BIOS reset.
    • By Terriikk
      Hey guys, I have an Alienware m14x R2, and I have been trying to get access to the BIOS so that I can change the boot options (Everything is locked, I am unsure if someone set a password of if these are locked by default).I've tried updating the BIOS, and resetting the CMOS and nothing has changed this. Would anyone know if there are other options I can explore? Thank you. 
    • By IAmSteveRogers
      I have been attempting to change my boost clocks values for the longest time, though I've been unsuccessful. I managed to flash my modded BIOS, though no changes seem to have had happened, along with no errors either. Here's all the stuff I used and was able to get. If someone is able to help me with this, it would be greatly appreciated.
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.