Jump to content
Review: E-Win Champion Series Gaming Chair Read more... ×
EwinRacing Flash Series Gaming Chairs
enyan0

Intel XTU broke my Nvidia card

Recommended Posts

Hi all,

I had some overclocking by using the Intel XTU utility with no problems, until I tried overclocking and underclocking the integrated Intel 4600 GPU. :butterfly:

I believe that this broke the nvidia 970M. Basically it was recognised no longer under bios. I tried flashing everything but no way. So I had to send my clevo p651se for repairs (and now it's back).

I would not want to run into the same problem again but I'd like to know if that wasn't what potentially caused the issue.

Did you guys experienced a similar issue or can comment on that?

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.