Jump to content
rgpu

17" Acer V3-771G + GTX980Ti@4Gbps-mPCIe2 (EXP GDC Beast) + Win7/64 [rgpu]

Recommended Posts

Notebook

Acer Aspire V3-771G-9441 Intel Core i7 3630QM (2.40GHz) 8GB Memory NVIDIA GeForce GT 730M
OS: Windows 7 Ultimate SP1 64BIT
BIOS: BIOS_Acer_1.15_A_A
Monitor: Asus LED VS247HR 23.6'' wide, Full HD, 2ms, DVI, HDMI, black
SYSTEM HDD: Kingston Digital HyperX FURY 120GB SSD SATA 3 2.5 Solid State Drive

eGPU parts

video card: GAINWARD GeForce GTX 980 Ti Reference Cooler Model
video card: ZOTAC GeForce GTX 970 AMP! Omega Edition
adapter: EXP GDC Beast v6.1 mPCI-E version
PSU: 750W ATX Corsair CX750M

How it looks (in spoiler)





gpuz.png

14714d1430342040-unigine.png


Getting it all going

Everything is plug and play - I did not have to install anything third party or configure anything, steps I did:

  1. connect eGPU and start the system
  2. install desktop version of GeForce 900 series driver (which uninstalled dGPU driver)
  3. restarted Windows, but with BSOD, so I removed eGPU, started up again and disable dGPU, shut down and then connected eGPU and started Windows with no BSOD
  4. connected monitor to eGPU
  5. when I am using eGPU in Windows display settings I disable laptops internal display and enable only external monitor (my laptop display is turned off)


I had used my first Beast for couple of days and then I broke it by connecting wrong 4-PIN power cable from ATX PSU - be very careful when you first connect it, then bought a replacement and have been using it heavily for 3 month now with no Gen2 glitches.

Note for best performance: I am no guru and by mistake had set global Nvidia settings to respect quality instead of performance and was still getting 30+ FPS in new games maxed out (all GTX 970 benchmarks below are with "prefer quality" setting on), but when I set it to respect performance I was blown away, game like Shadow of Mordor ran 30-40 FPS before and 60+ FPS after maxed out and the visuals are the same, at least no difference what eye can tell.

Benchmark results

I have ran 3dMark tests, here are the results (want to mention that GPU was at 100% usage at times, so this means mPCI-E did not bottleneck the eGPU):

GTX 980TI:

3dmark06=13919
3dmark11.GPU=17728
3dmark13-FS.GPU=15321


GTX 970:

3dmark06=12877
3dmark11.GPU=12207
3dmark13-FS.GPU=9815

Final comments

Setup with GTX 970 runs latest games 30-60 FPS on maximum settings. Totally recommended if you already own this laptop or GPU - just use eGPU of your choice.

I then upgraded to GTX 980 TI (Gainward reference version, mainly because of 6GB of VRAM), I was not expecting this (because I thought limited PCI-E bandwidth will have more impact on performance), but it is performing significantly better than GTX 970.
Tested Witcher 3 and Dragon Age Inquisition so far, both games run 10-20 FPS better depending on an area.

I was able to overclock the card to +200 core clock and +450 memory clock - running stable around 70C-80C. Did not change any voltage parameters.

I can say that this setup is not running as good as decent desktop PC with same card, but it runs great.

GTX 970 games performance:

I tested all of following games with latest available patch/update/version for each of them.
 

Quote

 

Tested GTA V, runs 1080P 30-40 FPS gameplay-50-80 FPS cut scenes almost all on ULTRA, except:
Reflection MSAA: 2x
MSAA: 2x + TXAA
And in advanced options EDS on 0%
Grass quality: Very High

CRYSIS 3 - big areas where there is long grass at start of the game are killing performance when maxed out (very high) - 15-20 FPS, have to lower settings to high or medium. But 70% of the game is 30-60 FPS completely maxed out at 1080p.
Call of Duty Advanced Warfare - All maxed out except both caches OFF (if you turn on Caches, then you get low resolution textures even if your textures are set to MAX), mostly 40-60 FPS, some areas between 25-30 FPS.


Battlefield 4 - All on ULTRA 1080p, FOV 100%, Motion Blur OFF, Resolution Scale 100% - mostly around 40-50 FPS, never below 30, rarely above 60 FPS, some areas 90+ FPS, like snow, ship, water.


Far Cry 4 - All on maximum except shadows on ULTRA (instead of soft) and TXAA on 2x not 4x, 1080p is 40-60 (rarely 30) FPS very stable. some areas way above 60FPS


Dying Light - All on maximum (including FOV) 1080p is 30-60 FPS, frame rate jumping all over the place, even above 100 FPS when climbing on roof. Cut scenes are 55-80 FPS


Evil Within - All on maximum 1080p is 40-80 FPS, most of the time between 50-60 FPS.


Dragon Age Inquisition - All on ultra (AA on 2x MSAA) 1080p is 30-40 FPS most of the time (in the woods), rarely down to 27 FPS (like in swamps), sometimes up to 40-60 FPS (like beginning of the game - in the snow).


Middle Earth Shadow of Mordor - Ultra preset (AO on high) 1080p no HD texture pack, in game benchmark result 65FPS AVG, this games runs closest to desktop computer GTX 970 setups from games I have tried. only loading areas, entering menus (where text is overlayed) have frame drops - which take around 1-2 seconds down to 20-30 FPS. I capped the game at 60FPS and rarely see below it when playing. The frame drops seem to be due to GTX 970 3.5 GB VRAM issue, this game is very VRAM demanding. SOLVED: I was able to make it run smooth by setting texture resolution to HIGH instead of ULTRA.


Witcher 3 - All maxed out (all settings on ultra - including hairworks and hbao+) except foliage visibility range on medium, 1080p is stable 30-45 FPS (nicely playbale for this game), some areas are 60 FPS. EDIT: when using dGPU as dedicated PhysX card it runs smooth at all times.


Batman Arkham Knight - this game needs 5+ GB of VRAM to run on ultra, as a result of that game stutters when scene changes fast. a sacrifice has to be made if you want no stutters - either game on 720p or lower the texture quality (or get a video card with 6GB+ of VRAM). If not the stutters, then the game runs 60 FPS @ 1080p maxed out except the Nvidia smoke and particles effects (which kill the performance and runs at 20 FPS).

 

EDIT: It is possible to avoid lack of VRAM caused stutters by restarting checkpoint as soon as stutters begins (which flushes VRAM). And I found a way to max out the game 1080p and retain 30 - 60 FPS most of the time, for this enable dGPU in Windows and in Nvidia control panel chose the dGPU as PhysX processor. Overclock your dGPU (in my case GT 730M) to max core clock and memory clock to +200.

Tried an old game - Alan Wake, it is a dx9 game with normal sys requirements, runs terrible - eGPU 24 FPS on max settings (eGPU is at 100% usage and CPUs around 40-50% usage) and 28-30 FPS on lowest settings. Strangely it runs even worse on dGPU - around 10 FPS maxed out settings, dGPU is at 100% usage and 25 FPS low settings. Could not find how to fix this. I see people running this game 80FPS on GTX 970. strange. tried driver cleaner, did not help

 

Tried another old game - Witcher 2, it is also dx9 game, almost maxed out except ubersampling off, cinematic depth of field off, blur effect off, lod distance near, 1080p runs great - mostly 60 FPS, but drops as low as 30 FPS, not lower.

 

 

  • Thumbs Up 6

Share this post


Link to post
Share on other sites
So you don't have to use DSDT override for gtx970?

as I wrote - for my hardware (laptop, eGPU adatper, GPU) nothing had to be done or configured - it was all plug and play.

I also know that for one other member here with same laptop and a GTX 970 (only MSI version) and same eGPU adapter (Beast v6.1) was plug and play.

So as for the GPU: GTX 970, it sure does not need any overrides, same goes for the Beast v6.1 adapter. So only variable left is your laptop - if you are lucky, then you will not need no extra configuration or setup to run this.

As far as I understood it does not come down to CPU, MB, iGPU only. There are some other factors that might affect things, like BIOS and other I dont know.

But if you have same hardware as I do (or lucky and you hardware is good) - you are good to go.

One thing I noticed though - although my GPU is at 100% usage at all times when gaming, overclocking the GPU does not affect FPS. So I guess that mPCI-E is bottle necking the GTX 970. Or it could be the CPU that is the bottleneck.

In other words - there is no point in using anything more powerful than a GTX 970 for this hardware that I have.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Hi there! Brand new to this forum and eGPU in general. Lots of this is going over my head, but I'm catching up as best I can. Looks like you have the closest setup to what I'm working towards. Had a few questions:

Here's my laptop: MSI GE70 0ND / i7 3630qm / 8gb ram / GTX660m. I'm looking to get a GTX 970 for eGPU purposes. I came across this post: http://forum.techinferno.com/implementation-guides-pc/8442-17-msi-ge70-gtx970%404gbps-c-mpcie2-exp-gdc-beast-win7-%5Bjezkovivoci%5D.html#post115321 which looks like they're running the same laptop and everything. Unfortunately, that post isn't written very well. I can't tell if it's written for people who already know a ton about eGPU configurations or what is going on. What is error code 12? Did this person have to do the DSDT override in order to install the eGPU? The information about this DSDT override looks complicated. Is there a good resource for learning more about this?

About your setup: your 3dMark links say GT 730M for GPU and the Heaven benchmark says it was run on your iGPU. Is this just a glitch of running the eGPU? Are you satisfied with the performance jump over your GT 730M? Is there a way to use the eGPU on your laptop display?

Share this post


Link to post
Share on other sites
Hi there! Brand new to this forum and eGPU in general. Lots of this is going over my head, but I'm catching up as best I can. Looks like you have the closest setup to what I'm working towards. Had a few questions:

Here's my laptop: MSI GE70 0ND / i7 3630qm / 8gb ram / GTX660m. I'm looking to get a GTX 970 for eGPU purposes. I came across this post: http://forum.techinferno.com/implementation-guides-pc/8442-17-msi-ge70-gtx970%404gbps-c-mpcie2-exp-gdc-beast-win7-%5Bjezkovivoci%5D.html#post115321 which looks like they're running the same laptop and everything. Unfortunately, that post isn't written very well. I can't tell if it's written for people who already know a ton about eGPU configurations or what is going on. What is error code 12? Did this person have to do the DSDT override in order to install the eGPU? The information about this DSDT override looks complicated. Is there a good resource for learning more about this?

About your setup: your 3dMark links say GT 730M for GPU and the Heaven benchmark says it was run on your iGPU. Is this just a glitch of running the eGPU? Are you satisfied with the performance jump over your GT 730M? Is there a way to use the eGPU on your laptop display?

jezkovivoci explains in the link that he is disabling his GTX660M dGPU using Setup 1.30. When the dGPU is disabled then the eGPU can provided accelerated internal LCD mode.

He may not have had to do the DSDT override to overcome error 12 as he hijaaked the dGPU PCIe config space with the eGPU. error 12 is a flagged against a device such as an eGPU when there are insufficient resources available to host the eGPU. A BIOS locked setting of TOLUD will determine how much 32-bit space is available for PCIe devices, then your devices will claim it and you may have some free for the eGPU to use. If not, then need to apply workarounds such as hijaaking or extending into 64-bit PCIe config space using a DSDT override.

Share this post


Link to post
Share on other sites

Whew! Ok. I think I get it. So, since I have the same laptop as jezkovivoci, does that mean that I'll run into the same issues? Took my a while to figure out what Setup 1.30 was. Looks useful. Thanks for the help!

Share this post


Link to post
Share on other sites

I upgraded to GTX 980 TI (Gainward reference version, mainly because of 6GB of VRAM), I was not expecting this (because I thought limited PCI-E bandwidth will have more impact on performance), but it is performing significantly better than GTX 970.

Tested Witcher 3 and Dragon Age Inquisition so far, both games run 10-20 FPS better depending on an area.

I was able to overclock the card to +200 core clock and +450 memory clock - running stable around 70C-80C. Did not change any voltage parameters.

Here is 3dmark firestrike benchmark result of GTX 980 TI:

3dmark13-FS.GPU=15321

I can say that this setup is not running as good as decent desktop PC with same card, but it runs great.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Today I upgraded from Windows 7 to Windows 10 (PRO) and am very happy by my choice.

The only problem I had is with Intel HD 4000 drivers - the Acer version is not supported, so I let Windows install latest drivers automatically. And problem with not running Acer driver is that I have to turn off laptop display using FN+DISPLAY key manually after Windows restarted.

The main thing I am happy about is that now Optimus is working. So basically I have everything eGPU user can wish for - everything running stock software/drivers, no extra software/drivers required.

For comparison:

on Windows 7 (no Optimus) dx9 game Alan Wake ran at 24 FPS on highest settings on both GTX 970 and GTX 980 TI, but with Windows 10 (with Optimus - on external display) I get minimum of 35 FPS and 40 FPS AVG (playable for this game).

The second thing I am happy about is DirectX 12. I dont know if it will improve performance for me (mPCIE bandwidth limited), but at least I will be able to try when games support it :)

Otherwise I am happy with how Windows 10 feels - it does not require much time to get used to after Windows 7.

EDIT: I think that the reason why I cant use dGPU as PhysX processor is that Optimus is powering off my dGPU to save power, I wonder if anyone knows how to work around this or disable Optimus at all.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
Today I upgraded from Windows 7 to Windows 10 (PRO) and am extremely happy by my choice.

The only problem I had is with Intel HD 4000 drivers - the Acer version is not supported, so I downloaded latest driver from Intel website. And problem with not running Acer driver is that I have to turn off laptop display using FN+DISPLAY key manually after Windows restarted.

The main thing I am happy about is that now Optimus is working. So basically I have everything eGPU user can wish for - everything running stock software/drivers, no extra software/drivers required.

For comparison:

on Windows 7 (no Optimus) dx9 game Alan Wake ran at 24 FPS on highest settings on both GTX 970 and GTX 980 TI, but with Windows 10 (with Optimus - on external display) I get minimum of 35 FPS and 40 FPS AVG (playable for this game).

The second thing I am happy about is DirectX 12. I dont know if it will improve performance for me (mPCIE bandwidth limited), but at least I will be able to try :)

Otherwise I am happy with how Windows 10 feels - it does not require much time to get used to after Windows 7.

EDIT: found out why I can use Optimus, it seems that even though I can see dGPU in device manager normally with no error (funny fact that when I upgraded windows I had to remove eGPU so that it does not BSOD and after upgrade it did not update dGPU drivers, but when I connected eGPU it installed latest - Win10 compatible drivers, so right after Win10 upgrade I had dGPU running driver from Win7 and eGPU running driver from Win10), I tried to reinstall Nvidia drivers, now I have both Nvidia GPUs running latest drivers, but the dGPU still does not seem to function properly (even though it has no errors in Device manager). First thing - I can not set it as PhysX processor, well I can, but game does not allow to enable PhysX then. And second thing is - when I start MSI Afterburner, then dGPU reports crazy clock speeds and invalid data. So far I could not get dGPU to work properly (and maybe I should not because I have Optimus now). Checked that dGPU works when eGPU is disabled.

Just ask bro is mpcie or EC card is too bad to use GTX 980Ti

Share this post


Link to post
Share on other sites
Just ask bro is mpcie or EC card is too bad to use GTX 980Ti

As I wrote, when I compare performance with desktop computer with GTX 980 TI I see that my setup is around 30% slower in games than desktop computer with proper CPU. So for example if you find on youtube a performance test for a game for example:

with same settings on my setup I get ~50 FPS, not 70 as you can see in benchmark.

Same applies for GTX 970 and GTX 980 TI. I get 30% slower performance. Than desktop computer with those GPUs.

I get better 10-20 FPS better performance with GTX 980 TI compared with GTX 970 on same games so same game - Witcher 3 ran 30-40 FPS in same area with GTX 970.

But when you compare the price - GTX 980 TI is twice the price of GTX 970 - you have to decide is it worth your money? If you are addicted gamer, then probably it is worth it.

Personally I upgraded to GTX 980 TI only because of 6GB of VRAM, it helps in games like: Shadow Of Mordor, Batman Arkham Knight, Lords Of Fallen when you play on maximum texture details. 970 not only was 10-20 FPS slower, but it also had terrible stuttering if I was running the game on maximum texture detail level (because textures have to be loaded into GPU constantly using slow mPCIE interface).

In short Withcer 3 comparison:

Proper desktop computer with GTX 980 TI: 70 FPS

Proper desktop computer with GTX 970: 50 FPS

eGPU with GTX 980 TI: 50 FPS

eGPU with GTX 970: 30 FPS

For games that use alot of VRAM (shadow or mordor, batman arkham knight, lords of fallen on maximum texture details level):

980 TI - no stuttering

970 - constant stuttering

There is one thing you should know also that applies for any eGPU setup (970 and 980 TI also) - when the game uses mPCIE bandwidth to load textures (usually it is loading screen, but in open world games textures are being swapped constantly) you get performance drops in 30%. So for example if you get 50 FPS in Witcher 3, then for example when you load from save game, then for 2-3 seconds while textures are still being loaded you would get framerate drop to 30 FPS.

As I am planning to make desktop computer within 1 year I think that it was totally worth buying the 980 TI for me, as I get not stutters now and get +10-20 FPS, and when I make my desktop computer I will extend the life of this GPU because I will get even better performance. I am not afraid that 6 GB of VRAM will not be enough in near future, because current generation consoles have only 8 GB of VRAM, and while there is no new generation of consoles 6 GB of VRAM will be enough - this means that 980 TI will not get outdated that soon (until new consoles come).

Share this post


Link to post
Share on other sites
As I wrote, when I compare performance with desktop computer with GTX 980 TI I see that my setup is around 30% slower in games than desktop computer with proper CPU. So for example if you find on youtube a performance test for a game for example:

with same settings on my setup I get ~50 FPS, not 70 as you can see in benchmark.

Same applies for GTX 970 and GTX 980 TI. I get 30% slower performance. Than desktop computer with those GPUs.

I get better 10-20 FPS better performance with GTX 980 TI compared with GTX 970 on same games so same game - Witcher 3 ran 30-40 FPS in same area with GTX 970.

But when you compare the price - GTX 980 TI is twice the price of GTX 970 - you have to decide is it worth your money? If you are addicted gamer, then probably it is worth it.

Personally I upgraded to GTX 980 TI only because of 6GB of VRAM, it helps in games like: Shadow Of Mordor, Batman Arkham Knight, Lords Of Fallen when you play on maximum texture details. 970 not only was 10-20 FPS slower, but it also had terrible stuttering if I was running the game on maximum texture detail level (because textures have to be loaded into GPU constantly using slow mPCIE interface).

In short Withcer 3 comparison:

Proper desktop computer with GTX 980 TI: 70 FPS

Proper desktop computer with GTX 970: 50 FPS

eGPU with GTX 980 TI: 50 FPS

eGPU with GTX 970: 30 FPS

For games that use alot of VRAM (shadow or mordor, batman arkham knight, lords of fallen on maximum texture details level):

980 TI - no stuttering

970 - constant stuttering

There is one thing you should know also that applies for any eGPU setup (970 and 980 TI also) - when the game uses mPCIE bandwidth to load textures (usually it is loading screen, but in open world games textures are being swapped constantly) you get performance drops in 30%. So for example if you get 50 FPS in Witcher 3, then for example when you load from save game, then for 2-3 seconds while textures are still being loaded you would get framerate drop to 30 FPS.

As I am planning to make desktop computer within 1 year I think that it was totally worth buying the 980 TI for me, as I get not stutters now and get +10-20 FPS, and when I make my desktop computer I will extend the life of this GPU because I will get even better performance. I am not afraid that 6 GB of VRAM will not be enough in near future, because current generation consoles have only 8 GB of VRAM, and while there is no new generation of consoles 6 GB of VRAM will be enough - this means that 980 TI will not get outdated that soon (until new consoles come).

Me too, i prefer to play pc gaming but may be i can use eGPU at least 1 year to have enough money and build desktop

Share this post


Link to post
Share on other sites

You seem to know thing or two about setting this up and you obviously went through this painful process of gathering all the information to make it work.

If I may ask did you ever found a post or any information about missing Physx.

I have this problem where CUDA and Physx is not detected, it is not in GPU-Z and there is no Physx option in NVidia Control Panel.

I never had any nvidia product but apparently this is common thing and solution is to reinstall drivers but that does not do anything.

Since this is eGPU and not normal installation I wonder if this is yet another common obstacle that laptop owners need to overcome and if anybody have any solution or idea about it I would be grateful.

BTW I updated to win10 recently and it might be problem there but I cant find any solution for it right now, should I just try older drivers for win7/8 instead?

Share this post


Link to post
Share on other sites
You seem to know thing or two about setting this up and you obviously went through this painful process of gathering all the information to make it work.

If I may ask did you ever found a post or any information about missing Physx.

I have this problem where CUDA and Physx is not detected, it is not in GPU-Z and there is no Physx option in NVidia Control Panel.

I never had any nvidia product but apparently this is common thing and solution is to reinstall drivers but that does not do anything.

Since this is eGPU and not normal installation I wonder if this is yet another common obstacle that laptop owners need to overcome and if anybody have any solution or idea about it I would be grateful.

BTW I updated to win10 recently and it might be problem there but I cant find any solution for it right now, should I just try older drivers for win7/8 instead?

Hi, I did not have any problems with PhysX not on W7 not on W10 (right after upgrade with W10 preinstalled Nvidia drivers nor with the latest Nvidia drivers). I have options in Nvidia control panel.

I dont know what is the cause in your case.

I have a problem chosing dGPU as PhysX processor though in W10, I could do this with W7.

I ran W7 like this:

Optimus: NO

PhysX: dGPU GT 730M

W10:

Optimus: YES

PhysX: eGPU GTX 980 TI

The problem with W10 is that dGPU is being turned off after 3 seconds of usage, I dont know how to fix it.

So Im using dual boot system, I can boot into W7 if I need to play a game with PhysX and for everything else I use W10.

Share this post


Link to post
Share on other sites

Good Day,

Unfortanly the EXP GDC Beast not working properly by me. I did everything like in the Tutorial and Still not Working I search the whole google and I couldn't solve the Problem.

I put some pictures to show you what i did and where the problem is.

EXP GDC - Album on Imgur

my Laptop: Acer Aspire V3-772G.

Some people have the same laptop as mine and it worked.I did everything like in the tutorial and at the Boot i get a Black Screen just black and it stay like that.

I even Disabled AND Uninstalled my graphic card from the Device-Manager in the Laptop (I have two, One [intel ..] and another one [From Nvidia..]) and deleted everything from Nvidia and still the same.

The new Graphic Card that i bought is MSI Geforce Gtx 970.

It turn on and everything work fine even the red lamp at the EXP is on but I still getting the Black screen.

I hope you can help me, because I don't know what to do more.

I have more pictures but I couldn't send all of them at once.

Thanks

Share this post


Link to post
Share on other sites
Good Day,

Unfortanly the EXP GDC Beast not working properly by me. I did everything like in the Tutorial and Still not Working I search the whole google and I couldn't solve the Problem.

I put some pictures to show you what i did and where the problem is.

EXP GDC - Album on Imgur

my Laptop: Acer Aspire V3-772G.

Some people have the same laptop as mine and it worked.I did everything like in the tutorial and at the Boot i get a Black Screen just black and it stay like that.

I even Disabled AND Uninstalled my graphic card from the Device-Manager in the Laptop (I have two, One [intel ..] and another one [From Nvidia..]) and deleted everything from Nvidia and still the same.

The new Graphic Card that i bought is MSI Geforce Gtx 970.

It turn on and everything work fine even the red lamp at the EXP is on but I still getting the Black screen.

I hope you can help me, because I don't know what to do more.

I have more pictures but I couldn't send all of them at once.

Thanks

I think I see your mistake (see attached picture).

you must not power GPU from BEAST, instead you power GPU directly from PSU using PCI-E 6/8 pin connectors accordingly.

Imgur: The most awesome images on the Internet

Share this post


Link to post
Share on other sites
http://i.imgur.com/ROHUE9o.jpgalready changed that. long ago but thanks for mention it .

Does PSU fan spin when you turn on your hardware? I saw in picture, that GPU fans are spinning, so Im know they are.

Share this post


Link to post
Share on other sites
Does PSU fan spin when you turn on your hardware? I saw in picture, that GPU fans are spinning, so Im know they are.

Yes they are working normal when I plug the egpu.

Share this post


Link to post
Share on other sites
I think I see your mistake (see attached picture).

you must not power GPU from BEAST, instead you power GPU directly from PSU using PCI-E 6/8 pin connectors accordingly.

Imgur: The most awesome images on the Internet

Hi, I did not have any problems with PhysX not on W7 not on W10 (right after upgrade with W10 preinstalled Nvidia drivers nor with the latest Nvidia drivers). I have options in Nvidia control panel.

I dont know what is the cause in your case.

I have a problem chosing dGPU as PhysX processor though in W10, I could do this with W7.

I ran W7 like this:

Optimus: NO

PhysX: dGPU GT 730M

W10:

Optimus: YES

PhysX: eGPU GTX 980 TI

The problem with W10 is that dGPU is being turned off after 3 seconds of usage, I dont know how to fix it.

So Im using dual boot system, I can boot into W7 if I need to play a game with PhysX and for everything else I use W10.

Good Day,

Unfortanly the EXP GDC Beast not working properly by me. I did everything like in the Tutorial and Still not Working I search the whole google and I couldn't solve the Problem.

I put some pictures to show you what i did and where the problem is.

EXP GDC - Album on Imgur

my Laptop: Acer Aspire V3-772G.

Some people have the same laptop as mine and it worked.I did everything like in the tutorial and at the Boot i get a Black Screen just black and it stay like that.

I even Disabled AND Uninstalled my graphic card from the Device-Manager in the Laptop (I have two, One [intel ..] and another one [From Nvidia..]) and deleted everything from Nvidia and still the same.

The new Graphic Card that i bought is MSI Geforce Gtx 970.

It turn on and everything work fine even the red lamp at the EXP is on but I still getting the Black screen.

I hope you can help me, because I don't know what to do more.

I have more pictures but I couldn't send all of them at once.

Thanks

Does PSU fan spin when you turn on your hardware? I saw in picture, that GPU fans are spinning, so Im know they are.
http://i.imgur.com/ROHUE9o.jpgalready changed that. long ago but thanks for mention it .
Yes they are working normal when I plug the egpu.

Okay hi all one more time i solved the whole problems i worked on all issues for 5 days now and everything working thanks to all of your advices.

EXCEPT my external Monitor. I'm in Windows 8.1, my device manager just showing my gtx970(eGPU) and the Intel Graphics card(iGPU)- no errors everything as it should be, laptop at HD.

My Problem:

my hdmi cabel are plugged at the eGPU but my screen is showing Noo-Signal. I installed didy egpu 1.30x the program from @Tech Inferno Faneva and changed a couple of things :

endpoint : 3,87

scope= nothing becasue my dgpu are disabled completely ( but its there just make it dGPU

closeunse. : on

ignore=none

didnt do DSDT override - i think i dont need it, or better said i dont know if i need it.

so i read in google a couple of forums and they say i must change something in the setups and its gonna work but no idea what ??

I am open for any suggestion so please some help guys

thanks

Share this post


Link to post
Share on other sites
Notebook

Acer Aspire V3-771G-9441 Intel Core i7 3630QM (2.40GHz) 8GB Memory NVIDIA GeForce GT 730M

OS: Windows 7 Ultimate SP1 64BIT

BIOS: BIOS_Acer_1.15_A_A

Monitor: Asus LED VS247HR 23.6'' wide, Full HD, 2ms, DVI, HDMI, black

SYSTEM HDD: Kingston Digital HyperX FURY 120GB SSD SATA 3 2.5 Solid State Drive

eGPU parts

video card: GAINWARD GeForce GTX 980 Ti Reference Cooler Model

video card: ZOTAC GeForce GTX 970 AMP! Omega Edition

adapter: EXP GDC Beast v6.1 mPCI-E version

PSU: 750W ATX Corsair CX750M

How it looks (in spoiler)

20150430_101058.jpg

20150430_100237.jpg

20150430_101129.jpg

gpuz.png

14714d1430342040-unigine.png

Getting it all going

Everything is plug and play - I did not have to install anything third party or configure anything, steps I did:

  1. connect eGPU and start the system
  2. install desktop version of GeForce 900 series driver (which uninstalled dGPU driver)
  3. restarted Windows, but with BSOD, so I removed eGPU, started up again and disable dGPU, shut down and then connected eGPU and started Windows with no BSOD
  4. connected monitor to eGPU
  5. when I am using eGPU in Windows display settings I disable laptops internal display and enable only external monitor (my laptop display is turned off)

I had used my first Beast for couple of days and then I broke it by connecting wrong 4-PIN power cable from ATX PSU - be very careful when you first connect it, then bought a replacement and have been using it heavily for 3 month now with no Gen2 glitches.

Note for best performance: I am no guru and by mistake had set global Nvidia settings to respect quality instead of performance and was still getting 30+ FPS in new games maxed out (all GTX 970 benchmarks below are with "prefer quality" setting on), but when I set it to respect performance I was blown away, game like Shadow of Mordor ran 30-40 FPS before and 60+ FPS after maxed out and the visuals are the same, at least no difference what eye can tell.

Benchmark results

I have ran 3dMark tests, here are the results (want to mention that GPU was at 100% usage at times, so this means mPCI-E did not bottleneck the eGPU):

GTX 980TI:

3dmark06=13919

3dmark11.GPU=17728

3dmark13-FS.GPU=15321

GTX 970:

3dmark06=12877

3dmark11.GPU=12207

3dmark13-FS.GPU=9815

Final comments

Setup with GTX 970 runs latest games 30-60 FPS on maximum settings. Totally recommended if you already own this laptop or GPU - just use eGPU of your choice.

I then upgraded to GTX 980 TI (Gainward reference version, mainly because of 6GB of VRAM), I was not expecting this (because I thought limited PCI-E bandwidth will have more impact on performance), but it is performing significantly better than GTX 970.

Tested Witcher 3 and Dragon Age Inquisition so far, both games run 10-20 FPS better depending on an area.

I was able to overclock the card to +200 core clock and +450 memory clock - running stable around 70C-80C. Did not change any voltage parameters.

I can say that this setup is not running as good as decent desktop PC with same card, but it runs great.

GTX 970 games performance:

I tested all of following games with latest available patch/update/version for each of them.

Tested GTA V, runs 1080P 30-40 FPS gameplay-50-80 FPS cut scenes almost all on ULTRA, except:

Reflection MSAA: 2x

MSAA: 2x + TXAA

And in advanced options EDS on 0%

Grass quality: Very High

CRYSIS 3 - big areas where there is long grass at start of the game are killing performance when maxed out (very high) - 15-20 FPS, have to lower settings to high or medium. But 70% of the game is 30-60 FPS completely maxed out at 1080p.

Call of Duty Advanced Warfare - All maxed out except both caches OFF (if you turn on Caches, then you get low resolution textures even if your textures are set to MAX), mostly 40-60 FPS, some areas between 25-30 FPS.

Battlefield 4 - All on ULTRA 1080p, FOV 100%, Motion Blur OFF, Resolution Scale 100% - mostly around 40-50 FPS, never below 30, rarely above 60 FPS, some areas 90+ FPS, like snow, ship, water.

Far Cry 4 - All on maximum except shadows on ULTRA (instead of soft) and TXAA on 2x not 4x, 1080p is 40-60 (rarely 30) FPS very stable. some areas way above 60FPS

Dying Light - All on maximum (including FOV) 1080p is 30-60 FPS, frame rate jumping all over the place, even above 100 FPS when climbing on roof. Cut scenes are 55-80 FPS

Evil Within - All on maximum 1080p is 40-80 FPS, most of the time between 50-60 FPS.

Dragon Age Inquisition - All on ultra (AA on 2x MSAA) 1080p is 30-40 FPS most of the time (in the woods), rarely down to 27 FPS (like in swamps), sometimes up to 40-60 FPS (like beginning of the game - in the snow).

Middle Earth Shadow of Mordor - Ultra preset (AO on high) 1080p no HD texture pack, in game benchmark result 65FPS AVG, this games runs closest to desktop computer GTX 970 setups from games I have tried. only loading areas, entering menus (where text is overlayed) have frame drops - which take around 1-2 seconds down to 20-30 FPS. I capped the game at 60FPS and rarely see below it when playing. The frame drops seem to be due to GTX 970 3.5 GB VRAM issue, this game is very VRAM demanding. SOLVED: I was able to make it run smooth by setting texture resolution to HIGH instead of ULTRA.

Witcher 3 - All maxed out (all settings on ultra - including hairworks and hbao+) except foliage visibility range on medium, 1080p is stable 30-45 FPS (nicely playbale for this game), some areas are 60 FPS. EDIT: when using dGPU as dedicated PhysX card it runs smooth at all times.

Batman Arkham Knight - this game needs 5+ GB of VRAM to run on ultra, as a result of that game stutters when scene changes fast. a sacrifice has to be made if you want no stutters - either game on 720p or lower the texture quality (or get a video card with 6GB+ of VRAM). If not the stutters, then the game runs 60 FPS @ 1080p maxed out except the Nvidia smoke and particles effects (which kill the performance and runs at 20 FPS). EDIT: It is possible to avoid lack of VRAM caused stutters by restarting checkpoint as soon as stutters begins (which flushes VRAM). And I found a way to max out the game 1080p and retain 30 - 60 FPS most of the time, for this enable dGPU in Windows and in Nvidia control panel chose the dGPU as PhysX processor. Overclock your dGPU (in my case GT 730M) to max core clock and memory clock to +200.

Tried an old game - Alan Wake, it is a dx9 game with normal sys requirements, runs terrible - eGPU 24 FPS on max settings (eGPU is at 100% usage and CPUs around 40-50% usage) and 28-30 FPS on lowest settings. Strangely it runs even worse on dGPU - around 10 FPS maxed out settings, dGPU is at 100% usage and 25 FPS low settings. Could not find how to fix this. I see people running this game 80FPS on GTX 970. strange. tried driver cleaner, did not help

Tried another old game - Witcher 2, it is also dx9 game, almost maxed out except ubersampling off, cinematic depth of field off, blur effect off, lod distance near, 1080p runs great - mostly 60 FPS, but drops as low as 30 FPS, not lower.

Hi,

i did everything the same except 1 thing that i dont know how you do it.

  1. install desktop version of GeForce 900 series driver (which uninstalled dGPU driver) - done
  2. restarted Windows, but with BSOD, so I removed eGPU, started up again and disable dGPU, shut down and then connected eGPU and started Windows with no BSOD done i dont know why you are disabling and renabling the BSOD because iam not getting any Error with them.
  3. connected monitor to eGPU - should it be the whole time unplugged and then Plug / When should i plug him when iam in windows at boot ? or when u mean that ?
  4. when I am using eGPU in Windows display settings I disable laptops internal display and enable only external monitor (my laptop display is turned off) - that's mean you are in windows and u can duel Screen but you disable the Laptop screen from windows setting or the gtx setting right ? so you dont turn it off from DIY eGPU or something like that ?

I have acer Aspire v3-772g 32gb ram and gtx 850 and intel.. and windows 8.1 and i want to install gtx970. Everything done fine: look :

post-39509-14495000903901_thumb.png

Picture of mine GtX970 how i plugged it with a Jumper http://i.imgur.com/Chybqdu.jpg

my Physx:

post-39509-14495000904224_thumb.png

Scrren Resoultion:

post-39509-14495000904587_thumb.png

Monitor: http://i.imgur.com/spLPKS4.jpg

All Pictures at once : Imgur: The most awesome images on the Internet

as you can see, My only problem is my external Monitor dont work ? or not getting detected ( normally its working i plugged the HDMI cable at another laptop and everything just fine) ?

iam open for any soultion please some help guys.

Thanks a lot

Share this post


Link to post
Share on other sites

Hi, I can only comment on these:

  1. install desktop version of GeForce 900 series driver (which uninstalled dGPU driver) - done //////ok
  2. restarted Windows, but with BSOD, so I removed eGPU, started up again and disable dGPU, shut down and then connected eGPU and started Windows with no BSOD done i dont know why you are disabling and renabling the BSOD because iam not getting any Error with them. //////I only get BSOD on Win 7, I have not tried windows 8.1, but there is not BSOD on Windows 10 (dGPU is just auto disabling after few seconds of use, but it shows fine in device manager at all times)
  3. connected monitor to eGPU - should it be the whole time unplugged and then Plug / When should i plug him when iam in windows at boot ? or when u mean that ? ////// I connect monitor to eGPU before I turn on the laptop, when I turn on the laptop in Windows 10 my external monitor turns on only when Windows is fully booted and read to insert the password, while Windows boots only laptop display is active.
  4. when I am using eGPU in Windows display settings I disable laptops internal display and enable only external monitor (my laptop display is turned off) - that's mean you are in windows and u can duel Screen but you disable the Laptop screen from windows setting or the gtx setting right ? so you dont turn it off from DIY eGPU or something like that ? ////// yes, when I log into windows and go into display settings I see 2 displays detected.

As for the solution to your problem - I dont know, I am not a guru myself, I would be stuck like yourself. I also used HDMI cable and it worked fine, I also tried DVI cable, also worked.

To me it seems that your eGPU is not fully detected by Windows. I never used any jumpers for PSU, I only connected that big 24 pin cable to Beast adapter via adapter cable that was included.

Sorry I cant be of more help.

Share this post


Link to post
Share on other sites
Hi, I can only comment on these:

  1. install desktop version of GeForce 900 series driver (which uninstalled dGPU driver) - done //////ok
  2. restarted Windows, but with BSOD, so I removed eGPU, started up again and disable dGPU, shut down and then connected eGPU and started Windows with no BSOD done i dont know why you are disabling and renabling the BSOD because iam not getting any Error with them. //////I only get BSOD on Win 7, I have not tried windows 8.1, but there is not BSOD on Windows 10 (dGPU is just auto disabling after few seconds of use, but it shows fine in device manager at all times)
  3. connected monitor to eGPU - should it be the whole time unplugged and then Plug / When should i plug him when iam in windows at boot ? or when u mean that ? ////// I connect monitor to eGPU before I turn on the laptop, when I turn on the laptop in Windows 10 my external monitor turns on only when Windows is fully booted and read to insert the password, while Windows boots only laptop display is active.
  4. when I am using eGPU in Windows display settings I disable laptops internal display and enable only external monitor (my laptop display is turned off) - that's mean you are in windows and u can duel Screen but you disable the Laptop screen from windows setting or the gtx setting right ? so you dont turn it off from DIY eGPU or something like that ? ////// yes, when I log into windows and go into display settings I see 2 displays detected.

As for the solution to your problem - I dont know, I am not a guru myself, I would be stuck like yourself. I also used HDMI cable and it worked fine, I also tried DVI cable, also worked.

To me it seems that your eGPU is not fully detected by Windows. I never used any jumpers for PSU, I only connected that big 24 pin cable to Beast adapter via adapter cable that was included.

Sorry I cant be of more help.

hank zou verz much i aprreciate zour fast answer. I will keep searching for a solution a lot of people have this problem but no one is giving it a solution iam lloking for some expert like nando but hes not answering anzmore. >PT

Share this post


Link to post
Share on other sites
hank zou verz much i aprreciate zour fast answer. I will keep searching for a solution a lot of people have this problem but no one is giving it a solution...

As mentioned by @rgpu, if using a HDMI cable, try using a DVI one instead or vice versa. Eg: I had a GTX660Ti card once with 2 DVI connectors. One had blown and only 1 still worked, allowing monitor detection. Having remaining warranty allowed the card to be swapped without cost. Only then did the second DVI connector work.

So the port you are attaching your external LCD onto may be faulty. Otherwise your screenshots within NVidia control panel indicate everything is working. To be doubley sure, go to the NVidia Control Panel -> Adjust image settings with Preview. Does the NVidia logo spin nice and smoothly on your internal LCD? If yes, then the eGPU is rendering the image and the iGPU attached LCD being used to display it. That would indicate the the eGPU is computationally functional.

Share this post


Link to post
Share on other sites
As mentioned by @rgpu, if using a HDMI cable, try using a DVI one instead or vice versa. Eg: I had a GTX660Ti card once with 2 DVI connectors. One had blown and only 1 still worked, allowing monitor detection. Having remaining warranty allowed the card to be swapped without cost. Only then did the second DVI connector work.

So the port you are attaching your external LCD onto may be faulty. Otherwise your screenshots within NVidia control panel indicate everything is working. To be doubley sure, go to the NVidia Control Panel -> Adjust image settings with Preview. Does the NVidia logo spin nice and smoothly on your internal LCD? If yes, then the eGPU is rendering the image and the iGPU attached LCD being used to display it. That would indicate the the eGPU is computationally functional.

Well finally i made everything working, but its totally annoying because i cant turn my laptop OFF or RESTART because iam gonna get this Erroor : http://i.imgur.com/IJF7Ubd.jpg?1 --> because the egpu is plugged in. and I CANT use the delay buttons at the adapter because the atx-cable is directly connected(Green with black). it means my Graphiccard is alwys on (Spinning and Working)

If i want to restart or shutdown i must UNPLUG everything and put the wireless card back and then i can turn my computer on.

And the other problem even if i want to use my egpu. i must start with the WiFi card and then go to the diy-egpuy 1.30 by Tech Inferno Fan and the choose option 3 for the menu options and after that i can FINALLY plug my eGPU and then F5-Button.after u done this I must change the whole options and after I canhged the whole options. I cant even restart or save anything because it wont help me because of the Error Before. BUT I can run chainloader mbr as --> TEST <-- and then its finally working and i can log in to windows(because there is no need to restart).

But anyway iam having fun atm.

Share this post


Link to post
Share on other sites

Well finally i made everything working, but its totally annoying because i cant turn my laptop OFF or RESTART because iam gonna get this Erroor : http://i.imgur.com/IJF7Ubd.jpg?1 --> because the egpu is plugged in. and I CANT use the delay buttons at the adapter because the atx-cable is directly connected(Green with black). it means my Graphiccard is alwys on (Spinning and Working)

If i want to restart or shutdown i must UNPLUG everything and put the wireless card back and then i can turn my computer on.

And the other problem even if i want to use my egpu. i must start with the WiFi card and then go to the diy-egpuy 1.30 by Tech Inferno Fan and the choose option 3 for the menu options and after that i can FINALLY plug my eGPU and then F5-Button.after u done this I must change the whole options and after I canhged the whole options. I cant even restart or save anything because it wont help me because of the Error Before. BUT I can run chainloader mbr as --> TEST <-- and then its finally working and i can log in to windows(because there is no need to restart).

But anyway iam having fun atm.

You do not have to do the booting via option 3 every time. Just ensure your startup.bat contains the following, which you can hand enter by booting Setup 1.30 -> menu-based -> startup.bat->Edit

call speedup lbacache
call iport dGPU off
call vidwait 60
if NOT '%eGPU%'=='' goto OS
call wait_e 5 "eGPU not found!!"

:OS
call chainload MBR

As for your problem with bootup stalling refer to the following thread that explains how to bypass BIOS detection of the eGPU: http://forum.techinferno.com/diy-e-gpu-projects/11393-mpcie-egpu-troubleshooting-steps.html

The CTD/PTD delay functions are independent of the ATX PSU being permanently on.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.