Jump to content
timohour

14" Dell Latitude E6430 - Performance Upgrades and System Mods

Recommended Posts

PCI-e gen2.JPG

 

This looks OK, right?  It is idling @x1 1.1 but, when I open 3D program, it changes to x1 2.0.  it was same with my X230 so, I guess it is normal behavior. 

Running HPET timers is needed only for Win8? I am running Windows 7. In Nvidia CP all settings are same- set to performance also using High Performance mode in power managment.  (In my Lenovo X230 and work T440p there are more additional plans, even Maximum Performance, but that is missing in Dell. In Dell there are only 3 main profiles- Power Saver, Balanced, High Performance). Could that be the case? Because in Lenovo there are both: Maximum Performance and High Performance.

Edited by viilutaja

Share this post


Link to post
Share on other sites
1 hour ago, viilutaja said:

PCI-e gen2.JPG

 

This looks OK, right?  It is idling @x1 1.1 but, when I open 3D program, it changes to x1 2.0.  it was same with my X230 so, I guess it is normal behavior. 

Running HPET timers is needed only for Win8? I am running Windows 7. In Nvidia CP all settings are same- set to performance also using High Performance mode in power managment.  (In my Lenovo X230 and work T440p there are more additional plans, even Maximum Performance, but that is missing in Dell. In Dell there are only 3 main profiles- Power Saver, Balanced, High Performance). Could that be the case? Because in Lenovo there are both: Maximum Performance and High Performance.

You should install the Dell Feature Enhancement Pack, especially the component responsible for power profiles. But as far i'm concerned, the only benefit of this is that you can set the fan to max levels, which is +500 RPM compared to the available without it. The power profiles provided by this pack also control the CPU throttling mechanism of the embedded controller, but i don't really think that the problem is caused by the embedded controller, nor the power profiles. If you are getting lower GPU score with the same OS, same connection, same drivers, the only thing comes to my mind is that the pcie compression provided by nVidia Optimus is not enabled for some reason, and i guess the dGPU is responsible for that, but since i own the iGPU only model, i can not help you from this point.

Edited by kondilac

Share this post


Link to post
Share on other sites
15 minutes ago, kondilac said:

 the only thing comes to my mind is that the pcie compression provided by nVidia Optimus is not enabled for some reason, and i guess the dGPU is responsible for that, but since i own the iGPU only model, i can not help you from this point.

 

Rightly so, we see the X230 results have a HD4000 iGPU listed as a secondary graphics card. No iGPU listed against the E6430 results. Without the iGPU, the NVidia driver won't enable x1 pci-e compression. This will give a huge difference in DX9 results like 3dmark06:

 

http://www.3dmark.com/fs/6345009 (X230)

http://www.3dmark.com/fs/7139888 (E6430)

 

@viilutaja did you follow the guides in this thread on configuring the eGPU correctly by setting UEFI variables to ensure the iGPU is enabled on boot, Gen2 set, TOLUD reduced, etc?

 

 

Share this post


Link to post
Share on other sites
1 minute ago, Tech Inferno Fan said:

 

Rightly so, we see the X230 results have a HD4000 iGPU listed as a secondary graphics card. No iGPU listed against the E6430 results. Without the iGPU, the NVidia driver won't enable x1 pci-e compression. This will give a huge difference in DX9 results like 3dmark06:

 

http://www.3dmark.com/fs/6345009 (X230)

http://www.3dmark.com/fs/7139888 (E6430)

 

@viilutaja did you follow the guides in this thread on configuring the eGPU correctly by setting UEFI variables to ensure the iGPU is enabled on boot, Gen2 set, TOLUD reduced, etc?

 

 

Actually he stated in his first post, and also visible on the 3dm results that he has the iGPU enabled, but also theNV5200, and i think the presence of the dedicated GPU could be the issue why the optimus compression is not kicking in, but i'm really just tapping in the darkness bc i never tried a laptop with dgpu + egpu.

Share this post


Link to post
Share on other sites
14 minutes ago, Tech Inferno Fan said:

 

Rightly so, we see the X230 results have a HD4000 iGPU listed as a secondary graphics card. No iGPU listed against the E6430 results. Without the iGPU, the NVidia driver won't enable x1 pci-e compression. This will give a huge difference in DX9 results like 3dmark06:

 

http://www.3dmark.com/fs/6345009 (X230)

http://www.3dmark.com/fs/7139888 (E6430)

 

@viilutaja did you follow the guides in this thread on configuring the eGPU correctly by setting UEFI variables to ensure the iGPU is enabled on boot, Gen2 set, TOLUD reduced, etc?

 

No, I didn't set UEFI variables as I connected the EC adapter booted and it worked after 2 restart (finding hardware and installed nvidia driver). In Lenovo bios, there was a place where I could set the Gen2, but in Dell bios i didn't notice that section to be honest. Have not touched TOLUD or other boot programs as Setup 1.30 etc.  
Where did You notice that HD4000 is secondary graphics card in my 3Dmark link? Searched myself but could not find...

 

Another thing I noticed, that when I apply  the OC in MSI afterburner. Save the settings, then after reboot the settings are defulted back to stock. Thinking about flashing my GTX670 default bios to higher clocks, but that doesn't explain lower default clock benchmark result...

 

14 minutes ago, Tech Inferno Fan said:

 

 

 

Share this post


Link to post
Share on other sites
15 hours ago, viilutaja said:

Oh, yes the memory oc. Missed that. it actually did no difference...

 

How do i find the correct root port to disable the dGPU?

 

in order to easily disable the NVS5200M within Windows go to

 

Device Manager -> System devices and disable NV2000 PCI bridge (Xeon® processor E3 - 1200 v2/3rd Gen Core processor PCI Express Root Port - 0151).

 

In order to do this you should set Optimus Enabled in BIOS and make sure that Intel HD4000 is enabled in Device Manager.

 

This way your dGPU will be disabled and Optimus compression will be enabled. Try that, reboot and report back.

 

Edited by timohour

Share this post


Link to post
Share on other sites
28 minutes ago, viilutaja said:

Cant check the bios right now, because I am at work. But managed to run FireStrike test over RDP. 

Disabled the Express Root Port and restarted the laptop beforehand... results are even worse.

http://www.3dmark.com/compare/fs/7178582/fs/7136982#

 

This result is with only HD4000 and GTΧ670 shown in Device Manager?

 

and pls when/if you have time do the CUDA-z performance test to see if it gives lower values than with your x230.

Edited by timohour

Share this post


Link to post
Share on other sites
29 minutes ago, timohour said:

This result is with only HD4000 and GTΧ670 shown in Device Manager?

Thats correct. No NVS gpu anymore listed in Display Adapters under Device Manager. GPU-Z confirms that. Only HD4000 and GTX670 is selectable from dropdown menu.  Only thing left to do is to check Optimus from Bios. If it is enabled. Can check that in 5-6 hours when back at home.

Can somebody direct me to the bios submenu where I can find that? And what other Bios settings should be overwatched for best performance with e-gpu?

Edited by viilutaja

Share this post


Link to post
Share on other sites
28 minutes ago, viilutaja said:

Thats correct. No NVS gpu anymore listed in Display Adapters under Device Manager. GPU-Z confirms that. Only HD4000 and GTX670 is selectable from dropdown menu. 

 

OK last favor. When you go home, try to startup the laptop as it is now (PCI Bridge disabled) confirm that it boots with HD4000 enabled and then reboot and hotplug the GTX670 AFTER post. It is reported from other users that with the E6x30 series when you connect an eGPU before boot, it will disable internal screen and iGPU making impossible for Optimus compression to kick in.
This is maybe why in your x230 score it states HD4000 as secondary GPU while in your E6430 score there is no secondary GPU  as noticed by @Tech Inferno Fan above.

 

Also check your x1.2 bandwidth using CUDA-z performance on both your x230 and your E6430 cause some other users reported that they had trouble establishing a stable x1.2 link. Such test will maybe prove that the E6430's ExpressCard link is problematic.

 

I never had such problem connecting my R9-280x to my E6430 and my scores where on par with the HP Probook 6470b I owned. Keep in mind though that my E6430 is one of the latest (Aug 2013) and there was maybe a silent revision.

 

Edited by timohour

Share this post


Link to post
Share on other sites

Altough, when I rebooted this morning at home, the POST data was on internal screen, even the Win boot logo came up on internal screen and then when login comes, it switches to external display connected to GTX670. That indicates to me that somekind of gpu was connected during post, was it iGPU or dGPU- don't know. When I get to home, I can check if there is still POST picture on screen and win logo (after disabling NVS gpu)  on internal screen when booting.

Edited by viilutaja
  • Thumbs Up 1

Share this post


Link to post
Share on other sites
3 hours ago, timohour said:

while in your E6430 score there is no secondary GPU  as noticed by @Tech Inferno Fan above.

Check the two secondary GPU dropdown menus http://www.3dmark.com/fs/7139888

 

@viilutaja

Since you have already disabled the dGPU-s root port,in order to get optimus working, iGPU must be set to always on, and set to primary. 
These settings like most of the advanced ones are not available from the BIOS, and can only be modified through EFI variables, which are accessable through an EFI shell. 
You can make a bootable thumbdrive with it, or follow the steps in my next post.
You should set EFI var  0x1d4 to 0x0, and 0x1d8 to 0x1.

No offense, but I highly recommend for you to read this whole thread because the advanced user base of this machine provided a great deal of useful information (everything about the accessibility of the advanced BIOS options through EFI shell also), but at least you should read the first post before asking questions which were answered many times before.
In my next post i will describe how to make a permanent boot option to get into EFI shell, but it will involve messing with the EFI system partition with wich one can easily brick his current OS boot so it is only for advanced users who know what are they doing, and i take no responsibility for anything.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
6 minutes ago, kondilac said:

Check the two secondary GPU dropdown menus http://www.3dmark.com/fs/7139888

 

@viilutaja

Since you have already disabled the dGPU-s root port,in order to get optimus working, iGPU must be set to always on, and set to primary. 
These settings like most of the advanced ones are not available from the BIOS, and can only be modified through EFI variables, which are accessable through an EFI shell. 
You can make a bootable thumbdrive with it, or follow the steps in my next post.
You should set EFI var  0x1d4 to 0x0, and 0x1d8 to 0x1.

No offense, but I highly recommend for you to read this whole thread because the advanced user base of this machine provided a great deal of useful information (everything about the accessibility of the advanced BIOS options through EFI shell also), but at least you should read the first post before asking questions which were answered many times before.
In my next post i will describe how to make a permanent boot option to get into EFI shell, but it will involve messing with the EFI system partition with wich one can easily brick his current OS boot so it is only for advanced users who know what are they doing, and i take no responsibility for anything.

Correct info. I was talking about the latest result... There is no secondary card there

If he boots with eGPU disconnected though and hotplug after post, iGPU will be set on and primary. He will need to set the EFI variables for a more permanent solution.


Just keep it informative... ;)

 

Edited by timohour

Share this post


Link to post
Share on other sites

I read this thread from the beginning many times before, thats why I decided to purchase this laptop at first place. I did not make a post about my problem without reading through the thread. There was no hint in first post to enabling Optimus through EFI shell hack... or did i miss that somehow :/ ?

Edited by viilutaja

Share this post


Link to post
Share on other sites
15 minutes ago, viilutaja said:

I read this thread from the beginning many times before, thats why I decided to purchase this laptop at first place. I did not make a post about my problem without reading through the thread. There was no hint in first post to enabling Optimus through EFI shell hack... or did i miss that somehow :/ ?

 
On 11/1/2015 at 2:09 PM, timohour said:
  • Set iGPU to enabled after booting with eGPU connected here.

 

I am sorry . You are right this is the note but I failed to explain it on the first port that this is for Optimus compression (it does say so that on the post headline though :) )

But again, not clear so my fault.

 

Connecting eGPU after post though would have the same effect. This is the hack for a more permanent solution.

 

Edited by timohour

Share this post


Link to post
Share on other sites

How do You open the program after extraction or what else is needed to operate?

Edited by viilutaja

Share this post


Link to post
Share on other sites
5 minutes ago, viilutaja said:

How do You open the program after extraction or what else is needed to operate?

Format a USB 2.0 flash drive to FAT32
place the file under

EFI\Boot\bootx64.efi

Start up your Dell press F12. Select the UEFI option of your flash drive. Check the NEWBIE GUIDE for the rest.

 

You can place it in your ssd's recovery partition too in the same directory..

Edited by timohour

Share this post


Link to post
Share on other sites

How to make a permanent boot option to EFI Shell

This guide is for advanced users only, i take no responsibility for any damage caused by doing this 

 

First determine the disk, and partition number of the EFI system partition. This can be checked using disk management in windows computer management

 

  • Press Windows + r
  • run compmgmt.msc

1.png.0fe0cc7336f879d7da5b075724414515.p

2.thumb.png.47c9a0afe4f6f5b03463c01d451a

 

Then run "DISKPART" through an elevated command prompt, and assign a drive letter for the EFI partition with the following commands:

select disk X 
select partition Y 
assign

Where:

  • X is the number of the disk which has the EFI system partition
  • Y is the number of the EFI system partition on the disk

(In my example, X = 0, Y = 2)

 

The EFI partition will be now accessible using your favourite file manager if it has administrator privileges.
Obtain a copy of the EFI shell from here and unpack the contents of the archive to the EFI partition in the following folder: /EFI/Boot

Now reboot the machine and get into the BIOS, and add a new boot entry. You name it as you want, and select the "bootx64.efi" file from the location you previously copied it.

3.thumb.png.a5fd2d5fbd04a484f28f60db7e90

 

From now on, you can boot into the EFI shell anytime you want, after selecting it from the boot menu (press F12 at boot)

5.thumb.png.2f6de3096f9a378b9eb393b7a449

 

Pro tip for lazy users like me:

The normal bios options can be changed using the Dell Command | Configure tool from the OS. Reboot required, mangling with the laggy bios interface isn't :P

Edited by kondilac
  • Thumbs Up 1

Share this post


Link to post
Share on other sites
1 hour ago, viilutaja said:

I read this thread from the beginning many times before, thats why I decided to purchase this laptop at first place. I did not make a post about my problem without reading through the thread. There was no hint in first post to enabling Optimus through EFI shell hack... or did i miss that somehow :/ ?

 

In my case, the necessary settings in the BIOS was only the ones regarding the iGPU state (the two variables i mentioned before), i did not touch the Optimus settings. I assumed that you did not read the first post, because you were looking for non existing options in the bios, which can be only set through EFI vars, and it is well documented in this thread, and you seem like you have never encountered with the whole thing before (requesting link, and instructions)

Edited by kondilac

Share this post


Link to post
Share on other sites
On 9/1/2016 at 5:38 PM, timohour said:

 

ICould you test your 3740QM with your unapproved psu adapter?

How much is  your maximum consumption 4C@3.9Ghz under full load (tbench 1024M)?

If it is under 56.25W it should probably work with your Dell Adapter for small windows of time (128 sec).

 

Oh, I WISH :)

My CPU is a mess, is like around 58,5W

Edited by Dewos

Share this post


Link to post
Share on other sites
2 minutes ago, Dewos said:

 

Oh, I WISH :)

My CPU is a mess, is like around 58W

 

Check then with the approved adapter @ x38 what's your consumption @ 3.8GHz?  Will it work? (use throttlestop to lower the multi)

Edited by timohour

Share this post


Link to post
Share on other sites
3 minutes ago, timohour said:

 

Check then @ x38 what's your consumption @ 3.8GHz?

 

Around 57,6 for 10 seconds, then x37\36

Edited by Dewos

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.