Jump to content
timohour

14" Dell Latitude E6430 - Performance Upgrades and System Mods

Recommended Posts

Dewos said:
What value I should set?

But first.... Is it safe? I really don't want to fry my CPU :)

 

 

Long Duration Power Limit 0xB40 [Power] To get the Optimal setting (no TDP Throttling), check with Throttlestop, (Example: 0x50 = 80W)
Short Duration Power Limit 0xB41 [Power] Sets short duration TDP limit of CPU. Default value is +12,5% of the original (x64=100W)

 

 

 

What do you mean safe? I have it like this for more than 3 months and it works great. I use mainly my 90W PSU and used my 130W for my Dock at work and when I OC my NVS5200M.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
Quote

Long Duration Power Limit 0xB40 [Power] To get the Optimal setting (no TDP Throttling), check with Throttlestop, (Example: 0x50 = 80W)
Short Duration Power Limit 0xB41 [Power] Sets short duration TDP limit of CPU. Default value is +12,5% of the original (x64=100W)
What do you mean safe? I have it like this for more than 3 months and it works great. I use mainly my 90W PSU and used my 130W for my Dock at work and when I OC my NVS5200M.



Oh well, thanks @timohour for your help, but it doesn't work. 4c bench keeps always max 44W and the results are the same. Should I do something other than this?

Share this post


Link to post
Share on other sites
Oh well, thanks @timohour for your help, but it doesn't work. 4c bench keeps always max 44W and the results are the same. Should I do something other than this?

Could you upload a screenshot of your TPL in ThrottleStop?

Share this post


Link to post
Share on other sites
Sure

[ATTACH=CONFIG]16304[/ATTACH]

try to enable Intel Power Balance set CPU 31 and GPU 0.

It won't go over 45W no matter what? Not even for a short time?

Share this post


Link to post
Share on other sites
try to enable Intel Power Balance set CPU 31 and GPU 0.

Nothing

It won't go over 45W no matter what? Not even for a short time?

Yes, max 45W, and I don't think is a faulty PSU.

UPDATE: It WAS a faulty PSU. Tried with another: it keeps 4c x39 rock solid for some seconds (until 105°). Yeah for us :)

post-18229-1449500101471_thumb.jpg

And now this:

http://www.ebay.it/itm/Alluminio-Dissipatore-Aluminum-Heat-Sink-For-Compute-Led-Power-IC-Transistor-New-/231643140574?hash=item35ef01d1de:g:L-0AAOSwMmBVweAH

Share this post


Link to post
Share on other sites
Nothing

Yes, max 45W, and I don't think is a faulty PSU.

UPDATE: It WAS a faulty PSU. Tried with another: it keeps 4c x39 rock solid for some seconds (until 105°). Yeah for us :)

[ATTACH=CONFIG]16305[/ATTACH]

Nice!!!

It shouldn't go up that fast though... Do you have the bottom lid closed?

Cause mine @3.98GHz with Prime95 after 6 minutes of full load with open bottom lid temperature wouldn't cross 95°C...

UPDATE: If this is with TSBench seems like your chip is not very good thermally. You can see here that my 3720QM @ 3.8GHz is ~ 50W @1.2109V. 59.4W is almost 10W more at the same voltage!

Do you still have your dGPU disabled?

Share this post


Link to post
Share on other sites
Nice!!!

It shouldn't go up that fast though... Do you have the bottom lid closed?

Cause mine @3.98GHz with Prime95 after 6 minutes of full load with open bottom lid temperature wouldn't cross 95°C...

UPDATE: If this is with TSBench seems like your chip is not very good thermally. You can see here that my 3720QM @ 3.8GHz is ~ 50W @1.2109V. 59.4W is almost 10W more at the same voltage!

Do you still have your dGPU disabled?

Yap, probably not the best CPU around, but if it keeps x39 is good enough.

In the future I will work on the heat building (additional heat sink). I'm not a big fan of the 'open bottom lid' route, it is not pratical and I'm more a 'daily' overclocker anyway.

Yes, the dGPU is disabled. Enabling it mess up with the drivers (because I need to cold-plug the eGPU before the boot), but it is worth a try for testing if you're interested :)

Share this post


Link to post
Share on other sites
Yap, probably not the best CPU around, but if it keeps x39 is good enough.

In the future I will work on the heat building (additional heat sink). I'm not a big fan of the 'open bottom lid' route, it is not pratical and I'm more a 'daily' overclocker anyway.

The bottom lid doesn't need to be screwed to stay in position. At least in my laptop. I had been carrying my E6430 to work every day for the past 3 months. I have the bottom lid unscrewed and I took it off every morning that I attached the laptop to the docking station. Using an extra fan showed much better perfomance but I was too lazy to adjust it everyday... Having an open lid and using the additional fan to cool it down shortened my render times more than I could imagine. Offcourse using a laptop cooler along with the open lid may have helped the same but I never tried one...

IMO you will be amazed by the temperature difference with open and closed lid.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Hello everyone, I made a tutorial for those who want to unlock raid 0/stripping on the Latitude E6430.

This is my first post and i use Google trad because i'm french.

This is at your own risk.

I used the bios version "a16":

01 - You need to download "bootx64.efi" here "http://brains.by/posts/bootx64.7z" to change the setting that blocks raid0 in the bios.

02 - Extract "bootx64.efi" on a fat32 formated usb key in "EFI\Boot\" .

03 - Now, set the bios boot option in UEFI mode, enable Legacy Boot, disable Secure Boot, save and reboot.

04 - Plug your usb key on the notebook.

During the boot press "f12" to boot menu to choose the key in "UEFI mode".

05 - If all goes well, you should have boot on the key and be on "Grub".

06 - In the command line type first:

"setup_var 0x12D" and you should get "0x0" as answer. This means that setting is disabled.

If you get an another responce, cancel everything.

07 - After for enable this setting type:

"setup_var 0x12D 0x1" and normally the setting is enabled.

08 - At last type:

"setup_var 0x12D" in command line, validate and reboot to bios config.

09 - Set data transfer to "RAID Mode", apply and reboot.

10 - During boot press "Ctrl+i" to boot in Intel Rapid Storage.

Normally, we can now create a RAID0 array...

Here, an little benchmark of my two PM830post-34661-14495001112464_thumb.png.

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

Normally, we can now create a RAID0 array...

Here, an little benchmark of my two PM830[ATTACH=CONFIG]16467[/ATTACH].

impressive!!! I have been dreaming for a while for such a setup... It can be costly though..

on the E6440 It would be fun to see a RAID0 3x250GB 850 (2 x sata & 1 x msata) touching 1,5GB/s R/W!!!

Share this post


Link to post
Share on other sites
impressive!!! I have been dreaming for a while for such a setup... It can be costly though..

on the E6440 It would be fun to see a RAID0 3x250GB 850 (2 x sata & 1 x msata) touching 1,5GB/s R/W!!!

On the e6440 in Grub type:

1 - setup_var 0x19D

2 - setup_var 0x19D 0x1

3 - setup_var 0x19D

Share this post


Link to post
Share on other sites

Hi!

I just joined the club! (although maybe not for so long)

My e6430 arrived yesterday. i3-2350, 4Gb, 320Gb, 2x60Wh T54FJ, very good condition, warranty. I live in Europe, and it had cost me my 2560p + 70$.

The BIOS version is A16, and the memory clock sped is locked down to 1333Mhz, although the module is 1600Mhz. Do previous BIOS versions have the same restraint?

I'm planning to upgrade (I already have a 16Gb 2133 HyperX kit in my other machine (and know about the problems too), and a Samsung 850 Pro 256Gb SSD, so basically a better CPU is missing only) but fist i would like to be sure that everything is OK with the machine, because it still has 1 month warranty. Could any long time user give advices, what to scrutinise?

Share this post


Link to post
Share on other sites
Hi!

I just joined the club! (although maybe not for so long)

My e6430 arrived yesterday. i3-2350, 4Gb, 320Gb, 2x60Wh T54FJ, very good condition, warranty. I live in Europe, and it had cost me my 2560p + 70$.

The BIOS version is A16, and the memory clock sped is locked down to 1333Mhz, although the module is 1600Mhz. Do previous BIOS versions have the same restraint?

I'm planning to upgrade (I already have a 16Gb 2133 HyperX kit in my other machine (and know about the problems too), and a Samsung 850 Pro 256Gb SSD, so basically a better CPU is missing only) but fist i would like to be sure that everything is OK with the machine, because it still has 1 month warranty. Could any long time user give advices, what to scrutinise?

This may be because you have an Sandy Bridge CPU on a Ivy Bridge laptop so try with Ivy cpu.

I have two 4gb 1600Mhz Crucial Ballistix Sport and i don't have this problem on my e6430 but i have it on my 2560p.

Share this post


Link to post
Share on other sites
Hi!

I just joined the club! (although maybe not for so long)

My e6430 arrived yesterday. i3-2350, 4Gb, 320Gb, 2x60Wh T54FJ, very good condition, warranty. I live in Europe, and it had cost me my 2560p + 70$.

The BIOS version is A16, and the memory clock sped is locked down to 1333Mhz, although the module is 1600Mhz. Do previous BIOS versions have the same restraint?

Hello, happy to see another E6430 implementation.

The reason your memory runs @ 1333MHz is your processor. SB i3-23xxM memory controller won't go over 1333MHz even if the module are clocked @ 1600MHz. Also the IB i3-31xxM won't go over 1600MHz.

It is definetely not a BIOS restriction. I am running A16 and paired with a i5/i7 it goes all the way up to 2133 if your memory supports it.

I'm planning to upgrade (I already have a 16Gb 2133 HyperX kit in my other machine (and know about the problems too), and a Samsung 850 Pro 256Gb SSD, so basically a better CPU is missing only) but fist i would like to be sure that everything is OK with the machine, because it still has 1 month warranty. Could any long time user give advices, what to scrutinise?

Check that every port of your machine works without issues (usb, e-sata, usb 3.0) etc. Check that the DVD is reading and burning successfully. Use the ePSA tests coming with your laptop and stress your memory with Memtest. If you have a dGPU run Furmark for some time and check for artifacts... It will probably pass everything without issues...

If you are planning to upgrade your CPU definetely consider an Ivy Bridge Processor as R.O.G. suggested.

i7-3720/3740QM and i7-3820/3840QM are the best performers... Consider them over an i7-36X0QM because on our Latitudes you can unlock the top 4 turbo bins using UEFI vars..

UPDATE 1: Seems that BPlus have possibly discontinued PE4C v2.1 (it is reported out of stock on their site for a while) and replaced it with the more stable PE4C v3 which has soldered both ends, Meaning that there is no available hardware at the moment to achieve a stable x2.2 link.

There are still some remnants on eBay but it is not possible to purchase the extra PM100C cable to create the x2 link. They are all out of stock.

UPDATE 2: PM100C is now again available for 20$ plus shipping. PE4C still not available.

Share this post


Link to post
Share on other sites

OK, looks like my reply to R.O.G will never get approved by the mods.

Yes, i totally forgot that it could be the cause that it is an i3, even worse SB.

@R.O.G : Check the latest 2560p BIOS (F.60) , since F.28 the ram freq. nerf is removed. I had no problems running @1600 with an i5 in my 2560p.

@timohour: Thanks for the advices, everything is fine with the unit. And yes, I definitely want to upgrade to IB, I'm aiming for an XM chip because the extra cache. But i have to find a (relatively) cheap one, until then i will get an IB i5, just to be able to migrate on the machine from my haswell POC. Skylake is already here in hand with Christmas, so i hope to find a used XM chip under 300$ soon (I got a 400$ quote on a new 3940XM . I have the iGPU only model, but my eGPU parts are already on the way.

Share this post


Link to post
Share on other sites
Thanks for the advices, everything is fine with the unit. And yes, I definitely want to upgrade to IB, I'm aiming for an XM chip because the extra cache. But i have to find a (relatively) cheap one, until then i will get an IB i5, just to be able to migrate on the machine from my haswell POC. Skylake is already here in hand with Christmas, so i hope to find a used XM chip under 300$ soon (I got a 400$ quote on a new 3940XM . I have the iGPU only model, but my eGPU parts are already on the way.

There is actually no reason to invest on an XM chip on the E6x30 series.Even if you need the extra cache (which IMHO is not a big deal) i7 38x0QM would have the exact same amount as the XM chips.

XM are better than the QMs in aspects that are useless for our small laptops.

- They have fully unlocked multipliers (useless cause after 4.0GHz we face serious thermal issues)

- They have unlocked voltage (useless cause there is no way to control voltage on these machines)

The cons:

- Their voltage can go over 1.2109V (limitation found on the 37x0QM possibly applies on 38X0QM) and this way XMs have higher voltage for higher frequencies resulting in more heat - throttling.

- They are more expensive than 38x0QM and even more expensive than the the 37x0QM which seem to be the best value for money.

Check the comparison here to see for yourself that there are minor differences between the two...

I would recommend to save the extra $$$ for your Skylake build or a better GPU...

I was about to grab an 3920XM myself but followed Tech Inferno Fan 's advice here, grabbed an i7-3720QM and have no regrets. My 3720QM runs @ 3.98GHz-4C turbo and is enough for my needs. I know that an XM chip WON'T have better performance cause throttling will kick in earlier due to thermal reasons. (Keep in mind with 300$ you could grab two 3720QM ;))

Share this post


Link to post
Share on other sites

For some reason, i was in the belief that unlike SB, in the IB generation only the XM models have 8M (and believe me, +33% cache counts), but You're right, and the 38X0QM chips also have the increased amount. I have no intentions in buying an XM now. Yes i've already read through this whole thread before even buying the machine, and know that the heat will be the limiting factor not the chip's maximum freq. By the way let me thank again for all the information You and others shared on this forum because without it, i don't think i would have ever think about buying this Dell machine, and so far I really like it.

@R.O.G : the SATA nerfing is also removed starting from BIOS version F.29 ( i.e SATAIII works flawless)

Share this post


Link to post
Share on other sites
For some reason, i was in the belief that unlike SB, in the IB generation only the XM models have 8M (and believe me, +33% cache counts), but You're right, and the 38X0QM chips also have the increased amount. I have no intentions in buying an XM now. Yes i've already read through this whole thread before even buying the machine, and know that the heat will be the limiting factor not the chip's maximum freq. By the way let me thank again for all the information You and others shared on this forum because without it, i don't think i would have ever think about buying this Dell machine, and so far I really like it.

@R.O.G : the SATA nerfing is also removed starting from BIOS version F.29 ( i.e SATAIII works flawless)

You just fired my curiosity... I was under the impression that 8MB wouldn't make a big difference.

Could you specify an example where an i7-3820QM would be faster than the 3740QM? (ark comparison)

Cause the price difference is usually huge...

Share this post


Link to post
Share on other sites

More cache is always better, because it will reduce cache misses. L3 cache is a magnitude faster than the RAM, both latency, and bandwidth wise. Although it has no big impact on average workloads (also regular 3D gaming), L3 cache can have a substantial impact on workstation-like loads, with many simultaneous processes. Switching a process to another core is a very expensive operation, and the L3 cache can make this faster. I.e virtualization/simulation (especially if you are running more virtual machines than the # of cores) or rendering. Of course everything depends on the actual software used. The question is whether this worth the extra $. I was not really aware of the huge price difference between a 37x0 and 38x0 , but i do a lot of virtualization (networking simulation), also multitrack audio editing/rendering.

So the conclusion is that the benefit from larger L3 depends on the workload. This thread has at least one user with a 38x0qm, maybe he can help you if you are curious if the larger L3 does affect the performance of a specific task.

EDIT: Ok i have to learn to use the reply buton... :)

EDIT: Dusty english grammar

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Finally, i reached "adult" status on this board, and now i can post by myself :)

I successfully upgraded the SB i3, to an IB i5-3230M for 15$. Since my HyperX 2133Mhz kit is already migrated to the Dell, the first boot revealed that the memory controller of the i5 cant cope with the PnP (JEDEC) 2133Mhz @CL11. I locked the memory speed down to 1600Mhz CL11 , replacing one of the kingstons with a samsung module, just to be able to check the new CPU is working properly. Yes it does, and a little bit of TSBench revealed that it does outperform my Haswell-ULV on the same clock not only with lower power consumption (15.1W thanks to the Haswells IVR and integrated PCH VS 10.9W) but a 32M TSBench completes almost a second faster. The Haswell system has a very lean w8.1 x64 install, and the Ivy has a bloated w7 x64. (no throttling occurs, both cpus are running @2.4Ghz during the whole bench)

The other thing which makes me very happy that when C-states are disabled in the bios, i can still toggle C1E using Throttlestop for the Battery profile(I was able to do the same on 1st gen. Core i anno, but unable to do it with 4th.gen.), and although it does not enable C3, C6 and C7, but still has a substantial impact in idle power consumption (3.1W vs 7.1W). And the advantages of disabled C states in my usage scenario is huge, so the ~+1W power consumption when idling is a fair trade-off for me.(This i5 idles around 2.5W with all C states enabled, although i have not tinkered with the settings so far to see if this can be reduced)

The next thing on my list is finding the limit of the memory controller, but i'll have to dig into the topic deeper... My kit is a Kingston HX321LS11IB2K2/16, if anybody with the same kit would share their settings that would be great.

UPDATE: Using EFI variables (Thanks timohour for the extract of A16 BIOS), i was able to lock the memory freq. to 1866, so my kit is running in dual channel 1866Mhz 10-11-12-30 CR1. This could be useful for some other folks too, when the automatic freq. configuration makes the system unusable, but one can get into the one-time boot menu (F12 during Dell logo). Unfortunately my machine wont even get to POST when the auto memory frequency configures the sticks to run @ 2133. Also, changing boot mode from Legacy to UEFI when one wants to mangle with EFI vars is unnecessary, because even in Legacy mode there is option to boot into the EFI shell from the USB drive. I guess SecureBoot still has to be disabled, but i will check.

Setting: Memory Frequency, Variable: 0x1E6 {05 A6 12 04 13 04 D1 01 02 00 E6 01 10 10 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00}
0x60BA3 Option: Auto, Value: 0x0 {09 0E BE 02 30 00 00 00 00 00 00 00 00 00}
0x60BB1 Option: 1067, Value: 0x1 {09 0E 14 04 00 00 01 00 00 00 00 00 00 00}
0x60BBF Option: 1333, Value: 0x2 {09 0E 15 04 00 00 02 00 00 00 00 00 00 00}
0x60BCD Option: 1600, Value: 0x3 {09 0E 16 04 00 00 03 00 00 00 00 00 00 00}
0x60BDB Option: 1867, Value: 0x4 {09 0E 17 04 00 00 04 00 00 00 00 00 00 00}
0x60BE9 Option: 2133, Value: 0x5 {09 0E 18 04 00 00 05 00 00 00 00 00 00 00}
0x60BF7 Option: 2400, Value: 0x6 {09 0E 19 04 00 00 06 00 00 00 00 00 00 00}
0x60C05 Option: 2667, Value: 0x7 {09 0E 1A 04 00 00 07 00 00 00 00 00 00 00}

There is another EFI var that for DIMM2 (the top slot) but it does not need to be modified if running dual chanel, because the freq, and timings will be determined by the module with the worst capabilities. I've also noticed that there is something wrong with the values, because this should be only 8 bit, instead of 12 (?!)

Setting: Memory Frequency, Variable: 0x1E7 {05 A6 12 04 13 04 D2 01 02 00 E7 01 10 11 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00}
0x60C3B Option: 1067, Value: 0x42B {09 0E 14 04 00 01 2B 04 00 00 00 00 00 00}
0x60C49 Option: 1333, Value: 0x535 {09 0E 15 04 30 01 35 05 00 00 00 00 00 00}
0x60C57 Option: 1600, Value: 0x640 {09 0E 16 04 00 01 40 06 00 00 00 00 00 00}
0x60C65 Option: 1867, Value: 0x74B {09 0E 17 04 00 01 4B 07 00 00 00 00 00 00}
0x60C73 Option: 2133, Value: 0x855 {09 0E 18 04 00 01 55 08 00 00 00 00 00 00}
0x60C81 Option: 2400, Value: 0x960 {09 0E 19 04 00 01 60 09 00 00 00 00 00 00}
0x60C8F Option: 2667, Value: 0xA75 {09 0E 1A 04 00 01 75 0A 00 00 00 00 00 00}

UPDATE2: I was also able to boot into windows @2133 CL11-12-13(factory) , when manually setting EFI var 0x1EF (Nmode) to 2N instead of auto. Using 2N mode improves stability, but 1N offers the maximum performance. Memory bandwith R/W/C was around 28k/30k/28k Mb/s. Before running a GFX bench to check for iGPU instability, i've restarted the system. Tried to restart, to be exact, because this functionality is lost, but there are some other settings available in the bios at the memory section, so maybe this could work out better than loosening the timings. I will continue to experiment tomorrow, until then i've reverted back to 1866, which is stable with the factory (tight) timings.

  • Thumbs Up 2

Share this post


Link to post
Share on other sites
Nothing

Yes, max 45W, and I don't think is a faulty PSU.

UPDATE: It WAS a faulty PSU. Tried with another: it keeps 4c x39 rock solid for some seconds (until 105°). Yeah for us :)

[ATTACH=CONFIG]16305[/ATTACH]

And now this:

Alluminio Dissipatore Aluminum Heat Sink For Compute Led Power IC Transistor New | eBay

Undervolt by using lower multiplier + BCLK overclock

Consider narrowing Intel's wide overvolting for stability to improve on your seen performance and lower temps.

eg: use 1 lower multiplier (x38) along with a 4.5-5% BCLK (100->105Mhz) overclock using XTU. That would get you just under 4Ghz 4-core.

Though that requires some expertise to pull off: (1) unlocking the flash descriptor using a pinmod (2) preparing a modifed ME FW and flashing it to allow BCLK overclocking. @timohour covers this topic on the opening post.

Share this post


Link to post
Share on other sites
Nothing

Yes, max 45W, and I don't think is a faulty PSU.

UPDATE: It WAS a faulty PSU. Tried with another: it keeps 4c x39 rock solid for some seconds (until 105°). Yeah for us :)

[ATTACH=CONFIG]16305[/ATTACH]

And now this:

Alluminio Dissipatore Aluminum Heat Sink For Compute Led Power IC Transistor New | eBay

Undervolt by using lower multiplier + BCLK overclock

Consider narrowing Intel's wide overvolting for stability to improve on your seen performance and noticably lower temps.

temps/TDP increases exponentially with increased multiplier.

eg: use 1 lower multiplier (x38) along with a 4.5-5% BCLK (100->105Mhz) overclock using XTU. That would get you just under 4Ghz 4-core.

Though that requires some expertise to pull off: (1) unlocking the flash descriptor using a pinmod (2) preparing a modifed ME FW and flashing it to allow BCLK overclocking. @timohour covers this topic on the opening post.

Share this post


Link to post
Share on other sites
Finally, i reached "adult" status on this board, and now i can post by myself :).

I successfully upgraded the SB i3, to an IB i5-3230M for 15$. Since my HyperX 2133Mhz kit is already migrated to the Dell, the first boot revealed that the memory controller of the i5 cant cope with the PnP (JEDEC) 2133Mhz @CL11. I locked the memory speed down to 1600Mhz CL11 , replacing one of the kingstons with a samsung module, just to be able to check the new CPU is working properly. Yes it does, and a little bit of TSBench revealed that it does outperform my Haswell-ULV on the same clock not only with lower power consumption (15.1W thanks to the Haswells IVR and integrated PCH VS 10.9W) but a 32M TSBench completes almost a second faster. The Haswell system has a very lean w8.1 x64 install, and the Ivy has a bloated w7 x64. (no throttling occurs, both cpus are running @2.4Ghz during the whole bench)

The other thing which makes me very happy that when C-states are disabled in the bios, i can still toggle C1E using Throttlestop for the Battery profile(I was able to do the same on 1st gen. Core i anno, but unable to do it with 4th.gen.), and although it does not enable C3, C6 and C7, but still has a substantial impact in idle power consumption (3.1W vs 7.1W). And the advantages of disabled C states in my usage scenario is huge, so the ~+1W power consumption when idling is a fair trade-off for me.(This i5 idles around 2.5W with all C states enabled, although i have not tinkered with the settings so far to see if this can be reduced)......

Nice to see your way through this. Regarding your memory you can adjust a custom profile. If you know your way around tweaking memory there are a bunch of variables that you could try check this post

Mine runs OK @ 12-12-12-36 CR 1T

26IQzQc.png

You could run an AIDA test to confirm but I believe that your CL11 2T is faster than my CL12 1T. A bunch of performace results here.

Could you help me with something? Could you test if your i5-3230M has any unlocked multipliers? It is confirmed that i7-37x0QM and i7-38xQM have 4 unlocked multipliers, meaning that the maximum 4C turbo for an 3720QM is x38 opposed to default x34.

The maximum multiplier on your i5 is x32. Could you use the UEFI variables to set your 1-Core Ratio Limit it something a little over x32 (let's say x33) and check if it has any impact on your maximum multiplier reported with Throttlestop? It would be great if dual core i5-32x0Ms or i5-33x0Ms have some unlocked multipliers. If the same rule applies an i5-3380M would go up to 3.8GHz 2C and 4GHz 1C...

Also, if you have some time. It would be helpful to investigate if we can OC the iGPU on an i5. You can check here how it worked with the i7. I tested with my i3 and it was a no go. Let's find out if it works with the i5s

Undervolt by using lower multiplier + BCLK overclock

Consider narrowing Intel's wide overvolting for stability to improve on your seen performance and lower temps.

eg: use 1 lower multiplier (x38) along with a 4.5-5% BCLK (100->105Mhz) overclock using XTU. That would get you just under 4Ghz 4-core.

Though that requires some expertise to pull off: (1) unlocking the flash descriptor using a pinmod (2) preparing a modifed ME FW and flashing it to allow BCLK overclocking. @timohour covers this topic on the opening post.

Although I think this would work on lower multipliers it seems that on the i7-37x0QM at least once voltage hits 1.21V it won't go higher than that. e.g. on my 3720QM x37 & x38 share the same maximum voltage 1.21V. Even if I set x37 there is no undervolt. I don't know if this is limited by the chip or the laptop. We need someone with another (gaming) laptop designed to host and OC these CPUs to confirm if the maximum voltage for non Extreme chips is 1.21V or it is just another BIOS bug on our Latitudes.

But, it can be used though to raise performance... with x39 it would go up to 4.09GHz ;P

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.