Jump to content
blazejka

E4310 - how to get 16GB ram?

Recommended Posts

Hello,

I have E4310 with 16GB ram - works great under Ubuntu but I need to use Windows 7 from time to time and that isn't working. I loaded modified dsdt to extend the root bridge into 36bit space that I found on this forum (http://forum.techinferno.com/diy-e-gpu-projects/7476-%5Bguide%5D-dsdt-override-fix-error-12-a.html) but Windows is freezing on "loading windows" screen when more that 8GB of ram is installed. Any chance that someone could help me to solve this issue? Is it solvable?

Share this post


Link to post
Share on other sites
Hello,

I have E4310 with 16GB ram - works great under Ubuntu but I need to use Windows 7 from time to time and that isn't working. I loaded modified dsdt to extend the root bridge into 36bit space that I found on this forum (http://forum.techinferno.com/diy-e-gpu-projects/7476-%5Bguide%5D-dsdt-override-fix-error-12-a.html) but Windows is freezing on "loading windows" screen when more that 8GB of ram is installed. Any chance that someone could help me to solve this issue? Is it solvable?

Looks like some E6410 owner's have the same problem: E6410 w/ 16GB ram - General Hardware - Laptop - Dell Community

You could try the BCD "truncatememory" option to limit Windows use of physical memory to identify at what point there is problem with the RAM: https://msdn.microsoft.com/en-us/library/windows/hardware/ff542202%28v=vs.85%29.aspx

If you find where it is, then there is ways of excluding "badmemory" from Windows usage: memory - Running Windows with defective RAM - Super User

memory - Running Windows with defective RAM - Super User

Given Linux can boot with 16GB of RAM you may want to check the dmesg output to see if there are any RAM locations above 8GB that it may remap/exclude to be able to function.

Share this post


Link to post
Share on other sites
In Windows anything above 4096MB results in a blue screen. Here is a output of Ubuntu dmesg (12GB of ram as it's easier for me to remove single 8GB stick). [ 0.000000] Initializing cgroup subsys cpuset [ 0.000000] Initializing cg - Pastebin.com Is there any way to use Ubuntu memory map in Windows ?

You'll have the review the dmesg output with 16GB of RAM installed and adapt the findings below appropriately. What I see with 12GB installed is a reserved RAM space 11.9375GB-12GB. You may try to exclude that using abovementioned settings in Windows and see if that helps.

([ 0.000000] BIOS-e820: [mem 0x00000002fc000000-0x00000002ffffffff] reserved

The address space then ends at 12.4375GB. That would be due to reserved areas in 32-bit having RAM remapped for use in the > 4GB space.

[ 0.000000] BIOS-e820: [mem 0x0000000300000000-0x000000031bffffff] usable

We can see too that Linux is using 11.8GB total:

[ 0.000000] Memory: 12077032K/12376032K available (7383K kernel code, 1145K rwdata, 3408K rodata, 1336K init, 1444K bss, 299000K reserved)

First thing I'd suggest is review my above post and limit Windows to use only 11GB (if have 12GB installed) or 15GB (if have 16GB installed). That then circumventing that reserved area near the end of the memory space. If that works, then increase it up to 11.9375GB (12GB installed) or 15.9375GB (16GB installed).

If you still have blue screens then suggest increase RAM available in Windows by 1GB starting at 5GB to see at what RAM amount Windows gets flakey.

You could also give Win8.1 a go. We are seeing some Lenovo systems with 16GB having sluggish performance with Win7 that's resolved with Win8.1: http://forum.techinferno.com/diy-e-gpu-projects/2109-diy-egpu-experiences-%5Bversion-2-0%5D-468.html#post129319 . Suggests to me that Win7 is not excluding certain problematic ranges as you are seeing.

Share this post


Link to post
Share on other sites

Below given instructions helps you in stop freezing and for RAM increase support check Dell Latitude E4310 Manual:

  • Start the computer
  • Tap 'F8' on the keyboard immediately and every one second until the Dell logo screen disappears. From there you will see the Windows Advanced Options Menu on the screen. (If the Windows Advanced Options Menu does not appear, restart the system and try again.)
  • Select Safe mode with Networking and press Enter
  • Log on as the administrator or as a user with administrative access

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.