Jump to content
Expecto

Throttling issue with 970m

Recommended Posts

So I took the plunge, and bought a 970m. Got it all up and running, but the GPU is throttling in every game I try and run.

Has anyone had this problem and been able to overcome it?

So far I've...

  • Tried a couple of different driver versions (345.20 and 347.88). Neither driver fixed the issue.
  • Flashed with the slv7 vbios. Still the same issue.
  • Reinstalled Windows 8, and tried the drivers again. Still not working.
  • Tried forcing P0 P-State in nVidia Inspector. Nothing happens.

Symptoms

  • Using MSI Afterburner, the GPU load never goes above 50%.
  • nVidia Inspector shows the P-State as P1 whenever I'm in a game, not P0.
  • 3DMark11 score is only ~P4000

Specs

  • Alienware M15x
  • Core i7 920XM (standard clocks)
  • GTX 970M 6GB with slv7 vbios
  • 8GB RAM
  • Windows 8.1 Pro (fresh install)
  • 240W PSU

Can anyone help? I'm completely stumped at this point...

Thanks!

Share this post


Link to post
Share on other sites

It might be due to Windows 8.

Are you sure you don't have another system setting overriding the performance state? Windows 8 has a few extra power management (and other setting) convolutions than Win 7 did.

Do you have CC installed? Do you have AlienFusion active?

Have you monitored the temperature of the GPU while under stress?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By michaelgqld
      Hi everyone. I have had a bit of search around but I have not found anything yet pertaining to my issue. I have an Alienware 17 R1 (Late 2013 model). It originally came with an i7 4900, a GTX780m, 120hz 3D panel with intel graphics disabled. I have just got a Dell GTX980m 8GB (BIOS 84.04.2F.00.79 - Device ID 10DE 13D7-1028 05AE) and put it in and it works fine getting into windows and running 2D. However, when I run any decent 3D the graphics constantly hits power limiter and downclocks to around 800mhz. This is confirmed to be power limit in gpuz perfcap reason and this happens regardless of temperature. Running a Unigine benchmark has actually showed the card's performance to be just lower than the 780m I replaced. Using HWiNFO64 I have found that the GPU is being limited to 80 watts. It briefly goes up to over 100 watts but drops to 80.

      Power Supply is 240 watt

      This laptop always runs off mains power and the battery only lasts a few seconds regardless of apparent charge.

      I should also mention that I have tried,
      Setting nvidia control panel power management mode to prefer maximum performance.
      Disabling Battery Boost in nvidia geforce experience
      Setting windows power options to high performance
      I have even installed a fresh windows 10 on a different hard drive and have observed the same result.

      Has anyone else done this upgrade and had no issues, are there any known fixes, is this card faulty or just not going to work correctly.

      Thanks
    • By Psycha
      Hello, I'm on an alienware m17 r4 and am trying mod my vbios for a 970m 3GB msi. I've managed to get the max boost with an increase in voltage, however I believe my voltage settings maybe unstable. When attempting to load programs capable of high gpu usage capabilities, the gpu begins to become pretty unstable. would anyone be able to provide assistance? I have both my edited and original roms as well.
       
      *update
       
      I'm not sure how to delete this thread but disregard this please. I've figured out the issue.
    • By Night
      My laptop doesn't display when I turn discrete mode it work only on mshybrit mode.I plug hdmı cable to pc it display to tv.Gpu z program show no uefi support on 970m(6gb) but  ıt show on intel hd  630 there is no problem about screen ıt justy problen on vbios ı thınk ı cant fınd on ınternet stock gpu vbios  can anybody help for it or to fix this promblem?
    • By Night
      My laptop doesn't display when I turn discrete mode it work only on mshybrit mode.I plug hdmı cable to pc it display to tv.Gpu z program show no uefi support on 970m(6gb) but  ıt show on intel hd  630 there is no problem about screen ıt justy problen on vbios ı thınk ı cant fınd on ınternet stock gpu vbios  can anybody help for it or to fix this promblem?
    • By true2456
      Hey all, just got my m17xr4 and put my 980m from my m15x (old) in it. I was able to score much higher graphics score in firestrike even though it is a much older machine. I made a custom vbios for the m15x to get rid of any throttling, and am in the process of making on for the m17xr4 but I'm wondering if there is anything else I have missed to deal with the throttling. any help would be appreciated
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.