Jump to content
EwinRacing Flash Series Gaming Chairs
Victolee

GPU not registering

Recommended Posts

Hello all,

For a while now with my lenovo Y580 there has been an issue with many games not reading my GT 660M. When playing games like Divinity Original Sin and Medieval Engineers my integrated graphics card is the only card being read by the games. I've searched the internet for solutions, but no luck. I was wondering if anyone has figured out a solution to this problem?

Share this post


Link to post
Share on other sites

It might be so it's just displaying the GPU incorrectly while still using the 660m- had that thing a while ago with a Radeon GPU. If the game peformance is alright then there's nothing to be worried about..

Share this post


Link to post
Share on other sites

Have you tried to press the Graphics switch button? At least my laptop brings a key to switch between I/D graphics. Also, I have a friend that his computer automatically switches the graphics when they are demanded.

Share this post


Link to post
Share on other sites

The graphics performance is very poor and yes I have tried to switch the GPU out of game, from the control panel and in game. The only card that is being registered is the internal graphics card.

Share this post


Link to post
Share on other sites

I've had this happen with my wife's optimus-enabled laptop. To fix the problem I needed to go into the global application settings in the NVidia control panel and enable/force dedicated GPU acceleration for all programs, effectively disabling optimus. Otherwise some games/programs just refused to switch to the discrete GPU. This was pretty annoying considering that optimus support was one of the reasons why we picked this particular laptop.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

First of all try instal Lenovo Energy Managment and change powet state to Dynamic graphics in it. Then go to nvidia panel and set High Performance for application you want. Remember that the exe you open can be not this one runing as app you see. For example you can have launcher.exe and game.exe, so set high performance in nv control panel for game.exe.

Share this post


Link to post
Share on other sites

Try the nvidia control panel and try the power options advanced options menu. I seem to remember something about integrated vs dedicated graphics in there.

Share this post


Link to post
Share on other sites

Check out Nvida Control panel as sup3er_b0wlz said, there you can select any program and set it for it to use your graphics card instead of the integrated one

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.