Jump to content
EwinRacing Flash Series Gaming Chairs
Ephemerality

Switchable Graphics Not Working (660M/HD4000)

Recommended Posts

Hi,

I have been having issues getting the switchable graphics on my R4 to work as expected. It has not worked for a while so I have just been using the discrete card only, but I would like to figure out what is going on.

I have the i7 3610QM (HD Graphics 4000) and a GTX 660M discrete card.

Everything works fine if I leave the internal disabled and only use the 660. When I enable the switchable graphics, everything is rendered with the internal card and the 660 does not seem to be used at all. The driver is installed and updated and the 660 is selected in the NVIDIA Control Panel, but HWInfo64 shows the card with no other data being reported for it. NvStateViewer shows the state as off.

I am unsure as to whether this will help or not, but this is what shows up in the Physx configuration page:

post-33611-14494999586535_thumb.png

Versus when only the 660 is enabled:

post-33611-14494999586675_thumb.png

Dell had replaced my motherboard and the graphics card a couple years ago for issues with graphical artifacts, but I can't recall if the switchable graphics had stopped working at that point or sometime after (I realize I probably should have looked into it and gotten Dell to deal with it back then but it's a bit late for that now).

I had been running BIOS A12 but recently flashed A11 unlocked.

I also just reinstalled Windows with the factory Alienware image and installed the recommended graphics driver from the Dell site, no change.

Any ideas? Any further information that might help?

Thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By gwstier
      (Watchdogs runs very smoothly if you wanted to know)
      I finally got my eGPU working on my Acer Aspire V3 - 517G. All credits goes to @Tech Inferno Fan for providing the DIY setup and helping me out with some problems.
      System configuration
      Acer Aspire V3 - 517G
      Intel core i7 - 3632QM @ 2.2GHz (with Turboboost up to 3.2GHz)
      8GB RAM (I added 4 GB)
      iGPU : Intel HD 4000
      dGPU : Nvidia Geforce 710m (2GB dedicated VRAM)
      Windows 8.1 / 64 bit
      eGPU
      AMD R7 260X ASUS Directcu II OC (1GB)
      500w PSU (has a 115W TDP any ATX PSU can drive it)
      PE4L 2.1b
      DIY eGPU Setup 1.3 software
      Setup
      If you own the exact laptop then you don't have to worry about the TOLUD value (it is 2.5 GB = no "error 12"). But there is a poblem (I had the problem) when you want to install the Setup 1.3 Software (you need it to deactivate the dGPU).
      Your Hard Drive must be in MBR NOT in UEFI/GPT. You will face the problem right after you installed Setup 1.3 Software and executed it. There are different ways to solve it. I solved the problem by changing my Hard Drive to MBR with a program called "AOMEI Partition Assistant".
      But after I booted my laptop there was no OS found. If you did it like me just press any F[Number] button (I can't remember which button it was) next to the "Escape" button. It will show you the BIOS and the only thing you have to do is changing from UEFI boot to the normal boot (you can now select Windows 8.1 or Setup 1.3).
      Like I just said there are many ways to solve the problem. One easy method is (I am not sure if this works) to do a fresh Windows 8 install.

      After you finished installing Setup 1.3 turn off your System / Laptop.
      Connect the eGPU (disconnect the WLAN card) which is connected with PE4L 2.1b and with the external monitor.
      Turn on your ATX PSU which is connected to the PE4L 2.1b AND to the eGPU.
      Turn on your Laptop and in the booting screen go to the Setup 1.3 (if you installed Setup 1.3 properly there will be a selection between Windows 8.1 and Setup 1.3).
      In Setup 1.3 select the "menu - based..." and then it will detect your eGPU automatically.
      Go to Video Cards and select your dGPU (Geforce 710m) and make sure it says in brackets "off" (like this : "dGPU: Nvidia 710m[OFF]").
      Go to Chainload selection and select test run.
      It will take you back to the booting screen where you can choose either to boot in Windows 8.1 or Setup 1.3 . Select Windows 8.1 .
      When you go to the Device Manager you will notice no "Nvidia Geforce 710m". Instead a new device called "VGA Adapter" or something.
      Put the CD (the one it was in the box with the GPU) into the Laptop to install the new driver.
      Wait till the Setup is finished and reboot! (Don't forget to go to Setup 1.3 and deactivate the dGPU every time and boot into chainload!)
      Questions and Troubleshootings
      Q: How is the performance with an AMD GPU? The performance is surprisingly better than expected.
      Q: I got a problem with the AOMEI program you used! Don't forget to click "apply" button left upper corner. Then change your boot mode.
      Q: The Setup 1.3 can't find my eGPU! (THAT was MY problem)
      - There are different ways to do it (it is also for those who do not have the exact same Laptop) :
      - Search in the Forum for "Anti - Whitelisting of the WLAN Card" because it may be possible that the card is whitelisted and it won't detect your eGPU (almost all Acer Laptop have a whitelisted card but mine wasn't whitelisted).
      - Try "hot plugging"
      - Try switching or "correcting" the switches on the PE4L 2.1b (there are tiny switches called SW1 (it should be on 1 - 2) and SW2 (this should be in 2 - 3) ).
      - Check that everything is connected to each other (for example, check if the ATX PSU is connected to the GPU as well)
      - The fans of the eGPU is working the ATX PSU is powering everything alright, I checked the connection twice, but for some reason my eGPU can still not be detected!
      - Go and check if your GPU is defect. I checked my GPU at my friends' Desktop PC and it could not be found either. It IS a rare case because the chances are pretty low that you buy a defect GPU or that the GPU dies fast.
      Tip : Go or contact the person you bought the GPU from. I got a refund and could get a new one.
      - I checked the GPU and it could be detected on a Desktop PC but it can't still be detected on my PE4L?
      - Now it can be anything. Your PE4L, or the ATX PSU, or etc... You would have to test everything out till you get the defect hardware.
      Benchmarks
      I've forgot to do a benchmark. I will update this post as soon as possible with a benchmark.
      Acknowledgements
      Thank you to all the others so I could do researches and solve my problem as soon as possible. And espescially, thank you @Tech Inferno Fan by helping me and keeping in touch by mailing! And also sorry for my bad english / mistakes. I am a Korean who lives in Germany


    • By AngieAndretti
      Hello. I've been tinkering with this issue for a couple months now, and wondering if anyone can shed some light or help think of something I have not.
      Purchased new M17x R4 from Dell, roughly 3 months ago. Unit has i7 3740 CPU and AMD 7970m GPU. I Added 240GB Mushkin SSD for boot and slaved the original 750GB drive into the secondary bay for data. Upgraded original 1600MHz RAM to 16GB (4x4GB) of Kingston's HyperX 2133MHz DDR3. The 2133MHz RAM does run - and passes all stress/performance tests with flying colors but is generally "finicky" at POST. Laptop likes to come on for a few seconds and then shut back off until a successful POST happens after a few tires. Once it's worked once, it works fine from then on - until you change something related to hardware configuration/settings. I read the wiki page for modern BIOS POST process and I'm thinking this "working fine once it's worked" behavior could be due to BIOS building a "hardware table" that it can then just read from instead of enumerating and detecting everything from scratch - until something changes.
      I have verified to my own satisfaction that it's not defective RAM. I purchased some extra sticks and observed same behavior with only new sticks installed.
      Another note - the 2133MHz RAM will function without this issue if forced into 1866MHz mode in BIOS (but I don't want to do that unless I absolutely have to.)
      Now, for most purposes, it's fine to just leave everything as-is and once I've tried a few power-ups and gotten a successful POST (sometimes it even works the first time after tinkering) all is well. The one place it's an issue is with manual graphics switching. I have the AMD 7970m card with Enduro (which sucks for certain games unless Enduro is disabled.) I don't want to leave the laptop in exclusive dGPU mode all the time because I do use it on battery at times and the discrete mode cuts battery life nearly 50%... so I switch modes with the Fn+F7 and reboot method when I want to play certain games. This causes a full reset and the failing at POST behavior is observed when the unit tries to power back on (in discrete or switchable mode - it's the ACT of switching that's the issue.)
      Final note - I use svl7's modified A10 BIOS (have verified same behavior with stock BIOS versions A05 and A10) so I have a lot of available options I can tinker with. Here are the things I've found that INCREASE stability (lessen the chances of the failure at POST, or the number of times it will repeat:)

      Reduce power limits on the CPU in the Performance menu (this helps but even at lowest stock settings, does not quite alleviate 100%)
      In advanced CPU power options menu, change boot performance mode from "Max Performance" to "Max Battery."
      In advanced CPU power options menu, apply a current limit setting of 160 (20 amps) to 2nd plane current limit (integrated GPU.)

      The fact that these things make an impact suggests that available power at time of POST may be a component of the problem. I do own 2x 240w PSU's and same behavior is observed with both, as is on battery. I wonder if the issue could have to do with the 7970m card not supporting power gating? I have observed that if I hang out in BIOS for a while, the 7970 card gets extremely hot - so it's definitely sucking back the juice at boot time! Once I exit and Windows begins to load, the GPU fan will then spin up fast for a few seconds to cool the chip. It runs cool then-on unless under stress.
      Adding voltage to the RAM (1.55v vs. the standard 1.5v) DOES NOT help, and in fact decreases stability.
      If anyone has any thoughts or suggestions, I'd much appreciate!
      -Adieu,
      Angie.
    • By Brian
      Aurora-R1Aurora-R2
      Aurora-R3
      Area-51
      M11x-R1
      M11x-R2
      M11x-R3
      M14x
      M15x
      M17x-R1
      M17x-R2
      M17x-R3
      M18x

      http://forum.techinferno.com/alienware/1877-alienware-engineering-troubleshooting-guides.html
      http://forum.techinferno.com/alienware/1879-how-reduce-shutdown-timeouts.html
      http://forum.techinferno.com/alienware/1919-how-get-back-alienware-software-after-windows-reinstallation.html
      http://forum.techinferno.com/alienware/1908-check-status-your-order-part-replacement-depot-status.html
      http://forum.techinferno.com/alienware/1907-alienware-recommended-diagnostic-tools.html
      http://forum.techinferno.com/alienware/1900-alienware-no-sound-troubleshooting.html
      http://forum.techinferno.com/alienware/1890-alienware-no-boot.html
      http://forum.techinferno.com/alienware/1869-macro-keys-3-keys-combo.html

      Callouts!!
      Alienware Gaming Tips for Gaming
      Looking for drivers and updates for your Alienware System
      M18x computer with AMD HD6990m Video Cards shutting down or fans not spinning
      M18x A05 Bios Released. This BIOS solves the issue of AMD Radeon HD6990 GPU2 fan not spinning up after a cold boot.
      M18x Intel Wireless Card 6300 not connecting at Full Speed
      M18x AMD Video Card not scaling when using full screen benchmarks and gamesBattlefield 3 crashes when using an overclocked Nvidia Video Card
      Battlefield 3 & Rage: Textures issues and Low FPS
      Alienware System displays the error message: “Display driver ATIKMDAG.sys stopped responding and has recovered”
      How to Set Up Wireless HD in your Alienware computer
      Nvidia Optimus Technology Summary
      Dell WWAN Wireless not detected?
      iTunes & Bigfoot Killer Wireless-N 1102 and 1103 Wireless Card compatibility issues
      nVidia Notebook BETA Driver (NV) Release Date: 10/31/2011
      M14X Webcam Flickering/ Blue Line
      M11x-R1 & R2 LCD Broken Hinges
      What is Alienware Respawn?
      How to restore your computer to factory conditions using Alienware Respawn?
      What is AlienContact?
      Youtube Product Support Videos
      Alienware Arena
      McAfee Expiration Date Issue
      Dell/Alienware Enhanced Diagnostics (ePSA)


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.