Jump to content
EwinRacing Flash Series Gaming Chairs
Selenium

P170EM - Upgrading the GPU

Recommended Posts

I've been wondering lately whether this would be a good idea or not.

I'm not quite knowledgeable enough however to determine what the best GPU is compatibile with my machine. Forgive me for not knowing where to look! :P

So I'm asking here. I currently have an Nvidia GTX 675MX. And it's not bad, honestly. But I'm just wondering if there's another I could aim for later this year that'd be a significant upgrade.

Share this post


Link to post
Share on other sites

Cheers.

And I gather anything 6 or 9 that has an M at the end of it, yeah? :P

I'll have to take a close look at the price and power of them.

Share this post


Link to post
Share on other sites
I've been wondering lately whether this would be a good idea or not.

I'm not quite knowledgeable enough however to determine what the best GPU is compatibile with my machine. Forgive me for not knowing where to look! :P

So I'm asking here. I currently have an Nvidia GTX 675MX. And it's not bad, honestly. But I'm just wondering if there's another I could aim for later this year that'd be a significant upgrade.

Depends how much later this year. Right now only 6xxm and AMD 7970m work with no problems, while 7xxm 8xxm do not work at all, the 9xxm require a modded driver and the 980m can only work at 970m speed, however Prema is working on a mod that will make 7xxm, 8xxm and 9xxm work at full potential with standard drivers, so if you are willing to wait long enough you could go with any of the aforementioned cards, though no one knows how long you'd have to wait as there were no news of progress since ~2 months.

Anyways, as it is, if you don't want to get your hands dirty 680m and 7970m are your only options, while 970m offers the best performance out of all cards that work.

Share this post


Link to post
Share on other sites

Currently in no hurry due to lack of funds anyway. :P But that sounds promising.

I'll keep my eye on the 970m for the moment then, but also check on Prema's mods for progress at times.

Cheers.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By TechDrago
      Hi,
       
      I am having some heat issues with the GTX 680m I installed on my Alienware M17x R2 (yes, its old).  Having installed and ran HWiNFO64, it appears that the maximum rpm of the GPU fan is 2560rpm, even when the GPU reached a maximum of 93° Celsius.  The rpm seems low, but what is the maximum rpm of the fan, does anyone have any ideas?
       
      Thanks
       
    • By Edrc
      Hello,
       
      I am new on this forum, so I am sorry if posting at the wrong place. It's been 2 weeks that I am searching how to make my GTX 980M 8GB working Inside my Alienware 17 R1 (June 2014, i7 4710MQ, 60 Herts Display, OPTIMUS and the GTX 880M Inside died.)
      After "quickly" looking some forums, I saw that a 980M would easily fit Inside … but maybe I was wrong.
       
      Hardware wasn't a problem. I've also could install drivers by modding the nvdmi or nvcvi. inf files. The card was recognied BUT :
      the clock speed is locked a 135 or 405 Mherts and fan is not runing when booted up.
      I tried to flash vBios with nvflash and some ROM I found on vBios collection … but no way to get this working properly.
       
      So, i'm coming here. I've seen many people talking about Prema or svl7 or other big boss in the place … but ? how ? where ? when ?
       
      Inside the peripherial manager I have this in remote acces path : PCI\VEN_10DE&DEV_1617&SUBSYS_05AA1028&REV_A1\4&D590A51&0&0008
      So I assume my GTX 980M card ID is 1617 and vendor and PC Model are 05AA 1028.
      But near the "Standard Microsoft Video Card" there is a yellow exclamation point and Inside details it says "this peripherial doesn't work properly" when no Nvidia drivers installed.
      I could find some vBios with 1617 (Asus) but black screen at boot up. Since laptop model where not the same .. probably.
      And I wasn't able to find 1617 with the existing 05AA 1028 … as the GTX 980M was not an option for my model. (AW 17 R1 2014 ,60Herts)
      I tried 353.60, 382.33 and 419.35 drivers. The latest one seems easier to install but longer.
       
      BIOS is A16 from Dell. And I am using Windows 10. Got a Dell 330W brick. 
       
      I saw a guy with the exact model as me, he gets a modded vBios especially for his configuration, then everything worked easily … but can't find the topic again
       
      I guess depending on the card info and the laptop model … a dedicated vBios is required … 
       
      So, If anyone here got some informations or any kind of help for me, it would be very nice.
       
      Thanks for reading and help.  
       
      PS: there are a lot of files, pictures and links that I can't see on this forum .. even after registration …. 
       
    • By captcavy
      Hello everyone,, I need your expertise, I have a m17 r4, (2012) unlocked A15 bios thanks to Klem, it has a Gtx 675m in it now, 
      I would like to know the best GPU to upgrade to without losing a lot of the factory functions of the alienware laptop, like being able to use both VGA functions such as intel 4000, and the factory bios for the cooling of the GPU, I don't want to solely rely on the nvidia
      As a full dedicated GPU, let me know what VGA card to get and what vbios to use, I will gladly donate beer to you for your help, or point me to a member on this forum who can help me,
      Thanks, Shelby,  Aka captcavy
    • By yoshomiamoto
      Hello Fellow Tech Gurus!

      I am having a huge headache after upgrading the ram memory of my m17x r3. 

      First let me start by saying I have been experiencing issues with my current ram setup recently, and so i decided to replace the ram inside of my computer, thinking they had gone out on me. It originally came with x4 2gb memory sticks, and as I started to experience issue, I started to removed them, and I was down to 1 2gb stick. It seems to me ram slots 1 & 2 are not working properly as when I put ram memory into them I would get BSOD in 5-10 mins of computer usage after boot. So I am thinking the slots have gone out. I also tested each slot individually and still same effect.

      So I went on the try out slots 3 & 4 under the keyboard, which seems to work just fine when I use only 1 ram chip in one or the other. But the problem occurs when I try and fill both ram slots in slots 3 & 4 under the keyboard with crucial 2x 8 gb of ram sticks, which total to 16gb total ram memory.

      BSOD and freezing occurs like crazy. But if I use just one of the ram sticks in either slot, no problem.

      I dunno if this is hardware or software. I am think that my motherboard is on its way out the door, but any suggestions you all have would be great. I have already clean installed win 7, and is currently running bios A10 (unlocked, I believe)

      I would also like to note that my motherboards internal vga is not detected, and just noticed this a few days ago upon trying to figure out the ram situation.

      other issues is my laptop battery is pretty much dead, and the only for my computer to cut on is if the AC adapter is connected

      I would also like to know can 1x 16gb 1600 ram stick run in my computer? or is it not supported by my motherboard? 

      thanks!

      Specs:

      Alienware M17xR3 (2011 3D FHD ed)

      Service Tag:
      30W75Q1

      Bios ver:
      A10 (should be unlocked)


      Operating System
      Microsoft Windows 7 Home Premium (64-bit)

      Processor
      Intel® Core™ i7-2960XM CPU @ 2.70GHz

      Chipset
      Intel® 6 Series/C200 Series Chipset Family

      Graphics
      Nvidia GTX 680m

      Audio
      IDT High Definition Audio CODEC
      High Definition Audio Device

      Networking and I/O
      DW1501 Wireless-N WLAN Half-Mini Card
      Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20)
      HMA TAP-Windows Adapter V9

      Memory
      Crucial 8 GB (x2 qty) DDR3 PC3-12800 • CL=11 • Unbuffered • NON-ECC • DDR3-1600 • 1.35V • 1024Meg x 64 •

      (these only work under bay 3 or 4, but not dual 8gb at the same time, otherwise BSOD)

      Configuration ID:
      CT3283724

      Storage
      WDC WDBNCE5000PNC SSD (installed into bay 0)
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.