Jump to content
rupek1995

Y510p with a single 755m and i5... pisspoor performance in some games?

Recommended Posts

Hi, I have a y510p laptop, with i5 cpu and a single 755m gt gpu. I am wondering - why some games have so poor performance even on lowest settings? I have done a clean install of GPU drivers today but it didn't help at all. I tried playing Battlefield 4, but I get about 20FPS on LOWEST POSSIBLE SETTINGS. Meanwhile, on Battlefield 3, or Max Payne 3, I can max out the game and have about 40-60FPS without a problem. I also had this problem with GTA 4, it's just weird that gta barely works, meanwhile a game on an updated engine works flawlessly on MAX settings with about 60FPS.

I am playing while on high performance mode, and I tried to change nvidia settings to my NVIDIA GPU only, and changing power plan to MAX performance.

Am I the only one who has this problem?

Share this post


Link to post
Share on other sites

I am using throttlestop, I tried turning down the settings to medium - no luck, even in singleplayer. I got about 80c on CPU and 76C on GPU after playing single for a couple minutes, and it never jumped past the 20-25fps mark, even on lowest settings.

Share this post


Link to post
Share on other sites

What are your CPU and GPU clock speeds and usage while playing? Monitor them in real-time using an OSD such as RTSS.

Share this post


Link to post
Share on other sites

The CPU doesn't even hit 70C, and same goes for GPU when playing BF4. It goes up to 85-87C (CPU) when playing Max Payne 3 on Max settings after playing for about an hour or two

Share this post


Link to post
Share on other sites

some games are more cpu intensive and some gpu intensive, and both cpu and gpu share same heatsink, so it can happen that something overheats and performance drops, also if i remember correctly when i played gta4 on pc around the time it came out for pc you had to change some game settings, there was a fix that disabled some shadows in the game which used to eat up alot of cpu and thats why the frames were low, try to google the fix

Share this post


Link to post
Share on other sites

Hello, Did you try ugrading to the latest NVIDIA drivers? I believe there was a driver update that fixed the issue recently. Use the GeForce Experience program, go to the games tab, and modify the quality settings from there. You may need to set the directory where the game is running from. Then the NVIDIA app will auto select the best graphics option for you. I recommend going into the nvidia control panel and set the 3d setting to "let the 3d application decide"

Share this post


Link to post
Share on other sites

What is the size of the RAM in your laptop? I'm asking this because the recommended memory is 8 gb for the Battlefield 4 .

GTA IV is a very poor optimized port from console, everybody complains about the low fps. At least you can try the 1.0.4 patch or the latest 1.0.7 it will help a little bit but not that much.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By PrecastFlame
      Hi, I'm having problems trying to connect a GTX 750 Ti to my Lenovo T420 using the dock EXP GDC Beast (express card version).
      My laptop: Lenovo T420
      RAM: 8GB DDR3
      CPU: Intel Core i5 2520M
      GPU: Intel HD Graphics 3000
       
      My problem is: if I plug the express card and I turn on the laptop it doesn't boot up and the screen becomes horrible, with coloured pixels and a sound like "bip-bip".
      If I try plugging the express card when the laptop is already turned on it sees the gpu, but if try installing the drivers I have to apply the modifies restarting the computer.
      I hope you understood my problem (I don't speak English very well).
      Please help me, It's making me crazy!
       
      EDIT: I didn't say that if I plug the express card when the pc is already turned on, in the device menager there is "Error 12" on the gtx 750 ti
    • By Kel
      I got the exp gdc beast 8.5 got all the connections right... laptop boots up... fans turn on the gpu.... device manager detects gtx 1060 with a “ ! “ in a yellow triangle. Now what to do.... i tried to do the bios mod.... but realised that i have 3.07 version. 
      Questions-
      1 is there any way to get this done without the mod?? 
      2 if mod is the only way... kindly help me with step by step instruction in laymans terms... i m not a techy... so i might not understand technical terms.... altho i am interested... but learning yet. Please help. 
    • By Klem
      In this thread you can post your requests for Lenovo Y50-70, Lenovo Y70-70, Lenovo Z50-70, Lenovo Z70-70, Lenovo G50-70, Lenovo G70-70.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, or unlocked vbios for overclock NVIDIA card, then you can post your request in this thread. Also, if you have a problem with fan pulsating/clicking on any modified bios then you can post your request in this thread.
       
      The flashing procedure include two steps:
      1.  Flash main system bios.
      2.  Flash EC firmware.
    • By rusTORK
      When my first CPU fan on Y500 is broke i replaced it on something compatible (non-original) and planned to replace it later on original. Since that time happened a lot things, but i still using that non-original fan. But i did some research and here is what i founded:
       
      I. ORIGINALS
       
      1. Forcecon (marked as FCN on fan)
      DFS5413005MH0T-FC1C (5V - 0.5A)
      Spotted in: Y400, Y500.

       
      2. Asia Vital Components (marked as AVC on fan)
      BNTA0612R5H-P007 (5V - 0.5A)
      Spotted in: Y410p, Y500, Y510p.

       
      3. Sunon (marked as SUNON MagLev on fan)
      MG60120V1-C230-S99 (5V - 2.25W (0.45A))
      Spotted in: Y410p, Y500.

      So, which to choose? Any recomendation? Maybe there also unexpected way (completely diffirent fan from another company for another laptop)?
       
       
    • By Malenford
      Is it possible to unlock bios on that model? Please help me with it if somebody can.
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.