Jump to content
parczefal

[GUIDE] Enabling Intel Iris Pro (HD5200) in Win8.1 on 15" Macbook Pro with GT750M

Recommended Posts

@juniordiscart Good evening, I have followed your instructions on my 2014 MBPR gt750m and have installed reFIND with apple_set_os.efi. I am having difficulties on the final step however and was wondering if you might be able to help? 


When I run the 'integrated.bat' or 'dedicated.bat' I get the response:


C:\Users\Tom Bolitho\Desktop\gpu-switch-master\gpu-switch-master\windows>gpu-swi
tch.exe -i
'gpu-switch.exe' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\Tom Bolitho\Desktop\gpu-switch-master\gpu-switch-master\windows>pause
Press any key to continue . . .

 

When I then boot in via reFIND and boot windows the integrated card is not active. 

 

If I click 'apple_set_os.efi' prior to booting the 'EFI Windows' partition ( or the other windows partition shown in the reFIND boot menu ) it goes to a black screen and no intel hd drivers appear to install or update. Is there something else I am missing ?

 

Many thanks for any response

Share this post


Link to post
Share on other sites

Can anyone confirm that your battery life gets extended using this method of switching to integrated gpu?

For my understanding when switched to integrated gpu dedicated is still using power even if I disabling it in Device Manager.

 

mmc_2016-02-28_14-51-24.png.f00ae7beb250

 

After I switched to integrated gpu the battery indicator saying that I have 1h and 40 min of battery life on 100% charged battery which is same amount of battery life I had being on dedicated gpu. I went to Device Manager and disabled the dedicated gpu. But battery indicator still showing that I had about 1.5 hours battery life so then dedicated is still using power even if it is disabled.

 

Also with integrated  gpu I have an issue that I cant change the screen brightness. I tried different fixes:

  • rollback intel driver
  • uninstall intel driver
  • disabling adaptive brightness in Power Advanced Settings
  • disabling-enabling Generic PnP monitor
  • disabling Service Monitoring service
  • rebooting after each change

 

Nothing helped. However when I switched back to dedicated gpu and restarted PC the screen brightness working the way it was working before but then when I switched back to integrated  gpu still have such issue. Any thoughts?

Edited by Ltvn

Share this post


Link to post
Share on other sites
On 1/26/2016 at 9:58 AM, maarten said:
On 2/27/2016 at 6:45 PM, Ltvn said:

Can anyone confirm that your battery life gets extended using this method of switching to integrated gpu?

For my understanding when switched to integrated gpu dedicated is still using power even if I disabling it in Device Manager.

 

mmc_2016-02-28_14-51-24.png.f00ae7beb250

 

After I switched to integrated gpu the battery indicator saying that I have 1h and 40 min of battery life on 100% charged battery which is same amount of battery life I had being on dedicated gpu. I went to Device Manager and disabled the dedicated gpu. But battery indicator still showing that I had about 1.5 hours battery life so then dedicated is still using power even if it is disabled.

 

Also with integrated  gpu I have an issue that I cant change the screen brightness. I tried different fixes:

  • rollback intel driver
  • uninstall intel driver
  • disabling adaptive brightness in Power Advanced Settings
  • disabling-enabling Generic PnP monitor
  • disabling Service Monitoring service
  • rebooting after each change

 

Nothing helped. However when I switched back to dedicated gpu and restarted PC the screen brightness working the way it was working before but then when I switched back to integrated  gpu still have such issue. Any thoughts?

 

I have exactly the same issue in Windows 10 with the screen brightness on my Macbook pro with Iris Pro and 750M. When I switch to integrated graphics, I cannot adjust the screen brightness. No solution has worked for me thus far.

 

I don't know about extending the battery life.. In theory it should I guess, but since we are working with "DIY" solutions here, there might be some bug that makes the dedicated GPU use power regardless of being disabled. Since these solutions are not officially supported.. there might be some problems there.

 

Share this post


Link to post
Share on other sites

Copied from my build thread (MacBookPro11,3 / 750m / Thunder2 + GTX 980)

 

My full boot/setup process for mobile gaming via Optimus, coming from normal eGPU usage with external monitor is as follows:

  1. Leave eGPU unplugged
  2. Boot into Windows
  3. Disable the 750m in Device Manager (I usually leave it enabled when booting Windows normally)
  4. Run the switch-GPU script to set the iGPU as primary
  5. Shut down Windows
  6. Plug in eGPU and start the computer
  7. Select apple_set_os (I've renamed this to "iGPU Enabler", the far right icon in rEFInd)
  8. Boot Windows

You'll need to install the rEFInd boot manager, the apple_set_os EFI app, and the switch-gpu Windows utility.

 

To "get out of Optimus mode", you need to run gpu-switch to set the dGPU as primary, re-enable the dGPU in Device Manager, and then reboot without running apple_set_os first.

 

Keep in mind that there's a bug with the Intel drivers in Windows 10, and once you've got Optimus up and running, you have to hibernate the system and then power it back on again (without unplugging anything) to get the driver to stop burning 10% CPU constantly. After that, it's ready to go.

Edited by P-Mac

Share this post


Link to post
Share on other sites
4 hours ago, P-Mac said:

Copied from my build thread (MacBookPro11,3 / 750m / Thunder2 + GTX 980)

 

My full boot/setup process for mobile gaming via Optimus, coming from normal eGPU usage with external monitor is as follows:

  1. Leave eGPU unplugged
  2. Boot into Windows
  3. Disable the 750m in Device Manager (I usually leave it enabled when booting Windows normally)
  4. Run the switch-GPU script to set the iGPU as primary
  5. Shut down Windows
  6. Plug in eGPU and start the computer
  7. Select apple_set_os (I've renamed this to "iGPU Enabler", the far right icon in rEFInd)
  8. Boot Windows

You'll need to install the rEFInd boot manager, the apple_set_os EFI app, and the switch-gpu Windows utility.

 

To "get out of Optimus mode", you need to run gpu-switch to set the dGPU as primary, re-enable the dGPU in Device Manager, and then reboot without running apple_set_os first.

 

Keep in mind that there's a bug with the Intel drivers in Windows 10, and once you've got Optimus up and running, you have to hibernate the system and then power it back on again (without unplugging anything) to get the driver to stop burning 10% CPU constantly. After that, it's ready to go.

 

These are indeed the steps you supposedly should follow.


However, I myself have a late 2013 macbook pro with 750m, and EVGA GTX 760 External GPU setup, and I have never gotten optimus to work. Not on Windows 8 and neither on Windows 10.

 

I have seen many reports here of people NOT getting it to work, and very few of people that have gotten it to work (you may be only the 3rd person I've seen reporting getting it to work).

 

So.,, you might be lucky, but chances are it won't work. So be warned!

Share this post


Link to post
Share on other sites
7 hours ago, maarten said:

I have seen many reports here of people NOT getting it to work, and very few of people that have gotten it to work (you may be only the 3rd person I've seen reporting getting it to work).

 

So.,, you might be lucky, but chances are it won't work. So be warned!

 

You're right, I was honestly surprised when I got it to work. I actually found the solution on an unrelated reddit thread where they were trying to figure out how to switch to the iGPU for battery savings as opposed to running Optimus. I just figured, if the Iris-only guys can run Optimus, and I can boot up with the Iris as my primary internal GPU, then...why not give it a try?

 

It's so weird that it doesn't work for you considering our Macs have the same exact internal GPU configuration. 

 

What happens when you try to boot Windows with the Iris as primary and eGPU connected?

Edited by P-Mac

Share this post


Link to post
Share on other sites

Hey everyone! I'm really new to all this, so I got the Akitio thunder2 with the 950 gtx, but I can't get it to work on the Retina display, external display no problem! 

 

Can an someone give me step by step help to do the internal display? Pleaseeeeee

Share this post


Link to post
Share on other sites
5 hours ago, jay.cella said:

Hey everyone! I'm really new to all this, so I got the Akitio thunder2 with the 950 gtx, but I can't get it to work on the Retina display, external display no problem! 

 

Can an someone give me step by step help to do the internal display? Pleaseeeeee

Nobody can give you step by step help because you can't use your eGPU for anything other than rendering and that stuff on your internal display in OS X. It's only possible in Windows. You will have to stick with the external display.

Share this post


Link to post
Share on other sites
19 hours ago, Morv said:

Nobody can give you step by step help because you can't use your eGPU for anything other than rendering and that stuff on your internal display in OS X. It's only possible in Windows. You will have to stick with the external display.

I have bootcamped Windows 10 though! I forgot to specify that, sorry!

Share this post


Link to post
Share on other sites
6 hours ago, jay.cella said:

I have bootcamped Windows 10 though! I forgot to specify that, sorry!

 

Well then, what type of Macbook do you own? 13", 15"? Which year? With dGPU or without(Intel only), especially this is important to help you. You need to provide better and basic information to receive help.

Share this post


Link to post
Share on other sites
On 25/7/2016 at 6:36 PM, Morv said:

 

Well then, what type of Macbook do you own? 13", 15"? Which year? With dGPU or without(Intel only), especially this is important to help you. You need to provide better and basic information to receive help.

Ok, 15 inch, mid 2014, nvidia 750m included

Share this post


Link to post
Share on other sites

is there any way to power down discrete GPU on Windows (to increase battery life)?

Edited by nmzik

Share this post


Link to post
Share on other sites
On 2015/5/9 at 6:54 AM, eeevan said:

Thanks for the info, you’re right- I removed reFind and installed the Optimus.dmg/grub and it seems to work as expected. The one downside is that I've lost the ability to boot Windows without apple_set_os automatically being applied on every boot.

@ah- I think the black screen issue is caused when the wrong GPU is set as primary. I had this happen when I disabled the 750m in device manager and rebooted with dedicated.bat. I thought I could switch back by setting “Integrated-only” in gfxCardStatus but that didn’t work. The solution was to boot into safe mode, and switch the 750m back on. However, I’m sure the problem is more complex then that.

I've been trying to enable Optimus with an Iris, 750m, and 970 that are visible in device manager after rebooting with gpu-switch's dedicated.bat + patched grub. When all devices are active, device manager puts up an out of resources warning on the second Nvidia GPU. If I then disable the 750m the 970 will become active, but only when outputting to a an external display, I can't change the Optimus settings in nvcpl as with the 750m.

 

I assumed the solution would be to boot with the 750m + Iris, enable Optimus, disable the 750m in device manager, then reboot with the eGPU plugged in. I figured this might trick the system to enable Optimus but unfortunately it causes Windows 8 to freeze (the wheel just stops) during boot. No other combination of settings caused Windows 8 to freeze this way. I tried this both with an external display attached to the eGPU and without, no luck!

 

The only thing I didn't try was to enable Optimus with the 750m+Iris, immediately uninstall the 750m driver in device manager, then reboot with the Iris + eGPU combo.

 

 

Using the similar method I did successfully enter win8.1 with gtx970 available, iris and disabled 750m. But it is still the iris that is rendering the internal screen. The Nvdia preference is not accessible, saying that not having a Nvdia device. The reason that caused the black screen is probably entering win8.1 without running apple set os.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.