Jump to content
EwinRacing Flash Series Gaming Chairs
khanhspiracy

Sager NP9150/Clevo P150EM Nvidia GTX 770M Problem

Recommended Posts

Hi all,

I come to this forum to seek advice on how to fix my poor laptop.

As stated in the title, I have a Sager NP9150/Clevo P150EM.

This laptop originally came with an AMD 7970M but it was faulty and I could never get it to work.

So anyways, the replacement GPU that I was given from the person who sold this laptop to me was an Nvidia GTX 770M.

We installed the GPU and that went fairly smoothly; however, the joy was lost when we got into windows.

The system cannot, for lack of better words, "recognize" the gpu as Nvidia?

It shows up in Device Manager as Microsoft Basic Display Adapter.

In BIOS, it shows VGA: Empty.

It seems like the system knows that something's there, but not what it is.

I've tried the Nvidia drivers from Sager, Clevo, Nvidia themself.

I even tried the first 10 and last 2 drivers from laptopvideo2go to no avail.

I desperately need some advice or suggestions on this.

Thanks!

Share this post


Link to post
Share on other sites

That card does not work properly in a P150EM without a bios mod that Prema is working on. Don't ask him about it. He's asked several times per day and is working on it.

To try to get it to work somewhat, you need to do a .inf mod to install a driver. J95 has a thread on how to do this in the Nvidia driver section. His guide is a bit cryptic, but in summary what you need to do is find the clevo .inf file, which is named something like nvci.inf, and change all 4 digit P150SM codes to the P150EM 4 digit code. You can find this code in the device manager, but I believe it is 5105. This will be required anyway even when Prema releases his mod.

Share this post


Link to post
Share on other sites
Guest

@khanhspiracy that card won't work with stock BIOS even with .inf Mod...

...his will be required anyway even when Prema releases his mod.

nope, no more .inf Mods required with Prema Mod! :)

Share this post


Link to post
Share on other sites
@khanhspiracy that card won't work with stock BIOS even with .inf Mod...

nope, no more .inf Mods with Prema Mod!

How does that work when the .inf does not have the P150EM subsystem code for 700, 800, and 900 series cards? Are you changing the EM subsystem ID in bios to that of an SM series?

Share this post


Link to post
Share on other sites
Guest
How does that work when the .inf does not have the P150EM subsystem code for 700, 800, and 900 series cards? Are you changing the EM subsystem ID in bios to that of an SM series?

Right, Prema does what Prema has to do..ha ha ha :D

Share this post


Link to post
Share on other sites

Hi Prema

I've also purchased a GTX 770M. Please shed me a light on how to make this card work on this laptop. Thank you.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Adomis63
      Hi all. I was wondering if anyone had ever figured out if windows 10 will work with the GTX 770m on the M15x (bios A09). I've found a few forum posts about it and they all end up off topic. Ive tried a few different driver versions but every single one ends up green/pink/white screening when I enable the IDT sound device in device manager and through driver setup. It is stable if I don't have the device enabled. Anyone have any advice?
    • By buduga
      Hello all,
       
      i have two questions...
       
      the first one is:
      i have a clevo p150em with 7970m. My mobo got a short circuit and fried... i replaced the mobo and discover that my processor fried too... replaced it too , but now i cant put my gpu to work, ati 7970m... I pretty sure that the video card fried too but im not 100% sure.... As I changed the motherboard for an equal, the gpu (if not fried) should work normally, right? or Is there something I might be missing?
      bios recognize its a 7970m, 
       
       
      the second question:
      I have a working gtx 260m that was pulled off from a alienware m17x r1... I installed it on clevo. Bios recognizes that there is a nvidia card. But I could not install it on windows. I searched for a driver for gtx 260m compatible with clevo p150em but I found nothing, anyware on the internet. my clevo p150 works with it pluged, not reset as if without a card but i cant install it on windows ... could anyone help?  do I have to do something like flash vbios of the video card? any driver mod suggest ? Or is this card really incompatible with my clevo?
       
       
      Thank you in advance.


    • By Selenium
      I've been wondering lately whether this would be a good idea or not.
      I'm not quite knowledgeable enough however to determine what the best GPU is compatibile with my machine. Forgive me for not knowing where to look!
      So I'm asking here. I currently have an Nvidia GTX 675MX. And it's not bad, honestly. But I'm just wondering if there's another I could aim for later this year that'd be a significant upgrade.
    • By Clearik
      Hello all! I really hope I'm not breaking any rules or anything by doing this, but I have a quick question.
      I'm currently using svl7's 770m inf. file for driver version 320.49 for my Alienware M15x. It works awesomely, and svl7 is a lifesaver, but I've had this particular driver for a good bit over a year now, and I was just wondering if he had maybe released a more up-to-date inf. file for the newer drivers for the 770m for the Alienware M15x.
      I noticed the newer drivers use a inf. file with the name "nvcvi" as opposed to "nvcvn".
      Thanks again everyone for y'all's help!
      P.S. My OS is Windows 7 Home Premium 64x
    • By djdblaster
      Would this combination work? GPU is from AW 17 R5.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.