Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

NVIDIA Maxwell VBIOS mods - 900m series overclocking versions

Recommended Posts

Ok. so here it is:

Original MSI stock vBIOS:

- colours are messed up on the laptop display

- display port, VGA and HDMI are fully working.

- the image is crystal clear on display port and HDMI.

benchmark: http://imagizer.imageshack.com/img905/690/UnOgxG.png (ran on my secondary display)

Nvidia GTX 970m - 'OC edition' rev0

- image on laptop display is messed up even worse

- system will post

- there is no image when I get to Windows unless I boot into safemode

- unable to test HDMI, VGA, DP

- even when placed in the secondary MXM port the card won't start and device manager will show an exclamation mark with code 43.

Prema's 970M Clevo vBIOS mod (https://biosmods.wordpress.com/clevo-mxm/)

- image on laptop display is messed up (worse then on stock, not as bad as with the one in this thread)

- system will post

- you can boot into Windows but now, besides the colour problems you get ghosting and lines

- I didn't test VGA, HDMI and DP, but I think they will work

So, no luck yet. But I think this could be fixed with the proper vBIOS.

My Kepler based 860M is working fine so far in my M17x R2, apart from the fact that when the display is turned off, it actually turns completely white instead of of going dark.

Ok. Now you can try flash this 3 different stock MSI vbios for GTX 980M.

MSI980M.zip

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
Ok. so here it is:

Original MSI stock vBIOS:

- colours are messed up on the laptop display

- display port, VGA and HDMI are fully working.

- the image is crystal clear on display port and HDMI.

benchmark: http://imagizer.imageshack.com/img905/690/UnOgxG.png (ran on my secondary display)

Nvidia GTX 970m - 'OC edition' rev0

- image on laptop display is messed up even worse

- system will post

- there is no image when I get to Windows unless I boot into safemode

- unable to test HDMI, VGA, DP

- even when placed in the secondary MXM port the card won't start and device manager will show an exclamation mark with code 43.

Prema's 970M Clevo vBIOS mod (https://biosmods.wordpress.com/clevo-mxm/)

- image on laptop display is messed up (worse then on stock, not as bad as with the one in this thread)

- system will post

- you can boot into Windows but now, besides the colour problems you get ghosting and lines

- I didn't test VGA, HDMI and DP, but I think they will work

So, no luck yet. But I think this could be fixed with the proper vBIOS.

My Kepler based 860M is working fine so far in my M17x R2, apart from the fact that when the display is turned off, it actually turns completely white instead of of going dark.

I don't think I've ever seen anyone test a Maxwell GPU (eg 980M/970M) in an M17xR2. It's possible that Maxwell just aren't compatible for whatever reason. For instance, Maxwell are not compatible with M17xR3 - won't POST. Maxwell is compatible with the old M15x though. If your system is heavily related to the M15x in terms of when the product was released and the way the BIOS and system is set up, then I think you've got a good chance of getting Maxwell to work in your machine - could just be incompatible though. I'm not convinced a different vBIOS is going to fix it for you. If anything I would think that your BIOS settings and other factors might be more important in getting it to work. For instance, Maxwell in dedicated GPU mode (No Optimus) will only work on M17xR4, A17, and M18xR2 if you have Windows 8, disk GPT partitioned, and within a 'pure' UEFI environment (no legacy boot option selected) - so these Maxwell GPUs can be very specifically incompatible or compatible based on very specific factors and settings. The factors needed to get a Maxwell GPU to work in your M17xR2 might be very specific as well, that's even if it is gonna be compatible - just letting you know what I've learned in case it can help you at all or give you some ideas.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
Ok. Now you can try flash this 3 different stock MSI vbios for GTX 980M.

Ok, here are the results:

first vBIOS

0A

exclamation mark in Windows as secondary MXM card

wrong memory size

when primary it won't post, system won't detect the card

second vBIOS

0B

no exclamation mark as secondary MXM card

when primary it won't post, system won't detect the card

third vBIOS

0C

no exclamation mark as secondary MXM card

when primary it won't post, system won't detect the card

reverted back to original 07 vBIOS

everything works fine except for laptop RGB-led screen

I am pretty sure now you can't use a 980M vBIOS on a 970M.

Currently typing from my secondary dell screen using my GTX 970M.\

I don't think I've ever seen anyone test a Maxwell GPU (eg 980M/970M) in an M17xR2. It's possible that Maxwell just aren't compatible for whatever reason. For instance, Maxwell are not compatible with M17xR3 - won't POST. Maxwell is compatible with the old M15x though. If your system is heavily related to the M15x in terms of when the product was released and the way the BIOS and system is set up.

Yeah, I know, I like to test things and push them beyond their limit. The M17x R2 is similar to the M15x . Hence why the 970M is partially working, only the internal RGB LED screen is not working properly. I am currently playing SC2 on the 970M installed in my M17x R2, just that I using my external monitor. It could be a BIOS fix, it could be a vBIOS fix. With other 970M vBIOS the image was even more messed up on my internal laptop display so I think it is fixable and I am willing to pay to get it fixed.

Share this post


Link to post
Share on other sites
Ok, here are the results:

first vBIOS

0A

exclamation mark in Windows as secondary MXM card

wrong memory size

when primary it won't post, system won't detect the card

second vBIOS

0B

no exclamation mark as secondary MXM card

when primary it won't post, system won't detect the card

third vBIOS

0C

no exclamation mark as secondary MXM card

when primary it won't post, system won't detect the card

reverted back to original 07 vBIOS

everything works fine except for laptop RGB-led screen

I am pretty sure now you can't use a 980M vBIOS on a 970M.

Currently typing from my secondary dell screen using my GTX 970M.\

Oh... I am wrong, forget that you have 970M instead 980M. :)

Ok. Now you can try flash this 4 different stock MSI vbios for GTX 970M

MSI970M.zip

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
Oh... I am wrong, forget that you have 970M instead 980M. :)

Ok. Now you can try flash this 4 different stock MSI vbios for GTX 970M

_1

BIOS 84.04.35.00.15

Image is even more messed up, with ghosting and lines.

Will get into Windows but I have no image unless I boot in SafeMade.

_2

BIOS 84.04.22.00.06

Image is even more messed up, with ghosting and lines.

Will boot into Windows, but it's very hard to make anything out.

After installing the drivers the LED strip stopped working but in the complete darkness of the screen I could tell the colours where no longer messed up, the lines dissapears but there was still some ghosting.

None of the external ports were working.

_3

BIOS 84.04.22.00.07

Same as my stock vBIOS.

Everything works except for the internal RGB led screen having it's colours messed up (there are no lines or ghosting present).

_4

BIOS 84.04.22.00.08

Seems to be the same as my stock vBIOS.

Everything works except for the internal RGB led screen having it's colours messed up (there are no lines or ghosting present).

However, during driver installation, when the screen went on and off, for a split second the colours on the laptop screen actually looked normal... strange.

Share this post


Link to post
Share on other sites

Why the mnvflash closes automatically for me? I just press Enter twice and it closes itself. I'm using win8.1, anyone know why?

Share this post


Link to post
Share on other sites

Hi, mnvflash won't recognize my 980m using nvflash -a command, I'm using win8.1, any help pleash?

Because it's a console program, and must run in command prompt window.

Yeah, I realized that. Thanks for answering my stupid question.

Share this post


Link to post
Share on other sites
Why the mnvflash closes automatically for me? I just press Enter twice and it closes itself. I'm using win8.1, anyone know why?

Because it's a console program, and must run in command prompt window.

Share this post


Link to post
Share on other sites
Because it's a console program, and must run in command prompt window.

Yeah, I realized that. Thanks for answering my stupid question.

Is this mnvflash's command line as same as nvflash? Because when I try to use mnvflash -a/mnvflash -b, the program freezes. Therefore I don't dare to use mnvflash -6, afraid of mess up sth. Anyone have the same problem?

Share this post


Link to post
Share on other sites
Yeah, I realized that. Thanks for answering my stupid question.

Is this mnvflash's command line as same as nvflash? Because when I try to use mnvflash -a/mnvflash -b, the program freezes. Therefore I don't dare to use mnvflash -6, afraid of mess up sth. Anyone have the same problem?

I know you already flashed with different version of nvflash, but that is how you do it the old way:

http://forum.techinferno.com/general-notebook-discussions/8560-nvidia-maxwell-vbios-mods-900m-series-overclocking-versions-37.html#post123356

Share this post


Link to post
Share on other sites

Ive just purchased a p375sm-a with dual 970m's. Are these vbios mods compatible with this clevo model? Is there instructions on how to flash the second card or just the first? (I cannot download yet until i have made 5 posts)

Thanks

Share this post


Link to post
Share on other sites

Hi I have a Alienware 15, 2015 model with Geforce GTX 980m 4gb Graphics. I am looking for an unlocked bios for it . I understand you can get the 8gb version on the first page but cant find one for mine? I have looked all over the web and cant find anything!!! Its driving me nuts!!!

Any help would be great. Ps is the problem because it is soldered to the board?

Share this post


Link to post
Share on other sites

Hy

I am new to overcklocking laptop gpu`s modded vbios etc.

i have the asus rog g751jt-t7093h with the gtx 970m 3gb. I managed to get +135 MHZ on core and +300 MHZ on ram it wont let me do more.

Can someone help me with a modded vbios for this card.

Share this post


Link to post
Share on other sites

btw.. is this bios like prema with a higher voltage (this one did mess my temps way too much) ... is this with standart 1.050 v? prema is 1.062

Share this post


Link to post
Share on other sites
btw.. is this bios like prema with a higher voltage (this one did mess my temps way too much) ... is this with standart 1.050 v? prema is 1.062

Voltage is 1.000 v

Share this post


Link to post
Share on other sites

hello,

i just did download that bios for my GTX 980m (in a msi gt60 2od) ... but there is no way overlocking it ... my driver (newest for windows 10) would always crash .. (TDP error detected )

No matter what voltage or Mhz. Always this problem.':(

anyone knows why? with the perma and stock bios i never saw this error.

Share this post


Link to post
Share on other sites

hey guys. was wondering if you could help me unlock my bios? i have an asus gl 552jx with a nvidia gtx 950m ddr3 in it. i cant make a copy of my bios though, gpu z doesnt allow it. :/

Share this post


Link to post
Share on other sites

So how come nobody has made a 980m vbios with "baked in" overclocks??? Is it not possible to do??? The 980m is capable of so much more than the unlocked rev 0 bios! If we were able to overclock the vbios we wouldn't have to worry about stupid NVIDIA disabling overclocking!!!

Share this post


Link to post
Share on other sites
So how come nobody has made a 980m vbios with "baked in" overclocks??? Is it not possible to do??? The 980m is capable of so much more than the unlocked rev 0 bios! If we were able to overclock the vbios we wouldn't have to worry about stupid NVIDIA disabling overclocking!!!

That is precisely why we have an unlocked vBIOS... NVIDIA have limited OCing but with this vBIOS no such problems..

Sent from my LG-H811 using Tapatalk

Share this post


Link to post
Share on other sites

Hi guys

I read all 60 pages of this forum, very interesting.:83: But I have a few questions. Hope they are not too obvious so please bare with me since I am a noobie on this subject ;)

I have an Asus G751JY with 980m (4 Gb). I understand it has a soldered GPU.

On the other hand most guys here have Clevo/MSI which if I understand well come with a MXM module 980m (8 Gb).

What I don't understand is the following: I was under the impression that in the case of soldered GPU's (like mine), the gpu bios is inside the central bios (not on the GPU). Am I right on this? If so:

1) how can some of the guys with G751 on this forum flash the GPU bios directly to the GPU with nvflash/mvflash?

I thought in the case of Asus (my case) you have to first extract the "vBIOS" from "central bios", then open it with a program like Maxwell tweaker (I tried but seems to not open my vBIOS) or HEX it, then mod it (volt, Mhz) and then put it back in the "central bios" as to have a new modded bios to flash on motherboard.

2) What do people mean when they say "unlocked" bios? Is it like an original dump GPU bios? Or is it an original dumped bios that has been modded to be "unlocked"

I apologise in advance if my questions don't seem not to make sense, I am not native english so I hope I made questions clear enough...

Share this post


Link to post
Share on other sites

Hi Everybody!

Do I need to uninstall nvidia drivers before the flashing process? When I tried to save the backup.rom file the mnvflash showed me a warning saying that I should make sure that the Nvidiai Display Driver is uninstalled. Or disabling it from Device Manger is enough?

Share this post


Link to post
Share on other sites

- - - Updated - - -

Hi Everybody!

Do I need to uninstall nvidia drivers before the flashing process? When I tried to save the backup.rom file the mnvflash showed me a warning saying that I should make sure that the Nvidiai Display Driver is uninstalled. Or disabling it from Device Manger is enough?

disabling is enough

Share this post


Link to post
Share on other sites

Hi Everybody, first of all sorry for my english:torn:

i bought a gtx980m from eurocom website to replace gtx880 in the alienware m17x r5. first of all i don't know why but this card is not recognized by any kind of official driver and i need always to replace the .inf file.

anyway i noticed that whit stock driver and bios was throttling realy often and i decided to flush few vbios just to try. i tried prema, msi , clevo bios but after few minutes without throttling i have tdp error and everything crush. this is happening whit win 10 and 8.1 and whit different kind of driver...

the worst thing is that i lost the stock bios and even whit some msi or clevo stock bios i have this kind of problem but less then custom vbios.

looks like i can overclock ram frequency without any problem but if i touch voltage and gpu frequency goes in error. now i tried to reduce 50 mhz leaving voltage on "-0+. seems to be better but still unstable and i think i will come back to stock frequency. just for information the max reached temperature with more than 1250mhz was 74 c

any suggestion? and please if somebody bought my same gpu can send me the stock bios? i will appreciate

post-38938-14495000725062_thumb.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By mrwayne
      My laptop is Monster Tulpar T7 v2.6. i7 4710MQ, 16 GB DDR3 1600 mHZ, GTX 970M 3GB.
    • By Hax
      I have tried to update nvidia drivers of my notebook ge72vr6rf apache pro. The only drivers that works are the ones provided by the msi. The problem is that they haven't updated those since 2016 and I can't play newer games. 
       
      Some say you need to mod your 1060 drivers, which I have no idea how to some says you need to update the flags in ini files. So please help me
       
      Thanks for your time.
    • By mx90
      Hello, I've got a Dell Precision M4700 with a 3940xm. I've read that in this particular CPU and laptop model, the bios is locked because the stock settings are considered an overclock. As-is, the core temps on the CPU do reach up to 90-100. They seem to spike up and down a bit when benchmarked with Intel's Extreme Tuning Utility, but they certainly do reach over 90C. Is there no way to unlock this bios (version a18, though a19 is released - I haven't updated yet, should I?) and even if there were, would my only option be a heatsink mod on top of that?
       
       
      edit: I've mistakenly posted this under Desktop & General Hardware, perhaps a mod could move or delete the thread? Apologies!
    • By mx90
      Hello, I've got a Quadro M2200 (GPU: GM206GL-A Revision A1, and MxM 3.0a Maxwell card) with the following bios: 84.06.76.00.1C
       
      I've read that this card is very similar to the GTX 965m, but that it has been underclocked considerably. It seems to be a good candidate for unlocking since I hardly see the temperature exceed 70C as-is. I'm requesting help with this - I'm not sure if it's possible to simply flash the vbios from a Dell GTX 965m (MxM 3.0a) or if some type of edit of the card's current vbios would do the trick. I'm hoping someone could help me out with the specifics of doing such an edit if that's the case. 
       
      Thanks!
    • By fibul
      Hello Everyone,
      I am an owner of MSI GT70-20C and my GTX770m gpu i now dead.
      I have a question and i hope someone will help.
       
      I have ordered GTX 970m 6GB DDR5 and i cannot find the exact vBios for that graphic card.
      My current bios version is: E1763IMS.51B
       
      Thanks in advance,
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.