Jump to content
Evo*

[GUIDE] Macbook: enabling Optimus internal LCD mode

Recommended Posts

I mean when I type /Volumes/EFI/EFI/Grub/grub.cfg in osx as it is said it is saying.

How was I supposed to know that you're talking of this?

Type "textedit /Volumes/EFI/EFI/Grub/grub.cfg" without quotes.

Alternatively you can also simply navigate to the mounted EFI partition with Finder. Maybe that's easier for you, you'd only need to double click the file then.

Share this post


Link to post
Share on other sites
How was I supposed to know that you're talking of this?

Type "textedit /Volumes/EFI/EFI/Grub/grub.cfg" without quotes.

Alternatively you can also simply navigate to the mounted EFI partition with Finder. Maybe that's easier for you, you'd only need to double click the file then.

Still when I put in terminal :textedit /Volumes/EFI/EFI/Grub/grub.cfg it is saying command not find and in finder: folder not find

Share this post


Link to post
Share on other sites
Still when I put in terminal :textedit /Volumes/EFI/EFI/Grub/grub.cfg it is saying command not find and in finder: folder not find

Have you mounted the EFI partition again...? Otherwise you surely can't find a thing.

Share this post


Link to post
Share on other sites
Have you mounted the EFI partition again...? Otherwise you surely can't find a thing.

to mounted the fi partition it is this? sudo mount -t msdos /dev/disk0s1 /Volumes/efi

Share this post


Link to post
Share on other sites
to mounted the fi partition it is this? sudo mount -t msdos /dev/disk0s1 /Volumes/efi

Yes, this...but I'm out now. These short answers without further information(have you mounted this partition, are you able to see it etc etc.) are annoying. May someone else help you.

Share this post


Link to post
Share on other sites
still i don't think it is working for me because I have a gtx650m

An m? How do you connect that to a mac? Aren't those already integrated in laptops?

Share this post


Link to post
Share on other sites
An m? How do you connect that to a mac? Aren't those already integrated in laptops?

I guess he's got a 2012 MBPr with GT 650M, not GTX. But he doesn't tell anything, you have to guess or ask and then maaaaaybe he'll answer it. Sometime.

Share this post


Link to post
Share on other sites
I guess he's got a 2012 MBPr with GT 650M, not GTX. But he doesn't tell anything, you have to guess or ask and then maaaaaybe he'll answer it. Sometime.

Yeah, not easy to provide help with such thin information [emoji14]

Share this post


Link to post
Share on other sites
Yeah, not easy to provide help with such thin information [emoji14]

XD now I will give you the all the information

SETUP:

MacBookPro mid 2012 with an gtx650m, 16gb ram, intel core i7

Windows 8.1 64bits

EGPU: akitio thunder2, galax gtx970

When I select in the boot loader the efi boot. It is showing me GRUB and when I type LS it is showing me :(hd0) (hd1,gpt4) (hd1,gpt3) (hd1,gpt2) (hd1,gpt1). Then i still follow the command modifying every time hd0,gpt1 into hd1,gpt1. so here are the command I type into grub: ls (hd1,gpt1)/ then set root='(hd1,gpt1)' then I press the power button until my macbookpro shut down and when I go into the osx terminal typing this command: /Volumes/EFI/EFI/Grub/grub.cfg it is saying me no such file in directory.

I hope you have an answer to this problem. XD:chuncky:

Share this post


Link to post
Share on other sites

@ DatScream: So you did step 1-5 already, right?

To open the grup.cfg on the EFI you have to mount it again! You can't just try to open the file without the EFI beeing mounted.

Soooooooo you need to mount it first:

mkdir /Volumes/efi

sudo mount -t msdos /dev/disk0s1 /Volumes/efi

After that start with step 6.5. When you applied the changes you need to unmount:

sudo diskutil unmount /dev/disk0s1

Keep in mind that disk0s1 is red, because you need to enter here the correct partition that contains your EFI!!!!

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
@ DatScream: So you did step 1-5 already, right?

To open the grup.cfg on the EFI you have to mount it again! You can't just try to open the file without the EFI beeing mounted.

Soooooooo you need to mount it first:

After that start with step 6.5. When you applied the changes you need to unmount:

Keep in mind that disk0s1 is red, because you need to enter here the correct partition that contains your EFI!!!!

Ok we are one the right way thank you but it is showing this

/Volumes/EFI/EFI/Grub/grub.cfg: line 1: apple_set_os: command not found

/Volumes/EFI/EFI/Grub/grub.cfg: line 2: insmod: command not found

/Volumes/EFI/EFI/Grub/grub.cfg: line 3: insmod: command not found

/Volumes/EFI/EFI/Grub/grub.cfg: line 5: chainloader: command not found

/Volumes/EFI/EFI/Grub/grub.cfg: line 6: boot: command not found

Do I just unmount now?

Sorry for being so nooby

Share this post


Link to post
Share on other sites

Ok, if you have mounted the EFI do this:

- open the Finder

- click in the top menu bar -> Go To -> Go to folder -> enter "/Volumes/EFI/EFI/Grub/grub.cfg" without ""

- open the grub.cfg with TextEdit

- Do the changes, save and close

- unmount the EFI partion (can be done in the finder with a right click on it)

Share this post


Link to post
Share on other sites

Dude… ^^

You need to change the set root to match your windows boot efi. That is what the whole thing is for…

set root='(hd1,gpt1)'

Share this post


Link to post
Share on other sites
Dude… ^^

You need to change the set root to match your windows boot efi. That is what the whole thing is for…

Yes but in my text edit is see

set root='(hd1,gpt1)' so what do I change ?

Share this post


Link to post
Share on other sites

The whole point with the step before this is to find the Windows boot EFI...

Sent from my GT-I9505 using Tapatalk

Share this post


Link to post
Share on other sites

if hd1,gpt1 is your windows boot efi, you are good to go and don't need to change anything.

Share this post


Link to post
Share on other sites
if hd1,gpt1 is your windows boot efi, you are good to go and don't need to change anything.

Still didn't change anything of my problem, I am still getting grub in the efi boot. I think it is because of my macbookpro who has a gtx650m.

post-36130-14495000394392_thumb.jpg

post-36130-14495000393152_thumb.jpg

Share this post


Link to post
Share on other sites

That might be a reason. Why did you want to do it in the first place?

Share this post


Link to post
Share on other sites
That might be a reason. Why did you want to do it in the first place?

Because with the egpu I boot only 1 out of 4 tries. Also just asking you because I have the same egpu. Did you have a code 12 error in device manager? Because I do and I need to take it off otherwise my egpu is not working.

Share this post


Link to post
Share on other sites

No problems, never had any. Simply installed it and it worked. With this guide I can boot into windows with/without an external monitor. Maybe you can consider to switch to a MBPr with only an Iris GPU?

Share this post


Link to post
Share on other sites
No problems, never had any. Simply installed it and it worked. With this guide I can boot into windows with/without an external monitor. Maybe you can consider to switch to a MBPr with only an Iris GPU?

XD and how do I switch without buying it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.