Jump to content
EwinRacing Flash Series Gaming Chairs
Nospheratu

M17x (All revisions) OSD Icons by Nospheratu

Recommended Posts

I suppose this isn't compatible for the r4? I would love to change the icons on my m17x :)

It has been confirmed to work with the R4 see long2905's post here.

Share this post


Link to post
Share on other sites

Welcome to the forums zork :)

You need 5 quality posts before being able to download from T|I, the link to download is in the first post.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

I'm probably sounding like an idiot, but would anyone mind telling me what these affect? I've got no clue...

Share this post


Link to post
Share on other sites

This mod replaces the On Screen Display (OSD) icons that show on screen when you use the dedicated touch panel or keyboard shortcuts to change a setting on the laptop. An example would be when you press the "volume up" button, the OSD icon for the volume level appears on the screen.

Share this post


Link to post
Share on other sites

Welcome to T|I gen0zid! :)

Best way to find out it to try. Its just replacing your OSD exe so if you can make a backup of the exe and before you test. You can always restore the backup if it doesn't work. You would probably have to use the M17x R3/R4 - M18x version.

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

Works on the m14x r2 and looks AWESOME!

but volume-up-button now turns the volume down, and the other way around xD

can i fix this somehow by myself?

ps: mute is not working either

Share this post


Link to post
Share on other sites

Thanks man :)

You can always create your own by using your original M14x OSD exe and my guide here. If you experience any problems or are unsure about anything, drop me a PM and I'll help where I can.

Share this post


Link to post
Share on other sites

Would be better to have new drivers instead of the almost 3 years old ones...i running on server 2008 R2 and have to hunt for my drivers to get them working...

Sent from my C6603

Share this post


Link to post
Share on other sites

Just checked out the OSD for the new 17, I was hoping they changed those pos icons as a revamp with the new model but no such luck :eek:

Guess I have to take the new exe under my wing then :P I'll update the first post once done.

Share this post


Link to post
Share on other sites

R5 aka 17 OSD mod added to the first post. If anyone has this abomination please let me know if you experience any problems :P

The exe is also compatible with the 14 and 18 as well.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Yes, its the same OSD thats available from Dell for the 14, 17 and 18. It works on Windows 7 and 8 64bit.

Share this post


Link to post
Share on other sites

do not work for me still showing the default windows OSD...

currently using the new alienware 17 r5 with windows 8 64bit

Share this post


Link to post
Share on other sites

Are the instructions correct on the first post? Does Dell's OSD installer install into the directory I mentioned? I've no way to test this I just assumed it would be the same as the R4. I'm not sure if Windows 8 has some built in restore functionality once you replace the file. But I doubt they would do that for the Program Files location.

Try to overwrite the existing exe with the modded one instead of backing up the old one. You can always run the Dell OSD installer again if you want the old one back.

Share this post


Link to post
Share on other sites

since day one i receive this alienware m17 r5, only the default OSD is being display.

Was wondering why.

someone was mentioning that by uninstalling nvidia driver 311.48, only the alienware OSD will work.

Share this post


Link to post
Share on other sites

Please write the exact steps you took to install this mod and I can maybe tell you if/where you are going wrong.

edit: It seems the OSD you were referring to was the default Windows 8 OSD and not the Alienware version. A few Alienware owners are having an issue with the OSD and Windows 8. Try the solution posted by Dell here and then attempt installing the mod.

Share this post


Link to post
Share on other sites

i am using the M18x software on my M17x R3, can i still use the "Install instructions for R3 / R4 / M18x " or which i should use?

Share this post


Link to post
Share on other sites

Technically the M18x R1 software for the OSD is the exact same install file as the R3. So yes, those instructions are correct.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

I'm new member and cannot view the attachment (probably being really dumb noob) and if someone wouldn't mind helping

Share this post


Link to post
Share on other sites

This look awesome, I think it is about time that Alienware make some changes to make it look better.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Nospheratu
      Dolby Home Theater v4 - M17x R2 and IDT High Definition Audio   So I decided I needed a headset with a mic and I'm a sucker for matching peripherals so I set my sights on the TactX headset (Rebranded SteelSeries 5HV2). There's some pretty appalling reviews of it online but I have to try them out for myself. One of the "problem" areas is an apparent lack of bass since its tuned for FPS gaming. In preparation I figured I should get some sound enhancement software. I've been using the Dolby Home Theater v4 application on my HTPC with a Xonar DX soundcard and its very effective particularly with movies and it's volume leveler feature. All processing effects can be switched off for music by just switching profiles using a handy system tray utility so its very convenient to use. You can read more about it on Dolby's official page.
       
      System Tray Utility

      I'm not sure if many users are still soldiering on with the M17x R2 but heres a fix if you wanted the use the Dolby Home Theater v4 application. Support for the IDT High Definition controller used in this machine is non-existant. The only driver I could use was the one's directly from Dell (apart from this Dolby Driver) so I hope this is of some help to fellow M17x R2 users who are looking for more customisable sound.

      I've replicated my steps a few times and I'm fairly certain should work without isue on an Alienware M17x R2 with Windows 8.1 as that's what I'm using. You could give it a try if you have an onboard IDT HD Audio card as well.

      Fixing the INF for use with an IDT High Definition Audio sound card 1. Uninstall all audio applications/drivers and reboot. Windows should install the default "High Definition Audio" driver. 2. Download the installation files from here. Extract the rar. 3. Extract the "Dolby PCEE Drivers.msi" installation file using msiexec and the command line. eg...
        msiexec /a "C:\Dolby PCEE Drivers.msi" /qb TARGETDIR="C:\Extracted Dolby PCEE Drivers"  

      4. Using the above extraction path as reference, go to C:\Extracted Dolby PCEE Drivers\Dolby PCEE Drivers\Drivers64\Release. You should see a file called PCEE4-DHT.INF 5. Open the file and find and replace all occurances of HDAUDIOFUNC_01&VEN_11D1 with HDAUDIOFUNC_01&VEN_111D. Save and close. 5.1 Optional depending on whether you're running Windows 8.1. Reboot with Driver signing off. ie. Hold down Shift when clicking Restart. Select Troubleshoot->Advanced Options->Startup Settings. Click Restart. Once the machine reboots press F7 at the Startup Settings screen to Disable driver signature enforcement. 6. Go back to the extracted Dolby PCEE Drivers folder and run "Dolby PCEE Drivers.msi". Select the "DHT(release)" driver. You should be prompted on whether to install the driver or not, select Install.

      Your drivers should now be installed. If you're using another machine (not an M17xR2) with IDT HD Audio and can hear a marked difference in sound when you go to your Playback Device's properties and switch between the Dolby profiles on the Dolby tab you can go ahead and install the "Dolby Home Theater v4.msi" application.

      If you do not have the Dolby Tab under your speaker playback device and have the Enhancements Tab instead read on. At this point if I plugged in a pair of Headphones into the 2nd or 3rd audio jacks, the Headphones properties under Playback Devices contained the Dolby Tab and the Dolby effects were working with the headphone playback devices.

      Enabling the Dolby Tab and effects on the Speaker Playback Device 1. Open regedit and go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\MMDevices\Audio\Render. There should be multiple entries here. Expand the entries and look for the ones with both "FxProperties" and "Properties" keys. To identify the Speakers playback device one of the "Properties" key values will have a string value called "{a45c254e-df1c-4efd-8020-67d146a850e0},2" with a data value of "Speakers". We're interested in the "FxProperties" key above this "Properties" key. 2. Under this "FxProperties" key, delete all values apart from (Default). 3. Copy and paste the below to Notepad making sure to change ****** to the name of the parent key of that particular "FxProperties" key. eg. Mines was called {36018a56-954a-437d-8bdb-0b6bbf830dbc}. The name will vary as it changes with every driver install.
       
      Windows Registry Editor Version 5.00 [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\MMDevices\Audio\Render\*********************\FxProperties] "{b725f130-47ef-101a-a5f1-02608c9eebac},10"="Dolby PCEE4" "{d04e05a6-594b-4fb6-a80d-01af5eed7d1d},3"="{C53E5AAF-5F6F-41c2-9F63-ADEBBC9B6B64}" "{d04e05a6-594b-4fb6-a80d-01af5eed7d1d},0"="{00000000-0000-0000-0000-000000000000}" "{d04e05a6-594b-4fb6-a80d-01af5eed7d1d},1"="{BC8E3B67-3306-4eef-B230-6798E9A67F0B}" "{1da5d803-d492-4edd-8c23-e0c0ffee7f0e},5"=dword:00000000
      3. Run this reg file and select yes when prompted on whether you want to add this information to the registry. If you have a look at the same "FxProperties" key again you will notice the above values have been added. 4. Reboot the machine. 5. You should now have Dolby effects working on your speaker device. Install the "Dolby Home Theater v4.msi" and you're done!

      Notes: The effects are only really worth while if you're using headphones, the M17x R2's speakers aren't that good. So this exercise is a bit pointless really. I'm not a fan of processed sound but what really annoyed me was that the effects only worked when the Headphones were plugged in. Hopefully some of you guys enjoy it.

      Credits: I'd like to thank @fr33jack from guru3d forums for providing the install files on his post here and @epguy19 also from guru3D for pointing out the flaw in the drivers INF for the IDT device ID on his post here. I'd also like to thank @erp-ster7n from the laptopvideo2go forums for the insight into the enhancement tab mods with his post here.

      DISCLAIMER: Perform this modification at your own risk. I take no responsibility for any damage caused by technical error, user inexperience or stupidity.
       
    • By Crustieraxe
      Hello Guys this is my first post here!
       
      So my original post was this:
       
      "I don't even know if any active forum is out there on this laptop and on this issue, but after installing my new DHCG2 LTN173HT02 120hz display, I am unable to boot up on it. I do have a modded bios which the video setting is set to PEG, and just about read every forum about this but have not found a solution. I have tried resetting the bios, made sure the cable is plugged into the Edp port, and have made sure I have an UFEI Windows installation and legacy mode is turned off. I don't know what else to do and if anyone could help it would mean alot to me! "
       
      The reason it was not booting up on a pure UEFI environment is because my 660m did not have the GOP compliant driver vbios. You would need this in order to boot up in a pure UEFI environment which at the time I didn't know, and my fix was to stick to legacy. Any card before the 660m will most likely require this if you need to boot up in a pure UEFI environment. If you do not have this vbios driver while it is set to UEFI and plug in the 120hz lcd, it will beep 8 times and you will be forced to plug back in the 60hz display to change it back to legacy.
       
      This was the vbios that I can say worked for me and had the GOP compliant driver for the 660m
       
      https://www.techpowerup.com/vgabios/144032/144032
       
      ------------------------------------------------------------------
       
      These are the steps to upgrade from a normal 1600x900 60hz display to a 1920x1080 3D 120hz Display which is needed if you want to update your graphics card to a more modern one.
       
      I am making this guide because I felt frustrated that for this awesome computer, there aren't really any post in 2020 to upgrade the LCD panel to the 3D 120hz one. And The older posts I scavaged through really helped me little in doing this upgrade.
       
      Anyways lets begin
       
       
      1) If you have a stock AMD graphics card, and are wanting to install the 120hz display, then your journey ends here and you will have to upgrade to an NVIDIA graphics card to do so. If you have an NVIDIA, you may continue
       
      1a) ( Only if upgrading to pascal graphics card )Your NVIDIA card Needs to have a GOP compliant vbios  or else it will not let you select the UEFI option on the bios. This is needed because you need to set a UEFI environment before upgrading to a 1060/1070 Since these cards don't support legacy mode. This means you will need to flash a vbios onto your card that will allow you to boot on a UEFI Environment. You will need to verify first wether your card has a GOP compliant vbios by searching up your vbios version in GPU-Z. If you have a 660m that doesn't have this, then here is the link to that vbios that does. https://www.techpowerup.com/vgabios/144032/144032 I think that all of the Nvida 6XXm are not GOP driver compliant and need this but do not quote me.
       
      2) On the 60hz display, I would start by making sure that you have windows 10 installed or reinstall with UEFI support as it is needed if you are installing a pascal graphics card. If you have legacy mode enabled, and are not planning to upgrade to a pascal graphics card and keeping your old Nvidia 6XXM, then disregard this and head on to step 5 (although I would recommend to read everything)
       
      3) turn the laptop off and boot into the bios. In order to boot into the bios, spam the F2 key while it is turning on.
       
      4) Once in the bios, go to the Boot menu, and make sure to Disable "Secure Boot", Make sure that importantly if you converted over to a UEFI installation of windows, UEFI mode is chosen (UEFI  Environment will be needed for a pascal graphic card and legacy will not be compatible) then again, if you are on a legacy installation of windows 10, disregard this if you don't want to upgrade to a pascal graphics card.
       
      5) we can now start looking at the 120hz display. I bought mine on ebay with this seller https://www.ebay.com/itm/New-Dell-Alienware-M17X-R4-17-3-FHD-WLED-3D-V-M-LCD-Screen-DP-N-DHCG2-GN36T/273644412867?hash=item3fb67a5fc3:g:9A0AAOSw5AhcP1pw:sc:USPSPriority!32720!US!-1 (Just in case the link goes bad, this was the listing name"Alienware M17X R4 17.3" FHD WLED 3D V M LCD Screen DP/N DHCG2 GN36T"  with the screen model being  LTN173HT02 and Dell part number GN36T )
       
      6) Since my listing came with the video cables, I did not have to go out and look for the video cable. If yours did not come with the cables, You will also NEED to get the video cable it is required. the Dell Part number is N392W. I cannot stress enough This video cable is required and the 60hz's video cable CANNOT be used with the 120hz one or else you will brick your computer from what I read.
       
      7) Once it comes In, we can start to take apart the computer to Install our new display. I watched this video to remove the old 60hz and install the 120hz panel 
       
       
       
      8) Before I would remove the whole 60hz lcd panel, I would first make sure that you can boot on the 120hz panel. Notice that there is one connecter with screws on both sides right next to where the 60hz screen connecter is. Make sure that you put the 120hz one with the connector where screws are. This is known as the Edp port and cannot be confused with the LVDS port. Again, you want to plug the new 120hz display into the EDP port and unplug the 60hz one.
       
      9) If the installation was done correctly, then you should have no problem booting with the screen. if it is giving you 8 beeps, then just plug in the 60hz display, and navigate back to the bios to make sure everything is in order and refer back to steps 2-3. If you happen to be an advanced user like me and went ahead and installed a modded bios, then on the 60hz display make sure that the video setting is set to PEG. I dont think this is necessary to have a modded bios since the bios automatically changes the video setting when the 120hz display is detected and should be a last resort option to install a modded bios. I got my modded A12 bios from a guy in this forum named klem for 10 US dollars thorough paypal. Shoot him a message in the forum below.
       
       
      10) Once the new LCD is tested and you know you can boot up with no problems, go ahead and finish removing the old 60hz LCD and proceed to finish installing the 120hz LCD. And you are done. 
       
      A couple of words from my personal experience: When I installed the 120hz display, and booted up windows on it, and turned the computer off, it refused to turn on for some weird reason. I don't know why it would turn on when the AC and battery where on. regardless of what this was, I fixed it by Reseting the CMOS. If you don't know how to do this, do a quick google search and after turning it on i got 5 beeps which i then turned the computer off, and then turned it back on which the computer just reset itself and when it turned back on I was able to boot up into windows.
       
      This is the forum that I was able to find about upgrading the graphics card to the 1060.
       
      Anyways I hope I at least helped someone transform their computer! In 2020!
       
       
    • By lilkuz2005
      hello all, i just got a gtx 980m from a seller on amazon. i have the card installed in my alienware m17x r4, i have updated the bios to A15 stock, in the bios its showing the card is there, in windows 10 the card is also shown in device manager, but it has the code 43 error, i have disabled driver signing and installed a modded driver but its not working, i have uefi legacy mode enabled, i need help getting this working, do i need a modded bios to get the card working? is my card a g-sync version ? any help with this would be great, also if it is a g-sync card, can i vbios flash it with a non g-sync vbios? how can i tell if this card is a clevo or msi ? thanks in advance
    • By Soapy
      I reversed the input polarity on my m15x jack after a botched psu repair. Computer worked fine, but overall power control is messed up. System only boot on both battery and psu, no battery charge, and a very low battery drain (arround 6wh).
       
      I aways had battery issues whith my 8 years old m15x after my original battery died. Bought a new one two years ago, didn't work. Checked on upower, basically no info on manufacturer, power or history. So i refunded and used the system hooked on the psu as usual. In August i bought a new one, worked flawlessly for a day. The next day the battery died from nowere. Checked upower, bus was ok, battery was charging extremely slowly (6wh), history showed subpar disharge before shutting down. I got mad at this point, decided that psu was to blame. Opened it, checked everything, noticed some wear on the male jack. Resoldered it, connected on computer. Nothing happened, so i checked the voltage. That's when i realised that i screwed up big time. I swaped the positive and negative wires. Decided that one mistake was enough, so i sent my m15x to a trusted repair shop (latter found that they just hooked the battery and gave me back as soon as it booted, they didnt even open it). Got my pc a week later, but the battery didn't charge . Worse, it was slowly discharging (same 6wh as before), and it needed both the psu and the battery to turn on. At 65%, it worked as usual for my college semester, but the battery is dead, and so is my computer. I bellieve i burned some voltage controller or something. I'm pretty competent at soldering thing's (evem smd components) when i know what to do, and i can understand simple circuit's, but when i got my hands on the m15x datasheet i got overblown. I cant make heads or tails about it. I aways lurked this forum and i bellieve your guys are the best when it comes to finding creative solutions to technical problems concerning microelectronics. I followed a guide in this forum as a teenager to upgrade this same computer to a gtx680m, overclocked stuff, got custom bios, and had a lot of fun learning. The m15x is a deprecated platform, but it's a part of my history that i dont want to let go.
      So please guys, help me.
       
    • By Lyency
      bonjour, je souhaiterai unlock mon bios A15 de mon alienware m17x r4 . pouvez vous m'aider?
      je possède l'unlock A14 est il compatible avec le bios A15?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.