Jump to content
EwinRacing Flash Series Gaming Chairs
anility

Clevo x7200

Recommended Posts

Hey everyone,

Im a proud owner of a x7200 clevo laptop and I just purchased a nvidia gtx 780m from ebay, from a user who had the card in a clevo machine(dont know which model).

The laptop wont post it just powers up and the fans spin high for 40 secs and die down. the screen is black.

Do i need another power supply?

Do i need to change my bios? Currant bios is MB97_bios firmware 12 (728BV12S)

Bios 1.01.12SA LS3

EC 1.00.07SA3

Get someone to change the vbios?

or did i royally mess up and get a card that is not compatible?

I appreciate all the feedback.

update:

Put back one 480m in master slot and 780m in slave. did not attach sli cable.

bios saw 480m in slot 1 and unknown vga in slot 2

windows recognized the 480m but not the 780m .

unable to update drivers on 780m card in windows.

Might see if i can change the vbios now since I can boot.

Update2:

780m bios ver 70.00.31.00.02

GPU=GK104 revision FF

Update3:

NVflash DOS sees 780m gtx card.

Flashed to the latest clevo vbios

still same issue :(

Share this post


Link to post
Share on other sites

did u get moddified inf drivers from laptopvideo2go.com,if you didnt thats almost guarenteed the issue.As the x7200 doesnt officially support the gtx780m u have to fudge the driver into thinking there compatable,its a 2 min job.

also break out ur wallet and grovel see if its possible and prema's willing to fix ur system bios so the cards recognised though that in its self wont stop it working alone.

Share this post


Link to post
Share on other sites

I believe the x7200 is not compatible with the 780m, although the 680m , even in SLI works fine.

Source: X7200 with SLI GTX 680m - how it works, Impressions, Benches

I'm sure you can find a buyer for the 780m, I myself may be interested if I can repair my Alienware M18x R1 (stripped torx screws and lack of plastic ribbon cable clips are inconvenient).

Share this post


Link to post
Share on other sites

Hi i have x7200 with 680m sli. Is impossible to upgrade to successive gtx card like 780, 880, 980. Sorry.

Share this post


Link to post
Share on other sites

Hi to all! I have a question...why the card(780m) shouldn't  work  despite the gpu chip is almost the same as the 680m? 

I'm very courious about that!

 

Edited by Robigarga 88
Bad writing

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.