Jump to content
EwinRacing Flash Series Gaming Chairs
P370SM3

1440P @ 120hz from DP on P370SM3

Recommended Posts

Hi all,

I'm wanting to get my self a nice 1440p display. It's looking like the Asus Swift at the moment but how knows what displays are about to hit coming into Christmas.

Now What I'm after is some\any\all Information I can get on experiences from people driving a 1440p or higher resolution display from the DP port of a P370SM3 or Clevo of around the same setup.

Any of you guys run a 1440p display from the DP port of a P370SM3 Let me know what your advice is relating to pitfalls to avoid etc?

Share this post


Link to post
Share on other sites

Well just for posterity I add that I now own an Asus ROG Swift 1440p Display.

Still can not get it to run from my P370SM3. Any one help.

The display is detected but no matter how I configure it I always end up at a blank screen and both the ROG and the Laptop display.

Nvidia drivers detect a Gsync monitor and take over like they no every thing. I suspect whats happening is that it's trying to force the ROG to primary and Gsync on?

I don't now. Ah well back to the drawing board.

Share this post


Link to post
Share on other sites

@ Prema and any other People who may be interested here is another update to the Asus ROG Swift 1440p display not working with my SLI 780m P370SM3.

The display port and adapter (Mini DP to Standard DP) and Cable all work well at 1680x1050@60Hz on my dell LCD. The ROG Swift Display is detected as stated above and I know the mobile 780M's do not support Gsync But I see some threads that state that it works with an Alienware M18 I can;t even get an image to the ROG Swift in any format. The Swift works as I have tested it on another Desktop I have here.

I tried 1920x10180@ 60Hz 85Hz etc.. But No go on the ROG Swift. Strange think is I get the option of only 23 or 24Hz refresh rate in the monitor options with the Swift. When I bought the P370SM3 it stated in the Advert that it supports the DP1.2 Standard but I fear it does not as if it did the Swift would work. I thought of trying the Alienware video drivers Should I?

Share this post


Link to post
Share on other sites
@ Prema and any other People who may be interested here is another update to the Asus ROG Swift 1440p display not working with my SLI 780m P370SM3.

The display port and adapter (Mini DP to Standard DP) and Cable all work well at 1680x1050@60Hz on my dell LCD. The ROG Swift Display is detected as stated above and I know the mobile 780M's do not support Gsync But I see some threads that state that it works with an Alienware M18 I can;t even get an image to the ROG Swift in any format. The Swift works as I have tested it on another Desktop I have here.

I tried 1920x10180@ 60Hz 85Hz etc.. But No go on the ROG Swift. Strange think is I get the option of only 23 or 24Hz refresh rate in the monitor options with the Swift. When I bought the P370SM3 it stated in the Advert that it supports the DP1.2 Standard but I fear it does not as if it did the Swift would work. I thought of trying the Alienware video drivers Should I?

have you therefor tried 1440p at 20 or 24hz just to see if you get an image?

might you have to hook it up with laptop closed and monitor as main display? with like external keyboard mouse, that probably isnt your intent.

Share this post


Link to post
Share on other sites
have you therefor tried 1440p at 20 or 24hz just to see if you get an image?

might you have to hook it up with laptop closed and monitor as main display? with like external keyboard mouse, that probably isnt your intent.

Yeah MW I tried those refresh rates but they didn't work. You may be on to something with the close the lid idea. Some have said I need to disable the internal LCD. I am going to try both when I get another cable. I took the adapter back and now I'm going to get a mini to standard cable in one to eliminate the adapter as the fault.

PS. Your right it isn't my intent but hay at this stage I'll be happy with the one display working as long as it's the ROG Swift that is.hehehhe

Thanks for the reply.

Share this post


Link to post
Share on other sites
Yeah MW I tried those refresh rates but they didn't work. You may be on to something with the close the lid idea. Some have said I need to disable the internal LCD. I am going to try both when I get another cable. I took the adapter back and now I'm going to get a mini to standard cable in one to eliminate the adapter as the fault.

PS. Your right it isn't my intent but hay at this stage I'll be happy with the one display working as long as it's the ROG Swift that is.hehehhe

Thanks for the reply.

You are very welcome and was just a thought. I hope it works or the change in cable in anycase. Cheers and ill be looking to see if you got any progress :D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.