Jump to content
EwinRacing Flash Series Gaming Chairs

petition to Lenovo to release unemcombered BIOS

Recommended Posts

There is an existing petition to have Lenovo release an unemcombered version of their BIOS located on Change.org

h t t p s : //www.change.org/p/lenovo-release-an-unencumbered-version-of-the-bios.

Share this post

Link to post
Share on other sites

Petitions rarely ever do anything. I bet you the only way this will ever happen is if we, as consumers, refuse to buy from Lenovo. However, in the meantime, we have the Modded bios that (from what I've heard) works well!

Share this post

Link to post
Share on other sites

Will sign. I find it infuriating to not be allowed to have control over my own laptop because Lenovo thinks they know what's best for me. It's a shame that they make such accesible hardware and impose ridiculous conditions on it. I hope they listen to the petition or I will never buy from them again..

Share this post

Link to post
Share on other sites

Agent349, I don't htink it's necessarily that they think they know better. I know how it sounds but really it seems like it comes down to trying to limit customer-caused hardware failures by limiting the accepted hardware. Yes, it's stupid. No, they shouldn't do it. Sadly we still have to deal with it at this point. Going to go sign.

Share this post

Link to post
Share on other sites

I do not think this petition will change Lenovo's marketing strategy. Maybe they change their thoughts when someone presents real statistics over customers satisfaction.

IMHO they think with this restriction they will sell more products. In this case they should create laptops in one solid cast, everything glued.

Share this post

Link to post
Share on other sites

It'll only take a minute of your time to sign. Maybe it won't help, but if you don't sign,- for sure nothing will happen.

Share this post

Link to post
Share on other sites

I think is better to file a letter to EU comission for fair concurency, and explain to them that Lenovo is actively blocking various manufacturers products to be used in their laptops.

If they get an injuction on selling their all laptops in Europe, maybe they will stop with whitelisting the ports.

Sent from my iPhone using Tapatalk

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By thinkdad
      I need help in fixing my Thinkpad.

      I just got a T440p yesterday. It was working perfectly until the following:

      I reinstalled Windows and then I installed Vantage.

      I installed all the latest drivers.
      I also choose to install the bios update. The bios update ran in Windows and it asked me to restart. After restarting, the screen was blank. I tried powering it off and on and I saw the Thinkpad logo but after that the screen was blank.

      I tried powering on and off again and there's no Thinkpad logo now and the screen is just blank with the green power on. No sound, no nothing.

      Here's what I tried:
      Pressing the power button 10 times and then holding it for 30 seconds. Unplugged and battery is detachted Detached the CMOS battery and the reattached it Removed the ram, harddisk and optical disk drive. Attached the battery and inserted the charger. I turned it on and there was a couple of beeps Tried pressing FN+R and created a bootable USB I'd like to ask: How do I fix this? What do I need to do?
      Can I reflash the bios in some other way? Do I need to buy a new motherboard? Will this solve the issue? It's my first thinkpad and I'm really excited but I was bummed out that this happened. Can you please help me?

      Thanks in advance!
    • By sam@83
      Hello !
      I tried a tutorial on the forum to remove the supervisor password on a X260 thinkpad but the winbond 25Q128FVPQ chip is not recognized with the programmer CH341A and ASprogramer (does not detect automatically and not manually). Plugged into the motherboard with a soic8.

      Can you help me with detection?
      Can I find the password with the software or do I have to write it?
      Thank you so much !!!
    • By Cubitci
      To install the unlocked bios, I prepared and booted a freedos usb. I start the installation by typing flash.bat but every time I get the following error: Error 28: Protected Range Registers are currently set by BIOS, preventing flash Access. Please contact the target System BIOS vendor for an option to disable Protected Range Registers.
      How can i solve this problem ?
    • By arifhsn
      please help i can't access my g5070's advanced menu
    • By raqall

      I would love to have my BIOS modded to disable the wireless whitelist.
      I tried to do it myself (dump BIOS from chip, disassemble, locate the reference to the error message "Unauthorized Wireless network card is plugged in..." memory address and modify the condition in the binary file so not to "land" in the infinite loop) but I couldn't dig to anything meaningful I could easily change.

      Laptop: Lenovo ThinkPad S440 (TYPE 20BB-S00400)
      BIOS version: 73ET71WW (1.71)
      Original WiFi/BT card: Intel Wireless-N 7260 (7260HMW BN) (vendor: 0x8086, device: 0x08B2, subdevice: 0x4262)
      Target WiFi/BT card: Broadcom BCM94352HMB (I haven't received it yet, waiting for delivery)

      Manufacturer BIOS download: bootable ISO, updater for Windows
      My BIOS dump (using CH341A SPI Programmer under Linux): http://www.mediafire.com/file/mn0gfr9ext7yqrn/S440_73ET71WW.bin/file
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.