Jump to content
EwinRacing Flash Series Gaming Chairs

Recommended Posts

Are u sure is part of the mother board ? Or is sealed to the mother board, because if is sealed we can always on sealed and change it .

But would the bios recognize the new GPU? post-361-14494988111443_thumb.jpg

Share this post


Link to post
Share on other sites

Yes, it's soldered to the mobo. When you tilt the mobo a bit and look at it from a different angle, you'll see how the PCB with the die on it is directly on the mobo PCB. It's BGA soldered, all the solder joints (quite a lot) are below this square, you can't see them.

The vbios is (as far as I know, maybe a M14x user can confirm this) part of the system bios. That's usual for systems with on-board GPUs, since it allows you to simplify things and use less components. Therefore no, a new GPU (even if the pin layout of the die was magically the same) would not work because of the bios.

In addition to this, all the integrated circuits on the mobo can't be changed, and it's almost impossible that the 555m circuit design is suitable for any different die.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Well that says it all

Only think we could expect is changing the mother board with the future mother board of the m14 R2 lol

Share this post


Link to post
Share on other sites

That's true, if the jacks stay at the same place this would be an option. I think it was possible to use an r2 mobo in a M17x r1 chassis... but don't take my word for it.

Share this post


Link to post
Share on other sites

See that was the problem with the m11x R1 vs R2. The layout of the case and MB had changed. Therefore couldn't use the old one. If their is a m14x R2, it will really depend on the updated features. I doubt we will get a r2 for a while. Why.. 1. the video is latest nvida offering 5xx vs older 4xx. 2. Only the 6770 ati offering would be as compatible thermally. 3. Size and MFG? are any of the ATI cards "all in one" mb and gpu combos? So why would they release an R2?

If I could wish on a star.. I know most of you like the nvidia cards. I am not a fanboy either way but the ATI cards REALLY impress me. I loved the 5850 and the OC ability. It put the smack down on most notebook gpu's. It's seems like for the longest time the only competition to the 5850/5870 were other 5850/5870 cards. (until the 6970). I would really like to see an R2 with an ATI 6850 (maybe even lower clocked if needed). This card pushes over 2200 in 3dmark11 stock. Overclocked you could easily hit 25xx or 26xx (close to the old 5850). I would trade mine right now for a 6850 m14x offering. I got credit and ready to spend if needed.

so if your listening alienware...

m14x

6850 ati or 7 series maybe?

better screen (higher quality)

option for added fan/cooling instead of optical drive

9 cell battery instead of 8

get to it please! I am will be happy to assist if you are able to pay my hourly rate!

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Crustieraxe
      Hello Guys this is my first post here!
       
      So my original post was this:
       
      "I don't even know if any active forum is out there on this laptop and on this issue, but after installing my new DHCG2 LTN173HT02 120hz display, I am unable to boot up on it. I do have a modded bios which the video setting is set to PEG, and just about read every forum about this but have not found a solution. I have tried resetting the bios, made sure the cable is plugged into the Edp port, and have made sure I have an UFEI Windows installation and legacy mode is turned off. I don't know what else to do and if anyone could help it would mean alot to me! "
       
      The reason it was not booting up on a pure UEFI environment is because my 660m did not have the GOP compliant driver vbios. You would need this in order to boot up in a pure UEFI environment which at the time I didn't know, and my fix was to stick to legacy. Any card before the 660m will most likely require this if you need to boot up in a pure UEFI environment. If you do not have this vbios driver while it is set to UEFI and plug in the 120hz lcd, it will beep 8 times and you will be forced to plug back in the 60hz display to change it back to legacy.
       
      This was the vbios that I can say worked for me and had the GOP compliant driver for the 660m
       
      https://www.techpowerup.com/vgabios/144032/144032
       
      ------------------------------------------------------------------
       
      These are the steps to upgrade from a normal 1600x900 60hz display to a 1920x1080 3D 120hz Display which is needed if you want to update your graphics card to a more modern one.
       
      I am making this guide because I felt frustrated that for this awesome computer, there aren't really any post in 2020 to upgrade the LCD panel to the 3D 120hz one. And The older posts I scavaged through really helped me little in doing this upgrade.
       
      Anyways lets begin
       
       
      1) If you have a stock AMD graphics card, and are wanting to install the 120hz display, then your journey ends here and you will have to upgrade to an NVIDIA graphics card to do so. If you have an NVIDIA, you may continue
       
      1a) ( Only if upgrading to pascal graphics card )Your NVIDIA card Needs to have a GOP compliant vbios  or else it will not let you select the UEFI option on the bios. This is needed because you need to set a UEFI environment before upgrading to a 1060/1070 Since these cards don't support legacy mode. This means you will need to flash a vbios onto your card that will allow you to boot on a UEFI Environment. You will need to verify first wether your card has a GOP compliant vbios by searching up your vbios version in GPU-Z. If you have a 660m that doesn't have this, then here is the link to that vbios that does. https://www.techpowerup.com/vgabios/144032/144032 I think that all of the Nvida 6XXm are not GOP driver compliant and need this but do not quote me.
       
      2) On the 60hz display, I would start by making sure that you have windows 10 installed or reinstall with UEFI support as it is needed if you are installing a pascal graphics card. If you have legacy mode enabled, and are not planning to upgrade to a pascal graphics card and keeping your old Nvidia 6XXM, then disregard this and head on to step 5 (although I would recommend to read everything)
       
      3) turn the laptop off and boot into the bios. In order to boot into the bios, spam the F2 key while it is turning on.
       
      4) Once in the bios, go to the Boot menu, and make sure to Disable "Secure Boot", Make sure that importantly if you converted over to a UEFI installation of windows, UEFI mode is chosen (UEFI  Environment will be needed for a pascal graphic card and legacy will not be compatible) then again, if you are on a legacy installation of windows 10, disregard this if you don't want to upgrade to a pascal graphics card.
       
      5) we can now start looking at the 120hz display. I bought mine on ebay with this seller https://www.ebay.com/itm/New-Dell-Alienware-M17X-R4-17-3-FHD-WLED-3D-V-M-LCD-Screen-DP-N-DHCG2-GN36T/273644412867?hash=item3fb67a5fc3:g:9A0AAOSw5AhcP1pw:sc:USPSPriority!32720!US!-1 (Just in case the link goes bad, this was the listing name"Alienware M17X R4 17.3" FHD WLED 3D V M LCD Screen DP/N DHCG2 GN36T"  with the screen model being  LTN173HT02 and Dell part number GN36T )
       
      6) Since my listing came with the video cables, I did not have to go out and look for the video cable. If yours did not come with the cables, You will also NEED to get the video cable it is required. the Dell Part number is N392W. I cannot stress enough This video cable is required and the 60hz's video cable CANNOT be used with the 120hz one or else you will brick your computer from what I read.
       
      7) Once it comes In, we can start to take apart the computer to Install our new display. I watched this video to remove the old 60hz and install the 120hz panel 
       
       
       
      8) Before I would remove the whole 60hz lcd panel, I would first make sure that you can boot on the 120hz panel. Notice that there is one connecter with screws on both sides right next to where the 60hz screen connecter is. Make sure that you put the 120hz one with the connector where screws are. This is known as the Edp port and cannot be confused with the LVDS port. Again, you want to plug the new 120hz display into the EDP port and unplug the 60hz one.
       
      9) If the installation was done correctly, then you should have no problem booting with the screen. if it is giving you 8 beeps, then just plug in the 60hz display, and navigate back to the bios to make sure everything is in order and refer back to steps 2-3. If you happen to be an advanced user like me and went ahead and installed a modded bios, then on the 60hz display make sure that the video setting is set to PEG. I dont think this is necessary to have a modded bios since the bios automatically changes the video setting when the 120hz display is detected and should be a last resort option to install a modded bios. I got my modded A12 bios from a guy in this forum named klem for 10 US dollars thorough paypal. Shoot him a message in the forum below.
       
       
      10) Once the new LCD is tested and you know you can boot up with no problems, go ahead and finish removing the old 60hz LCD and proceed to finish installing the 120hz LCD. And you are done. 
       
      A couple of words from my personal experience: When I installed the 120hz display, and booted up windows on it, and turned the computer off, it refused to turn on for some weird reason. I don't know why it would turn on when the AC and battery where on. regardless of what this was, I fixed it by Reseting the CMOS. If you don't know how to do this, do a quick google search and after turning it on i got 5 beeps which i then turned the computer off, and then turned it back on which the computer just reset itself and when it turned back on I was able to boot up into windows.
       
      This is the forum that I was able to find about upgrading the graphics card to the 1060.
       
      Anyways I hope I at least helped someone transform their computer! In 2020!
       
       
    • By lilkuz2005
      hello all, i just got a gtx 980m from a seller on amazon. i have the card installed in my alienware m17x r4, i have updated the bios to A15 stock, in the bios its showing the card is there, in windows 10 the card is also shown in device manager, but it has the code 43 error, i have disabled driver signing and installed a modded driver but its not working, i have uefi legacy mode enabled, i need help getting this working, do i need a modded bios to get the card working? is my card a g-sync version ? any help with this would be great, also if it is a g-sync card, can i vbios flash it with a non g-sync vbios? how can i tell if this card is a clevo or msi ? thanks in advance
    • By Lyency
      bonjour, je souhaiterai unlock mon bios A15 de mon alienware m17x r4 . pouvez vous m'aider?
      je possède l'unlock A14 est il compatible avec le bios A15?
    • By learnfromit
      alienware 15 r2 970m with i7-6700hq vbios request so i can overclock and mess with voltage.

      BIOS version backup made with techpowerup GPU-z.

      GM204.rom
       
      or can someone re direct me to one already made that will work? all links i find are dead, thanks.

    • By Terriikk
      Hey guys, I have an Alienware m14x R2, and I have been trying to get access to the BIOS so that I can change the boot options (Everything is locked, I am unsure if someone set a password of if these are locked by default).I've tried updating the BIOS, and resetting the CMOS and nothing has changed this. Would anyone know if there are other options I can explore? Thank you. 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.