Jump to content
rambomhtri

Activate Num Lock automatically when turning on Y510P

Recommended Posts

Hi, I have a lenovo IdeaPad Y510P, Windows 8.1 x64, BIOS v3.05 rev 3.7.

I've used regedit to change every InitialKeyboardIndicatorslayout value to "2", cause there are like 4 or 5 of them. Now, when I restart the machine it automatically activates the Num lock, but not always, it's like random, it works 80% if the times. But when I shut it down, it activates the Num Lock much less often, like 10% of the times.

So, how in the hell can I just make it work always? It seems a pretty pretty easy thing to configure, but this randomness is driving me crazy.

Thanks!

Share this post


Link to post
Share on other sites
Hi, I have a lenovo IdeaPad Y510P, Windows 8.1 x64, BIOS v3.05 rev 3.7.

I've used regedit to change every InitialKeyboardIndicatorslayout value to "2", cause there are like 4 or 5 of them. Now, when I restart the machine it automatically activates the Num lock, but not always, it's like random, it works 80% if the times. But when I shut it down, it activates the Num Lock much lees often, like 10% of the times.

So, how in the hell can I just make it work always? It seems a pretty pretty easy thing to configure, but this randomness is driving me crazy.

Thanks!

Is there no setting in the BIOS? There has been a numlock setting in every BIOS that I've used.

Share this post


Link to post
Share on other sites

Nope, there's a setting for the yellow USB2.0 ALWAYS-ON and some other things, but no Num Lock setting. Yeah, huge fail of the BIOS.

Right now I've turned on the laptop and the Num Lock was activated. It's freaking random, I hate it.

Share this post


Link to post
Share on other sites

Normally it should be enough to just change/raise the value under the path

HKEY_USERS\.Default\Control Panel\Keyboard

by 2. The default number must be raised by 2 not only exchanged!

Share this post


Link to post
Share on other sites

Wow, what?

I've read thousand of times that "You must CHANGE the value, from, let's say, 20134124, to 2".

So you say I have to plus 2 to the default number? In this case, 20134126?

Thanks!

Share this post


Link to post
Share on other sites

The instructions I came across said so. In most cases the number seems to be zero and this case is mentioned in the most how-to's, even Microsoft itself says so, but people annoted to just add 2.

I would give it a try. :)

Share this post


Link to post
Share on other sites

Thanks, but in my case the numbers are:

2147483648

2147483650

Those were the numbers I found in the registry. I changed all of them to 2. And THAT change has done something, cause in the beginning it never turned on with lock num activated.

According to you, I should change them by:

2147483650

2147483652

Is that right?

Share this post


Link to post
Share on other sites

According to the how-to's yes, but why do you have two values to change? Normally it should only be one value.

Share this post


Link to post
Share on other sites

Yeah, that's because I've changed like 5 or 6 registry paths (KeyboardIndicator value's). Some of them had one of those numbers, the others the other one. I'll give it a try. Thanks, hope it works :D

Share this post


Link to post
Share on other sites

I fixed it by changing the value like you said in the first post, but in the adavnced power options, you also have to disbale windows fast startup. This works for me, I also enabled hibernate so the notebook still boots up fast (windows 8 fast startup is actual some mix between shut down and hibernate) and not a regular shutdown like in windows 7 or earlier (In windows 8 you have to disable it in the power options or you can hold the SHIFT key while you click on Shut down))

Share this post


Link to post
Share on other sites

Due to an Intel® Wireless-N 7260 problem (ultra low WiFi range, didn't find a solution in 3 days of intense searching), I've restored the laptop to factory setup. After 3 days using it, it seems that it's now fixed. But you know, as I'm used to its random activation, it's probably a matter of time that this bug strikes back.

BTW, I'm not disabling Fast Startup because of this problem, it's like cure you leg cutting it off. I know you can hibernate, but it's not the same.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.