Jump to content
EwinRacing Flash Series Gaming Chairs
SkorPwN

MSI GS70 BIOS Dead ?

Recommended Posts

Good Morning,

After I upgraded the firmware of my GS70 successfully, I tried to flash my BIOS.( I know in retrospective, this was absurd).

I used the files available from MSI download page, but it crashed midway, and tried to reboot. Then the drama starts : the laptop was running, with one fan (CPU) on full power, LEDs were on, but I had a black screen and the laptop was completely unresponsive.

So I pulled out the battery, now the laptop won't boot, actually nothing happen, the laptop is a total brick.

I suppose my BIOS is dead.

After I read https://forum-en.msi.com/index.php?topic=119375.0 , I come here for a little help.

What should I have exactly on my USB drive, and what should I do with it ? (which button to push when I plug it in, with or without battery ?)

Thanks a lot !

Share this post


Link to post
Share on other sites

Have you tried a full cold boot? Remove the battery and remove the AC adapter, then hold the power button for 30 seconds. Plug the AC adapter back in and hold the power button again.

Does anything AT ALL happen?

Share this post


Link to post
Share on other sites

I take it you tried to Flash the bios in Windows? If so thats the mistake everyone makes. Its not the safest way of flashing.

Now on MSI laptops you can try Dumping all the power out of the laptop.

Thats removing the PSU and the Battery and holding the power button down for a while.

Then using another PC format a USB Key with a FAT32 file system anything lower then 2GB USB should do. Download the latest Bios you can.

Extract the Bios zip and locate the Bios file which is something like E1771IMS.70E

Now place this file on the USB stick and also then rename the file on the USB stick to R.ROM.

Place this USB into your laptop only plug back in the PSU leave Battery out!!!!!

Press Power and then Spam CTRL + FN + Numpad 7

Give it about 30 minutes just incase and then Power Down the laptop and then power back up. If that doesn't work the BIOS is Bricked and will need to be sent off to MSI to reprogram the chip.

For future reference always flash a Bios via a DOS Bootable USB Stick, never use Windows to flash a Bios or EC Firmware it will end in issues.

If Dos is not available and its UEFI with a Shell then use UEFI to flash the bios.

Share this post


Link to post
Share on other sites

I have almost the same problem with GX660, IS there a problem if i try that with 8gb USB flash drive ? And only "bios" file must be on the drive or all (4) BIOS files which i got from Bios arhive ?

When i try this, USB flashes for a 5-7 seconds, and nothing! What the problem could be ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.