Jump to content
EwinRacing Flash Series Gaming Chairs
J95

[Guide] Modding Nvidia OEM INF Files

Recommended Posts

Hey J95

I'm at my wits end here with trying to figure out the right combo for the modified inf file.. so I'm just gonna tuck my tail at this point..

PCI\VEN_10DE&DEV_119F&SUBSYS_04901028&REV_A1

PCI\VEN_10DE&DEV_119F&SUBSYS_04901028

PCI\VEN_10DE&DEV_119F&CC_030000

PCI\VEN_10DE&DEV_119F&CC_0300

Windows 7 Ultimate 64 on a M17xR3 from 2011. 780M is the new card installed coming from a 460M. Any help would be greatly appreciated. Thanks!

Share this post


Link to post
Share on other sites
Hey J95

I'm at my wits end here with trying to figure out the right combo for the modified inf file.. so I'm just gonna tuck my tail at this point..

PCI\VEN_10DE&DEV_119F&SUBSYS_04901028&REV_A1

PCI\VEN_10DE&DEV_119F&SUBSYS_04901028

PCI\VEN_10DE&DEV_119F&CC_030000

PCI\VEN_10DE&DEV_119F&CC_0300

Windows 7 Ultimate 64 on a M17xR3 from 2011. 780M is the new card installed coming from a 460M. Any help would be greatly appreciated. Thanks!

Welcome to T|I [MENTION=34127]Lord VoGoR[/MENTION].


    Remove the card (2 screws/keep the heat sink) clean the MXM connector with a soft cloth. Try reseating the card a couple of times.
  • BIOS Settings. Integrated sound card disabled -> disable the integrated graphics - Second Advanced Menu -> Video Configuration -> disable IGP -> set display to PEG ->F10 reboot.
  • Uninstall IDT drivers. Programs & Features -> reboot.
  • Run DDU/Safe mode - under options uncheck AMD Audio Bus (bug) -> Clean and Shutdown option
  • BIOS -> enable the integrated sound card -> F10
  • Install IDT drivers -> reboot
  • Download GeForce 347.52 WHQL
  • Extract driver w/ 7-Zip/winrar
  • Display.Driver folder -> copy/overwrite nvdmi.inf
  • Extracted driver package -> run setup exe.
  • If the above still doesn't work, try reasiting the card once again. RMA..."previously tested" BS/eurocom.
    Notepad CTRL+H nvdmi.inf (1028/Dell), just replace 05AE with 0490 then hit 'Replace All'

nvdmi.inf_v347.52_AW_0490_GTX_780M.zip

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
Welcome to T|I @Lord VoGoR.

  • Remove the card (2 screws/keep the heat sink) clean the MXM connector with a soft cloth. Try reseating the card a couple of times.
  • BIOS Settings. Integrated sound card disabled -> disable the integrated graphics - Second Advanced Menu -> Video Configuration -> disable IGP -> set display to PEG ->F10 reboot.
  • Uninstall IDT drivers. Programs & Features -> reboot.
  • Run DDU/Safe mode - under options uncheck AMD Audio Bus (bug) -> Clean and Shutdown option
  • BIOS -> enable the integrated sound card -> F10
  • Install IDT drivers -> reboot
  • Download GeForce 347.52 WHQL
  • Extract driver w/ 7-Zip/winrar
  • Display.Driver folder -> copy/overwrite nvdmi.inf
  • Extracted driver package -> run setup exe.
  • If the above still doesn't work, try reasiting the card once again. RMA..."previously tested" BS/eurocom.
    Notepad CTRL+H nvdmi.inf (1028/Dell), just replace 05AE with 0490 then hit 'Replace All'

Hi! I'm trying to make this work, im new here, but got the basic knowledges of this.

m17xr3 460m to 780m

windows 7 ultimate

HARDWARE IDS

PCI\VEN_10DE&DEV_119F&SUBSYS_04901028&REV_A1

PCI\VEN_10DE&DEV_119F&SUBSYS_04901028

PCI\VEN_10DE&DEV_119F&CC_030000

PCI\VEN_10DE&DEV_119F&CC_0300

-------------------------

tried same steps, getting conflict when enabling IDT, blackscreen and sometimes light blue screen.

any ideas?

Share this post


Link to post
Share on other sites

Hi J95

I'm new here. Does this modding guide apply for all nVIDIA cards from all vendors? I have a Clevo P151EM and I want to upgrade my graphic card to 770M.

Thank you

Share this post


Link to post
Share on other sites

It's pretty much the same except you would be putting the device signature into the clevo file(nvcvi.inf) instead of dells file(nvdmi.inf). I've done that yesterday for 880M on 347.88, works like a charm

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

Can anyone tell me what is the hardware code dell'Alienware M18X r1?

Thanks! :)

Share this post


Link to post
Share on other sites

It's not really significant afaik, as long as you paste your GPUs device ID into the nvdmi.inf file. GPU PCI id can be found in the Device Manager, assuming you're using Windows

Share this post


Link to post
Share on other sites

Hello everyone first real post,

I've been wanting to learning to mod Nvidia's inf files. I tried the latest driver 350.05, I was rewarding was a black screen. After reading the guide this is what I did:

1-opened the nvdmi file

2-went to [NVIDIA_SetA_Devices.NTamd64.6.3] since I'm using win8.1

3-I found these 2 lines:

%NVIDIA_DEV.13D7.0685.1028% = Section325, PCI\VEN_10DE&DEV_13D7&SUBSYS_06851028

%NVIDIA_DEV.13D7.0688.1028% = Section325, PCI\VEN_10DE&DEV_13D7&SUBSYS_06881028

Since I have AW 18, with dual GTX 980m I inserted line:

%NVIDIA_DEV.13D7.05AB.1028% = Section325, PCI\VEN_10DE&DEV_13D7&SUBSYS_05AB1028

4-then went to Nvidia windows (64 bit) Driver library installation disk 1 and found:

NVIDIA_DEV.13D7.0685.1028 = "NVIDIA GeForce GTX 980M"

NVIDIA_DEV.13D7.0688.1028 = "NVIDIA GeForce GTX 980M "

I added:

NVIDIA_DEV.13D7.05AB.1028 = "NVIDIA GeForce GTX 980M "

I saved closed and tried to install, but got black screen. Should I have deleted the lines I found, and then inserted my lines, or did I totally miss something in the guide.

This is my Hardware ID:

PCI\VEN_10DE&DEV_13D7&SUBSYS_05AB1028&REV_A1

PCI\VEN_10DE&DEV_13D7&SUBSYS_05AB1028

PCI\VEN_10DE&DEV_13D7&CC_030000

PCI\VEN_10DE&DEV_13D7&CC_0300

Thanks for any help.

Share this post


Link to post
Share on other sites
Can anyone tell me what is the hardware code dell'Alienware M18X r1?

Thanks! :)

PCI\VEN_10DE&DEV_XXXX&SUBSYS_048F1028

GPU ID XXXX

048F M18xR1

1028 Dell

Hello everyone first real post,

I've been wanting to learning to mod Nvidia's inf files. I tried the latest driver 350.05, I was rewarding was a black screen. After reading the guide this is what I did:

1-opened the nvdmi file

2-went to [NVIDIA_SetA_Devices.NTamd64.6.3] since I'm using win8.1

3-I found these 2 lines:

%NVIDIA_DEV.13D7.0685.1028% = Section325, PCI\VEN_10DE&DEV_13D7&SUBSYS_06851028

%NVIDIA_DEV.13D7.0688.1028% = Section325, PCI\VEN_10DE&DEV_13D7&SUBSYS_06881028

Since I have AW 18, with dual GTX 980m I inserted line:

%NVIDIA_DEV.13D7.05AB.1028% = Section325, PCI\VEN_10DE&DEV_13D7&SUBSYS_05AB1028

4-then went to Nvidia windows (64 bit) Driver library installation disk 1 and found:

NVIDIA_DEV.13D7.0685.1028 = "NVIDIA GeForce GTX 980M"

NVIDIA_DEV.13D7.0688.1028 = "NVIDIA GeForce GTX 980M "

I added:

NVIDIA_DEV.13D7.05AB.1028 = "NVIDIA GeForce GTX 980M "

I saved closed and tried to install, but got black screen. Should I have deleted the lines I found, and then inserted my lines, or did I totally miss something in the guide.

This is my Hardware ID:

PCI\VEN_10DE&DEV_13D7&SUBSYS_05AB1028&REV_A1

PCI\VEN_10DE&DEV_13D7&SUBSYS_05AB1028

PCI\VEN_10DE&DEV_13D7&CC_030000

PCI\VEN_10DE&DEV_13D7&CC_0300

Thanks for any help.

980M/970M/965M, Edit nv_dispi.inf desktop 980 instead http://forum.techinferno.com/nvidia/6307-%5Balienware%5D-aftermarket-upgrades-driver-support-modded-inf-22.html#post128779


Replace:
%NVIDIA_DEV.13C0% = Section146, PCI\VEN_10DE&DEV_13C0
NVIDIA_DEV.13C0 = "NVIDIA GeForce GTX 980"

With:
%NVIDIA_DEV.13D7.05AB.1028% = Section146, PCI\VEN_10DE&DEV_13D7&SUBSYS_05AB1028
NVIDIA_DEV.13D7.05AB.1028 = "NVIDIA GeForce GTX 980M"

Share this post


Link to post
Share on other sites

Hello J95,

Thank you for your reply. A friend came over and before I read your reply he showed me the following:

In the nv_dispi inf. file under [NVIDIA_SetA_Devices.NTamd64.6.3] (for 8.1 OS) he added line:

%NVIDIA_DEV.13D7% = Section159, PCI\VEN_10DE&DEV_13D7

and under [strings]

DiskID1 = "NVIDIA Windows (64 bit) Driver Library Installation Disk 1" he added line:

NVIDIA_DEV.13D7 = "NVIDIA GeForce GTX 980"

The file installed with no problem and seems to be working. My questions, since his insertions don't look exactly like yours did everything install correctly, or should I uninstall it?

2- question don't touch nvdmi.inf, only mod nv_displ file?

3-When you say replace, do you mean delete?

Finally, can I use those to lines for future mods of NVidia drivers

Thank you again. I like learning new things.

Share this post


Link to post
Share on other sites
Hello J95,

Thank you for your reply. A friend came over and before I read your reply he showed me the following:

In the nv_dispi inf. file under [NVIDIA_SetA_Devices.NTamd64.6.3] (for 8.1 OS) he added line:

%NVIDIA_DEV.13D7% = Section159, PCI\VEN_10DE&DEV_13D7

and under [strings]

DiskID1 = "NVIDIA Windows (64 bit) Driver Library Installation Disk 1" he added line:

NVIDIA_DEV.13D7 = "NVIDIA GeForce GTX 980"

The file installed with no problem and seems to be working. My questions, since his insertions don't look exactly like yours did everything install correctly, or should I uninstall it?

2- question don't touch nvdmi.inf, only mod nv_displ file?

3-When you say replace, do you mean delete?

Finally, can I use those to lines for future mods of NVidia drivers

Thank you again. I like learning new things.

Section 159 is for Quadro M6000/GM200. Try enabling SLI without rebooting, keep it if it works. 900M series only using nv_dispi.inf (Desktop) or nvcvi.inf (Clevo), nvdmi.inf is messed up due to GA basically.

NVIDIA_DEV.13D7 = "NVIDIA GeForce GTX 980"

NVIDIA_DEV.13D7 = "NVIDIA GeForce GTX 980M"

Same method applied HERE, best driver so far/throttling removed.

Share this post


Link to post
Share on other sites
Section 159 is for Quadro M6000/GM200. Try enabling SLI without rebooting, keep it if it works. 900M series only using nv_dispi.inf (Desktop) or nvcvi.inf (Clevo), nvdmi.inf is messed up due to GA basically.

NVIDIA_DEV.13D7 = "NVIDIA GeForce GTX 980M"

Same method applied HERE, best driver so far/throttling removed.

J95,

I went back and removed the 350.05 driver my buddy helped me install, and started over. I installed the two lines you listed, but I put them in the nv_displ.inf file and it did not work. I then realized that those lines looked like the ones in the nvdm.inf file, and when I put them in there it installed without a problem. SLI is working and everything looks okay (fingers crossed). I could not find the line %NVIDIA_DEV.13C%=Section146. PCI\VEN_10DE&DEV_13C0NVIDIA_DEV.13C0, the only thing close had a different section number so I left it as is. Thanks for your help

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
Hi @toffefe welcome to T|I.

- Win8 -> disable driver signing.

- GeForce 340.52 WHQL

- Extract driver w/ 7-Zip/winrar

- Display.Driver folder -> open NVLTi.inf (notepad) CTRL+H -> Find What: Section109 Replace With: Section093 -> Hit 'Replace All'

- Find What: Section110 Replace With: Section094 -> 'Replace All'

- Find What: Section111 Replace With: Section095 -> 'Replace All'

- Find What: Section112 Replace With: Section096 -> 'Replace All' -> save.

- Extracted Nvidia 340.52...International\ -> run setup.exe.

Section093 Vista

Section094 Win7

Section095 Win8

Section096 Win8.1

Hello, J95.

I also have a lenovo w510 with a fx880m, I tried this but with 350.12 and had no success, it said that its not compatible with my quadro fx880m.

I am on win7.Can you please help me?

Share this post


Link to post
Share on other sites

Hello all!

I have a question about the new 350.12 drivers. I am running a m17x R1 with 280m in SLI and I have modded my INF 341.44 but ever since the drivers I have been unable to get anything to install any ideas? from what I can tell the 280m and older cards are not at all in the INF like they use to be/

Share this post


Link to post
Share on other sites

<article>

I like to mod my 780 Ti looks like Titan X.

Can somebody check what's wrong on this pics:

I make regedit to GPU Hardware ID and if I then boot GPU-Z or something like that, it looks like Titan X.

But if I boot my computer, it comes back to 780 Ti.

And I can't trick Nvidia Control Panel anyways.

There's no any editors either to change BIOS ID looks like Titan X.

</article>

Share this post


Link to post
Share on other sites
Quote

Anyone know how to mod Windows 10 drivers?



Search for [NVIDIA_SetA_Devices.NTamd64.10.0]





nv-dispi.inf



[NVIDIA_SetA_Devices.NTamd64.10.0]

%NVIDIA_DEV.0FC0% = Section011, PCIVEN_10DE&DEV_0FC0

%NVIDIA_DEV.0FC1% = Section011, PCIVEN_10DE&DEV_0FC1

%NVIDIA_DEV.0FC2% = Section011, PCIVEN_10DE&DEV_0FC2

%NVIDIA_DEV.0FC6% = Section011, PCIVEN_10DE&DEV_0FC6

%NVIDIA_DEV.0FC8% = Section011, PCIVEN_10DE&DEV_0FC8

%NVIDIA_DEV.0FC9% = Section011, PCIVEN_10DE&DEV_0FC9

%NVIDIA_DEV.0FEF% = Section016, PCIVEN_10DE&DEV_0FEF

%NVIDIA_DEV.0FF2% = Section017, PCIVEN_10DE&DEV_0FF2

%NVIDIA_DEV.0FF3% = Section018, PCIVEN_10DE&DEV_0FF3

%NVIDIA_DEV.0FF9% = Section021, PCIVEN_10DE&DEV_0FF9

%NVIDIA_DEV.0FFA% = Section021, PCIVEN_10DE&DEV_0FFA

%NVIDIA_DEV.0FFD% = Section022, PCIVEN_10DE&DEV_0FFD

%NVIDIA_DEV.0FFE% = Section021, PCIVEN_10DE&DEV_0FFE

%NVIDIA_DEV.0FFF% = Section021, PCIVEN_10DE&DEV_0FFF

%NVIDIA_DEV.1001% = Section023, PCIVEN_10DE&DEV_1001

%NVIDIA_DEV.1004% = Section011, PCIVEN_10DE&DEV_1004

%NVIDIA_DEV.1005% = Section011, PCIVEN_10DE&DEV_1005

%NVIDIA_DEV.1007% = Section011, PCIVEN_10DE&DEV_1007

%NVIDIA_DEV.1008% = Section011, PCIVEN_10DE&DEV_1008

%NVIDIA_DEV.100A% = Section011, PCIVEN_10DE&DEV_100A

%NVIDIA_DEV.100C% = Section011, PCIVEN_10DE&DEV_100C

%NVIDIA_DEV.1021% = Section024, PCIVEN_10DE&DEV_1021

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Hey Guys I just upgraded my Nvidia gtx 660m to 880m the problem is I can't get windows to recognize it in device manager it keeps showing up as Standard VGA Graphics Adapter. I was wondering if you guys can help me with this. Of course I did the steps the J95 told us told do but it still doesn't work.

Doc3.doc

Share this post


Link to post
Share on other sites
Hey Guys I just upgraded my Nvidia gtx 660m to 880m the problem is I can't get windows to recognize it in device manager it keeps showing up as Standard VGA Graphics Adapter. I was wondering if you guys can help me with this. Of course I did the steps the J95 told us told do but it still doesn't work.

Details -> Hardware IDs -> post results.

Share this post


Link to post
Share on other sites
Here is the Info.

1198=880M, 0051=M17xR4, 1028=Dell

Ref NVIDIA_DEV.1180 = "NVIDIA GeForce GTX 680"

- Win8.1 -> disable driver signature enforcement.

- Display.Driver folder -> open nv_dispi.inf (notepad) CTRL+H -> Find What: 1180 Replace With: 1198 -> Hit 'Replace All'

- Find What: GTX 680 Replace With: GTX 880M -> 'Replace All' -> save.

- Extracted driver package -> run setup.exe.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

So you are saying don't open nvdmi.inf file and open nv_dispi.inf to make it work? By the way I own a Windows 7 Home premium so would the one on the reference setup you gave me work the same?

Share this post


Link to post
Share on other sites
So you are saying don't open nvdmi.inf file and open nv_dispi.inf to make it work? By the way I own a Windows 7 Home premium so would the one on the reference setup you gave me work the same?

Yep, just edit nv_dispi.inf and skip DSE.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.