Jump to content
Review: E-Win Champion Series Gaming Chair Read more... ×
EwinRacing Flash Series Gaming Chairs
Nospheratu

[GUIDE] Dell 330W Power Adapter Mod for the M17X

Recommended Posts

This modification involves going a step further than a straight ID chip swap between the 240W and the 330W. The reason I chose this method was, I did not want to perform the mod again in the rare case that the 330W died and I had to get a new one.

In order to complete this mod, you will require the following items.

1. Dell 330W PSU (This PSU was built for the M18X and X51 product lines). Part Numbers: Y90RR / 5X3NX / F0K0N / XM3C3 / 331-2429

2. Dell 240W PSU (Either a Flextronix or Delta). Part numbers: PA-9E / J938H / Y044M / U896K / J211H / Y044M

3. Dell or HP standalone PSU cable/Connector. I used this as I wanted a right angle connector.

4. M17x/M18X Power Jack. I used this one.

5. Small PCB designed for a SOT-23 packaged chip. (If using the Flextronics 240W PSU). This seems like an ideal candidate.

6. Small housing (Optional depending on whether you would like to mod the ferrite choke housing)

 

PSU DISASSEMBLY

 

First we begin with the disassembly of the 240W PSU to retrieve the ID chip for our adapter. Since I had the Flextronics version some of these steps might not be the same for the Delta PSU. We start by lifting up the rubber feet on the bottom of the 240W using your nail or a flat tool. Underneath each rubber foot you will find a screw which you can go ahead and unscrew.

 

lift_rubber_feet.jpg.956dabe6a8d98b85d08770038327fc73.jpg

 

One of the screws will be a tamper-resistant Torx T10 type, the difference to a normal Torx T10 being a small pin the centre so you would have to use a Torx screwdriver with a hole in the center.

 

torx_screw.jpg.99aff6dd414de5a3d72af89aff3d8528.jpg

 

TIP: If you do not have this tamper-resistant screwdriver you can use a normal Torx T10 screwdriver but you will have to hammer down the pin at the centre of the screw slightly in order to get the normal T10 screwdriver to grip.

 

Once you have removed all screws you will have to pry open the casing. I stuck a thin knife between the power plug and the casing to gently pry it open.

 

pop-cover.jpg.fd9092c59398d0359d4e8c41b3f289c0.jpg

 

The top half and bottom half of the casing are held together by interlocking clips. Twist the case a bit to get them to unclip. Then remove the PSU from the case. You will then be presented with the first metal layer which is held on by tape. Cut the tape and slide out the first metal layer.

 

cut_tape.jpg.d7d8431bad7907f5715fd85f49581542.jpg

 

You will then see the second metal layer which is held in place by 3 points soldered onto the PSU PCB. It is indicated in the picture below. Desolder all 3 points and remove the second metal layer.

 

PSU-desolder-points.jpg.535b1e578c81b7ed4fc0aa478497bff1.jpg

 

The last layer is black and seems to be a type of flexible hard plastic. It will be stuck in place by white thermal stuff on the PCB, simply lift it and peel it away.

 

plastic-layer.jpg.d3d150e94903f22992de1f50203232e9.jpg

 

Depending on whether you have a Flextronics or Delta PSU your ID chip will look different.

 

ID-chip-on-PSU-PCB.jpg.c8a0bb8e91d4a3f74083ccc1c762ce35.jpg

 

Desolder this chip and keep it in a safe place (If you lose it, you have to buy a new 240W PSU). On the Flextronix PSU the chip is also stuck in place apart from being soldered on, so you have to work quickly heating the solder and pushing the chip away with a bit of force.

To reassemble the PSU reverse the above steps. You can still use this PSU connected to the adapter with your M17X so it won't be collecting dust.

 

THE ADAPTER MOD

 

You will have to decide on whether you want to mod the ferrite choke housing into your enclosure or use a dedicated enclosure (small as possible as this circuit is tiny). If you are using a dedicated enclosure jump straight to the labelled wire photo to continue. If you would like to mod the ferrite choke housing continue reading.

I did not take sufficient pictures during this portion as I was unsure if the ferrite choke housing would work. The rubber around the ferrite choke and the connector that I purchased was soft and very flexible which made it easy to work with. I used a knife and pressed against the rubber of the ferrite choke housing for a clean cut so that I could glue it back together. I cut off one end and then length ways along either seam of the housing making sure to leave a bit of extra cable.

 

cut-ferrite-housing.jpg.e97a5b731b5f452d99a97f03e098f7a4.jpg

 

Here is a picture of what we’re trying to achieve with the cutting.

 

rough-idea-of-cut.jpg.0e8ec91ca8c2a82d0f46b34fff1da0a7.jpg

 

You will then see the ferrite choke which you can crack with a hammer. Remove the pieces (be careful as they will be very sharp).

 

ferrite-choke.png.8caa364ec2933ca28d91c5416872f83d.png

 

Then the cut off the cable strain relief that's covering the cable with small wire snips.

 

cable-strain-relief.png.aade863919554a133f6eccbfd5a711ef.png

 

You will then see the cable which you can strip to positive, negative and the ID line.

 

Stripped-Cable-labelled.jpg.ee8134dc33d2ea2ee69c6a3dc67f1d0b.jpg

 

You will then need to connect those wires to the power jack. The two pins at the top are negative. The two pins at the back forming the shape of a U are positive and the pin at the back in the centre is the ID line.

 

power-jack-connections.jpg.eeea25cf7c68665249d8e61d68288e44.jpg

 

Solder the positive wire to positive pin and negative wire to negative pins as shown in the image below. The negative wire can be soldered to the negative pins and simultaneously joining the ID pin on the jack.

 

The reason behind joining the ID pin to the negative pins on the jack is because we need to ground the ID line coming from the 330W in order for it to operate beyond its artificial 240W limit.

 

jack-soldered-connections.jpg.3f028439b5fa449d8d6c7e7029e25555.jpg

 

Now all that’s left to do is connect the ID chip. If you have the Flextronics PSU the ID chip will be in a SOT-23 package and the Delta ID chip will be in a TO-92 package. The Flextronics SOT-23 package is difficult to work with and should be first soldered to a bit of PCB that had a SOT-23 package so that you do not break the legs off.

I initially soldered the wires directly to the legs and moving it about in my "enclosure" to find the best spot to place it was too much stress on the chips tiny legs and they broke off... yes, all of them. Luckily I could still see a tiny bit of metal from each of the legs. I managed to salvage it by soldering it to a piece of PCB that I jacked from a broken mouse which had SOT-23 connections.

The blue ID wire coming from the cable needs to be soldered to the data leg of the ID chip. Connect the remaining two pins from the ID Chip together and then to the negative connection on the PSU jack.

 

id-chip-on-sot23-pcb.jpg.05df3d26bfdfb46daa4c4e33db5348f2.jpg

Dont judge my pathetic soldering skills! :P

 

Place your ID chip into the enclosure and test the adapter to make sure all your connections have proper contact. If it’s working properly you can close it up.

 

adapter-labelled.jpg.80690d746c960de053cc7c87728f68ab.jpg

 

schematic.png.f71cfdecc1ef8481dbc809fb3bb54fbd.png

 

I considered flooding the enclosure with silicone to secure the ID chip and its connections but I did not, as I thought it would be more work if one of the connections broke and I had to open it up again. You can do it if you like.

 

I used a drill to make the hole at the centre of the disc large enough for the 330W connector tip fit through. I then stuck the enclosure back together using superglue along the sides and then attaching the disc. Add a bit of glue to the disc/jack so that the disc and jack are stuck together as well. This is so that the jack does not move when plugging the PSU connector tip in.

 

THE COMPLETED MOD

 

5ad590b3d2709_Completed1.jpg.1f8acc35ef3c945b9417953fbc3ed35c.jpg

5ad590baf0260_Completed2.jpg.2e7512771b4c059df4c85ad596de20fd.jpg5ad590c22c810_Completed3.jpg.3e792939f778ab2e15b15f1b6f68771a.jpg

 

Pros/Cons over the ID Chip swap Mod

Pros

- Allows you to use any PSU irrespective of wattage as long as the connector tip is compatible with the power jack.

- If the 330W PSU dies all you have to do is plug a new one in. No need to perform the mod on a new 330W.

- No need to open up the 330W at all.

- Your ID chip donor 240W PSU can still be used with your M17X by attaching this adapter.

Cons

- Allows you to use any PSU irrespective of wattage as long as the connector tip is compatible with the power jack (Could be dangerous with low wattage PSU's).

- A lot more work compared to swapping the chips.

 

Notes: I also had to trim a bit of rubber at the right angle connector for the cable I used as it’s a bit of a tight fit if you don't. The rubber around the connector did get a warm at the right angle after testing but it's being blasted by the heat of the CPU fan continuously so I don't think it’s the connector itself that's causing it. These cables are very short and should be able to handle the power easily.

Since there are two positive terminals you will have to either split the positive wire coming from the PSU connector to each pin or join both pins (bend one pin over to the other and solder them together making sure to place an insulator to cover the ID pin) and solder the positive wire to a single point.

Also worth noting is that this adapter mimics the original 240W adapter perfectly. So if you experienced the "plugged in, not charging" issue when connected this adapter will not resolve it (I still have to pop the battery and clip it back in to resolve).

 

Credits: @imsolidstate, without his in-depth investigation this would have not been possible. His website detailing his investigation and the ID chip transplant can be found here and the subsequent update here.

 

DISCLAIMER: Perform this modification at your own risk. I take no responsibility for any damage caused by technical error, user inexperience or stupidity.

Edited by Nospheratu
Restored images
  • Thumbs Up 16

Share this post


Link to post
Share on other sites
i am now !

i have already removed the ferrite ring !

image.jpg

Go for it Flingin bro'.

Nospheratu, great guide, great layout and great pics :D.

Share this post


Link to post
Share on other sites

@Nospheratu - This is a really sweet mod and a great guide. I love the way you planted the ID chip in the casing for the ferrite choke and created a dongle. Very creative and produces a clean mod.

Share this post


Link to post
Share on other sites

Thanks for the kind words [MENTION=119]Mr. Fox[/MENTION]. I like OEM looking mods. I plagiarized the wording from your disclaimer from your PSU mod, hope you don't mind. I was considering writing my own but it was just too awesome not to use... especially the "stupidity" part :P

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

No problem... I don't mind at all.

Conceptually, your mod should work equally well for M17xR3/R4 owners that are running into power limitations with their 240W AC adapters.

I am thinking about the possibility of incorporating the idea of using the power jack sockets and right angle cable into my dual 330W mod. That would allow the same benefit of replacing one of the two 330W adapters without any fuss and eliminate the need for having a total of three AC adapters. You would only need to buy one spare. I could mount the jack sockets to the box and make it similar to the Clevo junction block, then simply plug them into the box instead of cutting the cables and having them hardwired into the box.

I would need to figure out how to mount the jack connectors securely inside of the box, but it would otherwise be a simple tweak to the current mod.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
I would need to figure out how to mount the jack connectors securely inside of the box, but it would otherwise be a simple tweak to the current mod.

Well, you don't have to do that at all.

What i done is I soldered all the cables onto the Jack, then allign the jack inside so i could see where to make a hole, then drill the hole, allign the jack in it, and use a strong Two Part Resin Epoxy Glue :)

  • Thumbs Up 2

Share this post


Link to post
Share on other sites
....

I would need to figure out how to mount the jack connectors securely inside of the box, but it would otherwise be a simple tweak to the current mod.

The jack connectors come with a removable metal shroud that clips into place, which can be modded without affecting the actual jack itself.

You could drill a hole at the bottom of the shroud and screw it to your box making sure the screw is flush so the jack still is able to clip in place.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
The jack connectors come with a removable metal shroud that clips into place, which can be modded without affecting the actual jack itself.

You could drill a hole at the bottom of the shroud and screw it to your box making sure the screw is flush so the jack still is able to clip in place.

Good idea. If there is enough of air space to avoid a short, perhaps even a pop-rivet would mount the shroud securely to the box. Then the jack should be snapped into place once the soldering is completed.

The other thought I had was using blocks of acrylic or even small wood blocks inside of the box to pin the jacks in place so they would be unable to move without first removing those blocks.

Share this post


Link to post
Share on other sites

awesome work there!! just for a clarification, how much time difference does it make when charging from low battery level to full, between the standard 240W connector and this??

Share this post


Link to post
Share on other sites

Ummm.... I have no idea honestly :( I don't use the laptop on battery mode.

Theoretically speaking, I don't think it would make a difference.

Share this post


Link to post
Share on other sites

@Nospheratu - Looks like ImageShack is true to form with their mysterious vanishing photos again, LOL. They have lost dozens of my images.

Any chance you have backup images that you can replace those missing in the opening post.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

I have been looking at this thinking it may help my problem. For some reason my computer is reporting that I do not have a sufficient power supply to run my discrete graphics. It seems a bit out of my technical ability but plus one for the idea.

Share this post


Link to post
Share on other sites
Thanks for the heads up [MENTION=119]Mr. Fox[/MENTION] :) Re-uploaded them using postimage.org

Postimage.org FTW

And their app is very useful as well....

Sent from my SM-N9005 using Tapatalk

Share this post


Link to post
Share on other sites

Hmm, postimag.org? Never heard of it before... will have to check it out. Thanks for mention them.

ImageShack just sucks. I have been using Imgur for a while now and haven't had any issues with them losing my photos and screenshots like ImageShack, and now they actually want money, LOL. Nice! I like paying extra for poor service, ha ha.

Share this post


Link to post
Share on other sites

Uh oh... that does suck :P

If we look on the the bright side though it means the thread/post with the image has to be viewed twice a year (sort of) which isn't as bad as it seems, then again, I hate when I'm in research mode and seem to stumble across an old dead thread which seems to have the exact information I need and the images are dead...

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Hello Nospheratu

I have just recently done the Crossfire 7970M Upgrade on my M17x R2 and now need to do this power supply Mod..

I just wanted to ask, since I see your also from South Africa, How did you get a hold of a 330W power supply from Dell.

I spoke to there sales department earlier and they do not recognize any of the model numbers you gave on the opening post.

Thanks for any help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By BAKED
      BAKED BIOS FOR TM, KM, DM, P6, P4 SERIES with most menus and options unlocked.
       
      THESE BIOS MODS ARE ONLY FOR PEOPLE WHO KNOW WHAT THEY ARE DOING!
       
       
       
      NEW:
      I'VE BEEN BUSY WITH SOME STUFF PLUS MY SYSTEM HASN'T BEEN WORKING FOR SOME TIME BUT I SHOULD BE ABLE TO CONTINUE MY WORK SOON 
       
      I'M CURRENTLY WORKING ON V3.0 WHICH WILL INCLUDE UPDATED UEFI DRIVERS, MICROCODE BIOS SCREEN SHOT SUPPORT AMISCE SUPPORT(For some models) PLUS MORE. 
      I'M ALSO WORKING ON MODS FOR OTHER MODELS TOO.
      ALL TM, KM AND DM SERIES ARE V2.0 AND NOW HAVE WINDOWS FLASHER INSTEAD, JUST EXTRACT AND RUN FLASH.BAT
       
      WARNING! BIOS FLASHING IS RISKY SO MAKE SURE YOU KNOW WHAT YOU'RE DOING BEFORE PROCEEDING. 
      FLASHING THE WRONG BIOS OR INTERRUPTING THE FLASHING PROCESS WILL BRICK YOUR SYSTEM! 
      USE AT YOUR OWN RISK!
       
      TM, KM AND DM SERIES
       
      P6 AND P4 SERIES
       
      INSTRUCTIONS
        IF YOU LIKE MY WORK FEEL FRE TO BUY ME A COFFEE   ENJOY!
    • By Edrc
      Hello,
       
      I am new on this forum, so I am sorry if posting at the wrong place. It's been 2 weeks that I am searching how to make my GTX 980M 8GB working Inside my Alienware 17 R1 (June 2014, i7 4710MQ, 60 Herts Display, OPTIMUS and the GTX 880M Inside died.)
      After "quickly" looking some forums, I saw that a 980M would easily fit Inside … but maybe I was wrong.
       
      Hardware wasn't a problem. I've also could install drivers by modding the nvdmi or nvcvi. inf files. The card was recognied BUT :
      the clock speed is locked a 135 or 405 Mherts and fan is not runing when booted up.
      I tried to flash vBios with nvflash and some ROM I found on vBios collection … but no way to get this working properly.
       
      So, i'm coming here. I've seen many people talking about Prema or svl7 or other big boss in the place … but ? how ? where ? when ?
       
      Inside the peripherial manager I have this in remote acces path : PCI\VEN_10DE&DEV_1617&SUBSYS_05AA1028&REV_A1\4&D590A51&0&0008
      So I assume my GTX 980M card ID is 1617 and vendor and PC Model are 05AA 1028.
      But near the "Standard Microsoft Video Card" there is a yellow exclamation point and Inside details it says "this peripherial doesn't work properly" when no Nvidia drivers installed.
      I could find some vBios with 1617 (Asus) but black screen at boot up. Since laptop model where not the same .. probably.
      And I wasn't able to find 1617 with the existing 05AA 1028 … as the GTX 980M was not an option for my model. (AW 17 R1 2014 ,60Herts)
      I tried 353.60, 382.33 and 419.35 drivers. The latest one seems easier to install but longer.
       
      BIOS is A16 from Dell. And I am using Windows 10. Got a Dell 330W brick. 
       
      I saw a guy with the exact model as me, he gets a modded vBios especially for his configuration, then everything worked easily … but can't find the topic again
       
      I guess depending on the card info and the laptop model … a dedicated vBios is required … 
       
      So, If anyone here got some informations or any kind of help for me, it would be very nice.
       
      Thanks for reading and help.  
       
      PS: there are a lot of files, pictures and links that I can't see on this forum .. even after registration …. 
       
    • By Shuren
      Hello Thank You for taking time to read this...i got Clevo w550eu i would love if someone give me unlocked/Modded Bios for it ...thanks again
    • By picardilly
      Hey guys, I am Grga and i am new here. I rarely use forums but i am desperate in this case.
      So, as i have seen many of you have had the issue with obsolete BIOS versions for clevo P7xxZM machines,
      So i would like to hear your experiences and how you went about it. 
      I have recently bought an ssd Samsung 970 PRO NVMe M.2. From which i would like to boot the windows10.
      Little did i know that there was no support for that kind of protocol in the BIOS or that there is such thing as UEFI (for which i am still not sure what that is exactly, except some kind of successor of BIOS).
      So i did a bit of research and updated my Bios and ec to 1.03.15 and 1.03.09 respectively for which i understand is the last available official release. I changed to uefi mode with secure boot disabled etc... in short i did everything that my (limited) knowledge about these things allowed me to do (and the sweat of excitement and fear when i was flashing the bios for the first time in my life). But, alas, it all yielded no success,  and now i am lost. I have really no idea what to do, and whom to ask for help except for you guys here. The only thing that i understand worked for some of you is when you mentioned a wizard named @Prema so therefore i will try to do the same....
    • By yoshomiamoto
      Hello Fellow Tech Gurus!

      I am having a huge headache after upgrading the ram memory of my m17x r3. 

      First let me start by saying I have been experiencing issues with my current ram setup recently, and so i decided to replace the ram inside of my computer, thinking they had gone out on me. It originally came with x4 2gb memory sticks, and as I started to experience issue, I started to removed them, and I was down to 1 2gb stick. It seems to me ram slots 1 & 2 are not working properly as when I put ram memory into them I would get BSOD in 5-10 mins of computer usage after boot. So I am thinking the slots have gone out. I also tested each slot individually and still same effect.

      So I went on the try out slots 3 & 4 under the keyboard, which seems to work just fine when I use only 1 ram chip in one or the other. But the problem occurs when I try and fill both ram slots in slots 3 & 4 under the keyboard with crucial 2x 8 gb of ram sticks, which total to 16gb total ram memory.

      BSOD and freezing occurs like crazy. But if I use just one of the ram sticks in either slot, no problem.

      I dunno if this is hardware or software. I am think that my motherboard is on its way out the door, but any suggestions you all have would be great. I have already clean installed win 7, and is currently running bios A10 (unlocked, I believe)

      I would also like to note that my motherboards internal vga is not detected, and just noticed this a few days ago upon trying to figure out the ram situation.

      other issues is my laptop battery is pretty much dead, and the only for my computer to cut on is if the AC adapter is connected

      I would also like to know can 1x 16gb 1600 ram stick run in my computer? or is it not supported by my motherboard? 

      thanks!

      Specs:

      Alienware M17xR3 (2011 3D FHD ed)

      Service Tag:
      30W75Q1

      Bios ver:
      A10 (should be unlocked)


      Operating System
      Microsoft Windows 7 Home Premium (64-bit)

      Processor
      Intel® Core™ i7-2960XM CPU @ 2.70GHz

      Chipset
      Intel® 6 Series/C200 Series Chipset Family

      Graphics
      Nvidia GTX 680m

      Audio
      IDT High Definition Audio CODEC
      High Definition Audio Device

      Networking and I/O
      DW1501 Wireless-N WLAN Half-Mini Card
      Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20)
      HMA TAP-Windows Adapter V9

      Memory
      Crucial 8 GB (x2 qty) DDR3 PC3-12800 • CL=11 • Unbuffered • NON-ECC • DDR3-1600 • 1.35V • 1024Meg x 64 •

      (these only work under bay 3 or 4, but not dual 8gb at the same time, otherwise BSOD)

      Configuration ID:
      CT3283724

      Storage
      WDC WDBNCE5000PNC SSD (installed into bay 0)
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.